Update patches for new-upstream release 8.20, please DO NOT BUILD - no su
This commit is contained in:
parent
fa6f383f16
commit
8b177c8f26
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
|||||||
/coreutils-8.17.tar.xz
|
/coreutils-8.17.tar.xz
|
||||||
/coreutils-8.18.tar.xz
|
/coreutils-8.18.tar.xz
|
||||||
/coreutils-8.19.tar.xz
|
/coreutils-8.19.tar.xz
|
||||||
|
/coreutils-8.20.tar.xz
|
||||||
|
@ -111,20 +111,9 @@ diff -urNp coreutils-8.13-orig/gnulib-tests/gnulib.mk coreutils-8.13/gnulib-test
|
|||||||
|
|
||||||
## end gnulib module utimens-tests
|
## end gnulib module utimens-tests
|
||||||
|
|
||||||
diff -urNp coreutils-8.17-orig/tests/Makefile.am coreutils-8.17/tests/Makefile.am
|
diff -urNp coreutils-8.13-orig/tests/touch/no-dereference.sh coreutils-8.13/tests/touch/no-dereference.sh
|
||||||
--- coreutils-8.17-orig/tests/Makefile.am
|
--- coreutils-8.13-orig/tests/touch/no-dereference.sh 2011-08-08 09:42:16.000000000 +0200
|
||||||
+++ coreutils-8.17/tests/Makefile.am
|
+++ coreutils-8.13/tests/touch/no-dereference.sh 2011-09-09 10:15:21.167060702 +0200
|
||||||
@@ -87,7 +87,6 @@ TESTS = \
|
|
||||||
rm/cycle \
|
|
||||||
cp/link-heap \
|
|
||||||
misc/tty-eof \
|
|
||||||
- tail-2/inotify-hash-abuse \
|
|
||||||
tail-2/inotify-hash-abuse2 \
|
|
||||||
tail-2/F-vs-missing \
|
|
||||||
tail-2/F-vs-rename \
|
|
||||||
diff -urNp coreutils-8.13-orig/tests/touch/no-dereference coreutils-8.13/tests/touch/no-dereference
|
|
||||||
--- coreutils-8.13-orig/tests/touch/no-dereference 2011-08-08 09:42:16.000000000 +0200
|
|
||||||
+++ coreutils-8.13/tests/touch/no-dereference 2011-09-09 10:15:21.167060702 +0200
|
|
||||||
@@ -42,6 +42,8 @@ test -f nowhere && fail=1
|
@@ -42,6 +42,8 @@ test -f nowhere && fail=1
|
||||||
grep '^#define HAVE_UTIMENSAT 1' "$CONFIG_HEADER" > /dev/null ||
|
grep '^#define HAVE_UTIMENSAT 1' "$CONFIG_HEADER" > /dev/null ||
|
||||||
grep '^#define HAVE_LUTIMES 1' "$CONFIG_HEADER" > /dev/null ||
|
grep '^#define HAVE_LUTIMES 1' "$CONFIG_HEADER" > /dev/null ||
|
||||||
|
@ -108,9 +108,9 @@ diff -urNp coreutils-8.16-orig/src/df.c coreutils-8.16/src/df.c
|
|||||||
if (human_output_opts == -1)
|
if (human_output_opts == -1)
|
||||||
{
|
{
|
||||||
if (posix_format)
|
if (posix_format)
|
||||||
diff -urNp coreutils-8.16-orig/tests/df/direct coreutils-8.16/tests/df/direct
|
diff -urNp coreutils-8.16-orig/tests/df/direct.sh coreutils-8.16/tests/df/direct.sh
|
||||||
--- coreutils-8.16-orig/tests/df/direct 1970-01-01 01:00:00.000000000 +0100
|
--- coreutils-8.16-orig/tests/df/direct.sh 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ coreutils-8.16/tests/df/direct 2012-03-26 17:31:31.102897406 +0200
|
+++ coreutils-8.16/tests/df/direct.sh 2012-03-26 17:31:31.102897406 +0200
|
||||||
@@ -0,0 +1,55 @@
|
@@ -0,0 +1,55 @@
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
+# Ensure "df --direct" works as documented
|
+# Ensure "df --direct" works as documented
|
||||||
@ -167,14 +167,3 @@ diff -urNp coreutils-8.16-orig/tests/df/direct coreutils-8.16/tests/df/direct
|
|||||||
+compare file_out file_exp || fail=1
|
+compare file_out file_exp || fail=1
|
||||||
+
|
+
|
||||||
+Exit $fail
|
+Exit $fail
|
||||||
diff -urNp coreutils-8.16-orig/tests/Makefile.am coreutils-8.16/tests/Makefile.am
|
|
||||||
--- coreutils-8.16-orig/tests/Makefile.am 2012-03-26 17:31:08.642764437 +0200
|
|
||||||
+++ coreutils-8.16/tests/Makefile.am 2012-03-26 17:31:31.104015483 +0200
|
|
||||||
@@ -379,6 +379,7 @@ TESTS = \
|
|
||||||
dd/stderr \
|
|
||||||
dd/unblock \
|
|
||||||
dd/unblock-sync \
|
|
||||||
+ df/direct \
|
|
||||||
df/total-verify \
|
|
||||||
du/2g \
|
|
||||||
du/8gb \
|
|
||||||
|
@ -4016,31 +4016,9 @@ diff -urNp coreutils-8.19-orig/src/uniq.c coreutils-8.19/src/uniq.c
|
|||||||
skip_chars = 0;
|
skip_chars = 0;
|
||||||
skip_fields = 0;
|
skip_fields = 0;
|
||||||
check_chars = SIZE_MAX;
|
check_chars = SIZE_MAX;
|
||||||
diff -urNp coreutils-8.19-orig/tests/Makefile.am coreutils-8.19/tests/Makefile.am
|
diff -urNp coreutils-8.20-orig/tests/misc/cut.pl coreutils-8.20/tests/misc/cut.pl
|
||||||
--- coreutils-8.19-orig/tests/Makefile.am 2012-08-20 13:51:39.856841699 +0200
|
--- coreutils-8.20-orig/tests/misc/cut.pl 2012-07-21 16:54:31.000000000 +0200
|
||||||
+++ coreutils-8.19/tests/Makefile.am 2012-08-20 13:52:04.085491266 +0200
|
+++ coreutils-8.20/tests/misc/cut.pl 2012-08-20 13:52:04.086593767 +0200
|
||||||
@@ -247,6 +247,7 @@ TESTS = \
|
|
||||||
misc/sort-debug-warn \
|
|
||||||
misc/sort-discrim \
|
|
||||||
misc/sort-files0-from \
|
|
||||||
+ misc/sort-mb-tests \
|
|
||||||
misc/sort-float \
|
|
||||||
misc/sort-merge \
|
|
||||||
misc/sort-merge-fdlimit \
|
|
||||||
@@ -551,6 +552,10 @@ TESTS = \
|
|
||||||
$(root_tests)
|
|
||||||
|
|
||||||
pr_data = \
|
|
||||||
+ misc/mb1.X \
|
|
||||||
+ misc/mb1.I \
|
|
||||||
+ misc/mb2.X \
|
|
||||||
+ misc/mb2.I \
|
|
||||||
pr/0F \
|
|
||||||
pr/0FF \
|
|
||||||
pr/0FFnt \
|
|
||||||
diff -urNp coreutils-8.19-orig/tests/misc/cut coreutils-8.19/tests/misc/cut
|
|
||||||
--- coreutils-8.19-orig/tests/misc/cut 2012-07-21 16:54:31.000000000 +0200
|
|
||||||
+++ coreutils-8.19/tests/misc/cut 2012-08-20 13:52:04.086593767 +0200
|
|
||||||
@@ -23,14 +23,15 @@ use strict;
|
@@ -23,14 +23,15 @@ use strict;
|
||||||
# Turn off localization of executable's output.
|
# Turn off localization of executable's output.
|
||||||
@ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
|
@ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
|
||||||
@ -4070,9 +4048,9 @@ diff -urNp coreutils-8.19-orig/tests/misc/cut coreutils-8.19/tests/misc/cut
|
|||||||
['inval2', qw(-f -), {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
['inval2', qw(-f -), {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||||
['inval3', '-f', '4,-', {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
['inval3', '-f', '4,-', {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||||
['inval4', '-f', '1-2,-', {IN=>''}, {OUT=>''}, {EXIT=>1},
|
['inval4', '-f', '1-2,-', {IN=>''}, {OUT=>''}, {EXIT=>1},
|
||||||
diff -urNp coreutils-8.19-orig/tests/misc/expand coreutils-8.19/tests/misc/expand
|
diff -urNp coreutils-8.20-orig/tests/misc/expand.pl coreutils-8.20/tests/misc/expand.pl
|
||||||
--- coreutils-8.19-orig/tests/misc/expand 2012-07-21 16:54:31.000000000 +0200
|
--- coreutils-8.20-orig/tests/misc/expand.pl 2012-07-21 16:54:31.000000000 +0200
|
||||||
+++ coreutils-8.19/tests/misc/expand 2012-08-20 13:55:44.188467648 +0200
|
+++ coreutils-8.20/tests/misc/expand.pl 2012-08-20 13:55:44.188467648 +0200
|
||||||
@@ -23,6 +23,15 @@ use strict;
|
@@ -23,6 +23,15 @@ use strict;
|
||||||
# Turn off localization of executable's output.
|
# Turn off localization of executable's output.
|
||||||
@ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
|
@ENV{qw(LANGUAGE LANG LC_ALL)} = ('C') x 3;
|
||||||
@ -4127,41 +4105,41 @@ diff -urNp coreutils-8.19-orig/tests/misc/expand coreutils-8.19/tests/misc/expan
|
|||||||
my $save_temps = $ENV{DEBUG};
|
my $save_temps = $ENV{DEBUG};
|
||||||
my $verbose = $ENV{VERBOSE};
|
my $verbose = $ENV{VERBOSE};
|
||||||
|
|
||||||
diff -urNp coreutils-8.19-orig/tests/misc/mb1.I coreutils-8.19/tests/misc/mb1.I
|
diff -urNp coreutils-8.20-orig/tests/misc/mb1.I coreutils-8.20/tests/misc/mb1.I
|
||||||
--- coreutils-8.19-orig/tests/misc/mb1.I 1970-01-01 01:00:00.000000000 +0100
|
--- coreutils-8.20-orig/tests/misc/mb1.I 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ coreutils-8.19/tests/misc/mb1.I 2012-08-20 13:52:04.086593767 +0200
|
+++ coreutils-8.20/tests/misc/mb1.I 2012-08-20 13:52:04.086593767 +0200
|
||||||
@@ -0,0 +1,4 @@
|
@@ -0,0 +1,4 @@
|
||||||
+Apple@10
|
+Apple@10
|
||||||
+Banana@5
|
+Banana@5
|
||||||
+Citrus@20
|
+Citrus@20
|
||||||
+Cherry@30
|
+Cherry@30
|
||||||
diff -urNp coreutils-8.19-orig/tests/misc/mb1.X coreutils-8.19/tests/misc/mb1.X
|
diff -urNp coreutils-8.20-orig/tests/misc/mb1.X coreutils-8.20/tests/misc/mb1.X
|
||||||
--- coreutils-8.19-orig/tests/misc/mb1.X 1970-01-01 01:00:00.000000000 +0100
|
--- coreutils-8.20-orig/tests/misc/mb1.X 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ coreutils-8.19/tests/misc/mb1.X 2012-08-20 13:52:04.087526516 +0200
|
+++ coreutils-8.20/tests/misc/mb1.X 2012-08-20 13:52:04.087526516 +0200
|
||||||
@@ -0,0 +1,4 @@
|
@@ -0,0 +1,4 @@
|
||||||
+Banana@5
|
+Banana@5
|
||||||
+Apple@10
|
+Apple@10
|
||||||
+Citrus@20
|
+Citrus@20
|
||||||
+Cherry@30
|
+Cherry@30
|
||||||
diff -urNp coreutils-8.19-orig/tests/misc/mb2.I coreutils-8.19/tests/misc/mb2.I
|
diff -urNp coreutils-8.20-orig/tests/misc/mb2.I coreutils-8.20/tests/misc/mb2.I
|
||||||
--- coreutils-8.19-orig/tests/misc/mb2.I 1970-01-01 01:00:00.000000000 +0100
|
--- coreutils-8.20-orig/tests/misc/mb2.I 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ coreutils-8.19/tests/misc/mb2.I 2012-08-20 13:52:04.088593815 +0200
|
+++ coreutils-8.20/tests/misc/mb2.I 2012-08-20 13:52:04.088593815 +0200
|
||||||
@@ -0,0 +1,4 @@
|
@@ -0,0 +1,4 @@
|
||||||
+Apple@AA10@@20
|
+Apple@AA10@@20
|
||||||
+Banana@AA5@@30
|
+Banana@AA5@@30
|
||||||
+Citrus@AA20@@5
|
+Citrus@AA20@@5
|
||||||
+Cherry@AA30@@10
|
+Cherry@AA30@@10
|
||||||
diff -urNp coreutils-8.19-orig/tests/misc/mb2.X coreutils-8.19/tests/misc/mb2.X
|
diff -urNp coreutils-8.20-orig/tests/misc/mb2.X coreutils-8.20/tests/misc/mb2.X
|
||||||
--- coreutils-8.19-orig/tests/misc/mb2.X 1970-01-01 01:00:00.000000000 +0100
|
--- coreutils-8.20-orig/tests/misc/mb2.X 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ coreutils-8.19/tests/misc/mb2.X 2012-08-20 13:52:04.088593815 +0200
|
+++ coreutils-8.20/tests/misc/mb2.X 2012-08-20 13:52:04.088593815 +0200
|
||||||
@@ -0,0 +1,4 @@
|
@@ -0,0 +1,4 @@
|
||||||
+Citrus@AA20@@5
|
+Citrus@AA20@@5
|
||||||
+Cherry@AA30@@10
|
+Cherry@AA30@@10
|
||||||
+Apple@AA10@@20
|
+Apple@AA10@@20
|
||||||
+Banana@AA5@@30
|
+Banana@AA5@@30
|
||||||
diff -urNp coreutils-8.19-orig/tests/misc/sort-mb-tests coreutils-8.19/tests/misc/sort-mb-tests
|
diff -urNp coreutils-8.20-orig/tests/misc/sort-mb-tests.sh coreutils-8.20/tests/misc/sort-mb-tests.sh
|
||||||
--- coreutils-8.19-orig/tests/misc/sort-mb-tests 1970-01-01 01:00:00.000000000 +0100
|
--- coreutils-8.20-orig/tests/misc/sort-mb-tests.sh 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ coreutils-8.19/tests/misc/sort-mb-tests 2012-08-20 13:52:04.089593318 +0200
|
+++ coreutils-8.20/tests/misc/sort-mb-tests.sh 2012-08-20 13:52:04.089593318 +0200
|
||||||
@@ -0,0 +1,58 @@
|
@@ -0,0 +1,58 @@
|
||||||
+#! /bin/sh
|
+#! /bin/sh
|
||||||
+case $# in
|
+case $# in
|
||||||
|
@ -62,8 +62,8 @@ diff -urNp coreutils-8.13-orig/src/copy.h coreutils-8.13/src/copy.h
|
|||||||
--- coreutils-8.13-orig/src/copy.h 2011-07-28 12:38:27.000000000 +0200
|
--- coreutils-8.13-orig/src/copy.h 2011-07-28 12:38:27.000000000 +0200
|
||||||
+++ coreutils-8.13/src/copy.h 2011-09-09 10:30:39.565563712 +0200
|
+++ coreutils-8.13/src/copy.h 2011-09-09 10:30:39.565563712 +0200
|
||||||
@@ -158,6 +158,9 @@ struct cp_options
|
@@ -158,6 +158,9 @@ struct cp_options
|
||||||
bool preserve_mode;
|
|
||||||
bool preserve_timestamps;
|
bool preserve_timestamps;
|
||||||
|
bool explicit_no_preserve_mode;
|
||||||
|
|
||||||
+ /* If true, attempt to set specified security context */
|
+ /* If true, attempt to set specified security context */
|
||||||
+ bool set_security_context;
|
+ bool set_security_context;
|
||||||
@ -101,7 +101,7 @@ diff -urNp coreutils-8.13-orig/src/cp.c coreutils-8.13/src/cp.c
|
|||||||
fputs (HELP_OPTION_DESCRIPTION, stdout);
|
fputs (HELP_OPTION_DESCRIPTION, stdout);
|
||||||
fputs (VERSION_OPTION_DESCRIPTION, stdout);
|
fputs (VERSION_OPTION_DESCRIPTION, stdout);
|
||||||
@@ -786,6 +791,7 @@ cp_option_init (struct cp_options *x)
|
@@ -786,6 +791,7 @@ cp_option_init (struct cp_options *x)
|
||||||
x->preserve_timestamps = false;
|
x->explicit_no_preserve_mode = false;
|
||||||
x->preserve_security_context = false;
|
x->preserve_security_context = false;
|
||||||
x->require_preserve_context = false;
|
x->require_preserve_context = false;
|
||||||
+ x->set_security_context = false;
|
+ x->set_security_context = false;
|
||||||
@ -609,8 +609,8 @@ diff -urNp coreutils-8.13-orig/src/mv.c coreutils-8.13/src/mv.c
|
|||||||
--- coreutils-8.13-orig/src/mv.c 2011-07-28 12:38:27.000000000 +0200
|
--- coreutils-8.13-orig/src/mv.c 2011-07-28 12:38:27.000000000 +0200
|
||||||
+++ coreutils-8.13/src/mv.c 2011-09-09 10:30:39.578562234 +0200
|
+++ coreutils-8.13/src/mv.c 2011-09-09 10:30:39.578562234 +0200
|
||||||
@@ -118,6 +118,7 @@ cp_option_init (struct cp_options *x)
|
@@ -118,6 +118,7 @@ cp_option_init (struct cp_options *x)
|
||||||
x->preserve_mode = true;
|
|
||||||
x->preserve_timestamps = true;
|
x->preserve_timestamps = true;
|
||||||
|
x->explicit_no_preserve_mode= false;
|
||||||
x->preserve_security_context = selinux_enabled;
|
x->preserve_security_context = selinux_enabled;
|
||||||
+ x->set_security_context = false;
|
+ x->set_security_context = false;
|
||||||
x->reduce_diagnostics = false;
|
x->reduce_diagnostics = false;
|
||||||
@ -628,9 +628,9 @@ diff -urNp coreutils-8.13-orig/src/runcon.c coreutils-8.13/src/runcon.c
|
|||||||
With neither CONTEXT nor COMMAND, print the current security context.\n\
|
With neither CONTEXT nor COMMAND, print the current security context.\n\
|
||||||
\n\
|
\n\
|
||||||
CONTEXT Complete security context\n\
|
CONTEXT Complete security context\n\
|
||||||
diff -urNp coreutils-8.17-orig/tests/init.cfg coreutils-8.17/tests/init.cfg
|
diff -urNp coreutils-8.20-orig/init.cfg coreutils-8.20/init.cfg
|
||||||
--- coreutils-8.17-orig/tests/init.cfg
|
--- coreutils-8.20-orig/init.cfg
|
||||||
+++ coreutils-8.17/tests/init.cfg
|
+++ coreutils-8.20/init.cfg
|
||||||
@@ -253,8 +253,8 @@ require_selinux_()
|
@@ -253,8 +253,8 @@ require_selinux_()
|
||||||
|
|
||||||
# Independent of whether SELinux is enabled system-wide,
|
# Independent of whether SELinux is enabled system-wide,
|
||||||
@ -642,9 +642,9 @@ diff -urNp coreutils-8.17-orig/tests/init.cfg coreutils-8.17/tests/init.cfg
|
|||||||
skip_ "this system (or maybe just" \
|
skip_ "this system (or maybe just" \
|
||||||
"the current file system) lacks SELinux support"
|
"the current file system) lacks SELinux support"
|
||||||
;;
|
;;
|
||||||
diff -urNp coreutils-8.17-orig/tests/misc/selinux coreutils-8.17/tests/misc/selinux
|
diff -urNp coreutils-8.20-orig/tests/misc/selinux coreutils-8.20/tests/misc/selinux.sh
|
||||||
--- coreutils-8.17-orig/tests/misc/selinux
|
--- coreutils-8.20-orig/tests/misc/selinux.sh
|
||||||
+++ coreutils-8.17/tests/misc/selinux
|
+++ coreutils-8.20/tests/misc/selinux.sh
|
||||||
@@ -37,7 +37,7 @@ chcon $ctx f d p ||
|
@@ -37,7 +37,7 @@ chcon $ctx f d p ||
|
||||||
|
|
||||||
# inspect that context with both ls -Z and stat.
|
# inspect that context with both ls -Z and stat.
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||||
Name: coreutils
|
Name: coreutils
|
||||||
Version: 8.19
|
Version: 8.20
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -149,7 +149,7 @@ the old GNU fileutils, sh-utils, and textutils packages.
|
|||||||
%patch951 -p1 -b .selinuxman
|
%patch951 -p1 -b .selinuxman
|
||||||
%patch952 -p1 -b .cpZ
|
%patch952 -p1 -b .cpZ
|
||||||
|
|
||||||
chmod a+x tests/misc/sort-mb-tests tests/df/direct || :
|
chmod a+x tests/misc/sort-mb-tests.sh tests/df/direct.sh || :
|
||||||
|
|
||||||
#fix typos/mistakes in localized documentation(#439410, #440056)
|
#fix typos/mistakes in localized documentation(#439410, #440056)
|
||||||
find ./po/ -name "*.p*" | xargs \
|
find ./po/ -name "*.p*" | xargs \
|
||||||
@ -374,6 +374,9 @@ fi
|
|||||||
%{_sbindir}/chroot
|
%{_sbindir}/chroot
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 27 2012 Ondrej Vasik <ovasik@redhat.com> 8.20-1
|
||||||
|
- new upstream release 8.20
|
||||||
|
|
||||||
* Mon Aug 20 2012 Ondrej Vasik <ovasik@redhat.com> 8.19-1
|
* Mon Aug 20 2012 Ondrej Vasik <ovasik@redhat.com> 8.19-1
|
||||||
- new upstream release 8.19
|
- new upstream release 8.19
|
||||||
- fix multibyte issues in cut and expand (M.Briza, #821260)
|
- fix multibyte issues in cut and expand (M.Briza, #821260)
|
||||||
|
Loading…
Reference in New Issue
Block a user