New upstream release changes, su/runuser ones just commented out atm, don't build
This commit is contained in:
parent
0c6cba0357
commit
89d1aa92a0
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/coreutils-8.15.tar.xz
|
||||
/coreutils-8.16.tar.xz
|
||||
/coreutils-8.17.tar.xz
|
||||
/coreutils-8.18.tar.xz
|
||||
|
@ -3,7 +3,7 @@ diff -urNp coreutils-8.13-orig/src/stty.c coreutils-8.13/src/stty.c
|
||||
+++ coreutils-8.13/src/stty.c 2011-09-09 10:18:57.526687209 +0200
|
||||
@@ -1005,7 +1005,7 @@ main (int argc, char **argv)
|
||||
spurious difference in an uninitialized portion of the structure. */
|
||||
struct termios new_mode = { 0, };
|
||||
static struct termios new_mode;
|
||||
|
||||
- if (tcsetattr (STDIN_FILENO, TCSADRAIN, &mode))
|
||||
+ if (tcsetattr (STDIN_FILENO, TCSANOW, &mode))
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -urNp coreutils-8.17-orig/src/ls.c coreutils-8.17/src/ls.c
|
||||
--- coreutils-8.17-orig/src/ls.c 2012-05-11 20:59:01.467946060 +0200
|
||||
+++ coreutils-8.17/src/ls.c 2012-05-11 21:00:38.276821883 +0200
|
||||
@@ -3206,14 +3206,9 @@ make_link_name (char const *name, char const *linkname)
|
||||
if (IS_ABSOLUTE_FILE_NAME (linkname))
|
||||
return xstrdup (linkname);
|
||||
|
||||
- /* The link is to a relative name. Prepend any leading directory
|
||||
- in 'name' to the link name. */
|
||||
- size_t prefix_len = dir_len (name);
|
||||
- if (prefix_len == 0)
|
||||
- return xstrdup (linkname);
|
||||
-
|
||||
- char *p = xmalloc (prefix_len + 1 + strlen (linkname) + 1);
|
||||
- stpcpy (stpncpy (p, name, prefix_len + 1), linkname);
|
||||
+ char *d = dir_name (name);
|
||||
+ char *p = file_name_concat (d, linkname, NULL);
|
||||
+ free (d);
|
||||
return p;
|
||||
}
|
||||
|
@ -5,14 +5,14 @@ diff -urNp coreutils-8.16-orig/doc/coreutils.texi coreutils-8.16/doc/coreutils.t
|
||||
Scale sizes by @var{size} before printing them (@pxref{Block size}).
|
||||
For example, @option{-BG} prints sizes in units of 1,073,741,824 bytes.
|
||||
|
||||
+@itemx --direct
|
||||
+@item --direct
|
||||
+@opindex --direct
|
||||
+@cindex direct statfs for a file
|
||||
+Do not resolve mount point and show statistics directly for a file. It can be
|
||||
+especially useful for NFS mount points if there is a boundary between two
|
||||
+storage policies behind the mount point.
|
||||
+
|
||||
@itemx --total
|
||||
@item --total
|
||||
@opindex --total
|
||||
@cindex grand total of disk size, usage and available space
|
||||
diff -urNp coreutils-8.16-orig/src/df.c coreutils-8.16/src/df.c
|
||||
@ -29,11 +29,11 @@ diff -urNp coreutils-8.16-orig/src/df.c coreutils-8.16/src/df.c
|
||||
static struct fs_usage grand_fsu;
|
||||
|
||||
@@ -167,13 +170,15 @@ static size_t nrows;
|
||||
enum
|
||||
{
|
||||
NO_SYNC_OPTION = CHAR_MAX + 1,
|
||||
- SYNC_OPTION
|
||||
+ SYNC_OPTION,
|
||||
SYNC_OPTION,
|
||||
- MEGABYTES_OPTION /* FIXME: remove long opt in Aug 2013 */
|
||||
+ MEGABYTES_OPTION, /* FIXME: remove long opt in Aug 2013 */
|
||||
+ DIRECT_OPTION
|
||||
};
|
||||
|
||||
|
@ -2450,17 +2450,10 @@ diff -urNp coreutils-8.16-orig/src/pr.c coreutils-8.16/src/pr.c
|
||||
diff -urNp coreutils-8.17-orig/src/sort.c coreutils-8.17/src/sort.c
|
||||
--- coreutils-8.17-orig/src/sort.c
|
||||
+++ coreutils-8.17/src/sort.c
|
||||
@@ -22,12 +22,21 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <assert.h>
|
||||
#include <getopt.h>
|
||||
#include <pthread.h>
|
||||
#include <sys/resource.h>
|
||||
#include <sys/types.h>
|
||||
@@ -29,6 +29,14 @@
|
||||
#include <sys/wait.h>
|
||||
#include <signal.h>
|
||||
#include <assert.h>
|
||||
+#if HAVE_WCHAR_H
|
||||
+# include <wchar.h>
|
||||
+#endif
|
||||
|
@ -14,7 +14,7 @@ diff -urNp coreutils-8.13-orig/configure.ac coreutils-8.13/configure.ac
|
||||
+
|
||||
AC_FUNC_FORK
|
||||
|
||||
AC_ARG_ENABLE(pam, AS_HELP_STRING([--disable-pam],
|
||||
optional_bin_progs=
|
||||
diff -urNp coreutils-8.13-orig/man/chcon.x coreutils-8.13/man/chcon.x
|
||||
--- coreutils-8.13-orig/man/chcon.x 2009-09-01 13:01:16.000000000 +0200
|
||||
+++ coreutils-8.13/man/chcon.x 2011-09-09 10:30:39.524564991 +0200
|
||||
|
@ -2,7 +2,7 @@ diff -urNp coreutils-6.10-orig/doc/coreutils.texi coreutils-6.10/doc/coreutils.t
|
||||
--- coreutils-6.10-orig/doc/coreutils.texi 2008-04-07 17:52:11.000000000 +0200
|
||||
+++ coreutils-6.10/doc/coreutils.texi 2008-04-07 18:01:43.000000000 +0200
|
||||
@@ -6981,6 +6981,11 @@ for i; do
|
||||
done
|
||||
exit $fail
|
||||
@end example
|
||||
|
||||
+@item -c
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||
Name: coreutils
|
||||
Version: 8.17
|
||||
Release: 4%{?dist}
|
||||
Version: 8.18
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: System Environment/Base
|
||||
Url: http://www.gnu.org/software/coreutils/
|
||||
@ -18,7 +18,6 @@ Source202: coreutils-su-l.pamd
|
||||
Source203: coreutils-runuser-l.pamd
|
||||
|
||||
# From upstream
|
||||
Patch1: coreutils-8.17-ls-rootdir-symlink.patch
|
||||
|
||||
# Our patches
|
||||
#general patch to workaround koji build system issues
|
||||
@ -38,26 +37,26 @@ Patch107: coreutils-8.4-mkdir-modenote.patch
|
||||
#add info about TZ envvar to date manpage
|
||||
Patch703: sh-utils-2.0.11-dateman.patch
|
||||
#set paths for su explicitly, don't get influenced by paths.h
|
||||
Patch704: sh-utils-1.16-paths.patch
|
||||
#Patch704: sh-utils-1.16-paths.patch
|
||||
# RMS will never accept the PAM patch because it removes his historical
|
||||
# rant about Twenex and the wheel group, so we'll continue to maintain
|
||||
# it here indefinitely. Patch is now the same in Fedora and SUSE.
|
||||
Patch706: coreutils-8.5-pam.patch
|
||||
#Patch706: coreutils-8.5-pam.patch
|
||||
Patch713: coreutils-4.5.3-langinfo.patch
|
||||
|
||||
# (sb) lin18nux/lsb compliance - multibyte functionality patch
|
||||
Patch800: coreutils-i18n.patch
|
||||
|
||||
#Call setsid() in su under some circumstances (bug #173008).
|
||||
Patch900: coreutils-setsid.patch
|
||||
#Patch900: coreutils-setsid.patch
|
||||
#make runuser binary based on su.c
|
||||
Patch907: coreutils-8.7-runuser.patch
|
||||
#Patch907: coreutils-8.7-runuser.patch
|
||||
#getgrouplist() patch from Ulrich Drepper.
|
||||
Patch908: coreutils-getgrouplist.patch
|
||||
#Prevent buffer overflow in who(1) (bug #158405).
|
||||
Patch912: coreutils-overflow.patch
|
||||
#compile su with pie flag and RELRO protection
|
||||
Patch917: coreutils-8.4-su-pie.patch
|
||||
#Patch917: coreutils-8.4-su-pie.patch
|
||||
|
||||
#SELINUX Patch - implements Redhat changes
|
||||
#(upstream did some SELinux implementation unlike with RedHat patch)
|
||||
@ -107,7 +106,7 @@ BuildRequires: gettext bison
|
||||
BuildRequires: texinfo
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
%{?!nopam:BuildRequires: pam-devel}
|
||||
#%{?!nopam:BuildRequires: pam-devel}
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: libattr-devel
|
||||
BuildRequires: gmp-devel
|
||||
@ -118,7 +117,7 @@ Requires(pre): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(post): grep
|
||||
%{?!nopam:Requires: pam >= 1.1.3-7}
|
||||
#%{?!nopam:Requires: pam >= 1.1.3-7}
|
||||
Requires: ncurses
|
||||
Requires: gmp
|
||||
|
||||
@ -145,7 +144,6 @@ the old GNU fileutils, sh-utils, and textutils packages.
|
||||
%setup -q
|
||||
|
||||
# From upstream
|
||||
%patch1 -p1 -b .roodirsymlink
|
||||
|
||||
# Our patches
|
||||
%patch100 -p1 -b .configure
|
||||
@ -157,19 +155,19 @@ the old GNU fileutils, sh-utils, and textutils packages.
|
||||
|
||||
# sh-utils
|
||||
%patch703 -p1 -b .dateman
|
||||
%patch704 -p1 -b .paths
|
||||
%patch706 -p1 -b .pam
|
||||
#%patch704 -p1 -b .paths
|
||||
#%patch706 -p1 -b .pam
|
||||
%patch713 -p1 -b .langinfo
|
||||
|
||||
# li18nux/lsb
|
||||
%patch800 -p1 -b .i18n
|
||||
|
||||
# Coreutils
|
||||
%patch900 -p1 -b .setsid
|
||||
%patch907 -p1 -b .runuser
|
||||
#%patch900 -p1 -b .setsid
|
||||
#%patch907 -p1 -b .runuser
|
||||
%patch908 -p1 -b .getgrouplist
|
||||
%patch912 -p1 -b .overflow
|
||||
%patch917 -p1 -b .pie
|
||||
#%patch917 -p1 -b .pie
|
||||
|
||||
#SELinux
|
||||
%patch950 -p1 -b .selinux
|
||||
@ -200,8 +198,8 @@ automake --copy --add-missing
|
||||
# Regenerate manpages
|
||||
touch man/*.x
|
||||
|
||||
make all %{?_smp_mflags} \
|
||||
%{?!nopam:CPPFLAGS="-DUSE_PAM"}
|
||||
make all %{?_smp_mflags}
|
||||
# %{?!nopam:CPPFLAGS="-DUSE_PAM"}
|
||||
|
||||
# XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
|
||||
sed -i -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
|
||||
@ -228,7 +226,7 @@ bzip2 -9f ChangeLog
|
||||
|
||||
# let be compatible with old fileutils, sh-utils and textutils packages :
|
||||
mkdir -p $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}
|
||||
%{?!nopam:mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d}
|
||||
#%{?!nopam:mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d}
|
||||
|
||||
# chroot was in /usr/sbin :
|
||||
mv $RPM_BUILD_ROOT{%_bindir,%_sbindir}/chroot
|
||||
@ -241,20 +239,20 @@ install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.s
|
||||
install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
|
||||
|
||||
# su
|
||||
install -m 4755 src/su $RPM_BUILD_ROOT/%{_bindir}
|
||||
%{?!norunuser:install -m 755 src/runuser $RPM_BUILD_ROOT/%{_sbindir}}
|
||||
#install -m 4755 src/su $RPM_BUILD_ROOT/%{_bindir}
|
||||
#%{?!norunuser:install -m 755 src/runuser $RPM_BUILD_ROOT/%{_sbindir}}
|
||||
# do not ship runuser in /usr/bin/runuser
|
||||
rm -rf $RPM_BUILD_ROOT/%{_bindir}/runuser || :
|
||||
#rm -rf $RPM_BUILD_ROOT/%{_bindir}/runuser || :
|
||||
|
||||
# These come from util-linux and/or procps.
|
||||
for i in hostname uptime kill ; do
|
||||
rm $RPM_BUILD_ROOT{%{_bindir}/$i,%{_mandir}/man1/$i.1}
|
||||
done
|
||||
|
||||
%{?!nopam:install -p -m 644 %SOURCE200 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/su}
|
||||
%{?!nopam:install -p -m 644 %SOURCE202 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/su-l}
|
||||
%{?!nopam:install -p -m 644 %SOURCE201 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/runuser}
|
||||
%{?!nopam:install -p -m 644 %SOURCE203 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/runuser-l}
|
||||
#%{?!nopam:install -p -m 644 %SOURCE200 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/su}
|
||||
#%{?!nopam:install -p -m 644 %SOURCE202 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/su-l}
|
||||
#%{?!nopam:install -p -m 644 %SOURCE201 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/runuser}
|
||||
#%{?!nopam:install -p -m 644 %SOURCE203 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/runuser-l}
|
||||
|
||||
# Compress ChangeLogs from before the fileutils/textutils/etc merge
|
||||
bzip2 -f9 old/*/C*
|
||||
@ -306,10 +304,10 @@ fi
|
||||
%dir %{_datadir}/locale/*/LC_TIME
|
||||
%config(noreplace) %{_sysconfdir}/DIR_COLORS*
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/*
|
||||
%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/su}
|
||||
%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/su-l}
|
||||
%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/runuser}
|
||||
%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/runuser-l}
|
||||
#%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/su}
|
||||
#%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/su-l}
|
||||
#%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/runuser}
|
||||
#%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/runuser-l}
|
||||
%doc COPYING ABOUT-NLS ChangeLog.bz2 NEWS README THANKS TODO old/*
|
||||
%{_bindir}/arch
|
||||
%{_bindir}/basename
|
||||
@ -339,7 +337,7 @@ fi
|
||||
%{_bindir}/sleep
|
||||
%{_bindir}/sort
|
||||
%{_bindir}/stty
|
||||
%attr(4755,root,root) %{_bindir}/su
|
||||
#%attr(4755,root,root) %{_bindir}/su
|
||||
%{_bindir}/sync
|
||||
%{_bindir}/mktemp
|
||||
%{_bindir}/touch
|
||||
@ -416,9 +414,13 @@ fi
|
||||
%{_libexecdir}/coreutils*
|
||||
%{_mandir}/man*/*
|
||||
%{_sbindir}/chroot
|
||||
%{?!norunuser:%{_sbindir}/runuser}
|
||||
#%{?!norunuser:%{_sbindir}/runuser}
|
||||
|
||||
%changelog
|
||||
* Sun Aug 12 2012 Ondrej Vasik <ovasik@redhat.com> 8.18-1
|
||||
- new upstream release 8.18
|
||||
- su/runuser moved to util-linux
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.17-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
@ -1,18 +0,0 @@
|
||||
--- sh-utils-1.16/src/su.c.badpaths Mon Apr 14 14:26:55 1997
|
||||
+++ sh-utils-1.16/src/su.c Sun Aug 17 14:11:31 EDT 2003
|
||||
@@ -147,6 +147,15 @@
|
||||
# define DEFAULT_ROOT_LOGIN_PATH "/usr/ucb:/bin:/usr/bin:/etc"
|
||||
#endif
|
||||
|
||||
+/* The default paths which get set are both bogus and oddly influenced
|
||||
+ by <paths.h> and -D on the commands line. Just to be clear, we'll set
|
||||
+ these explicitly. -ewt */
|
||||
+#undef DEFAULT_LOGIN_PATH
|
||||
+#undef DEFAULT_ROOT_LOGIN_PATH
|
||||
+#define DEFAULT_LOGIN_PATH "/usr/local/bin:/bin:/usr/bin"
|
||||
+#define DEFAULT_ROOT_LOGIN_PATH \
|
||||
+ "/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin"
|
||||
+
|
||||
/* The shell to run if none is given in the user's passwd entry. */
|
||||
#define DEFAULT_SHELL "/bin/sh"
|
||||
|
Loading…
Reference in New Issue
Block a user