This commit is contained in:
parent
35cd801647
commit
826eac74c1
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
coreutils-8.5.tar.xz
|
||||
/coreutils-8.6.tar.xz
|
||||
/coreutils-8.7.tar.xz
|
||||
/coreutils-8.8.tar.xz
|
||||
|
@ -126,7 +126,7 @@ new file mode 100644
|
||||
index 0000000..9088f27
|
||||
--- /dev/null
|
||||
+++ b/tests/df/direct
|
||||
@@ -0,0 +1,59 @@
|
||||
@@ -0,0 +1,55 @@
|
||||
+#!/bin/sh
|
||||
+# Ensure "df --direct" works as documented
|
||||
+
|
||||
@ -145,12 +145,8 @@ index 0000000..9088f27
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+if test "$VERBOSE" = yes; then
|
||||
+ set -x
|
||||
+ df --version
|
||||
+fi
|
||||
+
|
||||
+. $srcdir/test-lib.sh
|
||||
+. "${srcdir=.}/init.sh"; path_prepend_ ../src
|
||||
+print_ver_ df
|
||||
+
|
||||
+df || skip_test_ "df fails"
|
||||
+
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -urNp coreutils-8.7-orig/lib/linebuffer.h coreutils-8.7/lib/linebuffer.h
|
||||
--- coreutils-8.7-orig/lib/linebuffer.h 2010-06-10 18:45:26.000000000 +0200
|
||||
+++ coreutils-8.7/lib/linebuffer.h 2010-11-15 09:59:36.974172148 +0100
|
||||
diff -urNp coreutils-8.8-orig/lib/linebuffer.h coreutils-8.8/lib/linebuffer.h
|
||||
--- coreutils-8.8-orig/lib/linebuffer.h 2010-04-23 15:44:00.000000000 +0200
|
||||
+++ coreutils-8.8/lib/linebuffer.h 2010-12-23 13:59:44.393514385 +0100
|
||||
@@ -21,6 +21,11 @@
|
||||
|
||||
# include <stdio.h>
|
||||
@ -23,9 +23,9 @@ diff -urNp coreutils-8.7-orig/lib/linebuffer.h coreutils-8.7/lib/linebuffer.h
|
||||
};
|
||||
|
||||
/* Initialize linebuffer LINEBUFFER for use. */
|
||||
diff -urNp coreutils-8.7-orig/src/cut.c coreutils-8.7/src/cut.c
|
||||
--- coreutils-8.7-orig/src/cut.c 2010-10-11 19:35:11.000000000 +0200
|
||||
+++ coreutils-8.7/src/cut.c 2010-11-15 09:59:36.976171659 +0100
|
||||
diff -urNp coreutils-8.8-orig/src/cut.c coreutils-8.8/src/cut.c
|
||||
--- coreutils-8.8-orig/src/cut.c 2010-08-14 01:49:07.000000000 +0200
|
||||
+++ coreutils-8.8/src/cut.c 2010-12-23 13:59:44.397514141 +0100
|
||||
@@ -28,6 +28,11 @@
|
||||
#include <assert.h>
|
||||
#include <getopt.h>
|
||||
@ -616,9 +616,9 @@ diff -urNp coreutils-8.7-orig/src/cut.c coreutils-8.7/src/cut.c
|
||||
}
|
||||
|
||||
if (optind == argc)
|
||||
diff -urNp coreutils-8.7-orig/src/expand.c coreutils-8.7/src/expand.c
|
||||
--- coreutils-8.7-orig/src/expand.c 2010-10-11 19:35:11.000000000 +0200
|
||||
+++ coreutils-8.7/src/expand.c 2010-11-15 09:59:36.977172637 +0100
|
||||
diff -urNp coreutils-8.8-orig/src/expand.c coreutils-8.8/src/expand.c
|
||||
--- coreutils-8.8-orig/src/expand.c 2010-08-14 01:49:07.000000000 +0200
|
||||
+++ coreutils-8.8/src/expand.c 2010-12-23 13:59:44.399514013 +0100
|
||||
@@ -38,12 +38,29 @@
|
||||
#include <stdio.h>
|
||||
#include <getopt.h>
|
||||
@ -806,9 +806,9 @@ diff -urNp coreutils-8.7-orig/src/expand.c coreutils-8.7/src/expand.c
|
||||
|
||||
if (have_read_stdin && fclose (stdin) != 0)
|
||||
error (EXIT_FAILURE, errno, "-");
|
||||
diff -urNp coreutils-8.7-orig/src/fold.c coreutils-8.7/src/fold.c
|
||||
--- coreutils-8.7-orig/src/fold.c 2010-10-16 13:28:01.000000000 +0200
|
||||
+++ coreutils-8.7/src/fold.c 2010-11-15 09:59:36.979181926 +0100
|
||||
diff -urNp coreutils-8.8-orig/src/fold.c coreutils-8.8/src/fold.c
|
||||
--- coreutils-8.8-orig/src/fold.c 2010-11-27 16:06:22.000000000 +0100
|
||||
+++ coreutils-8.8/src/fold.c 2010-12-23 13:59:44.401513895 +0100
|
||||
@@ -22,12 +22,34 @@
|
||||
#include <getopt.h>
|
||||
#include <sys/types.h>
|
||||
@ -1207,9 +1207,9 @@ diff -urNp coreutils-8.7-orig/src/fold.c coreutils-8.7/src/fold.c
|
||||
break;
|
||||
|
||||
case 's': /* Break at word boundaries. */
|
||||
diff -urNp coreutils-8.7-orig/src/join.c coreutils-8.7/src/join.c
|
||||
--- coreutils-8.7-orig/src/join.c 2010-10-11 19:35:11.000000000 +0200
|
||||
+++ coreutils-8.7/src/join.c 2010-11-15 09:59:36.980181716 +0100
|
||||
diff -urNp coreutils-8.8-orig/src/join.c coreutils-8.8/src/join.c
|
||||
--- coreutils-8.8-orig/src/join.c 2010-09-17 11:13:45.000000000 +0200
|
||||
+++ coreutils-8.8/src/join.c 2010-12-23 13:59:44.404513732 +0100
|
||||
@@ -22,18 +22,32 @@
|
||||
#include <sys/types.h>
|
||||
#include <getopt.h>
|
||||
@ -1692,9 +1692,9 @@ diff -urNp coreutils-8.7-orig/src/join.c coreutils-8.7/src/join.c
|
||||
break;
|
||||
|
||||
case NOCHECK_ORDER_OPTION:
|
||||
diff -urNp coreutils-8.7-orig/src/pr.c coreutils-8.7/src/pr.c
|
||||
--- coreutils-8.7-orig/src/pr.c 2010-10-11 19:35:11.000000000 +0200
|
||||
+++ coreutils-8.7/src/pr.c 2010-11-15 09:59:36.983181856 +0100
|
||||
diff -urNp coreutils-8.8-orig/src/pr.c coreutils-8.8/src/pr.c
|
||||
--- coreutils-8.8-orig/src/pr.c 2010-08-14 01:49:07.000000000 +0200
|
||||
+++ coreutils-8.8/src/pr.c 2010-12-23 13:59:44.410513374 +0100
|
||||
@@ -312,6 +312,32 @@
|
||||
|
||||
#include <getopt.h>
|
||||
@ -2417,9 +2417,9 @@ diff -urNp coreutils-8.7-orig/src/pr.c coreutils-8.7/src/pr.c
|
||||
/* We've just printed some files and need to clean up things before
|
||||
looking for more options and printing the next batch of files.
|
||||
|
||||
diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
--- coreutils-8.7-orig/src/sort.c 2010-10-25 12:07:57.000000000 +0200
|
||||
+++ coreutils-8.7/src/sort.c 2010-11-15 09:59:36.987932380 +0100
|
||||
diff -urNp coreutils-8.8-orig/src/sort.c coreutils-8.8/src/sort.c
|
||||
--- coreutils-8.8-orig/src/sort.c 2010-12-20 12:20:41.000000000 +0100
|
||||
+++ coreutils-8.8/src/sort.c 2010-12-23 13:59:44.420512797 +0100
|
||||
@@ -22,11 +22,20 @@
|
||||
|
||||
#include <config.h>
|
||||
@ -2441,7 +2441,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
#include "system.h"
|
||||
#include "argmatch.h"
|
||||
#include "error.h"
|
||||
@@ -159,12 +168,34 @@ static int thousands_sep;
|
||||
@@ -163,12 +172,34 @@ static int thousands_sep;
|
||||
|
||||
/* Nonzero if the corresponding locales are hard. */
|
||||
static bool hard_LC_COLLATE;
|
||||
@ -2477,7 +2477,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
/* The kind of blanks for '-b' to skip in various options. */
|
||||
enum blanktype { bl_start, bl_end, bl_both };
|
||||
|
||||
@@ -328,13 +359,11 @@ static bool reverse;
|
||||
@@ -335,13 +366,11 @@ static bool reverse;
|
||||
they were read if all keys compare equal. */
|
||||
static bool stable;
|
||||
|
||||
@ -2494,8 +2494,8 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
|
||||
/* Flag to remove consecutive duplicate lines from the output.
|
||||
Only the last of a sequence of equal lines will be output. */
|
||||
@@ -782,6 +811,46 @@ reap_some (void)
|
||||
update_proc (pid);
|
||||
@@ -768,6 +797,46 @@ reap_all (void)
|
||||
reap (-1);
|
||||
}
|
||||
|
||||
+/* Function pointers. */
|
||||
@ -2541,7 +2541,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
/* Clean up any remaining temporary files. */
|
||||
|
||||
static void
|
||||
@@ -1205,7 +1274,7 @@ zaptemp (char const *name)
|
||||
@@ -1200,7 +1269,7 @@ zaptemp (char const *name)
|
||||
free (node);
|
||||
}
|
||||
|
||||
@ -2550,7 +2550,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
|
||||
static int
|
||||
struct_month_cmp (void const *m1, void const *m2)
|
||||
@@ -1220,7 +1289,7 @@ struct_month_cmp (void const *m1, void c
|
||||
@@ -1215,7 +1284,7 @@ struct_month_cmp (void const *m1, void c
|
||||
/* Initialize the character class tables. */
|
||||
|
||||
static void
|
||||
@ -2559,7 +2559,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
{
|
||||
size_t i;
|
||||
|
||||
@@ -1232,7 +1301,7 @@ inittables (void)
|
||||
@@ -1227,7 +1296,7 @@ inittables (void)
|
||||
fold_toupper[i] = toupper (i);
|
||||
}
|
||||
|
||||
@ -2568,7 +2568,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
/* If we're not in the "C" locale, read different names for months. */
|
||||
if (hard_LC_TIME)
|
||||
{
|
||||
@@ -1314,6 +1383,84 @@ specify_nmerge (int oi, char c, char con
|
||||
@@ -1309,6 +1378,84 @@ specify_nmerge (int oi, char c, char con
|
||||
xstrtol_fatal (e, oi, c, long_options, s);
|
||||
}
|
||||
|
||||
@ -2653,7 +2653,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
/* Specify the amount of main memory to use when sorting. */
|
||||
static void
|
||||
specify_sort_size (int oi, char c, char const *s)
|
||||
@@ -1540,7 +1687,7 @@ buffer_linelim (struct buffer const *buf
|
||||
@@ -1537,7 +1684,7 @@ buffer_linelim (struct buffer const *buf
|
||||
by KEY in LINE. */
|
||||
|
||||
static char *
|
||||
@ -2662,7 +2662,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
{
|
||||
char *ptr = line->text, *lim = ptr + line->length - 1;
|
||||
size_t sword = key->sword;
|
||||
@@ -1549,10 +1696,10 @@ begfield (struct line const *line, struc
|
||||
@@ -1546,10 +1693,10 @@ begfield (struct line const *line, struc
|
||||
/* The leading field separator itself is included in a field when -t
|
||||
is absent. */
|
||||
|
||||
@ -2675,7 +2675,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
++ptr;
|
||||
if (ptr < lim)
|
||||
++ptr;
|
||||
@@ -1578,11 +1725,70 @@ begfield (struct line const *line, struc
|
||||
@@ -1575,11 +1722,70 @@ begfield (struct line const *line, struc
|
||||
return ptr;
|
||||
}
|
||||
|
||||
@ -2747,7 +2747,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
{
|
||||
char *ptr = line->text, *lim = ptr + line->length - 1;
|
||||
size_t eword = key->eword, echar = key->echar;
|
||||
@@ -1597,10 +1803,10 @@ limfield (struct line const *line, struc
|
||||
@@ -1594,10 +1800,10 @@ limfield (struct line const *line, struc
|
||||
`beginning' is the first character following the delimiting TAB.
|
||||
Otherwise, leave PTR pointing at the first `blank' character after
|
||||
the preceding field. */
|
||||
@ -2760,7 +2760,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
++ptr;
|
||||
if (ptr < lim && (eword || echar))
|
||||
++ptr;
|
||||
@@ -1646,10 +1852,10 @@ limfield (struct line const *line, struc
|
||||
@@ -1643,10 +1849,10 @@ limfield (struct line const *line, struc
|
||||
*/
|
||||
|
||||
/* Make LIM point to the end of (one byte past) the current field. */
|
||||
@ -2773,7 +2773,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
if (newlim)
|
||||
lim = newlim;
|
||||
}
|
||||
@@ -1680,6 +1886,130 @@ limfield (struct line const *line, struc
|
||||
@@ -1677,6 +1883,130 @@ limfield (struct line const *line, struc
|
||||
return ptr;
|
||||
}
|
||||
|
||||
@ -2904,7 +2904,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
/* Fill BUF reading from FP, moving buf->left bytes from the end
|
||||
of buf->buf to the beginning first. If EOF is reached and the
|
||||
file wasn't terminated by a newline, supply one. Set up BUF's line
|
||||
@@ -1766,8 +2096,22 @@ fillbuf (struct buffer *buf, FILE *fp, c
|
||||
@@ -1763,8 +2093,22 @@ fillbuf (struct buffer *buf, FILE *fp, c
|
||||
else
|
||||
{
|
||||
if (key->skipsblanks)
|
||||
@ -2929,7 +2929,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
line->keybeg = line_start;
|
||||
}
|
||||
}
|
||||
@@ -1888,7 +2232,7 @@ human_numcompare (char const *a, char co
|
||||
@@ -1885,7 +2229,7 @@ human_numcompare (char const *a, char co
|
||||
hideously fast. */
|
||||
|
||||
static int
|
||||
@ -2938,7 +2938,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
{
|
||||
while (blanks[to_uchar (*a)])
|
||||
a++;
|
||||
@@ -1898,6 +2242,25 @@ numcompare (char const *a, char const *b
|
||||
@@ -1895,6 +2239,25 @@ numcompare (char const *a, char const *b
|
||||
return strnumcmp (a, b, decimal_point, thousands_sep);
|
||||
}
|
||||
|
||||
@ -2964,7 +2964,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
static int
|
||||
general_numcompare (char const *sa, char const *sb)
|
||||
{
|
||||
@@ -1930,7 +2293,7 @@ general_numcompare (char const *sa, char
|
||||
@@ -1927,7 +2290,7 @@ general_numcompare (char const *sa, char
|
||||
Return 0 if the name in S is not recognized. */
|
||||
|
||||
static int
|
||||
@ -2973,9 +2973,9 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
{
|
||||
size_t lo = 0;
|
||||
size_t hi = MONTHS_PER_YEAR;
|
||||
@@ -2204,13 +2567,12 @@ debug_key (struct line const *line, stru
|
||||
{
|
||||
char saved = *lim; *lim = '\0';
|
||||
@@ -2202,13 +2565,12 @@ debug_key (struct line const *line, stru
|
||||
char saved = *lim;
|
||||
*lim = '\0';
|
||||
|
||||
- while (blanks[to_uchar (*beg)])
|
||||
- beg++;
|
||||
@ -2989,7 +2989,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
else if (key->general_numeric)
|
||||
ignore_value (strtold (beg, &tighter_lim));
|
||||
else if (key->numeric || key->human_numeric)
|
||||
@@ -2354,7 +2716,7 @@ key_warnings (struct keyfield const *gke
|
||||
@@ -2352,7 +2714,7 @@ key_warnings (struct keyfield const *gke
|
||||
bool maybe_space_aligned = !hard_LC_COLLATE && default_key_compare (key)
|
||||
&& !(key->schar || key->echar);
|
||||
bool line_offset = key->eword == 0 && key->echar != 0; /* -k1.x,1.y */
|
||||
@ -2998,7 +2998,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
&& ((!key->skipsblanks && !(implicit_skip || maybe_space_aligned))
|
||||
|| (!key->skipsblanks && key->schar)
|
||||
|| (!key->skipeblanks && key->echar)))
|
||||
@@ -2412,11 +2774,83 @@ key_warnings (struct keyfield const *gke
|
||||
@@ -2410,11 +2772,83 @@ key_warnings (struct keyfield const *gke
|
||||
error (0, 0, _("option `-r' only applies to last-resort comparison"));
|
||||
}
|
||||
|
||||
@ -3083,7 +3083,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
{
|
||||
struct keyfield *key = keylist;
|
||||
|
||||
@@ -2501,7 +2935,7 @@ keycompare (struct line const *a, struct
|
||||
@@ -2499,7 +2933,7 @@ keycompare (struct line const *a, struct
|
||||
else if (key->human_numeric)
|
||||
diff = human_numcompare (ta, tb);
|
||||
else if (key->month)
|
||||
@ -3092,7 +3092,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
else if (key->random)
|
||||
diff = compare_random (ta, tlena, tb, tlenb);
|
||||
else if (key->version)
|
||||
@@ -2617,6 +3051,179 @@ keycompare (struct line const *a, struct
|
||||
@@ -2615,6 +3049,179 @@ keycompare (struct line const *a, struct
|
||||
return key->reverse ? -diff : diff;
|
||||
}
|
||||
|
||||
@ -3272,7 +3272,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
/* Compare two lines A and B, returning negative, zero, or positive
|
||||
depending on whether A compares less than, equal to, or greater than B. */
|
||||
|
||||
@@ -4006,7 +4613,7 @@ main (int argc, char **argv)
|
||||
@@ -4077,7 +4684,7 @@ main (int argc, char **argv)
|
||||
initialize_exit_failure (SORT_FAILURE);
|
||||
|
||||
hard_LC_COLLATE = hard_locale (LC_COLLATE);
|
||||
@ -3281,7 +3281,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
hard_LC_TIME = hard_locale (LC_TIME);
|
||||
#endif
|
||||
|
||||
@@ -4027,6 +4634,29 @@ main (int argc, char **argv)
|
||||
@@ -4098,6 +4705,29 @@ main (int argc, char **argv)
|
||||
thousands_sep = -1;
|
||||
}
|
||||
|
||||
@ -3311,7 +3311,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
have_read_stdin = false;
|
||||
inittables ();
|
||||
|
||||
@@ -4297,13 +4927,34 @@ main (int argc, char **argv)
|
||||
@@ -4368,13 +4998,34 @@ main (int argc, char **argv)
|
||||
|
||||
case 't':
|
||||
{
|
||||
@ -3350,7 +3350,7 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
else
|
||||
{
|
||||
/* Provoke with `sort -txx'. Complain about
|
||||
@@ -4314,9 +4965,12 @@ main (int argc, char **argv)
|
||||
@@ -4385,9 +5036,12 @@ main (int argc, char **argv)
|
||||
quote (optarg));
|
||||
}
|
||||
}
|
||||
@ -3365,9 +3365,9 @@ diff -urNp coreutils-8.7-orig/src/sort.c coreutils-8.7/src/sort.c
|
||||
}
|
||||
break;
|
||||
|
||||
diff -urNp coreutils-8.7-orig/src/unexpand.c coreutils-8.7/src/unexpand.c
|
||||
--- coreutils-8.7-orig/src/unexpand.c 2010-10-11 19:35:11.000000000 +0200
|
||||
+++ coreutils-8.7/src/unexpand.c 2010-11-15 09:59:36.989931891 +0100
|
||||
diff -urNp coreutils-8.8-orig/src/unexpand.c coreutils-8.8/src/unexpand.c
|
||||
--- coreutils-8.8-orig/src/unexpand.c 2010-08-14 01:49:07.000000000 +0200
|
||||
+++ coreutils-8.8/src/unexpand.c 2010-12-23 13:59:44.423512620 +0100
|
||||
@@ -39,12 +39,29 @@
|
||||
#include <stdio.h>
|
||||
#include <getopt.h>
|
||||
@ -3621,9 +3621,9 @@ diff -urNp coreutils-8.7-orig/src/unexpand.c coreutils-8.7/src/unexpand.c
|
||||
|
||||
if (have_read_stdin && fclose (stdin) != 0)
|
||||
error (EXIT_FAILURE, errno, "-");
|
||||
diff -urNp coreutils-8.7-orig/src/uniq.c coreutils-8.7/src/uniq.c
|
||||
--- coreutils-8.7-orig/src/uniq.c 2010-10-11 19:35:11.000000000 +0200
|
||||
+++ coreutils-8.7/src/uniq.c 2010-11-15 09:59:36.992922043 +0100
|
||||
diff -urNp coreutils-8.8-orig/src/uniq.c coreutils-8.8/src/uniq.c
|
||||
--- coreutils-8.8-orig/src/uniq.c 2010-08-14 01:49:07.000000000 +0200
|
||||
+++ coreutils-8.8/src/uniq.c 2010-12-23 13:59:44.426512446 +0100
|
||||
@@ -21,6 +21,16 @@
|
||||
#include <getopt.h>
|
||||
#include <sys/types.h>
|
||||
@ -3990,10 +3990,10 @@ diff -urNp coreutils-8.7-orig/src/uniq.c coreutils-8.7/src/uniq.c
|
||||
skip_chars = 0;
|
||||
skip_fields = 0;
|
||||
check_chars = SIZE_MAX;
|
||||
diff -urNp coreutils-8.7-orig/tests/Makefile.am coreutils-8.7/tests/Makefile.am
|
||||
--- coreutils-8.7-orig/tests/Makefile.am 2010-11-15 09:58:44.197937898 +0100
|
||||
+++ coreutils-8.7/tests/Makefile.am 2010-11-15 09:59:36.993932170 +0100
|
||||
@@ -231,6 +231,7 @@ TESTS = \
|
||||
diff -urNp coreutils-8.8-orig/tests/Makefile.am coreutils-8.8/tests/Makefile.am
|
||||
--- coreutils-8.8-orig/tests/Makefile.am 2010-12-23 13:59:21.007870308 +0100
|
||||
+++ coreutils-8.8/tests/Makefile.am 2010-12-23 13:59:44.428512331 +0100
|
||||
@@ -233,6 +233,7 @@ TESTS = \
|
||||
misc/sort-debug-keys \
|
||||
misc/sort-debug-warn \
|
||||
misc/sort-files0-from \
|
||||
@ -4001,7 +4001,7 @@ diff -urNp coreutils-8.7-orig/tests/Makefile.am coreutils-8.7/tests/Makefile.am
|
||||
misc/sort-float \
|
||||
misc/sort-merge \
|
||||
misc/sort-merge-fdlimit \
|
||||
@@ -490,6 +491,10 @@ TESTS = \
|
||||
@@ -498,6 +499,10 @@ TESTS = \
|
||||
$(root_tests)
|
||||
|
||||
pr_data = \
|
||||
@ -4012,9 +4012,9 @@ diff -urNp coreutils-8.7-orig/tests/Makefile.am coreutils-8.7/tests/Makefile.am
|
||||
pr/0F \
|
||||
pr/0FF \
|
||||
pr/0FFnt \
|
||||
diff -urNp coreutils-8.7-orig/tests/misc/cut coreutils-8.7/tests/misc/cut
|
||||
--- coreutils-8.7-orig/tests/misc/cut 2010-10-11 19:35:11.000000000 +0200
|
||||
+++ coreutils-8.7/tests/misc/cut 2010-11-15 09:59:36.994932100 +0100
|
||||
diff -urNp coreutils-8.8-orig/tests/misc/cut coreutils-8.8/tests/misc/cut
|
||||
--- coreutils-8.8-orig/tests/misc/cut 2010-01-01 14:06:47.000000000 +0100
|
||||
+++ coreutils-8.8/tests/misc/cut 2010-12-23 13:59:44.429512273 +0100
|
||||
@@ -26,7 +26,7 @@ use strict;
|
||||
my $prog = 'cut';
|
||||
my $try = "Try \`$prog --help' for more information.\n";
|
||||
@ -4033,41 +4033,41 @@ diff -urNp coreutils-8.7-orig/tests/misc/cut coreutils-8.7/tests/misc/cut
|
||||
['inval2', qw(-f -), {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||
['inval3', '-f', '4,-', {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||
['inval4', '-f', '1-2,-', {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||
diff -urNp coreutils-8.7-orig/tests/misc/mb1.I coreutils-8.7/tests/misc/mb1.I
|
||||
--- coreutils-8.7-orig/tests/misc/mb1.I 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.7/tests/misc/mb1.I 2010-11-15 09:59:36.995931961 +0100
|
||||
diff -urNp coreutils-8.8-orig/tests/misc/mb1.I coreutils-8.8/tests/misc/mb1.I
|
||||
--- coreutils-8.8-orig/tests/misc/mb1.I 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.8/tests/misc/mb1.I 2010-12-23 13:59:44.430512213 +0100
|
||||
@@ -0,0 +1,4 @@
|
||||
+Apple@10
|
||||
+Banana@5
|
||||
+Citrus@20
|
||||
+Cherry@30
|
||||
diff -urNp coreutils-8.7-orig/tests/misc/mb1.X coreutils-8.7/tests/misc/mb1.X
|
||||
--- coreutils-8.7-orig/tests/misc/mb1.X 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.7/tests/misc/mb1.X 2010-11-15 09:59:36.995931961 +0100
|
||||
diff -urNp coreutils-8.8-orig/tests/misc/mb1.X coreutils-8.8/tests/misc/mb1.X
|
||||
--- coreutils-8.8-orig/tests/misc/mb1.X 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.8/tests/misc/mb1.X 2010-12-23 13:59:44.430512213 +0100
|
||||
@@ -0,0 +1,4 @@
|
||||
+Banana@5
|
||||
+Apple@10
|
||||
+Citrus@20
|
||||
+Cherry@30
|
||||
diff -urNp coreutils-8.7-orig/tests/misc/mb2.I coreutils-8.7/tests/misc/mb2.I
|
||||
--- coreutils-8.7-orig/tests/misc/mb2.I 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.7/tests/misc/mb2.I 2010-11-15 09:59:36.996933777 +0100
|
||||
diff -urNp coreutils-8.8-orig/tests/misc/mb2.I coreutils-8.8/tests/misc/mb2.I
|
||||
--- coreutils-8.8-orig/tests/misc/mb2.I 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.8/tests/misc/mb2.I 2010-12-23 13:59:44.431512154 +0100
|
||||
@@ -0,0 +1,4 @@
|
||||
+Apple@AA10@@20
|
||||
+Banana@AA5@@30
|
||||
+Citrus@AA20@@5
|
||||
+Cherry@AA30@@10
|
||||
diff -urNp coreutils-8.7-orig/tests/misc/mb2.X coreutils-8.7/tests/misc/mb2.X
|
||||
--- coreutils-8.7-orig/tests/misc/mb2.X 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.7/tests/misc/mb2.X 2010-11-15 09:59:36.997922462 +0100
|
||||
diff -urNp coreutils-8.8-orig/tests/misc/mb2.X coreutils-8.8/tests/misc/mb2.X
|
||||
--- coreutils-8.8-orig/tests/misc/mb2.X 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.8/tests/misc/mb2.X 2010-12-23 13:59:44.432512095 +0100
|
||||
@@ -0,0 +1,4 @@
|
||||
+Citrus@AA20@@5
|
||||
+Cherry@AA30@@10
|
||||
+Apple@AA10@@20
|
||||
+Banana@AA5@@30
|
||||
diff -urNp coreutils-8.7-orig/tests/misc/sort-mb-tests coreutils-8.7/tests/misc/sort-mb-tests
|
||||
--- coreutils-8.7-orig/tests/misc/sort-mb-tests 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.7/tests/misc/sort-mb-tests 2010-11-15 09:59:36.997922462 +0100
|
||||
diff -urNp coreutils-8.8-orig/tests/misc/sort-mb-tests coreutils-8.8/tests/misc/sort-mb-tests
|
||||
--- coreutils-8.8-orig/tests/misc/sort-mb-tests 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.8/tests/misc/sort-mb-tests 2010-12-23 13:59:44.433512037 +0100
|
||||
@@ -0,0 +1,58 @@
|
||||
+#! /bin/sh
|
||||
+case $# in
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||
Name: coreutils
|
||||
Version: 8.7
|
||||
Release: 2%{?dist}
|
||||
Version: 8.8
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: System Environment/Base
|
||||
Url: http://www.gnu.org/software/coreutils/
|
||||
@ -332,6 +332,10 @@ fi
|
||||
%{_libdir}/coreutils
|
||||
|
||||
%changelog
|
||||
* Thu Dec 23 2010 Ondrej Vasik <ovasik@redhat.com> - 8.8-1
|
||||
- fix parallel sorting issue (#655096)
|
||||
- new upstream release coreutils-8.8 (#665164)
|
||||
|
||||
* Thu Nov 18 2010 Ondrej Vasik <ovasik@redhat.com> - 8.7-2
|
||||
- don't prompt for password with runuser(#654367)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user