new upstream release 8.15, patches updated
This commit is contained in:
parent
377a7b8082
commit
7f6231bff1
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/coreutils-8.12.tar.xz
|
/coreutils-8.12.tar.xz
|
||||||
/coreutils-8.13.tar.xz
|
/coreutils-8.13.tar.xz
|
||||||
/coreutils-8.14.tar.xz
|
/coreutils-8.14.tar.xz
|
||||||
|
/coreutils-8.15.tar.xz
|
||||||
|
@ -52,20 +52,16 @@ diff -urNp coreutils-8.7-orig/man/runuser.x coreutils-8.7/man/runuser.x
|
|||||||
diff -urNp coreutils-8.7-orig/README coreutils-8.7/README
|
diff -urNp coreutils-8.7-orig/README coreutils-8.7/README
|
||||||
--- coreutils-8.7-orig/README 2010-10-11 19:35:11.000000000 +0200
|
--- coreutils-8.7-orig/README 2010-10-11 19:35:11.000000000 +0200
|
||||||
+++ coreutils-8.7/README 2010-11-15 10:10:43.002922253 +0100
|
+++ coreutils-8.7/README 2010-11-15 10:10:43.002922253 +0100
|
||||||
@@ -12,10 +12,10 @@ The programs that can be built with this
|
@@ -11,8 +11,8 @@ The programs that can be built with this
|
||||||
factor false fmt fold groups head hostid hostname id install join kill
|
factor false fmt fold groups head hostid hostname id install join kill
|
||||||
link ln logname ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup
|
link ln logname ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup
|
||||||
nproc od paste pathchk pinky pr printenv printf ptx pwd readlink rm rmdir
|
nproc od paste pathchk pinky pr printenv printf ptx pwd readlink realpath
|
||||||
- runcon seq sha1sum sha224sum sha256sum sha384sum sha512sum shred shuf
|
- rm rmdir runcon seq sha1sum sha224sum sha256sum sha384sum sha512sum shred
|
||||||
- sleep sort split stat stdbuf stty su sum sync tac tail tee test timeout
|
- shuf sleep sort split stat stdbuf stty su sum sync tac tail tee test
|
||||||
- touch tr true truncate tsort tty uname unexpand uniq unlink uptime users
|
+ rm rmdir runcon runuser seq sha1sum sha224sum sha256sum sha384sum sha512sum
|
||||||
- vdir wc who whoami yes
|
+ shred shuf sleep sort split stat stdbuf stty su sum sync tac tail tee test
|
||||||
+ runcon runuser seq sha1sum sha224sum sha256sum sha384sum sha512sum shred
|
timeout touch tr true truncate tsort tty uname unexpand uniq unlink
|
||||||
+ shuf sleep sort split stat stdbuf stty su sum sync tac tail tee test
|
uptime users vdir wc who whoami yes
|
||||||
+ timeout touch tr true truncate tsort tty uname unexpand uniq unlink uptime
|
|
||||||
+ users vdir wc who whoami yes
|
|
||||||
|
|
||||||
See the file NEWS for a list of major changes in the current release.
|
|
||||||
|
|
||||||
diff -urNp coreutils-8.7-orig/src/Makefile.am coreutils-8.7/src/Makefile.am
|
diff -urNp coreutils-8.7-orig/src/Makefile.am coreutils-8.7/src/Makefile.am
|
||||||
--- coreutils-8.7-orig/src/Makefile.am 2010-11-15 10:07:07.339171659 +0100
|
--- coreutils-8.7-orig/src/Makefile.am 2010-11-15 10:07:07.339171659 +0100
|
||||||
|
@ -67,7 +67,7 @@ diff -urNp coreutils-8.11-orig/src/df.c coreutils-8.11/src/df.c
|
|||||||
+ char *resolved = canonicalize_file_name (name);
|
+ char *resolved = canonicalize_file_name (name);
|
||||||
+ if (resolved)
|
+ if (resolved)
|
||||||
+ {
|
+ {
|
||||||
+ get_dev (NULL, resolved, NULL, NULL, false, false, NULL);
|
+ get_dev (NULL, resolved, NULL, NULL, false, false, NULL, false);
|
||||||
+ free (resolved);
|
+ free (resolved);
|
||||||
+ return;
|
+ return;
|
||||||
+ }
|
+ }
|
||||||
|
@ -10,7 +10,7 @@ diff -urNp coreutils-8.13-orig/lib/linebuffer.h coreutils-8.13/lib/linebuffer.h
|
|||||||
+# include <wchar.h>
|
+# include <wchar.h>
|
||||||
+# endif
|
+# endif
|
||||||
+
|
+
|
||||||
/* A `struct linebuffer' holds a line of text. */
|
/* A 'struct linebuffer' holds a line of text. */
|
||||||
|
|
||||||
struct linebuffer
|
struct linebuffer
|
||||||
@@ -28,6 +33,9 @@ struct linebuffer
|
@@ -28,6 +33,9 @@ struct linebuffer
|
||||||
@ -1784,8 +1784,8 @@ diff -urNp coreutils-8.13-orig/src/pr.c coreutils-8.13/src/pr.c
|
|||||||
static void getoptarg (char *arg, char switch_char, char *character,
|
static void getoptarg (char *arg, char switch_char, char *character,
|
||||||
+ int *character_length, int *character_width,
|
+ int *character_length, int *character_width,
|
||||||
int *number);
|
int *number);
|
||||||
void usage (int status);
|
|
||||||
static void print_files (int number_of_files, char **av);
|
static void print_files (int number_of_files, char **av);
|
||||||
|
static void init_parameters (int number_of_files);
|
||||||
@@ -439,7 +491,6 @@ static void store_char (char c);
|
@@ -439,7 +491,6 @@ static void store_char (char c);
|
||||||
static void pad_down (int lines);
|
static void pad_down (int lines);
|
||||||
static void read_rest_of_line (COLUMN *p);
|
static void read_rest_of_line (COLUMN *p);
|
||||||
|
@ -45,7 +45,7 @@ diff -urNp coreutils-8.13-orig/src/chcon.c coreutils-8.13/src/chcon.c
|
|||||||
+Change the SELinux security context of each FILE to CONTEXT.\n\
|
+Change the SELinux security context of each FILE to CONTEXT.\n\
|
||||||
With --reference, change the security context of each FILE to that of RFILE.\n\
|
With --reference, change the security context of each FILE to that of RFILE.\n\
|
||||||
\n\
|
\n\
|
||||||
-h, --no-dereference affect symbolic links instead of any referenced file\n\
|
"), stdout);
|
||||||
diff -urNp coreutils-8.13-orig/src/copy.c coreutils-8.13/src/copy.c
|
diff -urNp coreutils-8.13-orig/src/copy.c coreutils-8.13/src/copy.c
|
||||||
--- coreutils-8.13-orig/src/copy.c 2011-07-28 12:38:27.000000000 +0200
|
--- coreutils-8.13-orig/src/copy.c 2011-07-28 12:38:27.000000000 +0200
|
||||||
+++ coreutils-8.13/src/copy.c 2011-09-09 10:30:39.564562214 +0200
|
+++ coreutils-8.13/src/copy.c 2011-09-09 10:30:39.564562214 +0200
|
||||||
@ -243,10 +243,10 @@ diff -urNp coreutils-8.13-orig/src/ls.c coreutils-8.13/src/ls.c
|
|||||||
};
|
};
|
||||||
|
|
||||||
/* Display letters and indicators for each filetype.
|
/* Display letters and indicators for each filetype.
|
||||||
@@ -283,6 +284,7 @@ static void queue_directory (char const
|
@@ -282,6 +283,7 @@
|
||||||
|
bool command_line_arg);
|
||||||
static void sort_files (void);
|
static void sort_files (void);
|
||||||
static void parse_ls_color (void);
|
static void parse_ls_color (void);
|
||||||
void usage (int status);
|
|
||||||
+static void print_scontext_format (const struct fileinfo *f);
|
+static void print_scontext_format (const struct fileinfo *f);
|
||||||
|
|
||||||
/* Initial size of hash table.
|
/* Initial size of hash table.
|
||||||
@ -382,19 +382,6 @@ diff -urNp coreutils-8.13-orig/src/ls.c coreutils-8.13/src/ls.c
|
|||||||
default:
|
default:
|
||||||
usage (LS_FAILURE);
|
usage (LS_FAILURE);
|
||||||
}
|
}
|
||||||
@@ -2714,8 +2738,10 @@ clear_files (void)
|
|
||||||
struct fileinfo *f = sorted_file[i];
|
|
||||||
free (f->name);
|
|
||||||
free (f->linkname);
|
|
||||||
- if (f->scontext != UNKNOWN_SECURITY_CONTEXT)
|
|
||||||
- freecon (f->scontext);
|
|
||||||
+ if (f->scontext != UNKNOWN_SECURITY_CONTEXT) {
|
|
||||||
+ freecon (f->scontext);
|
|
||||||
+ f->scontext = NULL;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
cwd_n_used = 0;
|
|
||||||
@@ -2757,6 +2783,7 @@ gobble_file (char const *name, enum file
|
@@ -2757,6 +2783,7 @@ gobble_file (char const *name, enum file
|
||||||
memset (f, '\0', sizeof *f);
|
memset (f, '\0', sizeof *f);
|
||||||
f->stat.st_ino = inode;
|
f->stat.st_ino = inode;
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||||
Name: coreutils
|
Name: coreutils
|
||||||
Version: 8.14
|
Version: 8.15
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.gnu.org/software/coreutils/
|
Url: http://www.gnu.org/software/coreutils/
|
||||||
@ -322,6 +322,9 @@ fi
|
|||||||
%{?!norunuser:/sbin/runuser}
|
%{?!norunuser:/sbin/runuser}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 08 2012 Ondrej Vasik <ovasik@redhat.com> - 8.15-1
|
||||||
|
- new upstream release 8.15
|
||||||
|
|
||||||
* Thu Jan 05 2012 Ondrej Vasik <ovasik@redhat.com> - 8.14-6
|
* Thu Jan 05 2012 Ondrej Vasik <ovasik@redhat.com> - 8.14-6
|
||||||
- do not use shebang in sourced colorls.csh
|
- do not use shebang in sourced colorls.csh
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user