new upstream releases 6.12 + adapted patches
This commit is contained in:
parent
8738c500a0
commit
5f9af7f6c9
@ -1 +1 @@
|
||||
coreutils-6.11.tar.lzma
|
||||
coreutils-6.12.tar.lzma
|
||||
|
@ -34,7 +34,7 @@
|
||||
+#endif
|
||||
|
||||
+#ifndef AUTHORS
|
||||
#define AUTHORS "David MacKenzie"
|
||||
#define AUTHORS proper_name ("David MacKenzie")
|
||||
+#endif
|
||||
|
||||
#if HAVE_PATHS_H
|
||||
|
@ -1,3 +1,26 @@
|
||||
diff -urN coreutils-6.12-orig/tests/misc/cut coreutils-6.12/tests/misc/cut
|
||||
--- coreutils-6.12-orig/tests/misc/cut 2008-05-17 08:41:11.000000000 +0200
|
||||
+++ coreutils-6.12/tests/misc/cut 2008-06-02 11:13:08.000000000 +0200
|
||||
@@ -26,7 +26,7 @@
|
||||
my $prog = 'cut';
|
||||
my $try = "Try \`$prog --help' for more information.\n";
|
||||
my $from_1 = "$prog: fields and positions are numbered from 1\n$try";
|
||||
-my $inval = "$prog: invalid byte or field list\n$try";
|
||||
+my $inval = "$prog: invalid byte, character or field list\n$try";
|
||||
my $no_endpoint = "$prog: invalid range with no endpoint: -\n$try";
|
||||
|
||||
my @Tests =
|
||||
@@ -140,8 +140,8 @@
|
||||
['od-overlap5', '-b1-3,1-4', '--output-d=:', {IN=>"abcde\n"}, {OUT=>"abcd\n"}],
|
||||
|
||||
# None of the following invalid ranges provoked an error up to coreutils-6.9.
|
||||
- ['inval1', qw(-f 2-0), {IN=>''}, {OUT=>''}, {EXIT=>1},
|
||||
- {ERR=>"$prog: invalid decreasing range\n$try"}],
|
||||
+# ['inval1', qw(-f 2-0), {IN=>''}, {OUT=>''}, {EXIT=>1},
|
||||
+# {ERR=>"$prog: invalid decreasing range\n$try"}],
|
||||
['inval2', qw(-f -), {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||
['inval3', '-f', '4,-', {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||
['inval4', '-f', '1-2,-', {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||
diff -urNp coreutils-6.11-orig/tests/touch/no-create-missing coreutils-6.11/tests/touch/no-create-missing
|
||||
--- coreutils-6.11-orig/tests/touch/no-create-missing 2008-04-19 23:34:23.000000000 +0200
|
||||
+++ coreutils-6.11/tests/touch/no-create-missing 2008-04-24 12:34:52.000000000 +0200
|
||||
@ -10,13 +33,13 @@ diff -urNp coreutils-6.11-orig/tests/touch/no-create-missing coreutils-6.11/test
|
||||
touch -cm - >&- 2> /dev/null || fail=1
|
||||
touch -ca - >&- 2> /dev/null || fail=1
|
||||
fi
|
||||
diff -urNp coreutils-6.11-orig/tests/mkdir/selinux coreutils-6.11/tests/mkdir/selinux
|
||||
diff -urN coreutils-6.11-orig/tests/mkdir/selinux coreutils-6.11/tests/mkdir/selinux
|
||||
--- coreutils-6.11-orig/tests/mkdir/selinux 2008-04-19 23:34:23.000000000 +0200
|
||||
+++ coreutils-6.11/tests/mkdir/selinux 2008-04-22 13:23:50.000000000 +0200
|
||||
@@ -30,6 +30,7 @@ fi
|
||||
. $srcdir/../envvar-check
|
||||
. $srcdir/../lang-default
|
||||
. $srcdir/../test-lib.sh
|
||||
@@ -38,6 +28,7 @@
|
||||
# successfully, in spite of the invalid context string.
|
||||
|
||||
. $srcdir/test-lib.sh
|
||||
+require_selinux_
|
||||
|
||||
c=invalid-selinux-context
|
||||
|
@ -1,86 +1,46 @@
|
||||
diff -urNp coreutils-6.11-orig/src/install.c coreutils-6.11/src/install.c
|
||||
--- coreutils-6.11-orig/src/install.c 2008-05-20 16:08:03.000000000 +0200
|
||||
+++ coreutils-6.11/src/install.c 2008-05-20 16:12:27.000000000 +0200
|
||||
@@ -85,6 +85,7 @@ static bool install_file_in_dir (const c
|
||||
const struct cp_options *x);
|
||||
static bool install_file_in_file (const char *from, const char *to,
|
||||
const struct cp_options *x);
|
||||
+static void set_prefix (const char* from_dir, const char* to_dir);
|
||||
static void get_ids (void);
|
||||
static void strip (char const *name);
|
||||
static void announce_mkdir (char const *dir, void *options);
|
||||
@@ -200,25 +201,25 @@ cp_option_init (struct cp_options *x)
|
||||
x->src_info = NULL;
|
||||
}
|
||||
From a089634c855312a28f2ff3c2e7c08df5d030e2f5 Mon Sep 17 00:00:00 2001
|
||||
From: Jim Meyering <meyering <at> redhat.com>
|
||||
Date: Tue, 20 May 2008 17:58:42 +0200
|
||||
Subject: [PATCH] install: avoid a leak in currently-ifdef'd-out code
|
||||
|
||||
-/* Modify file context to match the specified policy.
|
||||
- If an error occurs the file will remain with the default directory
|
||||
- context. */
|
||||
-static void
|
||||
-setdefaultfilecon (char const *file)
|
||||
+static void
|
||||
+set_prefix (char const *from_dir, char const *to_dir)
|
||||
* src/install.c (setdefaultfilecon)
|
||||
[ENABLE_WHEN_MATCHPATHCON_IS_MORE_EFFICIENT]:
|
||||
Call matchpathcon_init_prefix only once.
|
||||
Suggestion from Stephen Smalley. Reported by Ben Webb in
|
||||
<http://bugzilla.redhat.com/447410>.
|
||||
---
|
||||
src/install.c | 5 ++++-
|
||||
1 files changed, 4 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/install.c b/src/install.c
|
||||
index 964ab36..b531f45 100644
|
||||
--- a/src/install.c
|
||||
+++ b/src/install.c
|
||||
@@ -208,6 +208,8 @@ setdefaultfilecon (char const *file)
|
||||
{
|
||||
+ const char *from_base = last_component (from_dir);
|
||||
+ char *file = file_name_concat (to_dir, from_base, NULL);
|
||||
struct stat st;
|
||||
- security_context_t scontext = NULL;
|
||||
security_context_t scontext = NULL;
|
||||
+ static bool first_call = true;
|
||||
+
|
||||
if (selinux_enabled != 1)
|
||||
{
|
||||
/* Indicate no context found. */
|
||||
return;
|
||||
}
|
||||
+
|
||||
@@ -216,7 +218,7 @@ setdefaultfilecon (char const *file)
|
||||
if (lstat (file, &st) != 0)
|
||||
return;
|
||||
|
||||
if (IS_ABSOLUTE_FILE_NAME (file))
|
||||
- if (IS_ABSOLUTE_FILE_NAME (file))
|
||||
+ if (first_call && IS_ABSOLUTE_FILE_NAME (file))
|
||||
{
|
||||
- /* Calling matchpathcon_init_prefix (NULL, "/first_component/")
|
||||
+ /* Calling matchpathcon_init_prefix (NULL, "/first_component/")
|
||||
/* Calling matchpathcon_init_prefix (NULL, "/first_component/")
|
||||
is an optimization to minimize the expense of the following
|
||||
matchpathcon call. */
|
||||
char const *p0;
|
||||
@@ -248,6 +249,26 @@ setdefaultfilecon (char const *file)
|
||||
@@ -247,6 +249,7 @@ setdefaultfilecon (char const *file)
|
||||
}
|
||||
}
|
||||
}
|
||||
+ first_call = false;
|
||||
|
||||
+ return;
|
||||
+}
|
||||
+
|
||||
+/* Modify file context to match the specified policy.
|
||||
+ If an error occurs the file will remain with the default directory
|
||||
+ context. */
|
||||
+static void
|
||||
+setdefaultfilecon (char const *file)
|
||||
+{
|
||||
+ struct stat st;
|
||||
+ security_context_t scontext = NULL;
|
||||
+ return;
|
||||
+ if (selinux_enabled != 1)
|
||||
+ {
|
||||
+ /* Indicate no context found. */
|
||||
+ return;
|
||||
+ }
|
||||
+ if (lstat (file, &st) != 0)
|
||||
+ return;
|
||||
+
|
||||
/* If there's an error determining the context, or it has none,
|
||||
return to allow default context */
|
||||
if ((matchpathcon (file, st.st_mode, &scontext) != 0) ||
|
||||
@@ -526,9 +547,13 @@ main (int argc, char **argv)
|
||||
{
|
||||
int i;
|
||||
dest_info_init (&x);
|
||||
- for (i = 0; i < n_files; i++)
|
||||
+ set_prefix (file[0], target_directory);
|
||||
+ for (i = 0; i < n_files; i++) {
|
||||
if (! install_file_in_dir (file[i], target_directory, &x))
|
||||
exit_status = EXIT_FAILURE;
|
||||
+ }
|
||||
+ if (selinux_enabled)
|
||||
+ matchpathcon_fini();
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
1.5.5.1.249.g68ef3
|
||||
|
@ -1,45 +1,3 @@
|
||||
diff -up coreutils-6.11/lib/sha256.c.sparc coreutils-6.11/lib/sha256.c
|
||||
--- coreutils-6.11/lib/sha256.c.sparc 2008-04-19 16:34:23.000000000 -0500
|
||||
+++ coreutils-6.11/lib/sha256.c 2008-05-29 18:48:56.000000000 -0500
|
||||
@@ -134,9 +134,13 @@ sha256_conclude_ctx (struct sha256_ctx *
|
||||
if (ctx->total[0] < bytes)
|
||||
++ctx->total[1];
|
||||
|
||||
- /* Put the 64-bit file length in *bits* at the end of the buffer. */
|
||||
- ctx->buffer[size - 2] = SWAP ((ctx->total[1] << 3) | (ctx->total[0] >> 29));
|
||||
- ctx->buffer[size - 1] = SWAP (ctx->total[0] << 3);
|
||||
+ /* Put the 64-bit file length in *bits* at the end of the buffer.
|
||||
+ Use set_uint32 rather than a simple assignment, to avoid risk of
|
||||
+ unaligned access. */
|
||||
+ set_uint32 ((char *) &ctx->buffer[size - 2],
|
||||
+ SWAP ((ctx->total[1] << 3) | (ctx->total[0] >> 29)));
|
||||
+ set_uint32 ((char *) &ctx->buffer[size - 1],
|
||||
+ SWAP (ctx->total[0] << 3));
|
||||
|
||||
memcpy (&((char *) ctx->buffer)[bytes], fillbuf, (size - 2) * 4 - bytes);
|
||||
|
||||
diff -up coreutils-6.11/lib/sha512.c.sparc coreutils-6.11/lib/sha512.c
|
||||
--- coreutils-6.11/lib/sha512.c.sparc 2008-04-19 16:34:23.000000000 -0500
|
||||
+++ coreutils-6.11/lib/sha512.c 2008-05-29 18:40:36.000000000 -0500
|
||||
@@ -141,10 +141,14 @@ sha512_conclude_ctx (struct sha512_ctx *
|
||||
if (u64lt (ctx->total[0], u64lo (bytes)))
|
||||
ctx->total[1] = u64plus (ctx->total[1], u64lo (1));
|
||||
|
||||
- /* Put the 64-bit file length in *bits* at the end of the buffer. */
|
||||
- ctx->buffer[size - 2] = SWAP (u64or (u64shl (ctx->total[1], 3),
|
||||
- u64shr (ctx->total[0], 61)));
|
||||
- ctx->buffer[size - 1] = SWAP (u64shl (ctx->total[0], 3));
|
||||
+ /* Put the 128-bit file length in *bits* at the end of the buffer.
|
||||
+ Use set_uint64 rather than a simple assignment, to avoid risk of
|
||||
+ unaligned access. */
|
||||
+ set_uint64 ((char *) &ctx->buffer[size - 2],
|
||||
+ SWAP (u64or (u64shl (ctx->total[1], 3),
|
||||
+ u64shr (ctx->total[0], 61))));
|
||||
+ set_uint64 ((char *) &ctx->buffer[size - 1],
|
||||
+ SWAP (u64shl (ctx->total[0], 3)));
|
||||
|
||||
memcpy (&((char *) ctx->buffer)[bytes], fillbuf, (size - 2) * 8 - bytes);
|
||||
|
||||
diff -up coreutils-6.11/src/Makefile.am.sparc coreutils-6.11/src/Makefile.am
|
||||
--- coreutils-6.11/src/Makefile.am.sparc 2008-04-19 16:34:23.000000000 -0500
|
||||
+++ coreutils-6.11/src/Makefile.am 2008-05-29 18:40:36.000000000 -0500
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- coreutils-5.92/tests/group-names.chgrp 2005-10-28 09:20:12.000000000 +0100
|
||||
+++ coreutils-5.92/tests/group-names 2005-10-28 09:55:27.000000000 +0100
|
||||
@@ -18,3 +18,11 @@
|
||||
(exit 77); exit 77
|
||||
;;
|
||||
esac
|
||||
+
|
||||
+set `id -Gn`
|
||||
+if echo "$2" | grep -q '[^0-9]'
|
||||
+then
|
||||
+ exit 0
|
||||
+else
|
||||
+ (exit 77); exit 77
|
||||
+fi
|
@ -1,9 +1,9 @@
|
||||
--- /dev/null 2007-03-01 09:16:39.219409909 +0000
|
||||
+++ coreutils-6.8+/tests/sort/sort-mb-tests 2007-03-01 15:08:24.000000000 +0000
|
||||
+++ coreutils-6.8+/tests/misc/sort-mb-tests 2007-03-01 15:08:24.000000000 +0000
|
||||
@@ -0,0 +1,58 @@
|
||||
+#! /bin/sh
|
||||
+case $# in
|
||||
+ 0) xx='../../src/sort';;
|
||||
+ 0) xx='../src/sort';;
|
||||
+ *) xx="$1";;
|
||||
+esac
|
||||
+test "$VERBOSE" && echo=echo || echo=:
|
||||
@ -16,38 +16,38 @@
|
||||
+locale -k LC_CTYPE 2>&1 | grep -q charmap.*UTF-8 || exit 77
|
||||
+errors=0
|
||||
+
|
||||
+$xx -t @ -k2 -n mb1.I > mb1.O
|
||||
+$xx -t @ -k2 -n misc/mb1.I > misc/mb1.O
|
||||
+code=$?
|
||||
+if test $code != 0; then
|
||||
+ $echo "Test mb1 failed: $xx return code $code differs from expected value 0" 1>&2
|
||||
+ errors=`expr $errors + 1`
|
||||
+else
|
||||
+ cmp mb1.O $srcdir/mb1.X > /dev/null 2>&1
|
||||
+ cmp misc/mb1.O $srcdir/misc/mb1.X > /dev/null 2>&1
|
||||
+ case $? in
|
||||
+ 0) if test "$VERBOSE"; then $echo "passed mb1"; fi;;
|
||||
+ 1) $echo "Test mb1 failed: files mb1.O and $srcdir/mb1.X differ" 1>&2
|
||||
+ (diff -c mb1.O $srcdir/mb1.X) 2> /dev/null
|
||||
+ 1) $echo "Test mb1 failed: files misc/mb1.O and $srcdir/misc/mb1.X differ" 1>&2
|
||||
+ (diff -c misc/mb1.O $srcdir/misc/mb1.X) 2> /dev/null
|
||||
+ errors=`expr $errors + 1`;;
|
||||
+ 2) $echo "Test mb1 may have failed." 1>&2
|
||||
+ $echo The command "cmp mb1.O $srcdir/mb1.X" failed. 1>&2
|
||||
+ $echo The command "cmp misc/mb1.O $srcdir/misc/mb1.X" failed. 1>&2
|
||||
+ errors=`expr $errors + 1`;;
|
||||
+ esac
|
||||
+fi
|
||||
+
|
||||
+$xx -t @ -k4 -n mb2.I > mb2.O
|
||||
+$xx -t @ -k4 -n misc/mb2.I > misc/mb2.O
|
||||
+code=$?
|
||||
+if test $code != 0; then
|
||||
+ $echo "Test mb2 failed: $xx return code $code differs from expected value 0" 1>&2
|
||||
+ errors=`expr $errors + 1`
|
||||
+else
|
||||
+ cmp mb2.O $srcdir/mb2.X > /dev/null 2>&1
|
||||
+ cmp misc/mb2.O $srcdir/misc/mb2.X > /dev/null 2>&1
|
||||
+ case $? in
|
||||
+ 0) if test "$VERBOSE"; then $echo "passed mb2"; fi;;
|
||||
+ 1) $echo "Test mb2 failed: files mb2.O and $srcdir/mb2.X differ" 1>&2
|
||||
+ (diff -c mb2.O $srcdir/mb2.X) 2> /dev/null
|
||||
+ 1) $echo "Test mb2 failed: files misc/mb2.O and $srcdir/misc/mb2.X differ" 1>&2
|
||||
+ (diff -c misc/mb2.O $srcdir/misc/mb2.X) 2> /dev/null
|
||||
+ errors=`expr $errors + 1`;;
|
||||
+ 2) $echo "Test mb2 may have failed." 1>&2
|
||||
+ $echo The command "cmp mb2.O $srcdir/mb2.X" failed. 1>&2
|
||||
+ $echo The command "cmp misc/mb2.O $srcdir/misc/mb2.X" failed. 1>&2
|
||||
+ errors=`expr $errors + 1`;;
|
||||
+ esac
|
||||
+fi
|
||||
@ -60,53 +60,55 @@
|
||||
+test $errors = 0 || errors=1
|
||||
+exit $errors
|
||||
--- /dev/null 2007-03-01 09:16:39.219409909 +0000
|
||||
+++ coreutils-6.8+/tests/sort/mb2.I 2007-03-01 15:08:24.000000000 +0000
|
||||
+++ coreutils-6.8+/tests/misc/mb2.I 2007-03-01 15:08:24.000000000 +0000
|
||||
@@ -0,0 +1,4 @@
|
||||
+Apple@AA10@@20
|
||||
+Banana@AA5@@30
|
||||
+Citrus@AA20@@5
|
||||
+Cherry@AA30@@10
|
||||
--- /dev/null 2007-03-01 09:16:39.219409909 +0000
|
||||
+++ coreutils-6.8+/tests/sort/mb2.X 2007-03-01 15:08:24.000000000 +0000
|
||||
+++ coreutils-6.8+/tests/misc/mb2.X 2007-03-01 15:08:24.000000000 +0000
|
||||
@@ -0,0 +1,4 @@
|
||||
+Citrus@AA20@@5
|
||||
+Cherry@AA30@@10
|
||||
+Apple@AA10@@20
|
||||
+Banana@AA5@@30
|
||||
--- /dev/null 2007-03-01 09:16:39.219409909 +0000
|
||||
+++ coreutils-6.8+/tests/sort/mb1.I 2007-03-01 15:08:24.000000000 +0000
|
||||
+++ coreutils-6.8+/tests/misc/mb1.I 2007-03-01 15:08:24.000000000 +0000
|
||||
@@ -0,0 +1,4 @@
|
||||
+Apple@10
|
||||
+Banana@5
|
||||
+Citrus@20
|
||||
+Cherry@30
|
||||
--- /dev/null 2007-03-01 09:16:39.219409909 +0000
|
||||
+++ coreutils-6.8+/tests/sort/mb1.X 2007-03-01 15:08:24.000000000 +0000
|
||||
+++ coreutils-6.8+/tests/misc/mb1.X 2007-03-01 15:08:24.000000000 +0000
|
||||
@@ -0,0 +1,4 @@
|
||||
+Banana@5
|
||||
+Apple@10
|
||||
+Citrus@20
|
||||
+Cherry@30
|
||||
--- coreutils-6.8+/tests/sort/Makefile.am.i18n 2007-01-24 07:47:37.000000000 +0000
|
||||
+++ coreutils-6.8+/tests/sort/Makefile.am 2007-03-01 15:09:59.000000000 +0000
|
||||
@@ -66,12 +66,14 @@
|
||||
bigfield.O bigfield.E obs-inval.O obs-inval.E realloc-buf.O realloc-buf.E
|
||||
##test-files-end
|
||||
diff -urN coreutils-6.12-orig/tests/Makefile.am coreutils-6.12/tests/Makefile.am
|
||||
--- coreutils-6.12-orig/tests/Makefile.am 2008-05-27 13:47:53.000000000 +0200
|
||||
+++ coreutils-6.12/tests/Makefile.am 2008-06-02 10:06:03.000000000 +0200
|
||||
@@ -191,6 +191,7 @@
|
||||
misc/shuf \
|
||||
misc/sort \
|
||||
misc/sort-compress \
|
||||
+ misc/sort-mb-tests \
|
||||
misc/sort-merge \
|
||||
misc/sort-rand \
|
||||
misc/split-a \
|
||||
@@ -391,6 +392,10 @@
|
||||
$(root_tests)
|
||||
|
||||
-EXTRA_DIST = Test.pm $x-tests $(explicit) $(maint_gen)
|
||||
-noinst_SCRIPTS = $x-tests
|
||||
+run_gen += mb1.0 mb2.0
|
||||
+
|
||||
+EXTRA_DIST = Test.pm $x-tests $(explicit) $(maint_gen) mb1.I mb1.X mb2.I mb2.X
|
||||
+noinst_SCRIPTS = $x-tests # $x-mb-tests
|
||||
|
||||
editpl = sed -e 's,@''PERL''@,$(PERL),g' -e 's,@''srcdir''@,$(srcdir),g'
|
||||
|
||||
-TESTS = $x-tests
|
||||
+TESTS = $x-tests $x-mb-tests
|
||||
|
||||
mk_script = $(srcdir)/../mk-script
|
||||
$(srcdir)/$x-tests: $(mk_script) Test.pm Makefile.am
|
||||
pr_data = \
|
||||
+ misc/mb1.X \
|
||||
+ misc/mb1.I \
|
||||
+ misc/mb2.X \
|
||||
+ misc/mb2.I \
|
||||
pr/0F \
|
||||
pr/0FF \
|
||||
pr/0FFnt \
|
||||
--- coreutils-6.8+/lib/linebuffer.h.i18n 2005-05-14 07:44:24.000000000 +0100
|
||||
+++ coreutils-6.8+/lib/linebuffer.h 2007-03-01 15:08:24.000000000 +0000
|
||||
@@ -22,6 +22,11 @@
|
||||
|
@ -1,116 +0,0 @@
|
||||
|
||||
From 2247d30eac99d1cb80d77b7713ad3e155dbd90c9 Mon Sep 17 00:00:00 2001
|
||||
From: =?utf-8?q?Ond=C5=99ej=20Va=C5=A1=C3=ADk?= <ovasik@redhat.com>
|
||||
Date: Wed, 23 Apr 2008 12:38:54 +0200
|
||||
Subject: [PATCH] id will now show selinux context only when used without specified user
|
||||
|
||||
* NEWS: Mention new behaviour
|
||||
* src/id.c: Tiny change to not show SELinux context when user is specified.
|
||||
* tests/misc/Makefile.am: List new test
|
||||
* tests/misc/id-context : Test for id program which checks if SELinux
|
||||
is displayed where it should be.
|
||||
Problem reported by Ronny Buchmann in http://bugzilla.redhat.com/443485.
|
||||
|
||||
Signed-off-by: Ondřej Vašík <ovasik@redhat.com>
|
||||
Signed-off-by: Jim Meyering <meyering@redhat.com>
|
||||
---
|
||||
NEWS | 4 ++++
|
||||
src/id.c | 10 +++++-----
|
||||
tests/Makefile.am | 1 +
|
||||
tests/misc/id-context | 36 +++++++++++++++++++++++++++++++++++++
|
||||
4 files changed, 46 insertions(+), 5 deletions(-)
|
||||
create mode 100755 tests/misc/id-context
|
||||
|
||||
diff --git a/NEWS b/NEWS
|
||||
index 04893c6..ef3feda 100644
|
||||
--- a/NEWS
|
||||
+++ b/NEWS
|
||||
@@ -75,6 +75,10 @@ GNU coreutils NEWS -*- outline -*-
|
||||
id and groups work around an AFS-related bug whereby those programs
|
||||
would print an invalid group number, when given no user-name argument.
|
||||
|
||||
+ id will now show selinux context only when used without specified
|
||||
+ user. Showing SELinux context of user who executed id command could
|
||||
+ be misleading.
|
||||
+
|
||||
ls --color no longer outputs unnecessary escape sequences
|
||||
|
||||
seq gives better diagnostics for invalid formats.
|
||||
diff --git a/src/id.c b/src/id.c
|
||||
index a178714..cbf75a5 100644
|
||||
--- a/src/id.c
|
||||
+++ b/src/id.c
|
||||
@@ -179,11 +179,11 @@ main (int argc, char **argv)
|
||||
cannot display context when selinux not enabled or when displaying the id\n\
|
||||
of a different user"));
|
||||
|
||||
- /* If we are on a selinux-enabled kernel, get our context.
|
||||
- Otherwise, leave the context variable alone - it has
|
||||
- been initialized known invalid value; if we see this invalid
|
||||
- value later, we will know we are on a non-selinux kernel. */
|
||||
- if (selinux_enabled)
|
||||
+ /* If we are on a selinux-enabled kernel and no user is specified,
|
||||
+ get our context. Otherwise, leave the context variable alone -
|
||||
+ it has been initialized known invalid value and will be not
|
||||
+ displayed in print_full_info() */
|
||||
+ if (selinux_enabled && argc == optind)
|
||||
{
|
||||
if (getcon (&context) && just_context)
|
||||
error (EXIT_FAILURE, 0, _("can't get process context"));
|
||||
diff --git a/tests/misc/Makefile.am b/tests/misc/Makefile.am
|
||||
index 3e491be..3658a02 100644
|
||||
--- a/tests/misc/Makefile.am
|
||||
+++ b/tests/misc/Makefile.am
|
||||
@@ -69,6 +69,7 @@ TESTS = \
|
||||
groups-version \
|
||||
head-c \
|
||||
head-pos \
|
||||
+ id-context \
|
||||
md5sum \
|
||||
md5sum-newline \
|
||||
mknod \
|
||||
diff --git a/tests/misc/id-context b/tests/misc/id-context
|
||||
new file mode 100755
|
||||
index 0000000..1bb830c
|
||||
--- /dev/null
|
||||
+++ b/tests/misc/id-context
|
||||
@@ -0,0 +1,36 @@
|
||||
+#!/bin/sh
|
||||
+# Ensure that "id" outputs SELinux context only without specified user
|
||||
+# Copyright (C) 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software: you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation, either version 3 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+if test "$VERBOSE" = yes; then
|
||||
+ set -x
|
||||
+ id --version
|
||||
+fi
|
||||
+
|
||||
+. $top_srcdir/tests/test-lib.sh
|
||||
+# Require selinux - when selinux is disabled, id never prints scontext
|
||||
+require_selinux_
|
||||
+
|
||||
+fail=0
|
||||
+
|
||||
+#check without specified user, context string should be present
|
||||
+id | grep context= >/dev/null || fail=1
|
||||
+
|
||||
+#check with specified user, no context string should be present
|
||||
+# But if the current user is nameless, skip this part.
|
||||
+id -nu > /dev/null && id $(id -nu) | grep "context=" >/dev/null && fail=1
|
||||
+
|
||||
+(exit $fail); exit $fail
|
||||
--
|
||||
1.5.2.2
|
||||
|
@ -498,28 +498,6 @@ diff -urp coreutils-6.10-orig/src/install.c coreutils-6.10/src/install.c
|
||||
x->recursive = false;
|
||||
x->sparse_mode = SPARSE_AUTO;
|
||||
x->symbolic_link = false;
|
||||
@@ -199,7 +199,6 @@ cp_option_init (struct cp_options *x)
|
||||
x->src_info = NULL;
|
||||
}
|
||||
|
||||
-#ifdef ENABLE_WHEN_MATCHPATHCON_IS_MORE_EFFICIENT
|
||||
/* Modify file context to match the specified policy.
|
||||
If an error occurs the file will remain with the default directory
|
||||
context. */
|
||||
@@ -266,13 +265,6 @@ setdefaultfilecon (char const *file)
|
||||
freecon (scontext);
|
||||
return;
|
||||
}
|
||||
-#else
|
||||
-static void
|
||||
-setdefaultfilecon (char const *file)
|
||||
-{
|
||||
- (void) file;
|
||||
-}
|
||||
-#endif
|
||||
|
||||
/* FILE is the last operand of this command. Return true if FILE is a
|
||||
directory. But report an error there is a problem accessing FILE,
|
||||
@@ -346,7 +338,7 @@ main (int argc, char **argv)
|
||||
we'll actually use backup_suffix_string. */
|
||||
backup_suffix_string = getenv ("SIMPLE_BACKUP_SUFFIX");
|
||||
|
@ -1,34 +0,0 @@
|
||||
diff -urNp coreutils-6.11-orig/tests/cp/thru-dangling coreutils-6.11/tests/cp/thru-dangling
|
||||
--- coreutils-6.11-orig/tests/cp/thru-dangling 2008-04-19 23:34:23.000000000 +0200
|
||||
+++ coreutils-6.11/tests/cp/thru-dangling 2008-04-23 16:52:30.000000000 +0200
|
||||
@@ -21,6 +21,7 @@ if test "$VERBOSE" = yes; then
|
||||
cp --version
|
||||
fi
|
||||
|
||||
+. $srcdir/../lang-default
|
||||
. $srcdir/../test-lib.sh
|
||||
|
||||
ln -s no-such dangle || framework_failure
|
||||
diff -urNp coreutils-6.11-orig/tests/chmod/thru-dangling coreutils-6.11/tests/chmod/thru-dangling
|
||||
--- coreutils-6.11-orig/tests/chmod/thru-dangling 2008-04-19 23:34:23.000000000 +0200
|
||||
+++ coreutils-6.11/tests/chmod/thru-dangling 2008-04-23 16:52:05.000000000 +0200
|
||||
@@ -21,6 +21,7 @@ if test "$VERBOSE" = yes; then
|
||||
chmod --version
|
||||
fi
|
||||
|
||||
+. $srcdir/../lang-default
|
||||
. $srcdir/../test-lib.sh
|
||||
|
||||
ln -s non-existent dangle || framework_failure
|
||||
diff -urNp coreutils-6.11-orig/tests/misc/printf-surprise coreutils-6.11/tests/misc/printf-surprise
|
||||
--- coreutils-6.11-orig/tests/misc/printf-surprise 2008-04-19 23:34:23.000000000 +0200
|
||||
+++ coreutils-6.11/tests/misc/printf-surprise 2008-04-23 16:53:09.000000000 +0200
|
||||
@@ -23,6 +23,8 @@ if test "$VERBOSE" = yes; then
|
||||
"$prog" --version
|
||||
fi
|
||||
|
||||
+
|
||||
+. $srcdir/../lang-default
|
||||
. $srcdir/../test-lib.sh
|
||||
require_ulimit_
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: The GNU core utilities: a set of tools commonly used in shell scripts
|
||||
Name: coreutils
|
||||
Version: 6.11
|
||||
Release: 5%{?dist}
|
||||
Version: 6.12
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: System Environment/Base
|
||||
Url: http://www.gnu.org/software/coreutils/
|
||||
@ -20,13 +20,10 @@ Source203: coreutils-runuser-l.pamd
|
||||
# From upstream
|
||||
|
||||
# Our patches
|
||||
Patch100: coreutils-chgrp.patch
|
||||
Patch101: coreutils-6.10-configuration.patch
|
||||
Patch102: coreutils-6.10-manpages.patch
|
||||
#Patch103: coreutils-6.10-longoptions.patch
|
||||
Patch104: coreutils-idcontext.patch
|
||||
Patch105: coreutils-testnonenglish.patch
|
||||
Patch106: coreutils-6.11-sparc-shafix.patch
|
||||
Patch100: coreutils-6.10-configuration.patch
|
||||
Patch101: coreutils-6.10-manpages.patch
|
||||
#Patch102: coreutils-6.10-longoptions.patch
|
||||
Patch103: coreutils-6.11-sparc-shafix.patch
|
||||
|
||||
# sh-utils
|
||||
Patch703: sh-utils-2.0.11-dateman.patch
|
||||
@ -102,13 +99,10 @@ cd %name-%version
|
||||
# From upstream
|
||||
|
||||
# Our patches
|
||||
%patch100 -p1 -b .chgrp
|
||||
%patch101 -p1 -b .configure
|
||||
%patch102 -p1 -b .manpages
|
||||
#%patch103 -p1 -b .longopt
|
||||
%patch104 -p1 -b .idcontext
|
||||
%patch105 -p1 -b .noneng
|
||||
%patch106 -p1 -b .sparc
|
||||
%patch100 -p1 -b .configure
|
||||
%patch101 -p1 -b .manpages
|
||||
#%patch102 -p1 -b .longopt
|
||||
%patch103 -p1 -b .sparc
|
||||
|
||||
# sh-utils
|
||||
%patch703 -p1 -b .dateman
|
||||
@ -131,10 +125,9 @@ cd %name-%version
|
||||
#SELinux
|
||||
%patch950 -p1 -b .selinux
|
||||
%patch951 -p1 -b .selinuxman
|
||||
%patch952 -p1 -b .matchcon
|
||||
|
||||
|
||||
chmod a+x tests/sort/sort-mb-tests
|
||||
chmod a+x tests/misc/sort-mb-tests
|
||||
chmod a+x tests/misc/id-context
|
||||
|
||||
#fix typos/mistakes in localized documentation(#439410, #440056)
|
||||
@ -153,7 +146,7 @@ export CFLAGS="$RPM_OPT_FLAGS -fPIC -O1"
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fpic"
|
||||
%endif
|
||||
%{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
|
||||
touch aclocal.m4 configure config.hin Makefile.in */Makefile.in */*/Makefile.in
|
||||
touch aclocal.m4 configure config.hin Makefile.in */Makefile.in
|
||||
aclocal -I m4
|
||||
autoconf --force
|
||||
automake --copy --add-missing
|
||||
@ -312,6 +305,9 @@ fi
|
||||
/sbin/runuser
|
||||
|
||||
%changelog
|
||||
* Mon Jun 02 2008 Ondrej Vasik <ovasik@redhat.com> - 6.12-1
|
||||
- New upstream release 6.12, adapted patches
|
||||
|
||||
* Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 6.11-5
|
||||
- fix SHA256/SHA512 to work on sparc
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user