make mv xattr support failures silent (as is done for cp -a) - #496142
This commit is contained in:
parent
1ef0ec681f
commit
187c0782af
12
coreutils-silentmv.patch
Normal file
12
coreutils-silentmv.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -urNp coreutils-7.2-orig/src/mv.c coreutils-7.2/src/mv.c
|
||||||
|
--- coreutils-7.2-orig/src/mv.c 2009-04-17 11:48:39.000000000 +0200
|
||||||
|
+++ coreutils-7.2/src/mv.c 2009-04-17 11:49:17.000000000 +0200
|
||||||
|
@@ -117,7 +117,7 @@ cp_option_init (struct cp_options *x)
|
||||||
|
x->preserve_timestamps = true;
|
||||||
|
x->preserve_security_context = selinux_enabled;
|
||||||
|
x->set_security_context = false;
|
||||||
|
- x->reduce_diagnostics = false;
|
||||||
|
+ x->reduce_diagnostics = true;
|
||||||
|
x->require_preserve = false; /* FIXME: maybe make this an option */
|
||||||
|
x->require_preserve_context = false;
|
||||||
|
x->preserve_xattr = true;
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||||
Name: coreutils
|
Name: coreutils
|
||||||
Version: 7.2
|
Version: 7.2
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.gnu.org/software/coreutils/
|
Url: http://www.gnu.org/software/coreutils/
|
||||||
@ -49,6 +49,9 @@ Patch916: coreutils-getfacl-exit-code.patch
|
|||||||
Patch950: coreutils-selinux.patch
|
Patch950: coreutils-selinux.patch
|
||||||
Patch951: coreutils-selinuxmanpages.patch
|
Patch951: coreutils-selinuxmanpages.patch
|
||||||
|
|
||||||
|
Patch960: coreutils-silentmv.patch
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: libselinux-devel >= 1.25.6-1
|
BuildRequires: libselinux-devel >= 1.25.6-1
|
||||||
BuildRequires: libacl-devel
|
BuildRequires: libacl-devel
|
||||||
BuildRequires: gettext bison
|
BuildRequires: gettext bison
|
||||||
@ -124,6 +127,8 @@ the old GNU fileutils, sh-utils, and textutils packages.
|
|||||||
%patch950 -p1 -b .selinux
|
%patch950 -p1 -b .selinux
|
||||||
%patch951 -p1 -b .selinuxman
|
%patch951 -p1 -b .selinuxman
|
||||||
|
|
||||||
|
%patch960 -p1 -b .silentmv
|
||||||
|
|
||||||
chmod a+x tests/misc/sort-mb-tests
|
chmod a+x tests/misc/sort-mb-tests
|
||||||
|
|
||||||
sed -i 's/1.10a/1.10.1/' configure.ac
|
sed -i 's/1.10a/1.10.1/' configure.ac
|
||||||
@ -309,6 +314,10 @@ fi
|
|||||||
/sbin/runuser
|
/sbin/runuser
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 17 2009 Ondrej Vasik <ovasik@redhat.com> 7.2-2
|
||||||
|
- make mv xattr support failures silent (as is done for
|
||||||
|
cp -a) - #496142
|
||||||
|
|
||||||
* Tue Mar 31 2009 Ondrej Vasik <ovasik@redhat.com> 7.2-1
|
* Tue Mar 31 2009 Ondrej Vasik <ovasik@redhat.com> 7.2-1
|
||||||
- New upstream bugfix release 7.2
|
- New upstream bugfix release 7.2
|
||||||
- removed applied patches
|
- removed applied patches
|
||||||
|
Loading…
Reference in New Issue
Block a user