new upstream release coreutils-8.10
This commit is contained in:
parent
b3f814c1b6
commit
16cfab74f0
@ -1,6 +1,6 @@
|
||||
diff -urNp coreutils-8.9-orig/lib/linebuffer.h coreutils-8.9/lib/linebuffer.h
|
||||
--- coreutils-8.9-orig/lib/linebuffer.h 2011-01-01 22:19:27.000000000 +0100
|
||||
+++ coreutils-8.9/lib/linebuffer.h 2011-01-04 17:41:55.358888521 +0100
|
||||
diff -urNp coreutils-8.10-orig/lib/linebuffer.h coreutils-8.10/lib/linebuffer.h
|
||||
--- coreutils-8.10-orig/lib/linebuffer.h 2011-01-06 09:47:56.000000000 +0100
|
||||
+++ coreutils-8.10/lib/linebuffer.h 2011-02-04 20:13:23.985464731 +0100
|
||||
@@ -21,6 +21,11 @@
|
||||
|
||||
# include <stdio.h>
|
||||
@ -23,9 +23,9 @@ diff -urNp coreutils-8.9-orig/lib/linebuffer.h coreutils-8.9/lib/linebuffer.h
|
||||
};
|
||||
|
||||
/* Initialize linebuffer LINEBUFFER for use. */
|
||||
diff -urNp coreutils-8.9-orig/src/cut.c coreutils-8.9/src/cut.c
|
||||
--- coreutils-8.9-orig/src/cut.c 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/src/cut.c 2011-01-04 17:41:55.361888730 +0100
|
||||
diff -urNp coreutils-8.10-orig/src/cut.c coreutils-8.10/src/cut.c
|
||||
--- coreutils-8.10-orig/src/cut.c 2011-01-31 13:40:38.000000000 +0100
|
||||
+++ coreutils-8.10/src/cut.c 2011-02-04 20:13:23.988464025 +0100
|
||||
@@ -28,6 +28,11 @@
|
||||
#include <assert.h>
|
||||
#include <getopt.h>
|
||||
@ -616,9 +616,9 @@ diff -urNp coreutils-8.9-orig/src/cut.c coreutils-8.9/src/cut.c
|
||||
}
|
||||
|
||||
if (optind == argc)
|
||||
diff -urNp coreutils-8.9-orig/src/expand.c coreutils-8.9/src/expand.c
|
||||
--- coreutils-8.9-orig/src/expand.c 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/src/expand.c 2011-01-04 17:41:55.363905562 +0100
|
||||
diff -urNp coreutils-8.10-orig/src/expand.c coreutils-8.10/src/expand.c
|
||||
--- coreutils-8.10-orig/src/expand.c 2011-01-31 13:40:38.000000000 +0100
|
||||
+++ coreutils-8.10/src/expand.c 2011-02-04 20:13:23.990463571 +0100
|
||||
@@ -38,12 +38,29 @@
|
||||
#include <stdio.h>
|
||||
#include <getopt.h>
|
||||
@ -806,9 +806,9 @@ diff -urNp coreutils-8.9-orig/src/expand.c coreutils-8.9/src/expand.c
|
||||
|
||||
if (have_read_stdin && fclose (stdin) != 0)
|
||||
error (EXIT_FAILURE, errno, "-");
|
||||
diff -urNp coreutils-8.9-orig/src/fold.c coreutils-8.9/src/fold.c
|
||||
--- coreutils-8.9-orig/src/fold.c 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/src/fold.c 2011-01-04 17:41:55.366888520 +0100
|
||||
diff -urNp coreutils-8.10-orig/src/fold.c coreutils-8.10/src/fold.c
|
||||
--- coreutils-8.10-orig/src/fold.c 2011-01-31 13:40:38.000000000 +0100
|
||||
+++ coreutils-8.10/src/fold.c 2011-02-04 20:13:23.992463115 +0100
|
||||
@@ -22,12 +22,34 @@
|
||||
#include <getopt.h>
|
||||
#include <sys/types.h>
|
||||
@ -1207,9 +1207,9 @@ diff -urNp coreutils-8.9-orig/src/fold.c coreutils-8.9/src/fold.c
|
||||
break;
|
||||
|
||||
case 's': /* Break at word boundaries. */
|
||||
diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
--- coreutils-8.9-orig/src/join.c 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/src/join.c 2011-01-04 17:41:55.369888660 +0100
|
||||
diff -urNp coreutils-8.10-orig/src/join.c coreutils-8.10/src/join.c
|
||||
--- coreutils-8.10-orig/src/join.c 2011-01-31 13:40:38.000000000 +0100
|
||||
+++ coreutils-8.10/src/join.c 2011-02-04 20:20:15.985114387 +0100
|
||||
@@ -22,18 +22,32 @@
|
||||
#include <sys/types.h>
|
||||
#include <getopt.h>
|
||||
@ -1244,7 +1244,7 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
/* The official name of this program (e.g., no `g' prefix). */
|
||||
#define PROGRAM_NAME "join"
|
||||
|
||||
@@ -122,10 +136,12 @@ static struct outlist outlist_head;
|
||||
@@ -129,10 +143,12 @@ static struct outlist outlist_head;
|
||||
/* Last element in `outlist', where a new element can be added. */
|
||||
static struct outlist *outlist_end = &outlist_head;
|
||||
|
||||
@ -1261,7 +1261,7 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
|
||||
/* If nonzero, check that the input is correctly ordered. */
|
||||
static enum
|
||||
@@ -249,13 +265,14 @@ xfields (struct line *line)
|
||||
@@ -257,13 +273,14 @@ xfields (struct line *line)
|
||||
if (ptr == lim)
|
||||
return;
|
||||
|
||||
@ -1279,7 +1279,7 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
{
|
||||
/* Skip leading blanks before the first field. */
|
||||
while (isblank (to_uchar (*ptr)))
|
||||
@@ -279,6 +296,148 @@ xfields (struct line *line)
|
||||
@@ -287,6 +304,148 @@ xfields (struct line *line)
|
||||
extract_field (line, ptr, lim - ptr);
|
||||
}
|
||||
|
||||
@ -1428,7 +1428,7 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
static void
|
||||
freeline (struct line *line)
|
||||
{
|
||||
@@ -300,56 +459,115 @@ keycmp (struct line const *line1, struct
|
||||
@@ -308,56 +467,115 @@ keycmp (struct line const *line1, struct
|
||||
size_t jf_1, size_t jf_2)
|
||||
{
|
||||
/* Start of field to compare in each file. */
|
||||
@ -1567,7 +1567,7 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
}
|
||||
|
||||
/* Check that successive input lines PREV and CURRENT from input file
|
||||
@@ -430,6 +648,11 @@ get_line (FILE *fp, struct line **linep,
|
||||
@@ -438,6 +656,11 @@ get_line (FILE *fp, struct line **linep,
|
||||
return false;
|
||||
}
|
||||
|
||||
@ -1579,9 +1579,9 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
xfields (line);
|
||||
|
||||
if (prevline[which - 1])
|
||||
@@ -529,11 +752,18 @@ prfield (size_t n, struct line const *li
|
||||
@@ -537,21 +760,28 @@ prfield (size_t n, struct line const *li
|
||||
|
||||
/* Print the join of LINE1 and LINE2. */
|
||||
/* Output all the fields in line, other than the join field. */
|
||||
|
||||
+#define PUT_TAB_CHAR \
|
||||
+ do \
|
||||
@ -1589,17 +1589,37 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
+ (tab != NULL) ? \
|
||||
+ fwrite(tab, sizeof(char), tablen, stdout) : putchar (' '); \
|
||||
+ } \
|
||||
+ while (0)
|
||||
+ while (0)
|
||||
+
|
||||
static void
|
||||
prfields (struct line const *line, size_t join_field, size_t autocount)
|
||||
{
|
||||
size_t i;
|
||||
size_t nfields = autoformat ? autocount : line->nfields;
|
||||
- char output_separator = tab < 0 ? ' ' : tab;
|
||||
|
||||
for (i = 0; i < join_field && i < nfields; ++i)
|
||||
{
|
||||
- putchar (output_separator);
|
||||
+ PUT_TAB_CHAR;
|
||||
prfield (i, line);
|
||||
}
|
||||
for (i = join_field + 1; i < nfields; ++i)
|
||||
{
|
||||
- putchar (output_separator);
|
||||
+ PUT_TAB_CHAR;
|
||||
prfield (i, line);
|
||||
}
|
||||
}
|
||||
@@ -562,7 +792,6 @@ static void
|
||||
prjoin (struct line const *line1, struct line const *line2)
|
||||
{
|
||||
const struct outlist *outlist;
|
||||
- char output_separator = tab < 0 ? ' ' : tab;
|
||||
size_t field;
|
||||
struct line const *line;
|
||||
|
||||
outlist = outlist_head.next;
|
||||
if (outlist)
|
||||
@@ -568,7 +798,7 @@ prjoin (struct line const *line1, struct
|
||||
@@ -596,7 +825,7 @@ prjoin (struct line const *line1, struct
|
||||
o = o->next;
|
||||
if (o == NULL)
|
||||
break;
|
||||
@ -1608,35 +1628,7 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
}
|
||||
putchar ('\n');
|
||||
}
|
||||
@@ -586,23 +816,23 @@ prjoin (struct line const *line1, struct
|
||||
prfield (join_field_1, line1);
|
||||
for (i = 0; i < join_field_1 && i < line1->nfields; ++i)
|
||||
{
|
||||
- putchar (output_separator);
|
||||
+ PUT_TAB_CHAR;
|
||||
prfield (i, line1);
|
||||
}
|
||||
for (i = join_field_1 + 1; i < line1->nfields; ++i)
|
||||
{
|
||||
- putchar (output_separator);
|
||||
+ PUT_TAB_CHAR;
|
||||
prfield (i, line1);
|
||||
}
|
||||
|
||||
for (i = 0; i < join_field_2 && i < line2->nfields; ++i)
|
||||
{
|
||||
- putchar (output_separator);
|
||||
+ PUT_TAB_CHAR;
|
||||
prfield (i, line2);
|
||||
}
|
||||
for (i = join_field_2 + 1; i < line2->nfields; ++i)
|
||||
{
|
||||
- putchar (output_separator);
|
||||
+ PUT_TAB_CHAR;
|
||||
prfield (i, line2);
|
||||
}
|
||||
putchar ('\n');
|
||||
@@ -1043,21 +1273,46 @@ main (int argc, char **argv)
|
||||
@@ -1075,21 +1304,46 @@ main (int argc, char **argv)
|
||||
|
||||
case 't':
|
||||
{
|
||||
@ -1692,9 +1684,9 @@ diff -urNp coreutils-8.9-orig/src/join.c coreutils-8.9/src/join.c
|
||||
break;
|
||||
|
||||
case NOCHECK_ORDER_OPTION:
|
||||
diff -urNp coreutils-8.9-orig/src/pr.c coreutils-8.9/src/pr.c
|
||||
--- coreutils-8.9-orig/src/pr.c 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/src/pr.c 2011-01-04 17:41:55.377138275 +0100
|
||||
diff -urNp coreutils-8.10-orig/src/pr.c coreutils-8.10/src/pr.c
|
||||
--- coreutils-8.10-orig/src/pr.c 2011-01-31 13:40:38.000000000 +0100
|
||||
+++ coreutils-8.10/src/pr.c 2011-02-04 20:13:24.002460897 +0100
|
||||
@@ -312,6 +312,32 @@
|
||||
|
||||
#include <getopt.h>
|
||||
@ -2417,9 +2409,9 @@ diff -urNp coreutils-8.9-orig/src/pr.c coreutils-8.9/src/pr.c
|
||||
/* We've just printed some files and need to clean up things before
|
||||
looking for more options and printing the next batch of files.
|
||||
|
||||
diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
--- coreutils-8.9-orig/src/sort.c 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/src/sort.c 2011-01-04 17:41:55.384888730 +0100
|
||||
diff -urNp coreutils-8.10-orig/src/sort.c coreutils-8.10/src/sort.c
|
||||
--- coreutils-8.10-orig/src/sort.c 2011-02-03 11:24:35.000000000 +0100
|
||||
+++ coreutils-8.10/src/sort.c 2011-02-04 20:15:44.160384535 +0100
|
||||
@@ -22,11 +22,20 @@
|
||||
|
||||
#include <config.h>
|
||||
@ -2973,7 +2965,7 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
{
|
||||
size_t lo = 0;
|
||||
size_t hi = MONTHS_PER_YEAR;
|
||||
@@ -2209,13 +2572,12 @@ debug_key (struct line const *line, stru
|
||||
@@ -2209,15 +2572,14 @@ debug_key (struct line const *line, stru
|
||||
char saved = *lim;
|
||||
*lim = '\0';
|
||||
|
||||
@ -2983,13 +2975,15 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
|
||||
char *tighter_lim = beg;
|
||||
|
||||
if (key->month)
|
||||
if (lim < beg)
|
||||
tighter_lim = lim;
|
||||
else if (key->month)
|
||||
- getmonth (beg, &tighter_lim);
|
||||
+ getmonth (beg, lim-beg, &tighter_lim);
|
||||
else if (key->general_numeric)
|
||||
ignore_value (strtold (beg, &tighter_lim));
|
||||
else if (key->numeric || key->human_numeric)
|
||||
@@ -2359,7 +2721,7 @@ key_warnings (struct keyfield const *gke
|
||||
@@ -2361,7 +2723,7 @@ key_warnings (struct keyfield const *gke
|
||||
bool maybe_space_aligned = !hard_LC_COLLATE && default_key_compare (key)
|
||||
&& !(key->schar || key->echar);
|
||||
bool line_offset = key->eword == 0 && key->echar != 0; /* -k1.x,1.y */
|
||||
@ -2998,7 +2992,7 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
&& ((!key->skipsblanks && !(implicit_skip || maybe_space_aligned))
|
||||
|| (!key->skipsblanks && key->schar)
|
||||
|| (!key->skipeblanks && key->echar)))
|
||||
@@ -2417,11 +2779,83 @@ key_warnings (struct keyfield const *gke
|
||||
@@ -2419,11 +2781,83 @@ key_warnings (struct keyfield const *gke
|
||||
error (0, 0, _("option `-r' only applies to last-resort comparison"));
|
||||
}
|
||||
|
||||
@ -3083,7 +3077,7 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
{
|
||||
struct keyfield *key = keylist;
|
||||
|
||||
@@ -2506,7 +2940,7 @@ keycompare (struct line const *a, struct
|
||||
@@ -2508,7 +2942,7 @@ keycompare (struct line const *a, struct
|
||||
else if (key->human_numeric)
|
||||
diff = human_numcompare (ta, tb);
|
||||
else if (key->month)
|
||||
@ -3092,7 +3086,7 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
else if (key->random)
|
||||
diff = compare_random (ta, tlena, tb, tlenb);
|
||||
else if (key->version)
|
||||
@@ -2622,6 +3056,179 @@ keycompare (struct line const *a, struct
|
||||
@@ -2624,6 +3058,179 @@ keycompare (struct line const *a, struct
|
||||
return key->reverse ? -diff : diff;
|
||||
}
|
||||
|
||||
@ -3272,7 +3266,7 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
/* Compare two lines A and B, returning negative, zero, or positive
|
||||
depending on whether A compares less than, equal to, or greater than B. */
|
||||
|
||||
@@ -4084,7 +4691,7 @@ main (int argc, char **argv)
|
||||
@@ -4087,7 +4694,7 @@ main (int argc, char **argv)
|
||||
initialize_exit_failure (SORT_FAILURE);
|
||||
|
||||
hard_LC_COLLATE = hard_locale (LC_COLLATE);
|
||||
@ -3281,7 +3275,7 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
hard_LC_TIME = hard_locale (LC_TIME);
|
||||
#endif
|
||||
|
||||
@@ -4105,6 +4712,29 @@ main (int argc, char **argv)
|
||||
@@ -4108,6 +4715,29 @@ main (int argc, char **argv)
|
||||
thousands_sep = -1;
|
||||
}
|
||||
|
||||
@ -3311,7 +3305,7 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
have_read_stdin = false;
|
||||
inittables ();
|
||||
|
||||
@@ -4375,13 +5005,34 @@ main (int argc, char **argv)
|
||||
@@ -4378,13 +5008,34 @@ main (int argc, char **argv)
|
||||
|
||||
case 't':
|
||||
{
|
||||
@ -3350,7 +3344,7 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
else
|
||||
{
|
||||
/* Provoke with `sort -txx'. Complain about
|
||||
@@ -4392,9 +5043,12 @@ main (int argc, char **argv)
|
||||
@@ -4395,9 +5046,12 @@ main (int argc, char **argv)
|
||||
quote (optarg));
|
||||
}
|
||||
}
|
||||
@ -3365,9 +3359,9 @@ diff -urNp coreutils-8.9-orig/src/sort.c coreutils-8.9/src/sort.c
|
||||
}
|
||||
break;
|
||||
|
||||
diff -urNp coreutils-8.9-orig/src/unexpand.c coreutils-8.9/src/unexpand.c
|
||||
--- coreutils-8.9-orig/src/unexpand.c 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/src/unexpand.c 2011-01-04 17:41:55.387888171 +0100
|
||||
diff -urNp coreutils-8.10-orig/src/unexpand.c coreutils-8.10/src/unexpand.c
|
||||
--- coreutils-8.10-orig/src/unexpand.c 2011-01-31 13:40:38.000000000 +0100
|
||||
+++ coreutils-8.10/src/unexpand.c 2011-02-04 20:13:24.015458014 +0100
|
||||
@@ -39,12 +39,29 @@
|
||||
#include <stdio.h>
|
||||
#include <getopt.h>
|
||||
@ -3621,9 +3615,9 @@ diff -urNp coreutils-8.9-orig/src/unexpand.c coreutils-8.9/src/unexpand.c
|
||||
|
||||
if (have_read_stdin && fclose (stdin) != 0)
|
||||
error (EXIT_FAILURE, errno, "-");
|
||||
diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
--- coreutils-8.9-orig/src/uniq.c 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/src/uniq.c 2011-01-04 17:41:55.391888381 +0100
|
||||
diff -urNp coreutils-8.10-orig/src/uniq.c coreutils-8.10/src/uniq.c
|
||||
--- coreutils-8.10-orig/src/uniq.c 2011-01-31 13:40:38.000000000 +0100
|
||||
+++ coreutils-8.10/src/uniq.c 2011-02-04 20:13:24.018457349 +0100
|
||||
@@ -21,6 +21,16 @@
|
||||
#include <getopt.h>
|
||||
#include <sys/types.h>
|
||||
@ -3682,7 +3676,7 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
{
|
||||
size_t count;
|
||||
char const *lp = line->buffer;
|
||||
@@ -228,6 +254,83 @@ find_field (struct linebuffer const *lin
|
||||
@@ -227,6 +253,83 @@ find_field (struct linebuffer const *lin
|
||||
return line->buffer + i;
|
||||
}
|
||||
|
||||
@ -3766,7 +3760,7 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
/* Return false if two strings OLD and NEW match, true if not.
|
||||
OLD and NEW point not to the beginnings of the lines
|
||||
but rather to the beginnings of the fields to compare.
|
||||
@@ -236,6 +339,8 @@ find_field (struct linebuffer const *lin
|
||||
@@ -235,6 +338,8 @@ find_field (struct linebuffer const *lin
|
||||
static bool
|
||||
different (char *old, char *new, size_t oldlen, size_t newlen)
|
||||
{
|
||||
@ -3775,7 +3769,7 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
if (check_chars < oldlen)
|
||||
oldlen = check_chars;
|
||||
if (check_chars < newlen)
|
||||
@@ -243,14 +348,92 @@ different (char *old, char *new, size_t
|
||||
@@ -242,14 +347,92 @@ different (char *old, char *new, size_t
|
||||
|
||||
if (ignore_case)
|
||||
{
|
||||
@ -3873,7 +3867,7 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
|
||||
/* Output the line in linebuffer LINE to standard output
|
||||
provided that the switches say it should be output.
|
||||
@@ -306,15 +489,43 @@ check_file (const char *infile, const ch
|
||||
@@ -305,15 +488,43 @@ check_file (const char *infile, const ch
|
||||
{
|
||||
char *prevfield IF_LINT ( = NULL);
|
||||
size_t prevlen IF_LINT ( = 0);
|
||||
@ -3917,7 +3911,7 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
if (prevline->length == 0
|
||||
|| different (thisfield, prevfield, thislen, prevlen))
|
||||
{
|
||||
@@ -333,17 +544,26 @@ check_file (const char *infile, const ch
|
||||
@@ -332,17 +543,26 @@ check_file (const char *infile, const ch
|
||||
size_t prevlen;
|
||||
uintmax_t match_count = 0;
|
||||
bool first_delimiter = true;
|
||||
@ -3944,7 +3938,7 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
if (readlinebuffer_delim (thisline, stdin, delimiter) == 0)
|
||||
{
|
||||
if (ferror (stdin))
|
||||
@@ -352,6 +572,15 @@ check_file (const char *infile, const ch
|
||||
@@ -351,6 +571,15 @@ check_file (const char *infile, const ch
|
||||
}
|
||||
thisfield = find_field (thisline);
|
||||
thislen = thisline->length - 1 - (thisfield - thisline->buffer);
|
||||
@ -3960,7 +3954,7 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
match = !different (thisfield, prevfield, thislen, prevlen);
|
||||
match_count += match;
|
||||
|
||||
@@ -384,6 +613,9 @@ check_file (const char *infile, const ch
|
||||
@@ -383,6 +612,9 @@ check_file (const char *infile, const ch
|
||||
SWAP_LINES (prevline, thisline);
|
||||
prevfield = thisfield;
|
||||
prevlen = thislen;
|
||||
@ -3970,7 +3964,7 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
if (!match)
|
||||
match_count = 0;
|
||||
}
|
||||
@@ -429,6 +661,19 @@ main (int argc, char **argv)
|
||||
@@ -428,6 +660,19 @@ main (int argc, char **argv)
|
||||
|
||||
atexit (close_stdout);
|
||||
|
||||
@ -3990,10 +3984,10 @@ diff -urNp coreutils-8.9-orig/src/uniq.c coreutils-8.9/src/uniq.c
|
||||
skip_chars = 0;
|
||||
skip_fields = 0;
|
||||
check_chars = SIZE_MAX;
|
||||
diff -urNp coreutils-8.9-orig/tests/Makefile.am coreutils-8.9/tests/Makefile.am
|
||||
--- coreutils-8.9-orig/tests/Makefile.am 2011-01-04 17:41:12.682173268 +0100
|
||||
+++ coreutils-8.9/tests/Makefile.am 2011-01-04 17:41:55.392900534 +0100
|
||||
@@ -233,6 +233,7 @@ TESTS = \
|
||||
diff -urNp coreutils-8.10-orig/tests/Makefile.am coreutils-8.10/tests/Makefile.am
|
||||
--- coreutils-8.10-orig/tests/Makefile.am 2011-02-04 20:12:58.236173903 +0100
|
||||
+++ coreutils-8.10/tests/Makefile.am 2011-02-04 20:13:24.020456905 +0100
|
||||
@@ -235,6 +235,7 @@ TESTS = \
|
||||
misc/sort-debug-keys \
|
||||
misc/sort-debug-warn \
|
||||
misc/sort-files0-from \
|
||||
@ -4001,7 +3995,7 @@ diff -urNp coreutils-8.9-orig/tests/Makefile.am coreutils-8.9/tests/Makefile.am
|
||||
misc/sort-float \
|
||||
misc/sort-merge \
|
||||
misc/sort-merge-fdlimit \
|
||||
@@ -498,6 +499,10 @@ TESTS = \
|
||||
@@ -505,6 +506,10 @@ TESTS = \
|
||||
$(root_tests)
|
||||
|
||||
pr_data = \
|
||||
@ -4012,9 +4006,9 @@ diff -urNp coreutils-8.9-orig/tests/Makefile.am coreutils-8.9/tests/Makefile.am
|
||||
pr/0F \
|
||||
pr/0FF \
|
||||
pr/0FFnt \
|
||||
diff -urNp coreutils-8.9-orig/tests/misc/cut coreutils-8.9/tests/misc/cut
|
||||
--- coreutils-8.9-orig/tests/misc/cut 2011-01-01 22:19:23.000000000 +0100
|
||||
+++ coreutils-8.9/tests/misc/cut 2011-01-04 17:41:55.393887822 +0100
|
||||
diff -urNp coreutils-8.10-orig/tests/misc/cut coreutils-8.10/tests/misc/cut
|
||||
--- coreutils-8.10-orig/tests/misc/cut 2011-01-31 13:40:38.000000000 +0100
|
||||
+++ coreutils-8.10/tests/misc/cut 2011-02-04 20:13:24.021456684 +0100
|
||||
@@ -26,7 +26,7 @@ use strict;
|
||||
my $prog = 'cut';
|
||||
my $try = "Try \`$prog --help' for more information.\n";
|
||||
@ -4033,41 +4027,41 @@ diff -urNp coreutils-8.9-orig/tests/misc/cut coreutils-8.9/tests/misc/cut
|
||||
['inval2', qw(-f -), {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||
['inval3', '-f', '4,-', {IN=>''}, {OUT=>''}, {EXIT=>1}, {ERR=>$no_endpoint}],
|
||||
['inval4', '-f', '1-2,-', {IN=>''}, {OUT=>''}, {EXIT=>1},
|
||||
diff -urNp coreutils-8.9-orig/tests/misc/mb1.I coreutils-8.9/tests/misc/mb1.I
|
||||
--- coreutils-8.9-orig/tests/misc/mb1.I 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.9/tests/misc/mb1.I 2011-01-04 17:41:55.394899835 +0100
|
||||
diff -urNp coreutils-8.10-orig/tests/misc/mb1.I coreutils-8.10/tests/misc/mb1.I
|
||||
--- coreutils-8.10-orig/tests/misc/mb1.I 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.10/tests/misc/mb1.I 2011-02-04 20:13:24.022456462 +0100
|
||||
@@ -0,0 +1,4 @@
|
||||
+Apple@10
|
||||
+Banana@5
|
||||
+Citrus@20
|
||||
+Cherry@30
|
||||
diff -urNp coreutils-8.9-orig/tests/misc/mb1.X coreutils-8.9/tests/misc/mb1.X
|
||||
--- coreutils-8.9-orig/tests/misc/mb1.X 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.9/tests/misc/mb1.X 2011-01-04 17:41:55.395888102 +0100
|
||||
diff -urNp coreutils-8.10-orig/tests/misc/mb1.X coreutils-8.10/tests/misc/mb1.X
|
||||
--- coreutils-8.10-orig/tests/misc/mb1.X 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.10/tests/misc/mb1.X 2011-02-04 20:13:24.023456240 +0100
|
||||
@@ -0,0 +1,4 @@
|
||||
+Banana@5
|
||||
+Apple@10
|
||||
+Citrus@20
|
||||
+Cherry@30
|
||||
diff -urNp coreutils-8.9-orig/tests/misc/mb2.I coreutils-8.9/tests/misc/mb2.I
|
||||
--- coreutils-8.9-orig/tests/misc/mb2.I 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.9/tests/misc/mb2.I 2011-01-04 17:41:55.395888102 +0100
|
||||
diff -urNp coreutils-8.10-orig/tests/misc/mb2.I coreutils-8.10/tests/misc/mb2.I
|
||||
--- coreutils-8.10-orig/tests/misc/mb2.I 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.10/tests/misc/mb2.I 2011-02-04 20:13:24.024456019 +0100
|
||||
@@ -0,0 +1,4 @@
|
||||
+Apple@AA10@@20
|
||||
+Banana@AA5@@30
|
||||
+Citrus@AA20@@5
|
||||
+Cherry@AA30@@10
|
||||
diff -urNp coreutils-8.9-orig/tests/misc/mb2.X coreutils-8.9/tests/misc/mb2.X
|
||||
--- coreutils-8.9-orig/tests/misc/mb2.X 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.9/tests/misc/mb2.X 2011-01-04 17:41:55.396892432 +0100
|
||||
diff -urNp coreutils-8.10-orig/tests/misc/mb2.X coreutils-8.10/tests/misc/mb2.X
|
||||
--- coreutils-8.10-orig/tests/misc/mb2.X 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.10/tests/misc/mb2.X 2011-02-04 20:13:24.024456019 +0100
|
||||
@@ -0,0 +1,4 @@
|
||||
+Citrus@AA20@@5
|
||||
+Cherry@AA30@@10
|
||||
+Apple@AA10@@20
|
||||
+Banana@AA5@@30
|
||||
diff -urNp coreutils-8.9-orig/tests/misc/sort-mb-tests coreutils-8.9/tests/misc/sort-mb-tests
|
||||
--- coreutils-8.9-orig/tests/misc/sort-mb-tests 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.9/tests/misc/sort-mb-tests 2011-01-04 17:41:55.396892432 +0100
|
||||
diff -urNp coreutils-8.10-orig/tests/misc/sort-mb-tests coreutils-8.10/tests/misc/sort-mb-tests
|
||||
--- coreutils-8.10-orig/tests/misc/sort-mb-tests 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ coreutils-8.10/tests/misc/sort-mb-tests 2011-02-04 20:13:24.025455797 +0100
|
||||
@@ -0,0 +1,58 @@
|
||||
+#! /bin/sh
|
||||
+case $# in
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: A set of basic GNU tools commonly used in shell scripts
|
||||
Name: coreutils
|
||||
Version: 8.9
|
||||
Release: 2%{?dist}
|
||||
Version: 8.10
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: System Environment/Base
|
||||
Url: http://www.gnu.org/software/coreutils/
|
||||
@ -329,6 +329,9 @@ fi
|
||||
%{_libdir}/coreutils
|
||||
|
||||
%changelog
|
||||
* Fri Feb 03 2011 Ondrej Vasik <ovasik@redhat.com> - 8.10-1
|
||||
- new upstream release coreutils-8.10
|
||||
|
||||
* Sat Jan 08 2011 Dennis Gilmore <dennis@ausil.us> - 8.9-2
|
||||
- drop no longer needed mkstemp patch for sparc
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user