diff --git a/coreutils-8.31-improve-test-cp-proc-short-read.patch b/coreutils-8.31-improve-test-cp-proc-short-read.patch
deleted file mode 100644
index 188a75e..0000000
--- a/coreutils-8.31-improve-test-cp-proc-short-read.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From fb4cb651666adb43e8b332de95616e250b4d16f7 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?P=C3=A1draig=20Brady?=
-Date: Tue, 4 Feb 2020 00:37:23 +0000
-Subject: [PATCH] tests: avoid false failure due to varying /proc/kallsyms
-
-* tests/cp/proc-short-read.sh: Switch to using /proc/cpuinfo,
-rather than /proc/kallsyms which was seen to vary in some cases.
-Fixes https://bugs.gnu.org/39357
-
-Upstream-commit: ab108667ba6112efdd42f9618a1920dc9b8f6e51
-Signed-off-by: Kamil Dudka
----
- tests/cp/proc-short-read.sh | 22 +++++++++-------------
- 1 file changed, 9 insertions(+), 13 deletions(-)
-
-diff --git a/tests/cp/proc-short-read.sh b/tests/cp/proc-short-read.sh
-index 6c58881de..dcc8b30d5 100755
---- a/tests/cp/proc-short-read.sh
-+++ b/tests/cp/proc-short-read.sh
-@@ -19,22 +19,18 @@
- . "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
- print_ver_ cp
-
--kall=/proc/kallsyms
-+proc_large=/proc/cpuinfo # usually > 4KiB
-
--test -r $kall || skip_ "your system lacks $kall"
-+test -r $proc_large || skip_ "your system lacks $proc_large"
-
--# Before coreutils-7.3, cp would copy less than 4KiB of this 1MB+ file.
--cp $kall 1 || fail=1
--cat $kall > 2 || fail=1
--compare 1 2 || fail=1
-+# Before coreutils-7.3, cp would copy less than 4KiB of this file.
-+cp $proc_large 1 || fail=1
-+cat $proc_large > 2 || fail=1
-
--# Also check md5sum, just for good measure.
--md5sum $kall > 3 || fail=1
--md5sum 2 > 4 || fail=1
-+# adjust varying parts
-+sed '/MHz/d; /bogomips/d;' 1 > proc.cp || framework_failure_
-+sed '/MHz/d; /bogomips/d;' 2 > proc.cat || framework_failure_
-
--# Remove each file name before comparing checksums.
--sed 's/ .*//' 3 > sum.proc || fail=1
--sed 's/ .*//' 4 > sum.2 || fail=1
--compare sum.proc sum.2 || fail=1
-+compare proc.cp proc.cat || fail=1
-
- Exit $fail
---
-2.21.1
-
diff --git a/coreutils-8.31-root-tests.patch b/coreutils-8.31-root-tests.patch
deleted file mode 100644
index 02a150a..0000000
--- a/coreutils-8.31-root-tests.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 57324f74fb8855d4888b1e6b6dbaaec781bb6db9 Mon Sep 17 00:00:00 2001
-From: Kamil Dudka
-Date: Fri, 7 Feb 2020 17:05:06 +0100
-Subject: [PATCH] tests: ensure tests/cp/preserve-gid.sh works with single
- binary
-
-* tests/cp/preserve-gid.sh: If configured with --enable-single-binary
-copy the coreutils single binary, instead of the cp one-line launcher.
-
-Discussed at https://bugzilla.redhat.com/1800597
-Fixes https://bugs.gnu.org/39485
-
-Upstream-commit: b96b1a47286632fd1cb738cf5a9893cf72a70d30
-Signed-off-by: Kamil Dudka
----
- tests/cp/preserve-gid.sh | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/tests/cp/preserve-gid.sh b/tests/cp/preserve-gid.sh
-index e48584c1e..bba09df09 100755
---- a/tests/cp/preserve-gid.sh
-+++ b/tests/cp/preserve-gid.sh
-@@ -110,7 +110,14 @@ cleanup_() { rm -rf "$tmp_path"; }
- # is not readable by our nameless IDs.
- test -d /tmp && TMPDIR=/tmp
- tmp_path=$(mktemp -d) || fail_ "failed to create temporary directory"
--cp "$abs_path_dir_/cp" "$tmp_path"
-+if test -x "$abs_path_dir_/coreutils" &&
-+ { test -l "$abs_path_dir_/cp" ||
-+ test $(wc -l < "$abs_path_dir_/cp") = 1; } then
-+ # if configured with --enable-single-binary we need to use the single binary
-+ cp "$abs_path_dir_/coreutils" "$tmp_path/cp" || framework_failure_
-+else
-+ cp "$abs_path_dir_/cp" "$tmp_path"
-+fi
- chmod -R a+rx "$tmp_path"
-
- t1() {
---
-2.21.1
-
-From 94a47b51e64c21fef4ad8faca1599099c459b2ad Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?P=C3=A1draig=20Brady?=
-Date: Mon, 10 Feb 2020 15:05:43 +0000
-Subject: [PATCH] tests: fix test for symlink
-
-* tests/cp/preserve-gid.sh: s/-l/-L/.
-Reported by Kamil Dudka
-
-Upstream-commit: 3150f4a82ef6542c4a8f0bf413815e78766f044f
-Signed-off-by: Kamil Dudka
----
- tests/cp/preserve-gid.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/cp/preserve-gid.sh b/tests/cp/preserve-gid.sh
-index bba09df09..547bf66bc 100755
---- a/tests/cp/preserve-gid.sh
-+++ b/tests/cp/preserve-gid.sh
-@@ -111,7 +111,7 @@ cleanup_() { rm -rf "$tmp_path"; }
- test -d /tmp && TMPDIR=/tmp
- tmp_path=$(mktemp -d) || fail_ "failed to create temporary directory"
- if test -x "$abs_path_dir_/coreutils" &&
-- { test -l "$abs_path_dir_/cp" ||
-+ { test -L "$abs_path_dir_/cp" ||
- test $(wc -l < "$abs_path_dir_/cp") = 1; } then
- # if configured with --enable-single-binary we need to use the single binary
- cp "$abs_path_dir_/coreutils" "$tmp_path/cp" || framework_failure_
---
-2.21.1
-
diff --git a/coreutils-8.31-sums-man-pages.patch b/coreutils-8.31-sums-man-pages.patch
deleted file mode 100644
index 094aaaa..0000000
--- a/coreutils-8.31-sums-man-pages.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From ef6be60dcaf424bdb21392aff42331bd4dc272e0 Mon Sep 17 00:00:00 2001
-From: Kamil Dudka
-Date: Thu, 14 Mar 2019 13:48:01 +0100
-Subject: [PATCH] md5sum,b2sum,sha*sum: --help: add note about binary/text mode
-
-* src/md5sum.c (usage): Make it clear that there is no difference
-between binary mode and text mode on GNU systems.
-
-Bug: https://bugzilla.redhat.com/406981
-Bug: https://bugzilla.redhat.com/1688740
-
-Upstream-commit: ae61b1066351bb784b54fbfd7b52caf129ec286c
-Signed-off-by: Kamil Dudka
----
- src/md5sum.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/md5sum.c b/src/md5sum.c
-index 3532f7b7a..f75b6de02 100644
---- a/src/md5sum.c
-+++ b/src/md5sum.c
-@@ -287,7 +287,10 @@ The following five options are useful only when verifying checksums:\n\
- The sums are computed as described in %s. When checking, the input\n\
- should be a former output of this program. The default mode is to print a\n\
- line with checksum, a space, a character indicating input mode ('*' for binary,\
--\n' ' for text or where binary is insignificant), and name for each FILE.\n"),
-+\n' ' for text or where binary is insignificant), and name for each FILE.\n\
-+\n\
-+Note: There is no difference between binary mode and text mode on GNU systems.\
-+\n"),
- DIGEST_REFERENCE);
- emit_ancillary_info (PROGRAM_NAME);
- }
---
-2.17.2
-
diff --git a/coreutils-8.31.tar.xz.sig b/coreutils-8.31.tar.xz.sig
deleted file mode 100644
index 5aa60a1..0000000
--- a/coreutils-8.31.tar.xz.sig
+++ /dev/null
@@ -1,17 +0,0 @@
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2
-
-iQIcBAABCAAGBQJchaqkAAoJEN9v2XEwYDfZKBMQAJNjmYU6VrbHvlSJm1d+9Qch
-rvVtE5VGsTj3jUj1dh9MpuN9GhJifWJat9DEKUat0J4Z5G8d55LvyzQJppby2az2
-kwbp/ffK0wR1tfGNii3Hop3pMVizqJn+LbT01qcS3E7tVQ2nJP/JVIeXOtOf9kJk
-gPviDaqO8OUiV2l3gCwLtuOETKHXRGyraWRxCb9ZxOS12Gspqfwui7t4jQUDf2Ge
-Kvhcawas+XomGdWx+io/VxwkOZkOCr9vQdMM7ZqLDnu+d7nGsnPMxxdGcP72WBnV
-1LxFxHIel52yuRh3T1RggQMKxXPFPEyDRgaBNN0Yfk3a2CHFHf+YtySgLzKSqyS5
-1P5syvSbNj9ASEuX428lpwI3EC5G3T9W/MLTKUpwVhfU8/WELI261F95dnFIfoar
-mMPqbBMHwHpIasJfDy60m8H8/z8PEOmpRP0xfAuOtf47YpDLsH+AvrAJM4CH9kkS
-lysMUZITyIqUBSoUs8mVygV7b4mq2X2US0Mkja/hDFAcq2O7m2eyvi61z7Oa1Y/r
-tV+q/XS8ZTOtSTBBZzRVTJDPno1ZwFBl/MIiD5FgF7szgiR2z0KVMfAlVBdQwxKw
-Mj6N/HYeP6yE3g9I5+8LmRLwQcXeC2B0ZzpvGE7DaKd5aFDC6YVDD8wyLEQFDAav
-XGtN62+yfXArdYVjXygm
-=LVk4
------END PGP SIGNATURE-----
diff --git a/coreutils-8.32.tar.xz.sig b/coreutils-8.32.tar.xz.sig
new file mode 100644
index 0000000..e1420fc
--- /dev/null
+++ b/coreutils-8.32.tar.xz.sig
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCAAdFiEEbDfcEhIaUAa8HbgE32/ZcTBgN9kFAl5hC5MACgkQ32/ZcTBg
+N9n92Q//Td2GE1f8AZKkxCNI76Q/TqbxAwhjbkR+KdzvsyMePmgHcMgHG6sO2MNF
+g6DIBmHpO3vWGzvUxUZRRhuW5QBOnMxHb/WXZ0p/g45d5MQdn4i0dA0wUJgByOqn
+/WVfygNg9mrWFx/uTeCdhrwL11m71C7j/eQVu7Wr5DIb20VJ8+nVC2IWW33ZvxRj
+Goa0wwDpeeD9qYe/Y+E5ZyhDYHJGRmNAlS03SXLO3+RfsbZFwdQEtzvr+v1VN6/S
+9OsoI/GLdRjY1tByppaoZ63ZybB6iF5zZfJiWDF7Nw4MduJpjZQDSywiNleJ9vOi
+fwR1180PjMV6aTXvPwqbqQxZjDl7nqvO36ghlTvErJbqdJVIYxmUGNjeJyjqI85l
+Lhckh0GWos9K/kl13Ry9KWsxNQgfjNhtgjXGh+W47ojrho2kCiK5BTwDFeVU0jtU
+H/1EePSGAIUF/Sfjz3rmGgLaaBwPiRiyzEIuZMyd4NCJWwfOTqgOshOYw15GCWYq
+wGesN/4LWzEja7Au5lHP7imXjP0bp4qE/sYrOb4WzVVLCn+z2hu6SEIzjJzSm+D+
+8Wv3Ia1/ypVpR+Z7gUt7VtEvI8zAwlySd/6Jw5U7TL0rzvZsTVWmCvEjPp+o3jCB
+Fy/4ybao1gowBFtT1AtPMmxmiJ41KWCxLFrTuGJpFYCGvBH2y8s=
+=yHV6
+-----END PGP SIGNATURE-----
diff --git a/coreutils.spec b/coreutils.spec
index 11cfbec..2dbf3f3 100644
--- a/coreutils.spec
+++ b/coreutils.spec
@@ -1,7 +1,7 @@
Summary: A set of basic GNU tools commonly used in shell scripts
Name: coreutils
-Version: 8.31
-Release: 10%{?dist}
+Version: 8.32
+Release: 1%{?dist}
License: GPLv3+
Url: https://www.gnu.org/software/coreutils/
Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
@@ -13,15 +13,6 @@ Source106: coreutils-colorls.csh
# do not make coreutils-single depend on /usr/bin/coreutils
%global __requires_exclude ^%{_bindir}/coreutils$
-# md5sum,b2sum,sha*sum: --help: add note about binary/text mode
-Patch1: coreutils-8.31-sums-man-pages.patch
-
-# improve an upstream test that relied on /proc/kallsyms being immutable
-Patch2: coreutils-8.31-improve-test-cp-proc-short-read.patch
-
-# make upstream test-suite work with root privileges (#1800597)
-Patch3: coreutils-8.31-root-tests.patch
-
# disable the test-lock gnulib test prone to deadlock
Patch100: coreutils-8.26-test-lock.patch
@@ -241,6 +232,9 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir
%license COPYING
%changelog
+* Thu Mar 05 2020 Kamil Dudka - 8.32-1
+- new upstream release 8.32
+
* Tue Feb 11 2020 Kamil Dudka - 8.31-10
- make upstream test-suite work with root privileges (#1800597)
diff --git a/sources b/sources
index ca35b8f..97fe361 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (coreutils-8.31.tar.xz) = ef8941dae845bbf5ae5838bc49e44554a766302930601aada6fa594e8088f0fbad74e481ee392ff89633e68b99e4da3f761fcb5d31ee3b233d540fe2a2d4e1af
+SHA512 (coreutils-8.32.tar.xz) = 1c8f3584efd61b4b02e7ac5db8e103b63cfb2063432caaf1e64cb2dcc56d8c657d1133bbf10bd41468d6a1f31142e6caa81d16ae68fa3e6e84075c253613a145