Initial import
This commit is contained in:
parent
45adab2c49
commit
fef3541999
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
||||
/console-setup_1.76.tar.gz
|
12
console-setup-1.76-fsf-address.patch
Normal file
12
console-setup-1.76-fsf-address.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up console-setup/Keyboard/ckbcomp.orig console-setup/Keyboard/ckbcomp
|
||||
--- console-setup/Keyboard/ckbcomp.orig 2012-06-26 12:04:16.612309745 +0200
|
||||
+++ console-setup/Keyboard/ckbcomp 2012-06-26 12:21:06.448385970 +0200
|
||||
@@ -15,7 +15,7 @@
|
||||
|
||||
# If you have not received a copy of the GNU General Public License
|
||||
# along with this program, write to the Free Software Foundation, Inc.,
|
||||
-# 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
|
||||
use warnings 'all';
|
||||
use strict;
|
163
console-setup-1.76-paths.patch
Normal file
163
console-setup-1.76-paths.patch
Normal file
@ -0,0 +1,163 @@
|
||||
diff -up console-setup/Makefile.orig console-setup/Makefile
|
||||
--- console-setup/Makefile.orig 2012-06-19 16:24:46.063272458 +0200
|
||||
+++ console-setup/Makefile 2012-06-20 13:11:09.926247002 +0200
|
||||
@@ -2,7 +2,7 @@ prefix = /usr/local
|
||||
# etcdir must be either /etc or
|
||||
etcdir = $(prefix)/etc
|
||||
bootprefix = $(patsubst %/usr,%/,$(prefix:%/=%))
|
||||
-mandir = $(prefix)/share/man
|
||||
+mandir = $(prefix)/usr/share/man
|
||||
|
||||
SHELL = /bin/sh
|
||||
|
||||
@@ -36,8 +36,8 @@ build-all: build-linux build-freebsd bui
|
||||
|
||||
.PHONY: install-common
|
||||
install-common: build-common
|
||||
- install -d $(bootprefix)/bin/
|
||||
- install setupcon $(bootprefix)/bin/
|
||||
+ install -d $(bootprefix)/usr/bin/
|
||||
+ install setupcon $(bootprefix)/usr/bin/
|
||||
install -d $(etcdir)/default
|
||||
install -m 644 config/keyboard $(etcdir)/default/
|
||||
install -m 644 config/console-setup $(etcdir)/default/
|
||||
@@ -49,10 +49,10 @@ install-common: build-common
|
||||
|
||||
.PHONY: install-common-linux
|
||||
install-common-linux: build-linux
|
||||
- install -d $(prefix)/share/consolefonts/
|
||||
- install -m 644 Fonts/*.psf.gz $(prefix)/share/consolefonts/
|
||||
- install -d $(prefix)/share/consoletrans
|
||||
- install -m 644 acm/*.acm.gz $(prefix)/share/consoletrans/
|
||||
+ install -d $(prefix)/usr/share/consolefonts/
|
||||
+ install -m 644 Fonts/*.psf.gz $(prefix)/usr/share/consolefonts/
|
||||
+ install -d $(prefix)/usr/share/consoletrans
|
||||
+ install -m 644 acm/*.acm.gz $(prefix)/usr/share/consoletrans/
|
||||
install -d $(etcdir)/console-setup
|
||||
install -m 644 Keyboard/compose.*.inc $(etcdir)/console-setup/
|
||||
install -m 644 Keyboard/remap.inc $(etcdir)/console-setup/
|
||||
@@ -77,8 +77,8 @@ install-ckbcomp:
|
||||
mkdir -p $(etcdir)/console-setup \
|
||||
&& cp -r Keyboard/ckb/ $(etcdir)/console-setup/ckb; \
|
||||
fi
|
||||
- install -d $(prefix)/bin/
|
||||
- install -m 755 Keyboard/ckbcomp $(prefix)/bin/
|
||||
+ install -d $(prefix)/usr/bin/
|
||||
+ install -m 755 Keyboard/ckbcomp $(prefix)/usr/bin/
|
||||
install -d $(mandir)/man1/
|
||||
install -m 644 man/ckbcomp.1 $(mandir)/man1/
|
||||
|
||||
diff -up console-setup/man/ckbcomp.1.orig console-setup/man/ckbcomp.1
|
||||
--- console-setup/man/ckbcomp.1.orig 2012-06-26 13:03:52.177823914 +0200
|
||||
+++ console-setup/man/ckbcomp.1 2012-06-26 14:21:00.460672366 +0200
|
||||
@@ -46,7 +46,7 @@ Print a usage message and exit.
|
||||
.BI -charmap\ charmap
|
||||
The encoding to use for the output keymap. There should be an
|
||||
character mapping table defining this encoding in
|
||||
-.IR /usr/local/share/consoletrans .
|
||||
+.IR /usr/share/consoletrans .
|
||||
Definitions of the following charmaps are provided:
|
||||
.nh
|
||||
.BR ARMSCII-8 ,
|
||||
@@ -86,8 +86,9 @@ for files included by the keymap descrip
|
||||
multiple times. If a file can not be found in any of the specified
|
||||
directories, it will be searched also in some other standard
|
||||
locations, such as
|
||||
-.IR /usr/local/etc/console-setup/ckb ,
|
||||
-.IR /usr/local/share/X11/xkb
|
||||
+.IR /etc/console-setup/ckb ,
|
||||
+.IR /usr/local/share/X11/xkb ,
|
||||
+.IR /usr/share/X11/xkb
|
||||
and
|
||||
.IR /etc/X11/xkb
|
||||
|
||||
@@ -167,9 +168,9 @@ Specifies the layout variant used to cho
|
||||
Adds an option used to choose component names.
|
||||
|
||||
.SH FILES
|
||||
-.I /usr/local/share/consoletrans
|
||||
+.I /usr/share/consoletrans
|
||||
.br
|
||||
-.I /usr/local/etc/console-setup/ckb
|
||||
+.I /etc/console-setup/ckb
|
||||
.br
|
||||
.I /usr/share/X11/xkb
|
||||
.br
|
||||
diff -up console-setup/man/console-setup.5.orig console-setup/man/console-setup.5
|
||||
--- console-setup/man/console-setup.5.orig 2012-06-26 13:10:37.076260103 +0200
|
||||
+++ console-setup/man/console-setup.5 2012-06-26 14:19:44.635215971 +0200
|
||||
@@ -378,16 +378,16 @@ Completely covered by the following font
|
||||
The standard location of the
|
||||
.B console-setup
|
||||
configuration file is
|
||||
-.IR /usr/local/etc/default/console-setup .
|
||||
+.IR /etc/default/console-setup .
|
||||
The keyboard configuration is in
|
||||
-.IR /usr/local/etc/default/keyboard .
|
||||
+.IR /etc/default/keyboard .
|
||||
Fonts that can be used with the variable
|
||||
.B FONT
|
||||
are usually installed in
|
||||
-.IR /usr/share/consolefonts/ " or " /usr/share/syscons/fonts/ .
|
||||
+.IR /usr/share/consolefonts/ " or " /lib/kbd/consolefonts/ .
|
||||
Translation maps that can be used with the variable CONSOLE_MAP are
|
||||
usually installed in
|
||||
-.IR /usr/share/consoletrans/ " or " /usr/share/syscons/scrnmaps/ .
|
||||
+.IR /usr/share/consoletrans/ " or " /lib/kbd/consoletrans/ .
|
||||
|
||||
.SH NOTES
|
||||
The aim of the Terminus font is to reduce the eyes-fatigue when one
|
||||
diff -up console-setup/man/keyboard.5.orig console-setup/man/keyboard.5
|
||||
--- console-setup/man/keyboard.5.orig 2012-06-26 13:09:26.323834480 +0200
|
||||
+++ console-setup/man/keyboard.5 2012-06-26 13:34:33.243901584 +0200
|
||||
@@ -152,12 +152,12 @@ on FreeBSD.
|
||||
The standard location of the
|
||||
.B keyboard
|
||||
file is
|
||||
-.IR /usr/local/etc/default/keyboard .
|
||||
+.IR /etc/default/keyboard .
|
||||
Description of all available keyboard models, layouts, variants and
|
||||
options is available in
|
||||
-.IR /usr/local/share/X11/xkb/rules/xorg.lst .
|
||||
+.IR /usr/share/X11/xkb/rules/xorg.lst .
|
||||
In most cases, in
|
||||
-.IR /usr/share/keymaps/ " or " /usr/share/syscons/keymaps/
|
||||
+.IR /lib/kbd/keymaps/
|
||||
you will find several keymaps that can be used with the variable
|
||||
.BR KMAP .
|
||||
|
||||
diff -up console-setup/man/setupcon.1.orig console-setup/man/setupcon.1
|
||||
--- console-setup/man/setupcon.1.orig 2012-06-26 13:00:14.192512373 +0200
|
||||
+++ console-setup/man/setupcon.1 2012-06-26 13:03:27.247673862 +0200
|
||||
@@ -22,11 +22,11 @@ the console. Most of the time you invok
|
||||
without arguments. The keyboard configuration is specified in
|
||||
.I ~/.keyboard
|
||||
or
|
||||
-.IR /usr/local/etc/default/keyboard .
|
||||
+.IR /etc/default/keyboard .
|
||||
The font configuration is specified in
|
||||
.I ~/.console-setup
|
||||
or
|
||||
-.IR /usr/local/etc/default/console-setup .
|
||||
+.IR /etc/default/console-setup .
|
||||
Consult
|
||||
.BR keyboard (5)
|
||||
and
|
||||
@@ -131,13 +131,13 @@ for the default configuration.
|
||||
.br
|
||||
.I ~/.keyboard
|
||||
.br
|
||||
-.I /usr/local/etc/default/console-setup
|
||||
+.I /etc/default/console-setup
|
||||
.br
|
||||
-.I /usr/local/etc/default/keyboard
|
||||
+.I /etc/default/keyboard
|
||||
.br
|
||||
-.I /usr/local/etc/default/console-setup.VARIANT
|
||||
+.I /etc/default/console-setup.VARIANT
|
||||
.br
|
||||
-.I /usr/local/etc/default/keyboard.VARIANT
|
||||
+.I /etc/default/keyboard.VARIANT
|
||||
.br
|
||||
.I /etc/console-setup/
|
||||
|
73
console-setup.spec
Normal file
73
console-setup.spec
Normal file
@ -0,0 +1,73 @@
|
||||
|
||||
Name: console-setup
|
||||
Version: 1.76
|
||||
Release: 2%{?dist}
|
||||
Summary: Tools for configuring the console using X Window System key maps
|
||||
|
||||
Group: Applications/System
|
||||
# For a breakdown of the licensing, see COPYRIGHT, copyright, copyright.fonts and copyright.xkb
|
||||
License: GPLv2+ and MIT and Public Domain
|
||||
URL: http://packages.debian.org/cs/sid/console-setup
|
||||
Source0: http://ftp.de.debian.org/debian/pool/main/c/%{name}/%{name}_%{version}.tar.gz
|
||||
|
||||
# Fixes installing paths to Fedora style
|
||||
Patch0: console-setup-1.76-paths.patch
|
||||
# Fixes FSF address, sent to upstream
|
||||
Patch1: console-setup-1.76-fsf-address.patch
|
||||
|
||||
Requires: kbd
|
||||
# require 'xkeyboard-config' to have X Window keyboard descriptions?
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
This package provides the console with the same keyboard configuration
|
||||
scheme that X Window System has. Besides the keyboard, the package configures
|
||||
also the font on the console. It includes a rich collection of fonts and
|
||||
supports several languages that would be otherwise unsupported on the console
|
||||
(such as Armenian, Georgian, Lao and Thai).
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch0 -p1 -b .paths
|
||||
%patch1 -p1 -b .fsf-address
|
||||
|
||||
|
||||
%build
|
||||
make build-linux
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make prefix=$RPM_BUILD_ROOT install-linux
|
||||
# we don't want another set of keyboard descriptions, we want to use descriptions from
|
||||
# xkeyboard-config (require it?), so removing it
|
||||
# or maybe have these from tarball it in optional subpackage?
|
||||
rm -rf $RPM_BUILD_ROOT/etc/console-setup
|
||||
|
||||
|
||||
%files
|
||||
%doc README COPYRIGHT CHANGES copyright.fonts copyright.xkb Fonts/copyright
|
||||
%{_bindir}/ckbcomp
|
||||
%{_bindir}/setupcon
|
||||
%{_sysconfdir}/default/*
|
||||
%config(noreplace) %{_sysconfdir}/default/console-setup
|
||||
%config(noreplace) %{_sysconfdir}/default/keyboard
|
||||
# maybe move fonts/trans to separate subpackage?
|
||||
%{_datadir}/consolefonts
|
||||
%{_datadir}/consoletrans
|
||||
%{_datadir}/consolefonts/*
|
||||
%{_datadir}/consoletrans/*
|
||||
%{_mandir}/*/*
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 25 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.76-2
|
||||
- Fix License field
|
||||
- Do not own /etc/default directory
|
||||
- Fix FSF address in ckbcomp utility
|
||||
- Fix paths in manpages
|
||||
|
||||
* Wed Jun 20 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.76-1
|
||||
- Initial support
|
Loading…
Reference in New Issue
Block a user