bf65b481d4
- Drop lazy binding via patch from upstream - Add patches to fix for failing RPC header search Resolves: rhbz#2062810
61 lines
1.9 KiB
Diff
61 lines
1.9 KiB
Diff
From 456dcededa381afcba0d29332517bd941cfed6a6 Mon Sep 17 00:00:00 2001
|
|
From: Jeremy Sowden <jeremy@azazel.net>
|
|
Date: Sat, 25 Sep 2021 16:10:30 +0100
|
|
Subject: [PATCH] build: remove commented-out macros from configure.ac
|
|
|
|
This code has been commented out since at least 2007.
|
|
|
|
Signed-off-by: Jeremy Sowden <jeremy@azazel.net>
|
|
Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
|
(cherry picked from commit 3184d9936329dafbc2a24f546224a44f66d975b5)
|
|
(cherry picked from commit 9ec53c524d1201e6a9b2feca796ffbe2e5d1b743)
|
|
---
|
|
configure.ac | 25 -------------------------
|
|
1 file changed, 25 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index cb9659f4feeb4..5388054e64a58 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -75,37 +75,12 @@ AM_CONDITIONAL([HAVE_SYSTEMD], [test "x$enable_systemd" = "xyes"])
|
|
|
|
AC_CHECK_HEADERS([linux/capability.h],, [AC_MSG_ERROR([Cannot find linux/capabibility.h])])
|
|
|
|
-# Checks for libraries.
|
|
-# FIXME: Replace `main' with a function in `-lc':
|
|
-dnl AC_CHECK_LIB([c], [main])
|
|
-# FIXME: Replace `main' with a function in `-ldl':
|
|
-
|
|
AC_CHECK_HEADERS(arpa/inet.h)
|
|
-dnl check for inet_pton
|
|
AC_CHECK_FUNCS(inet_pton)
|
|
|
|
-# Checks for header files.
|
|
-dnl AC_HEADER_STDC
|
|
-dnl AC_CHECK_HEADERS([netinet/in.h stdlib.h])
|
|
-
|
|
-# Checks for typedefs, structures, and compiler characteristics.
|
|
-dnl AC_C_CONST
|
|
-dnl AC_C_INLINE
|
|
-
|
|
# Let nfct use dlopen() on helper libraries without resolving all symbols.
|
|
AX_CHECK_LINK_FLAG([-Wl,-z,lazy], [AC_SUBST([LAZY_LDFLAGS], [-Wl,-z,lazy])])
|
|
|
|
-# Checks for library functions.
|
|
-dnl AC_FUNC_MALLOC
|
|
-dnl AC_FUNC_VPRINTF
|
|
-dnl AC_CHECK_FUNCS([memset])
|
|
-
|
|
-dnl AC_CONFIG_FILES([Makefile
|
|
-dnl debug/Makefile
|
|
-dnl debug/src/Makefile
|
|
-dnl extensions/Makefile
|
|
-dnl src/Makefile])
|
|
-
|
|
if test ! -z "$libdir"; then
|
|
MODULE_DIR="\\\"$libdir/conntrack-tools/\\\""
|
|
CFLAGS="$CFLAGS -DCONNTRACKD_LIB_DIR=$MODULE_DIR"
|
|
--
|
|
2.34.1
|
|
|