conntrack-tools-0.9.12-1
This commit is contained in:
parent
b790960b28
commit
ef8501c724
@ -1 +1 @@
|
|||||||
conntrack-tools-0.9.9.tar.bz2
|
conntrack-tools-0.9.12.tar.bz2
|
||||||
|
@ -1,59 +0,0 @@
|
|||||||
diff --git a/Make_global.am b/Make_global.am
|
|
||||||
index 3ff531f..2eeb886 100644
|
|
||||||
--- a/Make_global.am
|
|
||||||
+++ b/Make_global.am
|
|
||||||
@@ -1,6 +1,5 @@
|
|
||||||
INCLUDES=$(all_includes) -I$(top_srcdir)/include
|
|
||||||
|
|
||||||
AM_CFLAGS = -std=gnu99 -W -Wall \
|
|
||||||
- -Werror \
|
|
||||||
-Wmissing-prototypes -Wwrite-strings -Wcast-qual -Wfloat-equal -Wshadow -Wpointer-arith -Wbad-function-cast -Wsign-compare -Waggregate-return -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline -Wstrict-prototypes -Wundef \
|
|
||||||
-Wno-unused-parameter
|
|
||||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
||||||
index 494da4f..2d8c6b6 100644
|
|
||||||
--- a/src/Makefile.am
|
|
||||||
+++ b/src/Makefile.am
|
|
||||||
@@ -1,8 +1,6 @@
|
|
||||||
include $(top_srcdir)/Make_global.am
|
|
||||||
|
|
||||||
-YACC=@YACC@ -d
|
|
||||||
-
|
|
||||||
-CLEANFILES = read_config_yy.c read_config_lex.c
|
|
||||||
+AM_YFLAGS = -d
|
|
||||||
|
|
||||||
sbin_PROGRAMS = conntrack conntrackd
|
|
||||||
|
|
||||||
@@ -22,9 +20,6 @@ conntrackd_SOURCES = alarm.c main.c run.c hash.c queue.c rbtree.c \
|
|
||||||
build.c parse.c \
|
|
||||||
read_config_yy.y read_config_lex.l
|
|
||||||
|
|
||||||
-# yacc and lex generate dirty code
|
|
||||||
-read_config_yy.o read_config_lex.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
|
|
||||||
|
|
||||||
conntrackd_LDFLAGS = $(all_libraries) @LIBNETFILTER_CONNTRACK_LIBS@
|
|
||||||
|
|
||||||
-EXTRA_DIST = read_config_yy.h
|
|
||||||
diff --git a/src/ignore_pool.c b/src/ignore_pool.c
|
|
||||||
index 027d628..2f951e8 100644
|
|
||||||
--- a/src/ignore_pool.c
|
|
||||||
+++ b/src/ignore_pool.c
|
|
||||||
@@ -25,6 +25,7 @@
|
|
||||||
#include <libnetfilter_conntrack/libnetfilter_conntrack.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <string.h>
|
|
||||||
+#include <limits.h>
|
|
||||||
|
|
||||||
/* XXX: These should be configurable, better use a rb-tree */
|
|
||||||
#define IGNORE_POOL_SIZE 128
|
|
||||||
diff --git a/src/main.c b/src/main.c
|
|
||||||
index 2e1ccd8..084643c 100644
|
|
||||||
--- a/src/main.c
|
|
||||||
+++ b/src/main.c
|
|
||||||
@@ -26,6 +26,7 @@
|
|
||||||
#include <string.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
+#include <limits.h>
|
|
||||||
|
|
||||||
struct ct_general_state st;
|
|
||||||
union ct_state state;
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: conntrack-tools
|
Name: conntrack-tools
|
||||||
Version: 0.9.9
|
Version: 0.9.12
|
||||||
Release: 2%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Tools to manipulate netfilter connection tracking table
|
Summary: Tools to manipulate netfilter connection tracking table
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -7,7 +7,7 @@ License: GPLv2
|
|||||||
URL: http://netfilter.org
|
URL: http://netfilter.org
|
||||||
Source0: http://netfilter.org/projects/%{name}/files/%{name}-%{version}.tar.bz2
|
Source0: http://netfilter.org/projects/%{name}/files/%{name}-%{version}.tar.bz2
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libnfnetlink-devel >= 0.0.33, libnetfilter_conntrack-devel >= 0.0.97
|
BuildRequires: libnfnetlink-devel >= 0.0.40, libnetfilter_conntrack-devel >= 0.0.99
|
||||||
BuildRequires: pkgconfig bison flex
|
BuildRequires: pkgconfig bison flex
|
||||||
Provides: conntrack = 1.0-1
|
Provides: conntrack = 1.0-1
|
||||||
Obsoletes: conntrack < 1.0-1
|
Obsoletes: conntrack < 1.0-1
|
||||||
@ -50,6 +50,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man8/*
|
%{_mandir}/man8/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun May 24 2009 Paul P. Komkoff Jr <i@stingr.net> - 0.9.12-1
|
||||||
|
- new upstream version
|
||||||
|
|
||||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.9-2
|
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.9-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user