conntrack-tools-0.9.6-0.1.svn7382
This commit is contained in:
parent
00781161f4
commit
a9812ae054
@ -1 +1,2 @@
|
||||
conntrack-tools-0.9.5.tar.bz2
|
||||
conntrack-tools-0.9.6-svn7382.patch.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -urN conntrack-tools-0.9.5/src/main.c conntrack-tools-0.9.5.p/src/main.c
|
||||
--- conntrack-tools-0.9.5/src/main.c 2007-07-07 13:10:13.000000000 +0100
|
||||
+++ conntrack-tools-0.9.5.p/src/main.c 2007-10-19 14:12:24.000000000 +0100
|
||||
@@ -264,7 +264,7 @@
|
||||
/*
|
||||
* lock file
|
||||
*/
|
||||
- if ((ret = open(CONFIG(lockfile), O_CREAT | O_EXCL | O_TRUNC)) == -1) {
|
||||
+ if ((ret = open(CONFIG(lockfile), O_CREAT | O_EXCL | O_TRUNC, S_IRUSR | S_IWUSR)) == -1) {
|
||||
fprintf(stderr, "lockfile `%s' exists, perhaps conntrackd "
|
||||
"already running?\n", CONFIG(lockfile));
|
||||
exit(EXIT_FAILURE);
|
@ -1,12 +0,0 @@
|
||||
diff --git a/src/main.c b/src/main.c
|
||||
index 007b76e..2ac4746 100644
|
||||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -17,6 +17,7 @@
|
||||
*/
|
||||
|
||||
#include <stdlib.h>
|
||||
+#include <limits.h>
|
||||
#include "conntrackd.h"
|
||||
#include "log.h"
|
||||
#include <sys/types.h>
|
72
conntrack-tools-rollup.patch
Normal file
72
conntrack-tools-rollup.patch
Normal file
@ -0,0 +1,72 @@
|
||||
diff --git a/Make_global.am b/Make_global.am
|
||||
index 3ff531f..2eeb886 100644
|
||||
--- a/Make_global.am
|
||||
+++ b/Make_global.am
|
||||
@@ -1,6 +1,5 @@
|
||||
INCLUDES=$(all_includes) -I$(top_srcdir)/include
|
||||
|
||||
AM_CFLAGS = -std=gnu99 -W -Wall \
|
||||
- -Werror \
|
||||
-Wmissing-prototypes -Wwrite-strings -Wcast-qual -Wfloat-equal -Wshadow -Wpointer-arith -Wbad-function-cast -Wsign-compare -Waggregate-return -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline -Wstrict-prototypes -Wundef \
|
||||
-Wno-unused-parameter
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 494da4f..2d8c6b6 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -1,8 +1,6 @@
|
||||
include $(top_srcdir)/Make_global.am
|
||||
|
||||
-YACC=@YACC@ -d
|
||||
-
|
||||
-CLEANFILES = read_config_yy.c read_config_lex.c
|
||||
+AM_YFLAGS = -d
|
||||
|
||||
sbin_PROGRAMS = conntrack conntrackd
|
||||
|
||||
@@ -22,9 +20,6 @@ conntrackd_SOURCES = alarm.c main.c run.c hash.c queue.c rbtree.c \
|
||||
build.c parse.c \
|
||||
read_config_yy.y read_config_lex.l
|
||||
|
||||
-# yacc and lex generate dirty code
|
||||
-read_config_yy.o read_config_lex.o: AM_CFLAGS += -Wno-missing-prototypes -Wno-missing-declarations -Wno-implicit-function-declaration -Wno-nested-externs -Wno-undef -Wno-redundant-decls
|
||||
|
||||
conntrackd_LDFLAGS = $(all_libraries) @LIBNETFILTER_CONNTRACK_LIBS@
|
||||
|
||||
-EXTRA_DIST = read_config_yy.h
|
||||
diff --git a/src/conntrack.c b/src/conntrack.c
|
||||
index 82ff544..23050a4 100644
|
||||
--- a/src/conntrack.c
|
||||
+++ b/src/conntrack.c
|
||||
@@ -299,7 +299,7 @@ err2str(int err, enum action command)
|
||||
{ CT_CREATE, ETIME, "conntrack has expired" },
|
||||
{ EXP_CREATE, ENOENT, "master conntrack not found" },
|
||||
{ EXP_CREATE, EINVAL, "invalid parameters" },
|
||||
- { ~0UL, EPERM, "sorry, you must be root or get "
|
||||
+ { (enum action) ~0UL, EPERM, "sorry, you must be root or get "
|
||||
"CAP_NET_ADMIN capability to do this"}
|
||||
};
|
||||
|
||||
diff --git a/src/ignore_pool.c b/src/ignore_pool.c
|
||||
index 027d628..2f951e8 100644
|
||||
--- a/src/ignore_pool.c
|
||||
+++ b/src/ignore_pool.c
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <libnetfilter_conntrack/libnetfilter_conntrack.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <limits.h>
|
||||
|
||||
/* XXX: These should be configurable, better use a rb-tree */
|
||||
#define IGNORE_POOL_SIZE 128
|
||||
diff --git a/src/main.c b/src/main.c
|
||||
index 2e1ccd8..084643c 100644
|
||||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
+#include <limits.h>
|
||||
|
||||
struct ct_general_state st;
|
||||
union ct_state state;
|
@ -1,13 +1,16 @@
|
||||
%define rev 7382
|
||||
%define basever 0.9.5
|
||||
|
||||
Name: conntrack-tools
|
||||
Version: 0.9.5
|
||||
Release: 5%{?dist}
|
||||
Version: 0.9.6
|
||||
Release: 0.1.svn%{rev}%{?dist}
|
||||
Summary: Tools to manipulate netfilter connection tracking table
|
||||
Group: System Environment/Base
|
||||
License: GPLv2
|
||||
URL: http://netfilter.org
|
||||
Source0: http://netfilter.org/projects/%{name}/files/%{name}-%{version}.tar.bz2
|
||||
Patch0: conntrack-tools-0.9.5-open.patch
|
||||
Patch1: conntrack-tools-pathmax.patch
|
||||
Source0: http://netfilter.org/projects/%{name}/files/%{name}-%{basever}.tar.bz2
|
||||
Patch0: conntrack-tools-%{version}-svn%{rev}.patch.bz2
|
||||
Patch1: conntrack-tools-rollup.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libnfnetlink-devel libnetfilter_conntrack-devel pkgconfig bison flex
|
||||
BuildRequires: autoconf automake libtool
|
||||
@ -31,7 +34,7 @@ In addition, you can also monitor connection tracking events, e.g.
|
||||
show an event message (one line) per newly established connection.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n %{name}-%{basever}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
autoreconf -i --force
|
||||
@ -39,7 +42,6 @@ autoreconf -i --force
|
||||
%build
|
||||
%configure --disable-static
|
||||
%{__make} %{?_smp_mflags}
|
||||
find examples -type f | xargs chmod a-x
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -50,12 +52,15 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc ChangeLog COPYING AUTHORS INSTALL TODO examples
|
||||
%doc ChangeLog COPYING AUTHORS INSTALL TODO
|
||||
%{_sbindir}/conntrack
|
||||
%{_sbindir}/conntrackd
|
||||
%{_mandir}/man8/*
|
||||
|
||||
%changelog
|
||||
* Sat Feb 23 2008 Paul P. Komkoff Jr <i@stingr.net> - 0.9.6-0.1.svn7382
|
||||
- new version from svn
|
||||
|
||||
* Fri Feb 22 2008 Paul P. Komkoff Jr <i@stingr.net> - 0.9.5-5
|
||||
- fix the PATH_MAX-related compilation problem
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user