conmon/conmon.spec
Jindrich Novy a600b8f72b conmon-2.1.12-1.el10
- update to https://github.com/containers/conmon/releases/tag/v2.1.12
- Related: RHEL-34195

Signed-off-by: Jindrich Novy <jnovy@redhat.com>
2024-05-27 17:54:22 +02:00

78 lines
1.5 KiB
RPMSpec

%global with_debug 1
%if 0%{?with_debug}
%global _find_debuginfo_dwz_opts %{nil}
%global _dwz_low_mem_die_limit 0
%else
%global debug_package %{nil}
%endif
%if 0%{?rhel}
%bcond_with docs
%else
%bcond_without docs
%endif
Name: conmon
Epoch: 2
Version: 2.1.12
License: Apache-2.0
Release: %autorelease
Summary: OCI container runtime monitor
URL: https://github.com/containers/%{name}
# Tarball fetched from upstream
Source0: %{url}/archive/v%{version}.tar.gz
%if %{with docs}
ExclusiveArch: %{golang_arches_future}
BuildRequires: go-md2man
%endif
BuildRequires: gcc
BuildRequires: git-core
BuildRequires: glib2-devel
BuildRequires: libseccomp-devel
BuildRequires: systemd-devel
BuildRequires: systemd-libs
BuildRequires: make
Requires: glib2
Requires: systemd-libs
Requires: libseccomp
%description
%{summary}.
%prep
%autosetup -Sgit %{name}-%{built_tag_strip}
sed -i 's/install.bin: bin\/conmon/install.bin:/' Makefile
sed -i 's/install.crio: bin\/conmon/install.crio:/' Makefile
%build
%{__make} DEBUGFLAG="-g" bin/conmon
%if %{with docs}
%{__make} GOMD2MAN=go-md2man -C docs
%endif
%install
%{__make} PREFIX=%{buildroot}%{_prefix} install.bin install.crio
%if %{with docs}
%{__make} PREFIX=%{buildroot}%{_prefix} -C docs install
%endif
#define license tag if not already defined
%{!?_licensedir:%global license %doc}
%files
%license LICENSE
%doc README.md
%{_bindir}/%{name}
%{_libexecdir}/crio/%{name}
%dir %{_libexecdir}/crio
%if %{with docs}
%{_mandir}/man8/%{name}.8.gz
%endif
%changelog
%autochangelog