import compiler-rt-14.0.6-1.el9
This commit is contained in:
parent
bab8e3d1d6
commit
f48cab9ef1
@ -1,2 +1,2 @@
|
|||||||
68e9e2f569ccfe0af9f5df61ec74808688198946 SOURCES/compiler-rt-13.0.1.src.tar.xz
|
91f03b578aff0fda6b9d3e2185e6ea5e588c6d47 SOURCES/compiler-rt-14.0.6.src.tar.xz
|
||||||
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
||||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/compiler-rt-13.0.1.src.tar.xz
|
SOURCES/compiler-rt-14.0.6.src.tar.xz
|
||||||
SOURCES/tstellar-gpg-key.asc
|
SOURCES/tstellar-gpg-key.asc
|
||||||
|
@ -1,44 +0,0 @@
|
|||||||
From f4d4ada2e920136870468f43e0f3c1efa265f2f7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: serge-sans-paille <sguelton@redhat.com>
|
|
||||||
Date: Thu, 25 Feb 2021 14:12:57 +0100
|
|
||||||
Subject: [PATCH] [PATCH][compiler-rt] Workaround libstdc++ limitation wrt.
|
|
||||||
thread copy
|
|
||||||
|
|
||||||
---
|
|
||||||
compiler-rt/lib/fuzzer/FuzzerDefs.h | 6 ++++++
|
|
||||||
compiler-rt/lib/fuzzer/FuzzerDriver.cpp | 2 +-
|
|
||||||
2 files changed, 7 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/compiler-rt/lib/fuzzer/FuzzerDefs.h b/compiler-rt/lib/fuzzer/FuzzerDefs.h
|
|
||||||
index 1a2752a..abfbb8d 100644
|
|
||||||
--- a/compiler-rt/lib/fuzzer/FuzzerDefs.h
|
|
||||||
+++ b/compiler-rt/lib/fuzzer/FuzzerDefs.h
|
|
||||||
@@ -50,6 +50,12 @@ template<typename T>
|
|
||||||
|
|
||||||
template<class Other>
|
|
||||||
struct rebind { typedef fuzzer_allocator<Other> other; };
|
|
||||||
+
|
|
||||||
+ template< class U, class... Args >
|
|
||||||
+ void construct( U* p, Args&&... args ) {
|
|
||||||
+ std::allocator<T>::construct(p, std::forward<Args>(args)...);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
};
|
|
||||||
|
|
||||||
template<typename T>
|
|
||||||
diff --git a/compiler-rt/lib/fuzzer/FuzzerDriver.cpp b/compiler-rt/lib/fuzzer/FuzzerDriver.cpp
|
|
||||||
index 447cafc..2fce139 100644
|
|
||||||
--- a/compiler-rt/lib/fuzzer/FuzzerDriver.cpp
|
|
||||||
+++ b/compiler-rt/lib/fuzzer/FuzzerDriver.cpp
|
|
||||||
@@ -294,7 +294,7 @@ static int RunInMultipleProcesses(const Vector<std::string> &Args,
|
|
||||||
std::thread Pulse(PulseThread);
|
|
||||||
Pulse.detach();
|
|
||||||
for (unsigned i = 0; i < NumWorkers; i++)
|
|
||||||
- V.push_back(std::thread(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors));
|
|
||||||
+ V.emplace_back(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors);
|
|
||||||
for (auto &T : V)
|
|
||||||
T.join();
|
|
||||||
return HasErrors ? 1 : 0;
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
37
SOURCES/add-llvm-cmake-package.patch
Normal file
37
SOURCES/add-llvm-cmake-package.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
commit b18bde7a9bd6ed80f5721c47c805f0158b4fe9f8
|
||||||
|
Author: Timm Bäder <tbaeder@redhat.com>
|
||||||
|
Date: Wed Mar 9 07:17:21 2022 +0100
|
||||||
|
|
||||||
|
[compiler-rt] Add LLVM cmake package in standalone builds
|
||||||
|
|
||||||
|
So the other files from the toplevel cmake/Modules directory have a
|
||||||
|
chance of being found.
|
||||||
|
|
||||||
|
diff --git a/compiler-rt/CMakeLists.txt b/compiler-rt/CMakeLists.txt
|
||||||
|
index 3a41aa43e406..6516e10fa3c5 100644
|
||||||
|
--- a/compiler-rt/CMakeLists.txt
|
||||||
|
+++ b/compiler-rt/CMakeLists.txt
|
||||||
|
@@ -28,6 +28,12 @@ else()
|
||||||
|
set(CMAKE_CFG_RESOLVED_INTDIR "")
|
||||||
|
endif()
|
||||||
|
|
||||||
|
+if(COMPILER_RT_STANDALONE_BUILD)
|
||||||
|
+ # Needed to find the other modules from the toplevel cmake/Modules dir
|
||||||
|
+ find_package(LLVM REQUIRED HINTS "${LLVM_CMAKE_DIR}")
|
||||||
|
+ list(APPEND CMAKE_MODULE_PATH "${LLVM_DIR}")
|
||||||
|
+endif()
|
||||||
|
+
|
||||||
|
include(SetPlatformToolchainTools)
|
||||||
|
include(base-config-ix)
|
||||||
|
include(CompilerRTUtils)
|
||||||
|
diff --git a/compiler-rt/test/CMakeLists.txt b/compiler-rt/test/CMakeLists.txt
|
||||||
|
index 5c2b634e1180..098fb0481517 100644
|
||||||
|
--- a/compiler-rt/test/CMakeLists.txt
|
||||||
|
+++ b/compiler-rt/test/CMakeLists.txt
|
||||||
|
@@ -1,6 +1,3 @@
|
||||||
|
-# Needed for lit support in standalone builds.
|
||||||
|
-include(AddLLVM)
|
||||||
|
-
|
||||||
|
option(COMPILER_RT_TEST_STANDALONE_BUILD_LIBS
|
||||||
|
"When set to ON and testing in a standalone build, test the runtime \
|
||||||
|
libraries built by this standalone build rather than the runtime libraries \
|
Binary file not shown.
BIN
SOURCES/compiler-rt-14.0.6.src.tar.xz.sig
Normal file
BIN
SOURCES/compiler-rt-14.0.6.src.tar.xz.sig
Normal file
Binary file not shown.
@ -1,6 +1,5 @@
|
|||||||
#global rc_ver 3
|
%global compiler_rt_version 14.0.6
|
||||||
|
#global rc_ver 2
|
||||||
%global compiler_rt_version 13.0.1
|
|
||||||
%global crt_srcdir compiler-rt-%{compiler_rt_version}%{?rc_ver:rc%{rc_ver}}.src
|
%global crt_srcdir compiler-rt-%{compiler_rt_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
# see https://sourceware.org/bugzilla/show_bug.cgi?id=25271
|
# see https://sourceware.org/bugzilla/show_bug.cgi?id=25271
|
||||||
@ -20,14 +19,14 @@ Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compil
|
|||||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz.sig
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz.sig
|
||||||
Source2: tstellar-gpg-key.asc
|
Source2: tstellar-gpg-key.asc
|
||||||
|
|
||||||
Patch0: 0001-PATCH-compiler-rt-Workaround-libstdc-limitation-wrt..patch
|
Patch0: add-llvm-cmake-package.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: ninja-build
|
BuildRequires: ninja-build
|
||||||
BuildRequires: python3
|
BuildRequires: python3
|
||||||
# We need python3-devel for pathfix.py.
|
# We need python3-devel for %%py3_shebang_fix
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: llvm-devel = %{version}
|
BuildRequires: llvm-devel = %{version}
|
||||||
|
|
||||||
@ -46,10 +45,10 @@ instrumentation, and Blocks C language extension.
|
|||||||
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||||
%autosetup -n %{crt_srcdir} -p2
|
%autosetup -n %{crt_srcdir} -p2
|
||||||
|
|
||||||
pathfix.py -i %{__python3} -pn lib/hwasan/scripts/hwasan_symbolize
|
%py3_shebang_fix lib/hwasan/scripts/hwasan_symbolize
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -GNinja \
|
%cmake -GNinja \
|
||||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||||
-DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
|
-DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
|
||||||
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
||||||
@ -104,13 +103,25 @@ popd
|
|||||||
%files
|
%files
|
||||||
%license LICENSE.TXT
|
%license LICENSE.TXT
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%{_libdir}/clang/%{version}/lib/*
|
%{_libdir}/clang/%{compiler_rt_version}/lib/*
|
||||||
%{_libdir}/clang/%{version}/share/*
|
%{_libdir}/clang/%{compiler_rt_version}/share/*
|
||||||
%ifarch x86_64 aarch64
|
%ifarch x86_64 aarch64
|
||||||
%{_bindir}/hwasan_symbolize
|
%{_bindir}/hwasan_symbolize
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 20 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.6-1
|
||||||
|
- 14.0.6 Release
|
||||||
|
|
||||||
|
* Wed Jun 22 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.5-1
|
||||||
|
- 14.0.5 Release
|
||||||
|
|
||||||
|
* Thu May 12 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-2
|
||||||
|
- Disable execstack on s390x
|
||||||
|
|
||||||
|
* Mon Apr 25 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
|
||||||
|
- 14.0.0 Release
|
||||||
|
|
||||||
* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
|
* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
|
||||||
- 13.0.1 Release
|
- 13.0.1 Release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user