Import rpm: 534823a42182b3b8dc9d099287c259c35e2cce83
This commit is contained in:
commit
cf2c5185d7
1
.fmf/version
Normal file
1
.fmf/version
Normal file
@ -0,0 +1 @@
|
|||||||
|
1
|
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/compiler-rt-14.0.0.src.tar.xz
|
||||||
|
SOURCES/tstellar-gpg-key.asc
|
24
0001-Drop-fno-stack-protector-from-the-compiler-flags.patch
Normal file
24
0001-Drop-fno-stack-protector-from-the-compiler-flags.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
From f007934385dc76b9299bd72cdef102fe979af93b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
|
Date: Wed, 5 Sep 2018 21:07:42 -0700
|
||||||
|
Subject: [PATCH] Drop -fno-stack-protector from the compiler flags
|
||||||
|
|
||||||
|
---
|
||||||
|
compiler-rt/CMakeLists.txt | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git compiler-rt.orig/CMakeLists.txt compiler-rt/CMakeLists.txt
|
||||||
|
index f26ae25..a6ac032 100644
|
||||||
|
--- compiler-rt.orig/CMakeLists.txt
|
||||||
|
+++ b/compiler-rt/CMakeLists.txt
|
||||||
|
@@ -271,7 +271,6 @@ if(NOT COMPILER_RT_DEBUG AND NOT APPLE)
|
||||||
|
append_list_if(COMPILER_RT_HAS_FOMIT_FRAME_POINTER_FLAG -fomit-frame-pointer SANITIZER_COMMON_CFLAGS)
|
||||||
|
endif()
|
||||||
|
append_list_if(COMPILER_RT_HAS_FUNWIND_TABLES_FLAG -funwind-tables SANITIZER_COMMON_CFLAGS)
|
||||||
|
-append_list_if(COMPILER_RT_HAS_FNO_STACK_PROTECTOR_FLAG -fno-stack-protector SANITIZER_COMMON_CFLAGS)
|
||||||
|
append_list_if(COMPILER_RT_HAS_FNO_SANITIZE_SAFE_STACK_FLAG -fno-sanitize=safe-stack SANITIZER_COMMON_CFLAGS)
|
||||||
|
append_list_if(COMPILER_RT_HAS_FVISIBILITY_HIDDEN_FLAG -fvisibility=hidden SANITIZER_COMMON_CFLAGS)
|
||||||
|
if(NOT COMPILER_RT_HAS_FVISIBILITY_HIDDEN_FLAG)
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
37
add-llvm-cmake-package.patch
Normal file
37
add-llvm-cmake-package.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
commit b18bde7a9bd6ed80f5721c47c805f0158b4fe9f8
|
||||||
|
Author: Timm Bäder <tbaeder@redhat.com>
|
||||||
|
Date: Wed Mar 9 07:17:21 2022 +0100
|
||||||
|
|
||||||
|
[compiler-rt] Add LLVM cmake package in standalone builds
|
||||||
|
|
||||||
|
So the other files from the toplevel cmake/Modules directory have a
|
||||||
|
chance of being found.
|
||||||
|
|
||||||
|
diff --git a/compiler-rt/CMakeLists.txt b/compiler-rt/CMakeLists.txt
|
||||||
|
index 3a41aa43e406..6516e10fa3c5 100644
|
||||||
|
--- a/compiler-rt/CMakeLists.txt
|
||||||
|
+++ b/compiler-rt/CMakeLists.txt
|
||||||
|
@@ -28,6 +28,12 @@ else()
|
||||||
|
set(CMAKE_CFG_RESOLVED_INTDIR "")
|
||||||
|
endif()
|
||||||
|
|
||||||
|
+if(COMPILER_RT_STANDALONE_BUILD)
|
||||||
|
+ # Needed to find the other modules from the toplevel cmake/Modules dir
|
||||||
|
+ find_package(LLVM REQUIRED HINTS "${LLVM_CMAKE_DIR}")
|
||||||
|
+ list(APPEND CMAKE_MODULE_PATH "${LLVM_DIR}")
|
||||||
|
+endif()
|
||||||
|
+
|
||||||
|
include(SetPlatformToolchainTools)
|
||||||
|
include(base-config-ix)
|
||||||
|
include(CompilerRTUtils)
|
||||||
|
diff --git a/compiler-rt/test/CMakeLists.txt b/compiler-rt/test/CMakeLists.txt
|
||||||
|
index 5c2b634e1180..098fb0481517 100644
|
||||||
|
--- a/compiler-rt/test/CMakeLists.txt
|
||||||
|
+++ b/compiler-rt/test/CMakeLists.txt
|
||||||
|
@@ -1,6 +1,3 @@
|
||||||
|
-# Needed for lit support in standalone builds.
|
||||||
|
-include(AddLLVM)
|
||||||
|
-
|
||||||
|
option(COMPILER_RT_TEST_STANDALONE_BUILD_LIBS
|
||||||
|
"When set to ON and testing in a standalone build, test the runtime \
|
||||||
|
libraries built by this standalone build rather than the runtime libraries \
|
BIN
compiler-rt-14.0.0.src.tar.xz.sig
Normal file
BIN
compiler-rt-14.0.0.src.tar.xz.sig
Normal file
Binary file not shown.
253
compiler-rt.spec
Normal file
253
compiler-rt.spec
Normal file
@ -0,0 +1,253 @@
|
|||||||
|
%global compiler_rt_version 14.0.0
|
||||||
|
#global rc_ver 2
|
||||||
|
%global crt_srcdir compiler-rt-%{compiler_rt_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
|
# see https://sourceware.org/bugzilla/show_bug.cgi?id=25271
|
||||||
|
%global optflags %(echo %{optflags} -D_DEFAULT_SOURCE)
|
||||||
|
|
||||||
|
# see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=93615
|
||||||
|
%global optflags %(echo %{optflags} -Dasm=__asm__)
|
||||||
|
|
||||||
|
Name: compiler-rt
|
||||||
|
Version: %{compiler_rt_version}%{?rc_ver:~rc%{rc_ver}}
|
||||||
|
Release: 3%{?dist}
|
||||||
|
Summary: LLVM "compiler-rt" runtime libraries
|
||||||
|
|
||||||
|
License: NCSA or MIT
|
||||||
|
URL: http://llvm.org
|
||||||
|
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz
|
||||||
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz.sig
|
||||||
|
Source2: tstellar-gpg-key.asc
|
||||||
|
|
||||||
|
Patch0: add-llvm-cmake-package.patch
|
||||||
|
|
||||||
|
# RHEL-specific patches
|
||||||
|
Patch100: 0001-Drop-fno-stack-protector-from-the-compiler-flags.patch
|
||||||
|
Patch101: fix-page-size-constant.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: ninja-build
|
||||||
|
BuildRequires: python3
|
||||||
|
# We need python3-devel for pathfix.py.
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: llvm-devel = %{version}
|
||||||
|
|
||||||
|
# For gpg source verification
|
||||||
|
BuildRequires: gnupg2
|
||||||
|
|
||||||
|
Requires: clang-resource-filesystem%{?isa} = %{version}
|
||||||
|
|
||||||
|
%description
|
||||||
|
The compiler-rt project is a part of the LLVM project. It provides
|
||||||
|
implementation of the low-level target-specific hooks required by
|
||||||
|
code generation, sanitizer runtimes and profiling library for code
|
||||||
|
instrumentation, and Blocks C language extension.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||||
|
%autosetup -n %{crt_srcdir} -p2
|
||||||
|
|
||||||
|
%py3_shebang_fix lib/hwasan/scripts/hwasan_symbolize
|
||||||
|
|
||||||
|
%build
|
||||||
|
mkdir -p %{_vpath_builddir}
|
||||||
|
cd %{_vpath_builddir}
|
||||||
|
|
||||||
|
%cmake .. -GNinja \
|
||||||
|
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||||
|
-DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
|
||||||
|
\
|
||||||
|
%if 0%{?__isa_bits} == 64
|
||||||
|
-DLLVM_LIBDIR_SUFFIX=64 \
|
||||||
|
%else
|
||||||
|
-DLLVM_LIBDIR_SUFFIX= \
|
||||||
|
%endif
|
||||||
|
-DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
|
||||||
|
|
||||||
|
%cmake_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
|
||||||
|
cd %{_vpath_builddir}
|
||||||
|
%cmake_install
|
||||||
|
|
||||||
|
# move blacklist/abilist files to where clang expect them
|
||||||
|
mkdir -p %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/share
|
||||||
|
mv -v %{buildroot}%{_datadir}/*list.txt %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/share/
|
||||||
|
|
||||||
|
# move sanitizer libs to better place
|
||||||
|
%global libclang_rt_installdir lib/linux
|
||||||
|
mkdir -p %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/lib
|
||||||
|
mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/*clang_rt* %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/lib
|
||||||
|
mkdir -p %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/lib/linux/
|
||||||
|
pushd %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/lib
|
||||||
|
for i in *.a *.so
|
||||||
|
do
|
||||||
|
ln -s ../$i linux/$i
|
||||||
|
done
|
||||||
|
|
||||||
|
# multilib support: also create symlink from lib to lib64, fixes rhbz#1678240
|
||||||
|
# the symlinks will be dangling if the 32 bits version is not installed, but that should be fine
|
||||||
|
%ifarch x86_64
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}/%{_exec_prefix}/lib/clang/%{compiler_rt_version}/lib/linux
|
||||||
|
for i in *.a *.so
|
||||||
|
do
|
||||||
|
target=`echo "$i" | sed -e 's/x86_64/i386/'`
|
||||||
|
ln -s ../../../../../lib/clang/%{compiler_rt_version}/lib/$target ../../../../%{_lib}/clang/%{compiler_rt_version}/lib/linux/
|
||||||
|
done
|
||||||
|
|
||||||
|
%endif
|
||||||
|
|
||||||
|
popd
|
||||||
|
|
||||||
|
%check
|
||||||
|
|
||||||
|
#%%cmake_build --target check-compiler-rt
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license LICENSE.TXT
|
||||||
|
%{_includedir}/*
|
||||||
|
%{_libdir}/clang/%{compiler_rt_version}/lib/*
|
||||||
|
%{_libdir}/clang/%{compiler_rt_version}/share/*
|
||||||
|
%ifarch x86_64 aarch64
|
||||||
|
%{_bindir}/hwasan_symbolize
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed May 25 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-3
|
||||||
|
- Fix page size constant size on aarch64 and ppc64le
|
||||||
|
|
||||||
|
* Fri Apr 29 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-2
|
||||||
|
- Remove llvm-cmake-devel BR
|
||||||
|
|
||||||
|
* Thu Apr 07 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
|
||||||
|
- Update to 14.0.0
|
||||||
|
|
||||||
|
* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
|
||||||
|
- 13.0.1 Release
|
||||||
|
|
||||||
|
* Fri Oct 15 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0-1
|
||||||
|
- 13.0.0 Release
|
||||||
|
|
||||||
|
* Fri Jul 16 2021 sguelton@redhat.com - 12.0.1-1
|
||||||
|
- 12.0.1 release
|
||||||
|
|
||||||
|
* Tue May 25 2021 sguelton@redhat.com - 12.0.0-2
|
||||||
|
- Backport several compatibility patches
|
||||||
|
|
||||||
|
* Thu May 6 2021 sguelton@redhat.com - 12.0.0-1
|
||||||
|
- 12.0.0 release
|
||||||
|
|
||||||
|
* Thu Oct 29 2020 sguelton@redhat.com - 11.0.0-1
|
||||||
|
- 11.0.0 final release
|
||||||
|
|
||||||
|
* Mon Sep 21 2020 sguelton@redhat.com - 11.0.0-0.1.rc2
|
||||||
|
- 11.0.0-rc2 Release
|
||||||
|
|
||||||
|
* Fri Jul 24 2020 sguelton@redhat.com - 10.0.1-1
|
||||||
|
- 10.0.1 release
|
||||||
|
|
||||||
|
* Mon Jun 15 2020 sguelton@redhat.com - 10.0.0-2
|
||||||
|
- Fix msan compilation warnings, see rhbz#1841165
|
||||||
|
|
||||||
|
* Wed Apr 8 2020 sguelton@redhat.com - 10.0.0-1
|
||||||
|
- 10.0.0 final
|
||||||
|
|
||||||
|
* Mon Jan 06 2020 Tom Stellard <tstellar@redhat.com> - 9.0.1-2
|
||||||
|
- Update fno-stack-protector patch to apply with -p2
|
||||||
|
|
||||||
|
* Fri Dec 20 2019 Tom Stellard <tstellar@redhat.com> - 9.0.1-1
|
||||||
|
- 9.0.1 Release
|
||||||
|
|
||||||
|
* Fri Sep 27 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-1
|
||||||
|
- 9.0.0 Release
|
||||||
|
|
||||||
|
* Thu Aug 1 2019 sguelton@redhat.com - 8.0.1-1
|
||||||
|
- 8.0.1 release
|
||||||
|
|
||||||
|
* Thu Jul 4 2019 sguelton@redhat.com - 8.0.1-0.2.rc2
|
||||||
|
- Fix rhbz#1678240
|
||||||
|
|
||||||
|
* Thu Jun 13 2019 sguelton@redhat.com - 8.0.1-0.1.rc2
|
||||||
|
- 8.0.1rc2 Release
|
||||||
|
|
||||||
|
* Wed Apr 17 2019 sguelton@redhat.com - 8.0.0-1
|
||||||
|
- 8.0.0 Release
|
||||||
|
|
||||||
|
* Fri Dec 14 2018 Tom Stellard <tstellar@redhat.com> - 7.0.1-1
|
||||||
|
- 7.0.1 Release
|
||||||
|
|
||||||
|
* Mon Dec 10 2018 Tom Stellard <tstellar@redhat.com> - 7.0.1-0.1.rc3
|
||||||
|
- 7.0.1-rc3 Release
|
||||||
|
|
||||||
|
* Tue Nov 27 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-1
|
||||||
|
- 7.0.0 Release
|
||||||
|
|
||||||
|
* Tue Oct 02 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-5
|
||||||
|
- Use python3 for build scripts
|
||||||
|
|
||||||
|
* Mon Oct 01 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-4
|
||||||
|
- Drop scl macros
|
||||||
|
|
||||||
|
* Thu Sep 06 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-3
|
||||||
|
- Drop -fno-stack-protector flag
|
||||||
|
|
||||||
|
* Thu Sep 06 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-2
|
||||||
|
- Explicitly BuildRequire: /usr/bin/python3
|
||||||
|
|
||||||
|
* Wed Jul 11 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-1
|
||||||
|
- 6.0.1 Release
|
||||||
|
|
||||||
|
* Tue Jan 09 2018 Tom Stellard <tstellar@redhat.com> - 5.0.1-1
|
||||||
|
- 5.0.1 Release
|
||||||
|
|
||||||
|
* Wed Jun 07 2017 Tom Stellard <tstellar@redhat.com> - 4.0.1-1
|
||||||
|
- 4.0.1 Release
|
||||||
|
|
||||||
|
* Wed Jun 07 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-3
|
||||||
|
- Build for llvm-toolset-7 rename
|
||||||
|
|
||||||
|
* Thu May 18 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-2
|
||||||
|
- Fix disabling debug on s390(x)
|
||||||
|
|
||||||
|
* Tue Mar 14 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-1
|
||||||
|
- compiler-rt 4.0.0 Final Release
|
||||||
|
|
||||||
|
* Thu Mar 02 2017 Dave Airlie <airlied@redhat.com> - 3.9.1-1
|
||||||
|
- compiler-rt 3.9.1
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.9.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 21 2016 Dan Horák <dan[at]danny.cz> - 3.9.0-3
|
||||||
|
- disable debuginfo on s390(x)
|
||||||
|
|
||||||
|
* Wed Nov 02 2016 Dave Airlie <airlied@redhat.com> - 3.9.0-2
|
||||||
|
- build for new arches.
|
||||||
|
|
||||||
|
* Wed Oct 26 2016 Dave Airlie <airlied@redhat.com> - 3.9.0-1
|
||||||
|
- compiler-rt 3.9.0 final release
|
||||||
|
|
||||||
|
* Mon May 2 2016 Tom Callaway <spot@fedoraproject.org> 3.8.0-2
|
||||||
|
- make symlinks to where the linker thinks these libs are
|
||||||
|
|
||||||
|
* Thu Mar 10 2016 Dave Airlie <airlied@redhat.com> 3.8.0-1
|
||||||
|
- compiler-rt 3.8.0 final release
|
||||||
|
|
||||||
|
* Thu Mar 03 2016 Dave Airlie <airlied@redhat.com> 3.8.0-0.2
|
||||||
|
- compiler-rt 3.8.0rc3
|
||||||
|
|
||||||
|
* Thu Feb 18 2016 Dave Airlie <airlied@redhat.com> - 3.8.0-0.1
|
||||||
|
- compiler-rt 3.8.0rc2
|
||||||
|
|
||||||
|
* Fri Feb 05 2016 Dave Airlie <airlied@redhat.com> 3.7.1-3
|
||||||
|
- fix compiler-rt paths - from rwindz0@gmail.com - #1304605
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Oct 06 2015 Jan Vcelak <jvcelak@fedoraproject.org> 3.7.0-100
|
||||||
|
- initial version using cmake build system
|
15
fix-page-size-constant.patch
Normal file
15
fix-page-size-constant.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -ruN compiler-rt-14.0.0.src.orig/lib/cfi/cfi.cpp compiler-rt-14.0.0.src/lib/cfi/cfi.cpp
|
||||||
|
--- a/compiler-rt-14.0.0.src.orig/lib/cfi/cfi.cpp 2022-03-14 10:44:55.000000000 +0100
|
||||||
|
+++ b/compiler-rt-14.0.0.src/lib/cfi/cfi.cpp 2022-05-25 17:03:51.114415534 +0200
|
||||||
|
@@ -51,7 +51,11 @@
|
||||||
|
|
||||||
|
namespace __cfi {
|
||||||
|
|
||||||
|
+#if defined(__aarch64__) || defined(__powerpc64__)
|
||||||
|
+#define kCfiShadowLimitsStorageSize 65536 // 1 page
|
||||||
|
+#else
|
||||||
|
#define kCfiShadowLimitsStorageSize 4096 // 1 page
|
||||||
|
+#endif
|
||||||
|
// Lets hope that the data segment is mapped with 4K pages.
|
||||||
|
// The pointer to the cfi shadow region is stored at the start of this page.
|
||||||
|
// The rest of the page is unused and re-mapped read-only.
|
18
gating.yaml
Normal file
18
gating.yaml
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
--- !Policy
|
||||||
|
product_versions:
|
||||||
|
- fedora-*
|
||||||
|
decision_context: bodhi_update_push_testing
|
||||||
|
rules:
|
||||||
|
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
|
||||||
|
--- !Policy
|
||||||
|
product_versions:
|
||||||
|
- fedora-*
|
||||||
|
decision_context: bodhi_update_push_stable
|
||||||
|
rules:
|
||||||
|
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
|
||||||
|
--- !Policy
|
||||||
|
product_versions:
|
||||||
|
- rhel-9
|
||||||
|
decision_context: osci_compose_gate
|
||||||
|
rules:
|
||||||
|
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.tier0.functional}
|
52
hans-gpg-key.asc
Normal file
52
hans-gpg-key.asc
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
-----BEGIN PGP PUBLIC KEY BLOCK-----
|
||||||
|
|
||||||
|
mQINBFS+1SABEACnmkESkY7eZq0GhDjbkWpKmURGk9+ycsfAhA44NqUvf4tk1GPM
|
||||||
|
5SkJ/fYedYZJaDVhIp98fHgucD0O+vjOzghtgwtITusYjiPHPFBd/MN+MQqSEAP+
|
||||||
|
LUa/kjHLjgyXxKhFUIDGVaDWL5tKOA7/AQKl1TyJ8lz89NHQoUHFsF/hu10+qhJe
|
||||||
|
V65d32MXFehIUSvegh8DrPuExrliSiORO4HOhuc6151dWA4YBWVg4rX5kfKrGMMT
|
||||||
|
pTWnSSZtgoRhkKW2Ey8cmZUqPuUJIfWyeNVu1e4SFtAivLvu/Ymz2WBJcNA1ZlTr
|
||||||
|
RCOR5SIRgZ453pQnI/Bzna2nnJ/TV1gGJIGRahj/ini0cs2x1CILfS/YJQ3rWGGo
|
||||||
|
OxwG0BVmPk0cmLVtyTq8gUPwxcPUd6WcBKhot3TDMlrffZACnQwQjlVjk5S1dEEz
|
||||||
|
atUfpEuNitU9WOM4jr/gjv36ZNCOWm95YwLhsuci/NddBN8HXhyvs+zYTVZEXa2W
|
||||||
|
l/FqOdQsQqZBcJjjWckGKhESdd7934+cesGD3O8KaeSGxww7slJrS0+6QJ8oBoAB
|
||||||
|
P/WCn/y2AiY2syEKp3wYIGJyAbsm542zMZ4nc7pYfSu49mcyhQQICmqN5QvOyYUx
|
||||||
|
OSqwbAOUNtlOyeRLZNIKoXtTqWDEu5aEiDROTw6Rkq+dIcxPNgOLdeQ3HwARAQAB
|
||||||
|
tCFIYW5zIFdlbm5ib3JnIDxoYW5zQGNocm9taXVtLm9yZz6JAlUEEwECAD8CGwMG
|
||||||
|
CwkIBwMCBhUIAgkKCwQWAgMBAh4BAheAFiEEtsj5goK5ROOw1cJTD8MELjRa0F0F
|
||||||
|
Alpd+i0FCQ8FJo0ACgkQD8MELjRa0F3X3A//dBQLm6GmXlQFjxZbukTw0lZsevFR
|
||||||
|
M/6ljZTxp7bsC+HFzYoaCKv6rikaWzytxk//SOaLKrB4Z9HjAlpBMtyLl2Hk7tcZ
|
||||||
|
bPpFafNmQ+4KgWNjLXCvt9se8BGrQvGQUrbE6YowbXa2YIgxIVEncFzIECAsp/+N
|
||||||
|
xbMcZN5/X1PJxKi/N22gP4nn47muN6L3pKez3CXgWnhGYSc7BuD5ALWYH7yMYUem
|
||||||
|
d4jlXfu5xkBIqirj1arIYC9wmF4ldbLNDPuracc8LmXcSqa5Rpao0s4iVzAD+tkX
|
||||||
|
vE/73m3rhepwBXxrfk0McXuI9aucf5h4/KkIBzZsaJ6JM1tzlrJzzjaBKJF9OI5T
|
||||||
|
jA0qTxdGzdPztS8gPaPcMkRFfh9ti0ZDx4VeF3s8sOtmMRHeGEWfxqUAbBUbwFsa
|
||||||
|
JDu/+8/VO4KijfcuUi8tqJ/JHeosCuGE7TM93LwJu6ZcqMYOPDROE/hsnGm0ZU92
|
||||||
|
xedu+07/X1ESHkSFPoaSHD5/DCNa/tXIyJZ8X7gF3eoDP5mSmrJqIqsOBR9WOVYv
|
||||||
|
dI8i0GHTXbrZj8WXdoS+N8wlyMLLbAS2jvTe7M5RoqbLz4ABOUUnLVoEE0CiccVZ
|
||||||
|
bW75BPxOfaD0szbinAeX6HDPI7St0MbKrRPjuDXjD0JVkLqFINtZfYLGMLss4tgn
|
||||||
|
suefr0Bo9ISwG3u5Ag0EVL7VIAEQAOxBxrQesChjrCqKjY5PnSsSYpeb4froucrC
|
||||||
|
898AFw2DgN/Zz+W7wtSTbtz/GRcCurjzZvN7o2rCuNk0j0+s1sgZZm2BdldlabLy
|
||||||
|
+UF/kSW1rb5qhfXcGGubu48OMdtSfok9lOc0Q1L4HNlGE4lUBkZzmI7Ykqfl+Bwr
|
||||||
|
m9rpi54g4ua9PIiiHIAmMoZIcbtOG1KaDr6CoXRk/3g2ZiGUwhq3jFGroiBsKEap
|
||||||
|
2FJ1bh5NJk2Eg8pV7fMOF7hUQKBZrNOtIPu8hA5WEgku3U3VYjRSI3SDi6QXnDL+
|
||||||
|
xHxajiWpKtF3JjZh8y/CCTD8PyP34YjfZuFmkdske5cdx6H0V2UCiH453ncgFVdQ
|
||||||
|
DXkY4n+0MTzhy2xu0IVVnBxYDYNhi+3MjTHJd9C4xMi9t+5IuEvDAPhgfZjDpQak
|
||||||
|
EPz6hVmgj0mlKIgRilBRK9/kOxky9utBpGk3jEJGru/hKNloFNspoYtY6zATAr8E
|
||||||
|
cOgoCFQE0nIktcg3wF9+OCEnV28/a7XZwUZ7Gl/qfOHtdr374wo8kd8R3V8d2G9q
|
||||||
|
5w0/uCV9NNQ0fGWZDPDoYt6wnPL6gZv/nJM8oZY+u0rC24WwScZIniaryC4JHDas
|
||||||
|
Ahr2S2CtgCvBgslK6f3gD16KHxPZMBpX73TzOYIhMEP/vXgVJbUD6dYht+U9c4Oh
|
||||||
|
EDJown0dABEBAAGJAjwEGAECACYCGwwWIQS2yPmCgrlE47DVwlMPwwQuNFrQXQUC
|
||||||
|
Wl36SwUJDwUmqwAKCRAPwwQuNFrQXT1/D/9YpRDNgaJl3YVDtVZoeQwh7BQ6ULZT
|
||||||
|
eXFPogYkF2j3VWg8s9UmAs4sg/4a+9KLSantXjX+JFsRv0lQe5Gr/Vl8VQ4LKEXB
|
||||||
|
fiGmSivjIZ7eopdd3YP2w6G5T3SA4d2CQfsg4rnJPnXIjzKNiSOi368ybnt9fL0Y
|
||||||
|
2r2aqLTmP6Y7issDUO+J1TW1XHm349JPR0Hl4cTuNnWm4JuX2m2CJEc5XBlDAha9
|
||||||
|
pUVs+J5C2D0UFFkyeOzeJPwy6x5ApWHm84n8AjhQSpu1qRKxKXdwei6tkQWWMHui
|
||||||
|
+TgSY/zCkmD9/oY15Ei5avJ4WgIbTLJUoZMi70riPmU8ThjpzA7S+Nk0g7rMPq+X
|
||||||
|
l1whjKU/u0udlsrIJjzkh6ftqKUmIkbxYTpjhnEujNrEr5m2S6Z6x3y9E5QagBMR
|
||||||
|
dxRhfk+HbyACcP/p9rXOzl4M291DoKeAAH70GHniGxyNs9rAoMr/hD5XW/Wrz3dc
|
||||||
|
KMc2s555E6MZILE2ZiolcRn+bYOMPZtWlbx98t8uqMf49gY4FGQBZAwPglMrx7mr
|
||||||
|
m7HTIiXahThQGOJg6izJDAD5RwSEGlAcL28T8KAuM6CLLkhlBfQwiKsUBNnh9r8w
|
||||||
|
V3lB+pV0GhL+3i077gTYfZBRwLzjFdhm9xUKEaZ6rN1BX9lzix4eSNK5nln0jUq1
|
||||||
|
67H2IH//2sf8dw==
|
||||||
|
=ADVe
|
||||||
|
-----END PGP PUBLIC KEY BLOCK-----
|
21
rpminspect.yaml
Normal file
21
rpminspect.yaml
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
---
|
||||||
|
# For compiler-rt, we filter out the following forbidden functions from the list:
|
||||||
|
# - gethostbyname
|
||||||
|
# - gethostbyname2
|
||||||
|
# - gethostbyaddr
|
||||||
|
# - inet_aton
|
||||||
|
# These are never actually used, and are installed just as interceptors.
|
||||||
|
badfuncs:
|
||||||
|
- inet_addr
|
||||||
|
- inet_nsap_addr
|
||||||
|
- inet_ntoa
|
||||||
|
- inet_nsap_ntoa
|
||||||
|
- inet_makeaddr
|
||||||
|
- inet_netof
|
||||||
|
- inet_network
|
||||||
|
- inet_neta
|
||||||
|
- inet_net_ntop
|
||||||
|
- inet_net_pton
|
||||||
|
- rcmd
|
||||||
|
- rexec
|
||||||
|
- rresvport
|
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SHA1 (compiler-rt-14.0.0.src.tar.xz) = 6e285bfcbd93160355011a276efec3112d3179f2
|
||||||
|
SHA1 (tstellar-gpg-key.asc) = b8d2648a01d36ed0186fd2c5af325fd28797f9a0
|
53
tests/build-gating.fmf
Normal file
53
tests/build-gating.fmf
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
#
|
||||||
|
# Build/PR gating tests for *LLVM 13*
|
||||||
|
#
|
||||||
|
# Imports and runs tests provided by Fedora LLVM git for the matching LLVM version.
|
||||||
|
#
|
||||||
|
# NOTE: *always* keep this file in sync with upstream, i.e. Fedora. Since we cannot "discover" a plan,
|
||||||
|
# we must duplicate at least some part of upstream plan setup, like `adjust` or `provision`. Not necessarily
|
||||||
|
# all steps, but if we do need some of them here, let's focus on making changes in upstream first, to preserve
|
||||||
|
# one source of truth. Once TMT learns to include whole plans, we could drop the copied content from here.
|
||||||
|
#
|
||||||
|
|
||||||
|
summary: compiler-rt tests for build/PR gating
|
||||||
|
adjust:
|
||||||
|
- because: "Plan to be ran when either executed locally, or executed by CI system to gate a build or PR."
|
||||||
|
when: >-
|
||||||
|
trigger is defined
|
||||||
|
and trigger != commit
|
||||||
|
and trigger != build
|
||||||
|
enabled: false
|
||||||
|
|
||||||
|
# Unfortunately, TMT does not support more declarative approach, we need to run commands on our own.
|
||||||
|
- because: "On RHEL, CRB must be enabled to provide rarer packages"
|
||||||
|
when: >-
|
||||||
|
distro == rhel-9
|
||||||
|
or distro == rhel-8
|
||||||
|
prepare+:
|
||||||
|
- name: Enable CRB
|
||||||
|
how: shell
|
||||||
|
script: dnf config-manager --set-enabled rhel-CRB
|
||||||
|
|
||||||
|
- because: "On CentOS, CRB must be enabled to provide rarer packages"
|
||||||
|
when: >-
|
||||||
|
distro == centos
|
||||||
|
prepare+:
|
||||||
|
- name: Enable CRB
|
||||||
|
how: shell
|
||||||
|
script: dnf config-manager --set-enabled crb
|
||||||
|
|
||||||
|
discover:
|
||||||
|
- name: compiler-rt-upstream-tests
|
||||||
|
how: fmf
|
||||||
|
url: https://src.fedoraproject.org/rpms/compiler-rt.git
|
||||||
|
ref: rawhide
|
||||||
|
- name: upstream-llvm-integration-testsuite
|
||||||
|
how: fmf
|
||||||
|
url: https://src.fedoraproject.org/rpms/llvm.git
|
||||||
|
ref: rawhide
|
||||||
|
test: integration-test-suite
|
||||||
|
execute:
|
||||||
|
how: tmt
|
||||||
|
provision:
|
||||||
|
hardware:
|
||||||
|
memory: ">= 4 GiB"
|
BIN
tstellar-gpg-key.asc
Normal file
BIN
tstellar-gpg-key.asc
Normal file
Binary file not shown.
Loading…
Reference in New Issue
Block a user