import compiler-rt-8.0.0-1.module+el8.1.0+3173+f36a2e38
This commit is contained in:
commit
67939b6908
1
.compiler-rt.metadata
Normal file
1
.compiler-rt.metadata
Normal file
@ -0,0 +1 @@
|
||||
5af387779120bb2a9fad5d6fff1a3d6f4fa6c352 SOURCES/compiler-rt-8.0.0.src.tar.xz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/compiler-rt-8.0.0.src.tar.xz
|
@ -0,0 +1,24 @@
|
||||
From 66b952a4aeab83a7692d9d80a046034de79fe2e2 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Wed, 5 Sep 2018 21:07:42 -0700
|
||||
Subject: [PATCH] Drop -fno-stack-protector from the compiler flags
|
||||
|
||||
---
|
||||
CMakeLists.txt | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 4b953b2..043cc31 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -207,7 +207,6 @@ if(NOT COMPILER_RT_DEBUG AND NOT APPLE)
|
||||
append_list_if(COMPILER_RT_HAS_FOMIT_FRAME_POINTER_FLAG -fomit-frame-pointer SANITIZER_COMMON_CFLAGS)
|
||||
endif()
|
||||
append_list_if(COMPILER_RT_HAS_FUNWIND_TABLES_FLAG -funwind-tables SANITIZER_COMMON_CFLAGS)
|
||||
-append_list_if(COMPILER_RT_HAS_FNO_STACK_PROTECTOR_FLAG -fno-stack-protector SANITIZER_COMMON_CFLAGS)
|
||||
append_list_if(COMPILER_RT_HAS_FNO_SANITIZE_SAFE_STACK_FLAG -fno-sanitize=safe-stack SANITIZER_COMMON_CFLAGS)
|
||||
append_list_if(COMPILER_RT_HAS_FVISIBILITY_HIDDEN_FLAG -fvisibility=hidden SANITIZER_COMMON_CFLAGS)
|
||||
if(NOT COMPILER_RT_HAS_FVISIBILITY_HIDDEN_FLAG)
|
||||
--
|
||||
1.8.3.1
|
||||
|
28
SOURCES/0001-PATCH-std-thread-copy.patch
Normal file
28
SOURCES/0001-PATCH-std-thread-copy.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -ru compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDefs.h compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDefs.h
|
||||
--- compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDefs.h 2019-01-09 21:46:09.000000000 +0000
|
||||
+++ compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDefs.h 2019-02-12 14:03:32.971147814 +0000
|
||||
@@ -176,6 +176,12 @@
|
||||
|
||||
template<class Other>
|
||||
struct rebind { typedef fuzzer_allocator<Other> other; };
|
||||
+
|
||||
+ template< class U, class... Args >
|
||||
+ void construct( U* p, Args&&... args ) {
|
||||
+ std::allocator<T>::construct(p, std::forward<Args>(args)...);
|
||||
+ }
|
||||
+
|
||||
};
|
||||
|
||||
template<typename T>
|
||||
diff -ru compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDriver.cpp compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDriver.cpp
|
||||
--- compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDriver.cpp 2019-01-15 22:12:51.000000000 +0000
|
||||
+++ compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDriver.cpp 2019-02-12 13:05:15.965113872 +0000
|
||||
@@ -252,7 +252,7 @@
|
||||
std::thread Pulse(PulseThread);
|
||||
Pulse.detach();
|
||||
for (unsigned i = 0; i < NumWorkers; i++)
|
||||
- V.push_back(std::thread(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors));
|
||||
+ V.emplace_back(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors);
|
||||
for (auto &T : V)
|
||||
T.join();
|
||||
return HasErrors ? 1 : 0;
|
165
SPECS/compiler-rt.spec
Normal file
165
SPECS/compiler-rt.spec
Normal file
@ -0,0 +1,165 @@
|
||||
%ifarch s390 s390x
|
||||
# only limited set of libs available on s390(x) and the existing ones (stats, ubsan) don't provide debuginfo
|
||||
%global debug_package %{nil}
|
||||
%endif
|
||||
|
||||
#%%global rc_ver 4
|
||||
|
||||
%global crt_srcdir compiler-rt-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
Name: compiler-rt
|
||||
Version: 8.0.0
|
||||
Release: 1%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Summary: LLVM "compiler-rt" runtime libraries
|
||||
|
||||
License: NCSA or MIT
|
||||
URL: http://llvm.org
|
||||
Source0: http://%{?rc_ver:pre}releases.llvm.org/%{version}/%{?rc_ver:rc%{rc_ver}}/%{crt_srcdir}.tar.xz
|
||||
|
||||
Patch0: 0001-PATCH-std-thread-copy.patch
|
||||
Patch1: 0001-Drop-fno-stack-protector-from-the-compiler-flags.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
BuildRequires: python3
|
||||
# We need python3-devel for pathfix.py.
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: llvm-devel = %{version}
|
||||
BuildRequires: llvm-static = %{version}
|
||||
|
||||
%description
|
||||
The compiler-rt project is a part of the LLVM project. It provides
|
||||
implementation of the low-level target-specific hooks required by
|
||||
code generation, sanitizer runtimes and profiling library for code
|
||||
instrumentation, and Blocks C language extension.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crt_srcdir} -p1
|
||||
|
||||
pathfix.py -i %{__python3} -pn .
|
||||
|
||||
%build
|
||||
mkdir -p _build
|
||||
cd _build
|
||||
%cmake .. \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
|
||||
\
|
||||
%if 0%{?__isa_bits} == 64
|
||||
-DLLVM_LIBDIR_SUFFIX=64 \
|
||||
%else
|
||||
-DLLVM_LIBDIR_SUFFIX= \
|
||||
%endif
|
||||
-DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
cd _build
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
|
||||
|
||||
%ifarch aarch64
|
||||
%global aarch64_blacklists hwasan_blacklist.txt
|
||||
%endif
|
||||
|
||||
for file in %{aarch64_blacklists} asan_blacklist.txt msan_blacklist.txt dfsan_blacklist.txt cfi_blacklist.txt dfsan_abilist.txt hwasan_blacklist.txt; do
|
||||
mv -v %{buildroot}%{_datadir}/${file} %{buildroot}%{_libdir}/clang/%{version}/ || :
|
||||
done
|
||||
|
||||
# move sanitizer libs to better place
|
||||
%global libclang_rt_installdir lib/linux
|
||||
mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/libclang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
|
||||
mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
|
||||
pushd %{buildroot}%{_libdir}/clang/%{version}/lib
|
||||
for i in *.a *.syms *.so; do
|
||||
ln -s ../$i linux/$i
|
||||
done
|
||||
|
||||
%check
|
||||
#make check-all -C _build
|
||||
|
||||
%files
|
||||
%{_includedir}/*
|
||||
%{_libdir}/clang/%{version}
|
||||
|
||||
%changelog
|
||||
* Wed Apr 17 2019 sguelton@redhat.com - 8.0.0-1
|
||||
- 8.0.0 Release
|
||||
|
||||
* Fri Dec 14 2018 Tom Stellard <tstellar@redhat.com> - 7.0.1-1
|
||||
- 7.0.1 Release
|
||||
|
||||
* Mon Dec 10 2018 Tom Stellard <tstellar@redhat.com> - 7.0.1-0.1.rc3
|
||||
- 7.0.1-rc3 Release
|
||||
|
||||
* Tue Nov 27 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-1
|
||||
- 7.0.0 Release
|
||||
|
||||
* Tue Oct 02 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-5
|
||||
- Use python3 for build scripts
|
||||
|
||||
* Mon Oct 01 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-4
|
||||
- Drop scl macros
|
||||
|
||||
* Thu Sep 06 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-3
|
||||
- Drop -fno-stack-protector flag
|
||||
|
||||
* Thu Sep 06 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-2
|
||||
- Explicitly BuildRequire: /usr/bin/python3
|
||||
|
||||
* Wed Jul 11 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-1
|
||||
- 6.0.1 Release
|
||||
|
||||
* Tue Jan 09 2018 Tom Stellard <tstellar@redhat.com> - 5.0.1-1
|
||||
- 5.0.1 Release
|
||||
|
||||
* Wed Jun 07 2017 Tom Stellard <tstellar@redhat.com> - 4.0.1-1
|
||||
- 4.0.1 Release
|
||||
|
||||
* Wed Jun 07 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-3
|
||||
- Build for llvm-toolset-7 rename
|
||||
|
||||
* Thu May 18 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-2
|
||||
- Fix disabling debug on s390(x)
|
||||
|
||||
* Tue Mar 14 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-1
|
||||
- compiler-rt 4.0.0 Final Release
|
||||
|
||||
* Thu Mar 02 2017 Dave Airlie <airlied@redhat.com> - 3.9.1-1
|
||||
- compiler-rt 3.9.1
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.9.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Nov 21 2016 Dan Horák <dan[at]danny.cz> - 3.9.0-3
|
||||
- disable debuginfo on s390(x)
|
||||
|
||||
* Wed Nov 02 2016 Dave Airlie <airlied@redhat.com> - 3.9.0-2
|
||||
- build for new arches.
|
||||
|
||||
* Wed Oct 26 2016 Dave Airlie <airlied@redhat.com> - 3.9.0-1
|
||||
- compiler-rt 3.9.0 final release
|
||||
|
||||
* Mon May 2 2016 Tom Callaway <spot@fedoraproject.org> 3.8.0-2
|
||||
- make symlinks to where the linker thinks these libs are
|
||||
|
||||
* Thu Mar 10 2016 Dave Airlie <airlied@redhat.com> 3.8.0-1
|
||||
- compiler-rt 3.8.0 final release
|
||||
|
||||
* Thu Mar 03 2016 Dave Airlie <airlied@redhat.com> 3.8.0-0.2
|
||||
- compiler-rt 3.8.0rc3
|
||||
|
||||
* Thu Feb 18 2016 Dave Airlie <airlied@redhat.com> - 3.8.0-0.1
|
||||
- compiler-rt 3.8.0rc2
|
||||
|
||||
* Fri Feb 05 2016 Dave Airlie <airlied@redhat.com> 3.7.1-3
|
||||
- fix compiler-rt paths - from rwindz0@gmail.com - #1304605
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Oct 06 2015 Jan Vcelak <jvcelak@fedoraproject.org> 3.7.0-100
|
||||
- initial version using cmake build system
|
Loading…
Reference in New Issue
Block a user