diff --git a/.compiler-rt.metadata b/.compiler-rt.metadata
index d2a6fc5..181a005 100644
--- a/.compiler-rt.metadata
+++ b/.compiler-rt.metadata
@@ -1,2 +1,2 @@
-d33af648dc9b901c6c9f6c5872af2f59203f1a25 SOURCES/compiler-rt-12.0.1.src.tar.xz
+68e9e2f569ccfe0af9f5df61ec74808688198946 SOURCES/compiler-rt-13.0.1.src.tar.xz
 b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
diff --git a/.gitignore b/.gitignore
index b91f9de..941953c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,2 @@
-SOURCES/compiler-rt-12.0.1.src.tar.xz
+SOURCES/compiler-rt-13.0.1.src.tar.xz
 SOURCES/tstellar-gpg-key.asc
diff --git a/SOURCES/compiler-rt-12.0.1.src.tar.xz.sig b/SOURCES/compiler-rt-12.0.1.src.tar.xz.sig
deleted file mode 100644
index c41c624..0000000
Binary files a/SOURCES/compiler-rt-12.0.1.src.tar.xz.sig and /dev/null differ
diff --git a/SOURCES/compiler-rt-13.0.1.src.tar.xz.sig b/SOURCES/compiler-rt-13.0.1.src.tar.xz.sig
new file mode 100644
index 0000000..92caabc
Binary files /dev/null and b/SOURCES/compiler-rt-13.0.1.src.tar.xz.sig differ
diff --git a/SPECS/compiler-rt.spec b/SPECS/compiler-rt.spec
index cdd58b7..5b736ba 100644
--- a/SPECS/compiler-rt.spec
+++ b/SPECS/compiler-rt.spec
@@ -1,6 +1,7 @@
-#%%global rc_ver 5
+#global rc_ver 3
 
-%global crt_srcdir compiler-rt-%{version}%{?rc_ver:rc%{rc_ver}}.src
+%global compiler_rt_version 13.0.1
+%global crt_srcdir compiler-rt-%{compiler_rt_version}%{?rc_ver:rc%{rc_ver}}.src
 
 # see https://sourceware.org/bugzilla/show_bug.cgi?id=25271
 %global optflags %(echo %{optflags} -D_DEFAULT_SOURCE)
@@ -9,14 +10,14 @@
 %global optflags %(echo %{optflags} -Dasm=__asm__)
 
 Name:		compiler-rt
-Version:	12.0.1%{?rc_ver:~rc%{rc_ver}}
+Version:	%{compiler_rt_version}%{?rc_ver:~rc%{rc_ver}}
 Release:	1%{?dist}
 Summary:	LLVM "compiler-rt" runtime libraries
 
 License:	NCSA or MIT
 URL:		http://llvm.org
-Source0:	https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz
-Source1:	https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz.sig
+Source0:	https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz
+Source1:	https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz.sig
 Source2:	tstellar-gpg-key.asc
 
 Patch0:		0001-PATCH-compiler-rt-Workaround-libstdc-limitation-wrt..patch
@@ -70,15 +71,15 @@ cd %{_vpath_builddir}
 %cmake_install
 
 # move blacklist/abilist files to where clang expect them
-mkdir -p %{buildroot}%{_libdir}/clang/%{version}/share
-mv -v %{buildroot}%{_datadir}/*list.txt  %{buildroot}%{_libdir}/clang/%{version}/share/
+mkdir -p %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/share
+mv -v %{buildroot}%{_datadir}/*list.txt  %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/share/
 
 # move sanitizer libs to better place
 %global libclang_rt_installdir lib/linux
-mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
-mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/*clang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
-mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
-pushd %{buildroot}%{_libdir}/clang/%{version}/lib
+mkdir -p %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/lib
+mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/*clang_rt* %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/lib
+mkdir -p %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/lib/linux/
+pushd %{buildroot}%{_libdir}/clang/%{compiler_rt_version}/lib
 for i in *.a *.so
 do
 	ln -s ../$i linux/$i
@@ -88,11 +89,11 @@ done
 # the symlinks will be dangling if the 32 bits version is not installed, but that should be fine
 %ifarch x86_64
 
-mkdir -p %{buildroot}/%{_exec_prefix}/lib/clang/%{version}/lib/linux
+mkdir -p %{buildroot}/%{_exec_prefix}/lib/clang/%{compiler_rt_version}/lib/linux
 for i in *.a *.so
 do
 	target=`echo "$i" | sed -e 's/x86_64/i386/'`
-	ln -s ../../../../../lib/clang/%{version}/lib/$target ../../../../%{_lib}/clang/%{version}/lib/linux/
+	ln -s ../../../../../lib/clang/%{compiler_rt_version}/lib/$target ../../../../%{_lib}/clang/%{compiler_rt_version}/lib/linux/
 done
 
 %endif
@@ -106,13 +107,19 @@ popd
 %files
 %license LICENSE.TXT
 %{_includedir}/*
-%{_libdir}/clang/%{version}/lib/*
-%{_libdir}/clang/%{version}/share/*
+%{_libdir}/clang/%{compiler_rt_version}/lib/*
+%{_libdir}/clang/%{compiler_rt_version}/share/*
 %ifarch x86_64 aarch64
 %{_bindir}/hwasan_symbolize
 %endif
 
 %changelog
+* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
+- 13.0.1 Release
+
+* Fri Oct 15 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0-1
+- 13.0.0 Release
+
 * Fri Jul 16 2021 sguelton@redhat.com - 12.0.1-1
 - 12.0.1 release