import compiler-rt-8.0.1-1.module+el8.1.0+3866+6be7f4d8
This commit is contained in:
parent
253c64a8ad
commit
16ccedc709
@ -1 +1 @@
|
||||
5ac063b474abe730b551477cdc02db789228f9c7 SOURCES/compiler-rt-7.0.1.src.tar.xz
|
||||
f6520fb47fae9cc4362a9d50abee22019c27457a SOURCES/compiler-rt-8.0.1.src.tar.xz
|
||||
|
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/compiler-rt-7.0.1.src.tar.xz
|
||||
SOURCES/compiler-rt-8.0.1.src.tar.xz
|
||||
|
28
SOURCES/0001-PATCH-std-thread-copy.patch
Normal file
28
SOURCES/0001-PATCH-std-thread-copy.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -ru compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDefs.h compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDefs.h
|
||||
--- compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDefs.h 2019-01-09 21:46:09.000000000 +0000
|
||||
+++ compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDefs.h 2019-02-12 14:03:32.971147814 +0000
|
||||
@@ -176,6 +176,12 @@
|
||||
|
||||
template<class Other>
|
||||
struct rebind { typedef fuzzer_allocator<Other> other; };
|
||||
+
|
||||
+ template< class U, class... Args >
|
||||
+ void construct( U* p, Args&&... args ) {
|
||||
+ std::allocator<T>::construct(p, std::forward<Args>(args)...);
|
||||
+ }
|
||||
+
|
||||
};
|
||||
|
||||
template<typename T>
|
||||
diff -ru compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDriver.cpp compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDriver.cpp
|
||||
--- compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDriver.cpp 2019-01-15 22:12:51.000000000 +0000
|
||||
+++ compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDriver.cpp 2019-02-12 13:05:15.965113872 +0000
|
||||
@@ -252,7 +252,7 @@
|
||||
std::thread Pulse(PulseThread);
|
||||
Pulse.detach();
|
||||
for (unsigned i = 0; i < NumWorkers; i++)
|
||||
- V.push_back(std::thread(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors));
|
||||
+ V.emplace_back(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors);
|
||||
for (auto &T : V)
|
||||
T.join();
|
||||
return HasErrors ? 1 : 0;
|
@ -1,24 +0,0 @@
|
||||
From 1353b7e97319f82ceee621e2e321c3f932c391fa Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Thu, 6 Sep 2018 17:32:09 -0700
|
||||
Subject: [PATCH] cmake: Don't prefer python2.7
|
||||
|
||||
---
|
||||
CMakeLists.txt | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 86ca2b3..ef8effa 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -71,7 +71,6 @@ if (COMPILER_RT_STANDALONE_BUILD)
|
||||
endif()
|
||||
|
||||
# Find Python interpreter.
|
||||
- set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5)
|
||||
include(FindPythonInterp)
|
||||
if(NOT PYTHONINTERP_FOUND)
|
||||
message(FATAL_ERROR "
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,21 +1,28 @@
|
||||
%ifarch s390 s390x
|
||||
# only limited set of libs available on s390(x) and the existing ones (stats, ubsan) don't provide debuginfo
|
||||
%global debug_package %{nil}
|
||||
%endif
|
||||
|
||||
#%%global rc_ver 2
|
||||
|
||||
%global crt_srcdir compiler-rt-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
Name: compiler-rt
|
||||
Version: 7.0.1
|
||||
Release: 1%{?dist}
|
||||
Version: 8.0.1
|
||||
Release: 1%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Summary: LLVM "compiler-rt" runtime libraries
|
||||
|
||||
License: NCSA or MIT
|
||||
URL: http://llvm.org
|
||||
Source0: http://llvm.org/releases/%{version}/%{crt_srcdir}.tar.xz
|
||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-%{rc_ver}}/%{crt_srcdir}.tar.xz
|
||||
|
||||
Patch0: 0001-Drop-fno-stack-protector-from-the-compiler-flags.patch
|
||||
Patch1: 0001-cmake-Don-t-prefer-python2.7.patch
|
||||
Patch0: 0001-PATCH-std-thread-copy.patch
|
||||
Patch1: 0001-Drop-fno-stack-protector-from-the-compiler-flags.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
BuildRequires: /usr/bin/python3
|
||||
BuildRequires: python3
|
||||
# We need python3-devel for pathfix.py.
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: llvm-devel = %{version}
|
||||
@ -37,7 +44,7 @@ mkdir -p _build
|
||||
cd _build
|
||||
%cmake .. \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config \
|
||||
-DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
|
||||
\
|
||||
%if 0%{?__isa_bits} == 64
|
||||
-DLLVM_LIBDIR_SUFFIX=64 \
|
||||
@ -58,28 +65,69 @@ mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
|
||||
%global aarch64_blacklists hwasan_blacklist.txt
|
||||
%endif
|
||||
|
||||
# move sanitizer lists to better place
|
||||
for file in %{aarch64_blacklists} asan_blacklist.txt msan_blacklist.txt dfsan_blacklist.txt cfi_blacklist.txt dfsan_abilist.txt hwasan_blacklist.txt; do
|
||||
mv -v %{buildroot}%{_datadir}/${file} %{buildroot}%{_libdir}/clang/%{version}/ || :
|
||||
done
|
||||
|
||||
# move sanitizer libs to better place
|
||||
mv -v %{buildroot}%{_prefix}/lib/linux/libclang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
|
||||
%global libclang_rt_installdir lib/linux
|
||||
mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/libclang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
|
||||
mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
|
||||
pushd %{buildroot}%{_libdir}/clang/%{version}/lib
|
||||
for i in *.a *.syms *.so; do
|
||||
for i in *.a *.so
|
||||
do
|
||||
ln -s ../$i linux/$i
|
||||
done
|
||||
popd
|
||||
|
||||
# multilib support: also create symlink from lib to lib64
|
||||
# fixes rhbz#1678240
|
||||
%ifarch %{ix86}
|
||||
%post
|
||||
if test "`uname -m`" = x86_64
|
||||
then
|
||||
cd %{_libdir}/clang/%{version}/lib
|
||||
mkdir -p ../../../../lib64/clang/%{version}/lib
|
||||
for i in *.a *.so
|
||||
do
|
||||
ln -s ../../../../%{_lib}/clang/%{version}/lib/$i ../../../../lib64/clang/%{version}/lib/$i
|
||||
done
|
||||
fi
|
||||
|
||||
%preun
|
||||
|
||||
if test "`uname -m`" = x86_64
|
||||
then
|
||||
cd %{_libdir}/clang/%{version}/lib
|
||||
for i in *.a *.so
|
||||
do
|
||||
rm ../../../../lib64/clang/%{version}/lib/$i
|
||||
done
|
||||
rmdir -p ../../../../lib64/clang/%{version}/lib 2>/dev/null 1>/dev/null || :
|
||||
fi
|
||||
|
||||
%endif
|
||||
|
||||
%check
|
||||
cd _build
|
||||
#make check-all
|
||||
#make check-all -C _build
|
||||
|
||||
%files
|
||||
%{_includedir}/*
|
||||
%{_libdir}/clang/%{version}
|
||||
|
||||
%changelog
|
||||
* Thu Aug 1 2019 sguelton@redhat.com - 8.0.1-1
|
||||
- 8.0.1 release
|
||||
|
||||
* Thu Jul 4 2019 sguelton@redhat.com - 8.0.1-0.2.rc2
|
||||
- Fix rhbz#1678240
|
||||
|
||||
* Thu Jun 13 2019 sguelton@redhat.com - 8.0.1-0.1.rc2
|
||||
- 8.0.1rc2 Release
|
||||
|
||||
* Wed Apr 17 2019 sguelton@redhat.com - 8.0.0-1
|
||||
- 8.0.0 Release
|
||||
|
||||
* Fri Dec 14 2018 Tom Stellard <tstellar@redhat.com> - 7.0.1-1
|
||||
- 7.0.1 Release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user