import UBI compiler-rt-16.0.6-2.el9_3
This commit is contained in:
parent
d1edb3eb21
commit
10144d9a28
36
SOURCES/0001-compiler-rt-Fix-FLOAT16-feature-detection.patch
Normal file
36
SOURCES/0001-compiler-rt-Fix-FLOAT16-feature-detection.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
From ce15f52198639e9195b8833ed60dc1a49c293956 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
|
Date: Tue, 29 Aug 2023 15:49:55 -0700
|
||||||
|
Subject: [PATCH] compiler-rt: Fix FLOAT16 feature detection
|
||||||
|
|
||||||
|
CMAKE_TRY_COMPILE_TARGET_TYPE defaults to EXECUTABLE, which causes
|
||||||
|
any feature detection code snippet without a main function to fail,
|
||||||
|
so we need to make sure it gets explicitly set to STATIC_LIBRARY.
|
||||||
|
---
|
||||||
|
compiler-rt/lib/builtins/CMakeLists.txt | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/compiler-rt/lib/builtins/CMakeLists.txt b/compiler-rt/lib/builtins/CMakeLists.txt
|
||||||
|
index 2fc70522895f..e83a1ecea50b 100644
|
||||||
|
--- a/compiler-rt/lib/builtins/CMakeLists.txt
|
||||||
|
+++ b/compiler-rt/lib/builtins/CMakeLists.txt
|
||||||
|
@@ -12,7 +12,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
|
||||||
|
"at least 3.20.0 now to avoid issues in the future!")
|
||||||
|
endif()
|
||||||
|
|
||||||
|
- set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
|
||||||
|
project(CompilerRTBuiltins C ASM)
|
||||||
|
set(COMPILER_RT_STANDALONE_BUILD TRUE)
|
||||||
|
set(COMPILER_RT_BUILTINS_STANDALONE_BUILD TRUE)
|
||||||
|
@@ -56,6 +55,8 @@ if (COMPILER_RT_STANDALONE_BUILD)
|
||||||
|
"Turns on or off -fPIC for the builtin library source"
|
||||||
|
ON)
|
||||||
|
endif()
|
||||||
|
+
|
||||||
|
+set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
|
||||||
|
|
||||||
|
include(builtin-config-ix)
|
||||||
|
include(CMakePushCheckState)
|
||||||
|
--
|
||||||
|
2.40.1
|
||||||
|
|
@ -16,7 +16,7 @@
|
|||||||
|
|
||||||
Name: compiler-rt
|
Name: compiler-rt
|
||||||
Version: %{compiler_rt_version}
|
Version: %{compiler_rt_version}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: LLVM "compiler-rt" runtime libraries
|
Summary: LLVM "compiler-rt" runtime libraries
|
||||||
|
|
||||||
License: Apache-2.0 WITH LLVM-exception OR NCSA OR MIT
|
License: Apache-2.0 WITH LLVM-exception OR NCSA OR MIT
|
||||||
@ -27,6 +27,8 @@ Source2: release-keys.asc
|
|||||||
Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz
|
Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz
|
||||||
Source4: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz.sig
|
Source4: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz.sig
|
||||||
|
|
||||||
|
Patch0: 0001-compiler-rt-Fix-FLOAT16-feature-detection.patch
|
||||||
|
|
||||||
BuildRequires: clang
|
BuildRequires: clang
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: ninja-build
|
BuildRequires: ninja-build
|
||||||
@ -124,6 +126,9 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 29 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-2
|
||||||
|
- Fix FLOAT16 detection
|
||||||
|
|
||||||
* Wed Jul 05 2023 Nikita Popov <npopov@redhat.com> - 16.0.6-1
|
* Wed Jul 05 2023 Nikita Popov <npopov@redhat.com> - 16.0.6-1
|
||||||
- Update to LLVM 16.0.6
|
- Update to LLVM 16.0.6
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user