13.0.0-rc1 Release
This commit is contained in:
parent
89dbe60334
commit
0ef86a0303
2
.gitignore
vendored
2
.gitignore
vendored
@ -81,3 +81,5 @@
|
||||
/compiler-rt-12.0.1rc3.src.tar.xz.sig
|
||||
/compiler-rt-12.0.1.src.tar.xz
|
||||
/compiler-rt-12.0.1.src.tar.xz.sig
|
||||
/compiler-rt-13.0.0rc1.src.tar.xz
|
||||
/compiler-rt-13.0.0rc1.src.tar.xz.sig
|
||||
|
@ -0,0 +1,30 @@
|
||||
From 1738127904d20d403d8cf8ad67b0f68d728ad6b8 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Mon, 9 Aug 2021 13:57:40 -0700
|
||||
Subject: [PATCH] Only add no-omit-frame-pointer flags when the compiler
|
||||
supports them
|
||||
|
||||
---
|
||||
compiler-rt/lib/scudo/standalone/CMakeLists.txt | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/compiler-rt/lib/scudo/standalone/CMakeLists.txt b/compiler-rt/lib/scudo/standalone/CMakeLists.txt
|
||||
index 8c3708d3a45f..6a1f2f3accff 100644
|
||||
--- a/compiler-rt/lib/scudo/standalone/CMakeLists.txt
|
||||
+++ b/compiler-rt/lib/scudo/standalone/CMakeLists.txt
|
||||
@@ -124,8 +124,10 @@ if (COMPILER_RT_HAS_GWP_ASAN)
|
||||
RTGwpAsan RTGwpAsanBacktraceLibc RTGwpAsanSegvHandler
|
||||
RTGwpAsanOptionsParser)
|
||||
|
||||
- list(APPEND SCUDO_CFLAGS -DGWP_ASAN_HOOKS -fno-omit-frame-pointer
|
||||
- -mno-omit-leaf-frame-pointer)
|
||||
+ append_list_if(COMPILER_RT_HAS_OMIT_FRAME_POINTER_FLAG -fno-omit-frame-pointer
|
||||
+ SCUDO_CFLAGS)
|
||||
+ list(APPEND SCUDO_CFLAGS -DGWP_ASAN_HOOKS)
|
||||
+
|
||||
endif()
|
||||
|
||||
set(SCUDO_LINK_LIBS)
|
||||
--
|
||||
2.27.0
|
||||
|
@ -1,6 +1,6 @@
|
||||
#global rc_ver 3
|
||||
%global rc_ver 1
|
||||
|
||||
%global compiler_rt_version 12.0.1
|
||||
%global compiler_rt_version 13.0.0
|
||||
%global crt_srcdir compiler-rt-%{compiler_rt_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
# see https://sourceware.org/bugzilla/show_bug.cgi?id=25271
|
||||
@ -11,7 +11,7 @@
|
||||
|
||||
Name: compiler-rt
|
||||
Version: %{compiler_rt_version}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: LLVM "compiler-rt" runtime libraries
|
||||
|
||||
License: NCSA or MIT
|
||||
@ -21,6 +21,7 @@ Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compil
|
||||
Source2: tstellar-gpg-key.asc
|
||||
|
||||
Patch0: 0001-PATCH-compiler-rt-Workaround-libstdc-limitation-wrt..patch
|
||||
Patch1: 0001-Only-add-no-omit-frame-pointer-flags-when-the-compil.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -110,6 +111,9 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Tom Stellard <tstellar@redhat.com> = 13.0.0~rc1-1
|
||||
- 13.0.0-rc1 Release
|
||||
|
||||
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 12.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (compiler-rt-12.0.1.src.tar.xz) = 708780aa47ef289a9700eb76c17cc1f3bab19b8245174e612b5f684c48448030263a72eeef1021b10bdffa6ace2df489adcbba9e7a790ccbcd5fe72056f63f92
|
||||
SHA512 (compiler-rt-12.0.1.src.tar.xz.sig) = f0feb25e0cc7431e47d2966c0d5cb5739a585b00ba61f0c65f5fa34368941a43ad7cbccb4c46c81b4339f7582f472c0b7e7a74c17ee663faa5f444cb54e16450
|
||||
SHA512 (compiler-rt-13.0.0rc1.src.tar.xz) = 4e03c76aef587cfdbe846e20690ae4143bb432e6bb92135c13d49cb8667d5590f2df492db15b6c1af03cec4e4d51aa044b16a487b04786ee8a002de0d3b2846b
|
||||
SHA512 (compiler-rt-13.0.0rc1.src.tar.xz.sig) = 3ffa21fa6c8ab3a93c63e05f80d1076aeeb15beedaf444ec60d9a70228f99ec6ad53e3426f045953400383a2dc5f4fb5c3e4be9db21dc6a2f6a3a056c2b40283
|
||||
|
Loading…
Reference in New Issue
Block a user