8.0.0rc1
This commit is contained in:
parent
95edda7d81
commit
049fbf79ef
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@
|
|||||||
/compiler-rt-7.0.0rc3.src.tar.xz
|
/compiler-rt-7.0.0rc3.src.tar.xz
|
||||||
/compiler-rt-7.0.0.src.tar.xz
|
/compiler-rt-7.0.0.src.tar.xz
|
||||||
/compiler-rt-7.0.1.src.tar.xz
|
/compiler-rt-7.0.1.src.tar.xz
|
||||||
|
/compiler-rt-8.0.0rc1.src.tar.xz
|
||||||
|
28
0001-PATCH-std-thread-copy.patch
Normal file
28
0001-PATCH-std-thread-copy.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
diff -ru compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDefs.h compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDefs.h
|
||||||
|
--- compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDefs.h 2019-01-09 21:46:09.000000000 +0000
|
||||||
|
+++ compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDefs.h 2019-02-12 14:03:32.971147814 +0000
|
||||||
|
@@ -176,6 +176,12 @@
|
||||||
|
|
||||||
|
template<class Other>
|
||||||
|
struct rebind { typedef fuzzer_allocator<Other> other; };
|
||||||
|
+
|
||||||
|
+ template< class U, class... Args >
|
||||||
|
+ void construct( U* p, Args&&... args ) {
|
||||||
|
+ std::allocator<T>::construct(p, std::forward<Args>(args)...);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
};
|
||||||
|
|
||||||
|
template<typename T>
|
||||||
|
diff -ru compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDriver.cpp compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDriver.cpp
|
||||||
|
--- compiler-rt-8.0.0rc1.src.orig/lib/fuzzer/FuzzerDriver.cpp 2019-01-15 22:12:51.000000000 +0000
|
||||||
|
+++ compiler-rt-8.0.0rc1.src/lib/fuzzer/FuzzerDriver.cpp 2019-02-12 13:05:15.965113872 +0000
|
||||||
|
@@ -252,7 +252,7 @@
|
||||||
|
std::thread Pulse(PulseThread);
|
||||||
|
Pulse.detach();
|
||||||
|
for (unsigned i = 0; i < NumWorkers; i++)
|
||||||
|
- V.push_back(std::thread(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors));
|
||||||
|
+ V.emplace_back(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors);
|
||||||
|
for (auto &T : V)
|
||||||
|
T.join();
|
||||||
|
return HasErrors ? 1 : 0;
|
@ -1,24 +0,0 @@
|
|||||||
From 1353b7e97319f82ceee621e2e321c3f932c391fa Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
|
||||||
Date: Thu, 6 Sep 2018 17:32:09 -0700
|
|
||||||
Subject: [PATCH] cmake: Don't prefer python2.7
|
|
||||||
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 1 -
|
|
||||||
1 file changed, 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index 86ca2b3..ef8effa 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -71,7 +71,6 @@ if (COMPILER_RT_STANDALONE_BUILD)
|
|
||||||
endif()
|
|
||||||
|
|
||||||
# Find Python interpreter.
|
|
||||||
- set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5)
|
|
||||||
include(FindPythonInterp)
|
|
||||||
if(NOT PYTHONINTERP_FOUND)
|
|
||||||
message(FATAL_ERROR "
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
@ -1,57 +0,0 @@
|
|||||||
From 4e657713e97a0e0b0ea907d5f8348fc3fedad70a Mon Sep 17 00:00:00 2001
|
|
||||||
From: cryptoad <cryptoad@91177308-0d34-0410-b5e6-96231b3b80d8>
|
|
||||||
Date: Thu, 9 Aug 2018 20:01:11 +0000
|
|
||||||
Subject: [PATCH] [sanitizer] Remove rsp from the clobber list in
|
|
||||||
internal_clone
|
|
||||||
|
|
||||||
Summary:
|
|
||||||
When compiling with WERROR=ON, a new fatal warning started popping up recently
|
|
||||||
(due to -Werror,-Winline-asm):
|
|
||||||
```
|
|
||||||
.../lib/sanitizer_common/sanitizer_linux.cc:1214:24: error: inline asm clobber list contains reserved registers: RSP [-Werror,-Winline-asm]
|
|
||||||
"syscall\n"
|
|
||||||
^
|
|
||||||
<inline asm>:1:1: note: instantiated into assembly here
|
|
||||||
syscall
|
|
||||||
^
|
|
||||||
.../lib/sanitizer_common/sanitizer_linux.cc:1214:24: note: Reserved registers on the clobber list may not be preserved across the asm statement, and clobbering them may lead to undefined behaviour.
|
|
||||||
"syscall\n"
|
|
||||||
^
|
|
||||||
<inline asm>:1:1: note: instantiated into assembly here
|
|
||||||
syscall
|
|
||||||
^
|
|
||||||
```
|
|
||||||
|
|
||||||
Removing `rsp` from the clobber list makes the warning go away, and does not
|
|
||||||
appear to have a functional impact. If there is another way to solve this, let
|
|
||||||
me know.
|
|
||||||
|
|
||||||
Reviewers: eugenis, vitalybuka
|
|
||||||
|
|
||||||
Reviewed By: eugenis
|
|
||||||
|
|
||||||
Subscribers: kubamracek, delcypher, llvm-commits, #sanitizers
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D50519
|
|
||||||
|
|
||||||
git-svn-id: http://llvm.org/svn/llvm-project/compiler-rt/trunk@339370 91177308-0d34-0410-b5e6-96231b3b80d8
|
|
||||||
---
|
|
||||||
lib/sanitizer_common/sanitizer_linux.cc | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/sanitizer_common/sanitizer_linux.cc b/lib/sanitizer_common/sanitizer_linux.cc
|
|
||||||
index 6b8b9fd2e..8d39c4d90 100644
|
|
||||||
--- a/lib/sanitizer_common/sanitizer_linux.cc
|
|
||||||
+++ b/lib/sanitizer_common/sanitizer_linux.cc
|
|
||||||
@@ -1244,7 +1244,7 @@ uptr internal_clone(int (*fn)(void *), void *child_stack, int flags, void *arg,
|
|
||||||
"d"(parent_tidptr),
|
|
||||||
"r"(r8),
|
|
||||||
"r"(r10)
|
|
||||||
- : "rsp", "memory", "r11", "rcx");
|
|
||||||
+ : "memory", "r11", "rcx");
|
|
||||||
return res;
|
|
||||||
}
|
|
||||||
#elif defined(__mips__)
|
|
||||||
--
|
|
||||||
2.19.2
|
|
||||||
|
|
@ -3,21 +3,20 @@
|
|||||||
%global debug_package %{nil}
|
%global debug_package %{nil}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#%%global rc_ver 3
|
%global rc_ver 1
|
||||||
|
|
||||||
%global crt_srcdir compiler-rt-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
%global crt_srcdir compiler-rt-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
Name: compiler-rt
|
Name: compiler-rt
|
||||||
Version: 7.0.1
|
Version: 8.0.0
|
||||||
Release: 2%{?rc_ver:.rc%{rc_ver}}%{?dist}.1
|
Release: 1%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||||
Summary: LLVM "compiler-rt" runtime libraries
|
Summary: LLVM "compiler-rt" runtime libraries
|
||||||
|
|
||||||
License: NCSA or MIT
|
License: NCSA or MIT
|
||||||
URL: http://llvm.org
|
URL: http://llvm.org
|
||||||
Source0: http://%{?rc_ver:pre}releases.llvm.org/%{version}/%{?rc_ver:rc%{rc_ver}}/%{crt_srcdir}.tar.xz
|
Source0: http://%{?rc_ver:pre}releases.llvm.org/%{version}/%{?rc_ver:rc%{rc_ver}}/%{crt_srcdir}.tar.xz
|
||||||
|
|
||||||
Patch0: 0001-cmake-Don-t-prefer-python2.7.patch
|
Patch0: 0001-PATCH-std-thread-copy.patch
|
||||||
Patch1: 0001-sanitizer-Remove-rsp-from-the-clobber-list-in-intern.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -79,14 +78,16 @@ for i in *.a *.syms *.so; do
|
|||||||
done
|
done
|
||||||
|
|
||||||
%check
|
%check
|
||||||
cd _build
|
#make check-all -C _build
|
||||||
#make check-all
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%{_libdir}/clang/%{version}
|
%{_libdir}/clang/%{version}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 11 2019 sguelton@redhat.com - 8.0.0-1.rc1
|
||||||
|
- 8.0.0 Release candidate 1
|
||||||
|
|
||||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-2.1
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-2.1
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (compiler-rt-7.0.1.src.tar.xz) = b94a2a1fb9a6d587cef59b04b951628747bb35bdbcb67de8825aad402a2ba875916a347eef7a9575ac27264e8372e2d67cd477fe2d750c0ed3ce7d67bbbc7dba
|
SHA512 (compiler-rt-8.0.0rc1.src.tar.xz) = 2e32da6de8e62bf64144adcbc2deb4bc55ab3f5b085d1d9802f2137435123893140c91b8815bbeb34e178efdee4033a4bf222bf8a655c09498b0e8f10218dbc5
|
||||||
|
Loading…
Reference in New Issue
Block a user