Fix a crash when calibrating
This commit is contained in:
parent
6c0689597e
commit
af41872ce6
30
0001-Fix-session-helper-failing-to-find-argyll-tool.patch
Normal file
30
0001-Fix-session-helper-failing-to-find-argyll-tool.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 301f24d02158f1e12a2e7ccdf9970d02ecddd534 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tim Waugh <twaugh@redhat.com>
|
||||||
|
Date: Mon, 23 Feb 2015 09:56:12 +0000
|
||||||
|
Subject: [PATCH] Fix session-helper failing to find argyll tool.
|
||||||
|
|
||||||
|
We don't want to free the thing we're trying to return. This fixes the
|
||||||
|
bug introduced in commit b6f7c4d117a06f059a6e852e2dce8c13a3bb1f2c.
|
||||||
|
|
||||||
|
See:
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1190720
|
||||||
|
---
|
||||||
|
contrib/session-helper/cd-main.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/contrib/session-helper/cd-main.c b/contrib/session-helper/cd-main.c
|
||||||
|
index 61e0c5b..0f93697 100644
|
||||||
|
--- a/contrib/session-helper/cd-main.c
|
||||||
|
+++ b/contrib/session-helper/cd-main.c
|
||||||
|
@@ -939,7 +939,7 @@ cd_main_find_argyll_tool (const gchar *command,
|
||||||
|
GError **error)
|
||||||
|
{
|
||||||
|
gboolean ret;
|
||||||
|
- _cleanup_free_ gchar *filename = NULL;
|
||||||
|
+ gchar *filename;
|
||||||
|
|
||||||
|
/* try the original argyllcms filename installed in /usr/local/bin */
|
||||||
|
filename = g_strdup_printf ("/usr/local/bin/%s", command);
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
10
colord.spec
10
colord.spec
@ -19,11 +19,14 @@
|
|||||||
Summary: Color daemon
|
Summary: Color daemon
|
||||||
Name: colord
|
Name: colord
|
||||||
Version: 1.2.9
|
Version: 1.2.9
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
URL: http://www.freedesktop.org/software/colord/
|
URL: http://www.freedesktop.org/software/colord/
|
||||||
Source0: http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
|
Source0: http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
|
# Already upstream
|
||||||
|
Patch1: 0001-Fix-session-helper-failing-to-find-argyll-tool.patch
|
||||||
|
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: docbook-utils
|
BuildRequires: docbook-utils
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -107,6 +110,7 @@ This may be useful for CMYK soft-proofing or for extra device support.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .fix-calibration
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Set ~2 GiB limit so that colprof is forced to work in chunks when
|
# Set ~2 GiB limit so that colprof is forced to work in chunks when
|
||||||
@ -280,6 +284,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/gtk-doc/html/colord/*
|
%{_datadir}/gtk-doc/html/colord/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 09 2015 Richard Hughes <richard@hughsie.com> 1.2.9-2
|
||||||
|
- Fix a crash when calibrating.
|
||||||
|
- Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1190720
|
||||||
|
|
||||||
* Fri Feb 20 2015 Richard Hughes <richard@hughsie.com> 1.2.9-1
|
* Fri Feb 20 2015 Richard Hughes <richard@hughsie.com> 1.2.9-1
|
||||||
- New upstream version
|
- New upstream version
|
||||||
- Add support for the ColorHug ALS device
|
- Add support for the ColorHug ALS device
|
||||||
|
Loading…
Reference in New Issue
Block a user