New upstream version
- Add some default GSetting schema values for the calibration helper - Add the sensor images as metadata on the D-Bus interface - Quit the session helper if the device or sensor was not found
This commit is contained in:
parent
7a1790a301
commit
a94e0036a4
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@
|
|||||||
/colord-0.1.25.tar.xz
|
/colord-0.1.25.tar.xz
|
||||||
/colord-0.1.26.tar.xz
|
/colord-0.1.26.tar.xz
|
||||||
/colord-0.1.27.tar.xz
|
/colord-0.1.27.tar.xz
|
||||||
|
/colord-0.1.28.tar.xz
|
||||||
|
24
colord.spec
24
colord.spec
@ -1,7 +1,7 @@
|
|||||||
|
|
||||||
# Building the extra print profiles requires colprof, +4Gb of RAM and
|
# Building the extra print profiles requires colprof, +4Gb of RAM and
|
||||||
# quite a lot of time. Don't enable this for test builds.
|
# quite a lot of time. Don't enable this for test builds.
|
||||||
%define enable_print_profiles 1
|
%define enable_print_profiles 0
|
||||||
|
|
||||||
# Don't build the print profiles for secondary architectures on the
|
# Don't build the print profiles for secondary architectures on the
|
||||||
# logic that these are probably not doing press proofing or editing
|
# logic that these are probably not doing press proofing or editing
|
||||||
@ -14,16 +14,12 @@
|
|||||||
|
|
||||||
Summary: Color daemon
|
Summary: Color daemon
|
||||||
Name: colord
|
Name: colord
|
||||||
Version: 0.1.27
|
Version: 0.1.28
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
URL: http://www.freedesktop.org/software/colord/
|
URL: http://www.freedesktop.org/software/colord/
|
||||||
Source0: http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
|
Source0: http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# backport from upstream -- only build one profile at a time
|
|
||||||
Patch0: notparallel.patch
|
|
||||||
|
|
||||||
BuildRequires: automake
|
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: docbook-utils
|
BuildRequires: docbook-utils
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -96,9 +92,6 @@ This may be useful for CMYK soft-proofing or for extra device support.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .notparallel
|
|
||||||
aclocal
|
|
||||||
automake --add-missing
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# we can't use _hardened_build here, see
|
# we can't use _hardened_build here, see
|
||||||
@ -147,7 +140,9 @@ getent passwd colord >/dev/null || \
|
|||||||
-c "User for colord" colord
|
-c "User for colord" colord
|
||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%post libs -p /sbin/ldconfig
|
%post
|
||||||
|
/sbin/ldconfig
|
||||||
|
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||||
|
|
||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
@ -157,6 +152,7 @@ exit 0
|
|||||||
%attr(755,colord,colord) %dir %{_localstatedir}/lib/colord
|
%attr(755,colord,colord) %dir %{_localstatedir}/lib/colord
|
||||||
%attr(755,colord,colord) %dir %{_localstatedir}/lib/colord/icc
|
%attr(755,colord,colord) %dir %{_localstatedir}/lib/colord/icc
|
||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
|
||||||
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
|
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
|
||||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
|
%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
|
||||||
%{_datadir}/polkit-1/actions/org.freedesktop.color.policy
|
%{_datadir}/polkit-1/actions/org.freedesktop.color.policy
|
||||||
@ -243,6 +239,12 @@ exit 0
|
|||||||
%{_datadir}/gtk-doc/html/colord/*
|
%{_datadir}/gtk-doc/html/colord/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 16 2013 Richard Hughes <richard@hughsie.com> 0.1.28-1
|
||||||
|
- New upstream version
|
||||||
|
- Add some default GSetting schema values for the calibration helper
|
||||||
|
- Add the sensor images as metadata on the D-Bus interface
|
||||||
|
- Quit the session helper if the device or sensor was not found
|
||||||
|
|
||||||
* Mon Jan 14 2013 Richard Hughes <richard@hughsie.com> 0.1.27-4
|
* Mon Jan 14 2013 Richard Hughes <richard@hughsie.com> 0.1.27-4
|
||||||
- Add BR systemd-devel so the seat tracking stuff works
|
- Add BR systemd-devel so the seat tracking stuff works
|
||||||
- Build with full compiler output
|
- Build with full compiler output
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
diff --git a/data/profiles/Makefile.am b/data/profiles/Makefile.am
|
|
||||||
index fd442fe..d82bd93 100644
|
|
||||||
--- a/data/profiles/Makefile.am
|
|
||||||
+++ b/data/profiles/Makefile.am
|
|
||||||
@@ -1,3 +1,5 @@
|
|
||||||
+.NOTPARALLEL:
|
|
||||||
+
|
|
||||||
profilesdir = $(datadir)/color/icc/colord
|
|
||||||
generatedprofiles = \
|
|
||||||
AdobeRGB1998.icc \
|
|
Loading…
Reference in New Issue
Block a user