New upstream version
This commit is contained in:
parent
a82fdd7959
commit
6210750709
1
.gitignore
vendored
1
.gitignore
vendored
@ -47,3 +47,4 @@
|
|||||||
/colord-1.2.2.tar.xz
|
/colord-1.2.2.tar.xz
|
||||||
/colord-1.2.3.tar.xz
|
/colord-1.2.3.tar.xz
|
||||||
/colord-1.2.4.tar.xz
|
/colord-1.2.4.tar.xz
|
||||||
|
/colord-1.2.5.tar.xz
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
From da60b2f4578a81e4a99bc47a4f146a61cd8aef81 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard Hughes <richard@hughsie.com>
|
|
||||||
Date: Mon, 27 Oct 2014 16:51:20 +0000
|
|
||||||
Subject: [PATCH] session-helper: Fix a crash in the session helper while
|
|
||||||
calibrating
|
|
||||||
|
|
||||||
---
|
|
||||||
contrib/session-helper/cd-main.c | 2 +-
|
|
||||||
contrib/session-helper/cd-state.c | 3 +--
|
|
||||||
2 files changed, 2 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/contrib/session-helper/cd-main.c b/contrib/session-helper/cd-main.c
|
|
||||||
index 5cd81d9..5b44305 100644
|
|
||||||
--- a/contrib/session-helper/cd-main.c
|
|
||||||
+++ b/contrib/session-helper/cd-main.c
|
|
||||||
@@ -1361,7 +1361,7 @@ cd_main_start_calibration (CdMainPrivate *priv,
|
|
||||||
CD_SESSION_INTERACTION_MOVE_TO_SURFACE);
|
|
||||||
return TRUE;
|
|
||||||
}
|
|
||||||
- g_propagate_error (error, error_local);
|
|
||||||
+ *error = g_error_copy (error_local);
|
|
||||||
return FALSE;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git a/contrib/session-helper/cd-state.c b/contrib/session-helper/cd-state.c
|
|
||||||
index 0ff68e6..e0b2a06 100644
|
|
||||||
--- a/contrib/session-helper/cd-state.c
|
|
||||||
+++ b/contrib/session-helper/cd-state.c
|
|
||||||
@@ -470,7 +470,7 @@ cd_state_show_profile (CdState *state)
|
|
||||||
gdouble total_time = 0.0f;
|
|
||||||
guint i;
|
|
||||||
guint uncumalitive = 0;
|
|
||||||
- _cleanup_string_free_ GString *result;
|
|
||||||
+ _cleanup_string_free_ GString *result = NULL;
|
|
||||||
|
|
||||||
/* get the total time so we can work out the divisor */
|
|
||||||
for (i = 0; i < state->priv->steps; i++)
|
|
||||||
@@ -492,7 +492,6 @@ cd_state_show_profile (CdState *state)
|
|
||||||
state->priv->step_profile[i] / division);
|
|
||||||
}
|
|
||||||
g_printerr ("\n\n%s-1 ] at %s\n\n", result->str, state->priv->id);
|
|
||||||
- g_string_free (result, TRUE);
|
|
||||||
}
|
|
||||||
|
|
||||||
/**
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
12
colord.spec
12
colord.spec
@ -18,15 +18,12 @@
|
|||||||
|
|
||||||
Summary: Color daemon
|
Summary: Color daemon
|
||||||
Name: colord
|
Name: colord
|
||||||
Version: 1.2.4
|
Version: 1.2.5
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
URL: http://www.freedesktop.org/software/colord/
|
URL: http://www.freedesktop.org/software/colord/
|
||||||
Source0: http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
|
Source0: http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# already upstream
|
|
||||||
Patch0: 0001-session-helper-Fix-a-crash-in-the-session-helper-whi.patch
|
|
||||||
|
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: docbook-utils
|
BuildRequires: docbook-utils
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -110,7 +107,6 @@ This may be useful for CMYK soft-proofing or for extra device support.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .fix-session-helper
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Set ~2 GiB limit so that colprof is forced to work in chunks when
|
# Set ~2 GiB limit so that colprof is forced to work in chunks when
|
||||||
@ -284,6 +280,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/gtk-doc/html/colord/*
|
%{_datadir}/gtk-doc/html/colord/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 10 2014 Richard Hughes <richard@hughsie.com> 1.2.5-1
|
||||||
|
- New upstream version
|
||||||
|
- Install the now-useful cd-it8 helper
|
||||||
|
|
||||||
* Mon Oct 27 2014 Richard Hughes <richard@hughsie.com> 1.2.4-2
|
* Mon Oct 27 2014 Richard Hughes <richard@hughsie.com> 1.2.4-2
|
||||||
- Backport a patch to fix calibration using the helper
|
- Backport a patch to fix calibration using the helper
|
||||||
- Resolves: #1157279
|
- Resolves: #1157279
|
||||||
|
Loading…
Reference in New Issue
Block a user