New upstream version
- Add an LED sample type - Add PrivateNetwork and PrivateTmp to the systemd service file - Fix InstallSystemWide() when running as the colord user
This commit is contained in:
parent
efde051b08
commit
11bbfad492
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
||||
/colord-0.1.14.tar.xz
|
||||
/colord-0.1.15.tar.xz
|
||||
/colord-0.1.16.tar.xz
|
||||
/colord-0.1.17.tar.xz
|
||||
|
17
colord.spec
17
colord.spec
@ -1,14 +1,11 @@
|
||||
Summary: Color daemon
|
||||
Name: colord
|
||||
Version: 0.1.16
|
||||
Release: 4%{?dist}
|
||||
Version: 0.1.17
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
URL: http://www.freedesktop.org/software/colord/
|
||||
Source0: http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
# https://bugs.freedesktop.org/show_bug.cgi?id=44966
|
||||
Patch0: variant-iter.patch
|
||||
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: docbook-utils
|
||||
BuildRequires: gettext
|
||||
@ -25,6 +22,7 @@ BuildRequires: libgusb-devel
|
||||
|
||||
Requires: shared-color-profiles
|
||||
Requires: color-filesystem
|
||||
Requires: systemd-units
|
||||
Requires(pre): shadow-utils
|
||||
|
||||
%description
|
||||
@ -40,7 +38,6 @@ Files for development with %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .iter
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -95,7 +92,7 @@ exit 0
|
||||
%{_libdir}/colord-sensors
|
||||
%{_libdir}/girepository-1.0/*.typelib
|
||||
%ghost %{_localstatedir}/lib/colord/*.db
|
||||
/lib/systemd/system/*.service
|
||||
/usr/lib/systemd/system/*.service
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
@ -106,6 +103,12 @@ exit 0
|
||||
%{_datadir}/vala/vapi/*.vapi
|
||||
|
||||
%changelog
|
||||
* Wed Feb 22 2012 Richard Hughes <richard@hughsie.com> 0.1.17-1
|
||||
- New upstream version
|
||||
- Add an LED sample type
|
||||
- Add PrivateNetwork and PrivateTmp to the systemd service file
|
||||
- Fix InstallSystemWide() when running as the colord user
|
||||
|
||||
* Fri Jan 20 2012 Matthias Clasen <mclasen@redha.com> - 0.1.16-4
|
||||
- Fix some obvious bugs
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
cb73ffdcebe4c06852c48355e83a4bc4 colord-0.1.16.tar.xz
|
||||
ad566a5b874bd924d96051cc5da0a1d8 colord-0.1.17.tar.xz
|
||||
|
@ -1,48 +0,0 @@
|
||||
diff -up colord-0.1.16/libcolord/cd-device.c.iter colord-0.1.16/libcolord/cd-device.c
|
||||
--- colord-0.1.16/libcolord/cd-device.c.iter 2012-01-20 12:54:20.620011834 -0500
|
||||
+++ colord-0.1.16/libcolord/cd-device.c 2012-01-20 13:15:12.164030613 -0500
|
||||
@@ -464,7 +464,7 @@ cd_device_get_metadata_item (CdDevice *d
|
||||
static void
|
||||
cd_device_set_metadata_from_variant (CdDevice *device, GVariant *variant)
|
||||
{
|
||||
- GVariantIter *iter = NULL;
|
||||
+ GVariantIter iter;
|
||||
const gchar *prop_key;
|
||||
const gchar *prop_value;
|
||||
|
||||
@@ -472,9 +472,8 @@ cd_device_set_metadata_from_variant (CdD
|
||||
g_hash_table_remove_all (device->priv->metadata);
|
||||
|
||||
/* insert the new metadata */
|
||||
- g_variant_get (variant, "a{ss}",
|
||||
- &iter);
|
||||
- while (g_variant_iter_loop (iter, "{ss}",
|
||||
+ g_variant_iter_init (&iter, variant);
|
||||
+ while (g_variant_iter_loop (&iter, "{ss}",
|
||||
&prop_key, &prop_value)) {
|
||||
g_hash_table_insert (device->priv->metadata,
|
||||
g_strdup (prop_key),
|
||||
diff -up colord-0.1.16/libcolord/cd-profile.c.iter colord-0.1.16/libcolord/cd-profile.c
|
||||
--- colord-0.1.16/libcolord/cd-profile.c.iter 2011-09-13 07:38:56.000000000 -0400
|
||||
+++ colord-0.1.16/libcolord/cd-profile.c 2012-01-20 13:15:15.379030662 -0500
|
||||
@@ -432,7 +432,7 @@ cd_profile_get_metadata_item (CdProfile
|
||||
static void
|
||||
cd_profile_set_metadata_from_variant (CdProfile *profile, GVariant *variant)
|
||||
{
|
||||
- GVariantIter *iter = NULL;
|
||||
+ GVariantIter iter;
|
||||
const gchar *prop_key;
|
||||
const gchar *prop_value;
|
||||
|
||||
@@ -440,9 +440,8 @@ cd_profile_set_metadata_from_variant (Cd
|
||||
g_hash_table_remove_all (profile->priv->metadata);
|
||||
|
||||
/* insert the new metadata */
|
||||
- g_variant_get (variant, "a{ss}",
|
||||
- &iter);
|
||||
- while (g_variant_iter_loop (iter, "{ss}",
|
||||
+ g_variant_iter_init (&iter, variant);
|
||||
+ while (g_variant_iter_loop (&iter, "{ss}",
|
||||
&prop_key, &prop_value)) {
|
||||
g_hash_table_insert (profile->priv->metadata,
|
||||
g_strdup (prop_key),
|
Loading…
Reference in New Issue
Block a user