f77a80a433
Signed-off-by: Adam Williamson <awilliam@redhat.com>
74 lines
1.8 KiB
Diff
74 lines
1.8 KiB
Diff
From fd05fb0a18b9719ae5652afe1aa22d71acce99f2 Mon Sep 17 00:00:00 2001
|
|
From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
|
|
Date: Fri, 22 Oct 2021 11:20:28 -0300
|
|
Subject: [PATCH 4/6] build: Rename 'gtk' meson variable to 'gtk3'
|
|
|
|
We'll be introducing a gtk4 variable soon, so it's good to be
|
|
more explicit with the variable naming.
|
|
---
|
|
client/meson.build | 2 +-
|
|
libcolord-gtk/meson.build | 6 +++---
|
|
meson.build | 2 +-
|
|
3 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/client/meson.build b/client/meson.build
|
|
index 9c65a9d..d2e9ec9 100644
|
|
--- a/client/meson.build
|
|
+++ b/client/meson.build
|
|
@@ -10,7 +10,7 @@ executable(
|
|
dependencies : [
|
|
glib,
|
|
gio,
|
|
- gtk,
|
|
+ gtk3,
|
|
colord,
|
|
],
|
|
link_with : colord_gtk,
|
|
diff --git a/libcolord-gtk/meson.build b/libcolord-gtk/meson.build
|
|
index 18f36a0..612f991 100644
|
|
--- a/libcolord-gtk/meson.build
|
|
+++ b/libcolord-gtk/meson.build
|
|
@@ -38,7 +38,7 @@ colord_gtk = shared_library(
|
|
dependencies : [
|
|
glib,
|
|
gio,
|
|
- gtk,
|
|
+ gtk3,
|
|
colord,
|
|
],
|
|
c_args : [
|
|
@@ -87,7 +87,7 @@ libcolord_gtk_gir = gnome.generate_gir(
|
|
dependencies : [
|
|
glib,
|
|
gio,
|
|
- gtk,
|
|
+ gtk3,
|
|
colord,
|
|
],
|
|
includes : [
|
|
@@ -156,7 +156,7 @@ if get_option('tests')
|
|
dependencies : [
|
|
glib,
|
|
gio,
|
|
- gtk,
|
|
+ gtk3,
|
|
colord,
|
|
],
|
|
link_with : colord_gtk,
|
|
diff --git a/meson.build b/meson.build
|
|
index 9dc56c5..c282ee9 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -94,7 +94,7 @@ endforeach
|
|
|
|
glib = dependency('glib-2.0', version : '>= 2.28.0')
|
|
gio = dependency('gio-2.0', version : '>= 2.25.9Z')
|
|
-gtk = dependency('gtk+-3.0')
|
|
+gtk3 = dependency('gtk+-3.0')
|
|
colord = dependency('colord', version : '>= 0.1.27')
|
|
|
|
if get_option('gtk2')
|
|
--
|
|
2.35.1
|
|
|