Update to 1.22.8

This commit is contained in:
Kalev Lember 2020-06-04 15:12:24 +02:00
parent 4ee4a9a69d
commit ea90f1bd9c
3 changed files with 5 additions and 50 deletions

View File

@ -1,44 +0,0 @@
diff --git a/configure.ac b/configure.ac
index da188edd721eb4884683c8ef7263a25cd4429851..b0b0c94d8945d095b7b31728fe5482e622599d96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -670,10 +670,15 @@ AS_IF([test "x$enable_gles1" = "xyes"],
AC_SUBST([COGL_EGL_INCLUDES])
AC_CHECK_HEADERS([EGL/eglext.h],
- [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDE
+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
#include <EGL/eglext.h>"],
[],
[$COGL_EGL_INCLUDES])
+ AC_CHECK_HEADERS([EGL/eglmesaext.h],
+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
+#include <EGL/eglmesaext.h>"],
+ [],
+ [$COGL_EGL_INCLUDES])
# Check for a GLES 1.x Common Profile library with/without EGL.
#
@@ -1178,6 +1183,12 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
[],
[AC_MSG_ERROR([Unable to locate required EGL headers])],
[#include <EGL/egl.h>])
+ AC_CHECK_HEADERS(
+ [EGL/eglmesaext.h],
+ [],
+ [AC_MSG_ERROR([Unable to locate required EGL headers])],
+ [#include <EGL/egl.h>
+#include <EGL/eglext.h>])
AC_CHECK_LIB(EGL, [eglInitialize],
[COGL_EXTRA_LDFLAGS="$COGL_EXTRA_LDFLAGS -lEGL"],
@@ -1188,7 +1199,8 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
)
COGL_EGL_INCLUDES="#include <EGL/egl.h>
-#include <EGL/eglext.h>"
+#include <EGL/eglext.h>
+#include <EGL/eglmesaext.h>"
AC_SUBST([COGL_EGL_INCLUDES])
])

View File

@ -1,7 +1,7 @@
%global with_tests 1
Name: cogl
Version: 1.22.6
Version: 1.22.8
Release: 1%{?dist}
Summary: A library for using 3D graphics hardware to draw pretty pictures
@ -23,10 +23,6 @@ Patch1: 0002-add-GL_ARB_shader_texture_lod-support.patch
# and do post blurring.
Patch2: 0003-texture-support-copy_sub_image.patch
# Fix building against libglvnd-provided EGL headers
# https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/17
Patch3: 9c4764224aded552fb855b1c2b85b26d2b894adf.diff
BuildRequires: chrpath
BuildRequires: pkgconfig(cairo)
BuildRequires: mesa-libEGL-devel
@ -154,6 +150,9 @@ chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libcogl-pango.so
%endif
%changelog
* Thu Jun 04 2020 Kalev Lember <klember@redhat.com> - 1.22.8-1
- Update to 1.22.8
* Mon Mar 09 2020 Kalev Lember <klember@redhat.com> - 1.22.6-1
- Update to 1.22.6

View File

@ -1 +1 @@
SHA512 (cogl-1.22.6.tar.xz) = b3475fa4fff3b6725f643b0d17d2de242fce1503cd83bd18031d98495501917bf5173152fb1aba7f2614fcf6553029fbb6f26bda5a497f5f12e2849ed301a483
SHA512 (cogl-1.22.8.tar.xz) = 702d5b1b22dc34bffaa82c9c57021caf036ee3a13fa7ca24a90cca1ebc0f8b7a86070cc1fe5125757132b02774fa874bb55675c96d1ccbc233fac0e6132da65f