Update to 1.16.2
This commit is contained in:
parent
55aecf88e0
commit
bebbf68a57
@ -1,12 +0,0 @@
|
||||
diff -up cogl-1.16.0/cogl/cogl-texture-2d.c.bigendian cogl-1.16.0/cogl/cogl-texture-2d.c
|
||||
--- cogl-1.16.0/cogl/cogl-texture-2d.c.bigendian 2013-09-25 12:53:31.932422121 -0400
|
||||
+++ cogl-1.16.0/cogl/cogl-texture-2d.c 2013-09-25 12:54:04.362422436 -0400
|
||||
@@ -315,7 +315,7 @@ cogl_wayland_texture_2d_new_from_buffer
|
||||
case WL_SHM_FORMAT_ARGB8888:
|
||||
format = COGL_PIXEL_FORMAT_ARGB_8888_PRE;
|
||||
break;
|
||||
- case WL_SHM_FORMAT_XRGB32:
|
||||
+ case WL_SHM_FORMAT_XRGB8888:
|
||||
format = COGL_PIXEL_FORMAT_ARGB_8888;
|
||||
internal_format = COGL_PIXEL_FORMAT_RGB_888;
|
||||
break;
|
10
cogl.spec
10
cogl.spec
@ -3,16 +3,14 @@
|
||||
%endif
|
||||
|
||||
Name: cogl
|
||||
Version: 1.16.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.16.2
|
||||
Release: 1%{?dist}
|
||||
Summary: A library for using 3D graphics hardware to draw pretty pictures
|
||||
|
||||
Group: Development/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://www.clutter-project.org/
|
||||
Source0: http://download.gnome.org/sources/cogl/1.16/cogl-%{version}.tar.xz
|
||||
# big endian fix
|
||||
Patch0: cogl-1.16.0-bigendian.patch
|
||||
|
||||
BuildRequires: cairo-devel
|
||||
BuildRequires: gdk-pixbuf2-devel
|
||||
@ -77,7 +75,6 @@ This package contains documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .bigendian
|
||||
|
||||
%build
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
||||
@ -126,6 +123,9 @@ rm %{buildroot}%{_datadir}/cogl/examples-data/crate.jpg
|
||||
%{_datadir}/gtk-doc/html/cogl-2.0-experimental
|
||||
|
||||
%changelog
|
||||
* Tue Jan 21 2014 Richard Hughes <rhughes@redhat.com> - 1.16.2-1
|
||||
- Update to 1.16.2
|
||||
|
||||
* Wed Sep 25 2013 Dan Horák <dan[at]danny.cz> - 1.16.0-2
|
||||
- fix build on big endians (#1011893)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user