try to fix build
This commit is contained in:
parent
dcc343c102
commit
b2d3f26c91
12
cogl-deps.patch
Normal file
12
cogl-deps.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up cogl-1.7.6/configure.ac.cogl-deps cogl-1.7.6/configure.ac
|
||||||
|
--- cogl-1.7.6/configure.ac.cogl-deps 2011-08-18 19:24:36.401394406 -0400
|
||||||
|
+++ cogl-1.7.6/configure.ac 2011-08-18 19:24:54.271427526 -0400
|
||||||
|
@@ -866,7 +866,7 @@ AM_PATH_GLIB_2_0([glib_req_version],
|
||||||
|
[gobject gthread gmodule-no-export])
|
||||||
|
AS_IF([test "x$have_glib" = "xno"], AC_MSG_ERROR([glib-2.0 is required]))
|
||||||
|
|
||||||
|
-COGL_PKG_REQUIRES="$COGL_PKG_REQUIRES glib-2.0"
|
||||||
|
+COGL_PKG_REQUIRES="$COGL_PKG_REQUIRES glib-2.0 gobject-2.0 gmodule-2.0"
|
||||||
|
AC_SUBST(COGL_PKG_REQUIRES)
|
||||||
|
PKG_CHECK_MODULES(COGL_DEP, [$COGL_PKG_REQUIRES])
|
||||||
|
if test -n "$COGL_PKG_REQUIRES_GL"; then
|
@ -8,6 +8,9 @@ License: LGPLv2+
|
|||||||
URL: http://www.clutter-project.org/
|
URL: http://www.clutter-project.org/
|
||||||
Source0: http://www.clutter-project.org/sources/%{name}/1.7/%{name}-%{version}.tar.xz
|
Source0: http://www.clutter-project.org/sources/%{name}/1.7/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
|
# fix missing libraries
|
||||||
|
Patch0: cogl-deps.patch
|
||||||
|
|
||||||
BuildRequires: cairo-devel
|
BuildRequires: cairo-devel
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
BuildRequires: gobject-introspection-devel
|
BuildRequires: gobject-introspection-devel
|
||||||
@ -20,6 +23,8 @@ BuildRequires: mesa-libGL-devel
|
|||||||
BuildRequires: pango-devel
|
BuildRequires: pango-devel
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
|
|
||||||
|
BuildRequires: autoconf automake libtool
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Cogl is a small open source library for using 3D graphics hardware to draw
|
Cogl is a small open source library for using 3D graphics hardware to draw
|
||||||
pretty pictures. The API departs from the flat state machine style of
|
pretty pictures. The API departs from the flat state machine style of
|
||||||
@ -59,6 +64,9 @@ This package contains documentation for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .deps
|
||||||
|
|
||||||
|
autoreconf -i -f
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
||||||
|
Loading…
Reference in New Issue
Block a user