Fix building against libglvnd-provided EGL headers
This commit is contained in:
parent
ba368d9d0f
commit
a0efb472ea
44
9c4764224aded552fb855b1c2b85b26d2b894adf.diff
Normal file
44
9c4764224aded552fb855b1c2b85b26d2b894adf.diff
Normal file
@ -0,0 +1,44 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index da188edd721eb4884683c8ef7263a25cd4429851..b0b0c94d8945d095b7b31728fe5482e622599d96 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -670,10 +670,15 @@ AS_IF([test "x$enable_gles1" = "xyes"],
|
||||
AC_SUBST([COGL_EGL_INCLUDES])
|
||||
|
||||
AC_CHECK_HEADERS([EGL/eglext.h],
|
||||
- [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDE
|
||||
+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
|
||||
#include <EGL/eglext.h>"],
|
||||
[],
|
||||
[$COGL_EGL_INCLUDES])
|
||||
+ AC_CHECK_HEADERS([EGL/eglmesaext.h],
|
||||
+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
|
||||
+#include <EGL/eglmesaext.h>"],
|
||||
+ [],
|
||||
+ [$COGL_EGL_INCLUDES])
|
||||
|
||||
# Check for a GLES 1.x Common Profile library with/without EGL.
|
||||
#
|
||||
@@ -1178,6 +1183,12 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
|
||||
[],
|
||||
[AC_MSG_ERROR([Unable to locate required EGL headers])],
|
||||
[#include <EGL/egl.h>])
|
||||
+ AC_CHECK_HEADERS(
|
||||
+ [EGL/eglmesaext.h],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([Unable to locate required EGL headers])],
|
||||
+ [#include <EGL/egl.h>
|
||||
+#include <EGL/eglext.h>])
|
||||
|
||||
AC_CHECK_LIB(EGL, [eglInitialize],
|
||||
[COGL_EXTRA_LDFLAGS="$COGL_EXTRA_LDFLAGS -lEGL"],
|
||||
@@ -1188,7 +1199,8 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
|
||||
)
|
||||
|
||||
COGL_EGL_INCLUDES="#include <EGL/egl.h>
|
||||
-#include <EGL/eglext.h>"
|
||||
+#include <EGL/eglext.h>
|
||||
+#include <EGL/eglmesaext.h>"
|
||||
AC_SUBST([COGL_EGL_INCLUDES])
|
||||
])
|
||||
|
11
cogl.spec
11
cogl.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Name: cogl
|
||||
Version: 1.22.4
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: A library for using 3D graphics hardware to draw pretty pictures
|
||||
|
||||
License: LGPLv2+
|
||||
@ -23,9 +23,13 @@ Patch1: 0002-add-GL_ARB_shader_texture_lod-support.patch
|
||||
# and do post blurring.
|
||||
Patch2: 0003-texture-support-copy_sub_image.patch
|
||||
|
||||
# Fix building against libglvnd-provided EGL headers
|
||||
# https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/17
|
||||
Patch3: 9c4764224aded552fb855b1c2b85b26d2b894adf.diff
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: pkgconfig(cairo)
|
||||
BuildRequires: pkgconfig(egl)
|
||||
BuildRequires: mesa-libEGL-devel
|
||||
BuildRequires: pkgconfig(gbm)
|
||||
BuildRequires: pkgconfig(gdk-pixbuf-2.0)
|
||||
BuildRequires: pkgconfig(gl)
|
||||
@ -150,6 +154,9 @@ chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libcogl-pango.so
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Mar 07 2020 Leigh Scott <leigh123linux@gmail.com> - 1.22.4-4
|
||||
- Fix building against libglvnd-provided EGL headers
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user