Update to 1.11.6
- Drop upstreamed cogl-1.11.4-mesa-strings.patch
This commit is contained in:
parent
9c08686e12
commit
a07f4deaab
@ -1,38 +0,0 @@
|
||||
From dfacbbd96f3fbadaffa4a76dfd71c47ece6ed6a3 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Bragg <robert@linux.intel.com>
|
||||
Date: Wed, 12 Sep 2012 13:36:00 +0000
|
||||
Subject: gpu-info: Match latest Mesa strings
|
||||
|
||||
Mesa now reports a vendor string of "Mesa Project" instead of "VMWare,
|
||||
Inc." and the software rasterizer renderer string is now "Software
|
||||
Rasterizer". This update cogl-gpu-info.c to recognize these new strings.
|
||||
|
||||
Thanks to Alexander Larsson for the original patch.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=683818
|
||||
---
|
||||
diff --git a/cogl/cogl-gpu-info.c b/cogl/cogl-gpu-info.c
|
||||
index 8e64d04..5bb0e65 100644
|
||||
--- a/cogl/cogl-gpu-info.c
|
||||
+++ b/cogl/cogl-gpu-info.c
|
||||
@@ -182,6 +182,8 @@ check_mesa_vendor (const CoglGpuInfoStrings *strings)
|
||||
return TRUE;
|
||||
else if (strcmp (strings->vendor_string, "VMware, Inc.") == 0)
|
||||
return TRUE;
|
||||
+ else if (strcmp (strings->vendor_string, "Mesa Project") == 0)
|
||||
+ return TRUE;
|
||||
|
||||
return FALSE;
|
||||
}
|
||||
@@ -214,7 +216,8 @@ check_softpipe_architecture (const CoglGpuInfoStrings *strings)
|
||||
static CoglBool
|
||||
check_swrast_architecture (const CoglGpuInfoStrings *strings)
|
||||
{
|
||||
- return match_phrase (strings->renderer_string, "software rasterizer");
|
||||
+ return match_phrase (strings->renderer_string, "software rasterizer") ||
|
||||
+ match_phrase (strings->renderer_string, "Software Rasterizer");
|
||||
}
|
||||
|
||||
static CoglBool
|
||||
--
|
||||
cgit v0.9.0.2
|
13
cogl.spec
13
cogl.spec
@ -1,14 +1,12 @@
|
||||
Name: cogl
|
||||
Version: 1.11.4
|
||||
Release: 2%{?dist}
|
||||
Version: 1.11.6
|
||||
Release: 1%{?dist}
|
||||
Summary: A library for using 3D graphics hardware to draw pretty pictures
|
||||
|
||||
Group: Development/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://www.clutter-project.org/
|
||||
Source0: http://download.gnome.org/sources/cogl/1.10/cogl-%{version}.tar.xz
|
||||
|
||||
Patch0: cogl-1.11.4-mesa-strings.patch
|
||||
Source0: http://download.gnome.org/sources/cogl/1.11/cogl-%{version}.tar.xz
|
||||
|
||||
BuildRequires: cairo-devel
|
||||
BuildRequires: gdk-pixbuf2-devel
|
||||
@ -62,7 +60,6 @@ This package contains documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .mesa-strings
|
||||
|
||||
%build
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
||||
@ -102,6 +99,10 @@ rm %{buildroot}%{_datadir}/cogl/examples-data/crate.jpg
|
||||
%{_datadir}/gtk-doc/html/cogl-2.0-experimental
|
||||
|
||||
%changelog
|
||||
* Tue Sep 18 2012 Kalev Lember <kalevlember@gmail.com> - 1.11.6-1
|
||||
- Update to 1.11.6
|
||||
- Drop upstreamed cogl-1.11.4-mesa-strings.patch
|
||||
|
||||
* Mon Sep 17 2012 Adam Jackson <ajax@redhat.com> 1.11.4-2
|
||||
- cogl-1.11.4-mesa-strings.patch: Update match strings for Mesa.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user