1.9.4
This commit is contained in:
parent
c452e9c237
commit
91554f859e
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
|||||||
/cogl-1.8.0.tar.xz
|
/cogl-1.8.0.tar.xz
|
||||||
/cogl-1.8.2.tar.xz
|
/cogl-1.8.2.tar.xz
|
||||||
/cogl-1.9.2.tar.xz
|
/cogl-1.9.2.tar.xz
|
||||||
|
/cogl-1.9.4.tar.xz
|
||||||
|
@ -1,81 +0,0 @@
|
|||||||
diff -up cogl-1.9.2/cogl/winsys/cogl-winsys-glx.c.drm cogl-1.9.2/cogl/winsys/cogl-winsys-glx.c
|
|
||||||
--- cogl-1.9.2/cogl/winsys/cogl-winsys-glx.c.drm 2011-11-22 09:33:02.000000000 -0500
|
|
||||||
+++ cogl-1.9.2/cogl/winsys/cogl-winsys-glx.c 2011-11-23 20:05:36.081142159 -0500
|
|
||||||
@@ -62,12 +62,6 @@
|
|
||||||
#include <GL/glx.h>
|
|
||||||
#include <X11/Xlib.h>
|
|
||||||
|
|
||||||
-#ifdef HAVE_DRM
|
|
||||||
-#include <drm.h>
|
|
||||||
-#include <sys/ioctl.h>
|
|
||||||
-#include <errno.h>
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#define COGL_ONSCREEN_X11_EVENT_MASK StructureNotifyMask
|
|
||||||
#define MAX_GLX_CONFIG_ATTRIBS 30
|
|
||||||
|
|
||||||
@@ -432,20 +426,6 @@ update_winsys_features (CoglContext *con
|
|
||||||
COGL_WINSYS_FEATURE_VBLANK_WAIT,
|
|
||||||
TRUE);
|
|
||||||
|
|
||||||
-#ifdef HAVE_DRM
|
|
||||||
- /* drm is really an extreme fallback -rumoured to work with Via
|
|
||||||
- * chipsets... */
|
|
||||||
- if (!glx_renderer->pf_glXWaitVideoSync)
|
|
||||||
- {
|
|
||||||
- if (glx_renderer->dri_fd < 0)
|
|
||||||
- glx_renderer->dri_fd = open("/dev/dri/card0", O_RDWR);
|
|
||||||
- if (glx_renderer->dri_fd >= 0)
|
|
||||||
- COGL_FLAGS_SET (context->winsys_features,
|
|
||||||
- COGL_WINSYS_FEATURE_VBLANK_WAIT,
|
|
||||||
- TRUE);
|
|
||||||
- }
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
if (glx_renderer->pf_glXCopySubBuffer || context->glBlitFramebuffer)
|
|
||||||
COGL_FLAGS_SET (context->winsys_features,
|
|
||||||
COGL_WINSYS_FEATURE_SWAP_REGION, TRUE);
|
|
||||||
@@ -1112,24 +1092,6 @@ _cogl_winsys_onscreen_bind (CoglOnscreen
|
|
||||||
glx_context->current_drawable = drawable;
|
|
||||||
}
|
|
||||||
|
|
||||||
-#ifdef HAVE_DRM
|
|
||||||
-static int
|
|
||||||
-drm_wait_vblank (int fd, drm_wait_vblank_t *vbl)
|
|
||||||
-{
|
|
||||||
- int ret, rc;
|
|
||||||
-
|
|
||||||
- do
|
|
||||||
- {
|
|
||||||
- ret = ioctl (fd, DRM_IOCTL_WAIT_VBLANK, vbl);
|
|
||||||
- vbl->request.type &= ~_DRM_VBLANK_RELATIVE;
|
|
||||||
- rc = errno;
|
|
||||||
- }
|
|
||||||
- while (ret && rc == EINTR);
|
|
||||||
-
|
|
||||||
- return rc;
|
|
||||||
-}
|
|
||||||
-#endif /* HAVE_DRM */
|
|
||||||
-
|
|
||||||
static void
|
|
||||||
_cogl_winsys_wait_for_vblank (void)
|
|
||||||
{
|
|
||||||
@@ -1148,18 +1110,6 @@ _cogl_winsys_wait_for_vblank (void)
|
|
||||||
(current_count + 1) % 2,
|
|
||||||
¤t_count);
|
|
||||||
}
|
|
||||||
-#ifdef HAVE_DRM
|
|
||||||
- else
|
|
||||||
- {
|
|
||||||
- drm_wait_vblank_t blank;
|
|
||||||
-
|
|
||||||
- COGL_NOTE (WINSYS, "Waiting for vblank (drm)");
|
|
||||||
- blank.request.type = _DRM_VBLANK_RELATIVE;
|
|
||||||
- blank.request.sequence = 1;
|
|
||||||
- blank.request.signal = 0;
|
|
||||||
- drm_wait_vblank (glx_renderer->dri_fd, &blank);
|
|
||||||
- }
|
|
||||||
-#endif /* HAVE_DRM */
|
|
||||||
}
|
|
||||||
|
|
||||||
static guint32
|
|
10
cogl.spec
10
cogl.spec
@ -1,6 +1,6 @@
|
|||||||
Name: cogl
|
Name: cogl
|
||||||
Version: 1.9.2
|
Version: 1.9.4
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A library for using 3D graphics hardware to draw pretty pictures
|
Summary: A library for using 3D graphics hardware to draw pretty pictures
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -21,7 +21,6 @@ BuildRequires: mesa-libGL-devel
|
|||||||
BuildRequires: pango-devel
|
BuildRequires: pango-devel
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
|
|
||||||
Patch0: cogl-1.9.2-no-drm-hax.patch
|
|
||||||
Patch1: cogl-1.8.2-lp-no-framebuffer-blit.patch
|
Patch1: cogl-1.8.2-lp-no-framebuffer-blit.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -63,7 +62,6 @@ This package contains documentation for %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .drm
|
|
||||||
%patch1 -p1 -b .llvmpipe
|
%patch1 -p1 -b .llvmpipe
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -104,6 +102,10 @@ rm %{buildroot}%{_datadir}/cogl/examples-data/crate.jpg
|
|||||||
%{_datadir}/gtk-doc/html/cogl-2.0-experimental
|
%{_datadir}/gtk-doc/html/cogl-2.0-experimental
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 17 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.9.4-1
|
||||||
|
- Update to 1.9.4
|
||||||
|
- http://ftp.gnome.org/pub/GNOME/sources/cogl/1.9/cogl-1.9.4.news
|
||||||
|
|
||||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
|
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user