Update to 1.10.4
Dropped cogl-1.8.2-lp-no-framebuffer-blit.patch, which is fixed upstream in http://git.gnome.org/browse/cogl/commit/?id=cb5efc11873a28409603094bb290c4736be83e6f
This commit is contained in:
parent
3a9ffbac0d
commit
87996a7eeb
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/cogl-1.9.8.tar.xz
|
||||
/cogl-1.10.0.tar.xz
|
||||
/cogl-1.10.2.tar.xz
|
||||
/cogl-1.10.4.tar.xz
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -up cogl-1.8.2/cogl/winsys/cogl-winsys-glx.c.jx cogl-1.8.2/cogl/winsys/cogl-winsys-glx.c
|
||||
--- cogl-1.8.2/cogl/winsys/cogl-winsys-glx.c.jx 2011-11-03 16:58:15.000000000 -0400
|
||||
+++ cogl-1.8.2/cogl/winsys/cogl-winsys-glx.c 2011-11-03 17:28:23.313469639 -0400
|
||||
@@ -418,8 +418,15 @@ update_winsys_features (CoglContext *con
|
||||
TRUE);
|
||||
|
||||
if (glx_renderer->pf_glXCopySubBuffer || context->glBlitFramebuffer)
|
||||
- COGL_FLAGS_SET (context->winsys_features,
|
||||
- COGL_WINSYS_FEATURE_SWAP_REGION, TRUE);
|
||||
+ {
|
||||
+ /* hack hack hack hack. llvmpipe's support for both is broken */
|
||||
+ const GLubyte *renderer = context->glGetString (GL_RENDERER);
|
||||
+ if (!strstr (renderer, "llvmpipe"))
|
||||
+ {
|
||||
+ COGL_FLAGS_SET (context->winsys_features,
|
||||
+ COGL_WINSYS_FEATURE_SWAP_REGION, TRUE);
|
||||
+ }
|
||||
+ }
|
||||
|
||||
/* Note: glXCopySubBuffer and glBlitFramebuffer won't be throttled
|
||||
* by the SwapInterval so we have to throttle swap_region requests
|
11
cogl.spec
11
cogl.spec
@ -1,12 +1,12 @@
|
||||
Name: cogl
|
||||
Version: 1.10.2
|
||||
Version: 1.10.4
|
||||
Release: 1%{?dist}
|
||||
Summary: A library for using 3D graphics hardware to draw pretty pictures
|
||||
|
||||
Group: Development/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://www.clutter-project.org/
|
||||
Source0: http://www.clutter-project.org/sources/%{name}/1.10/%{name}-%{version}.tar.xz
|
||||
Source0: http://download.gnome.org/sources/cogl/1.10/cogl-%{version}.tar.xz
|
||||
|
||||
BuildRequires: cairo-devel
|
||||
BuildRequires: gdk-pixbuf2-devel
|
||||
@ -21,8 +21,6 @@ BuildRequires: mesa-libGL-devel
|
||||
BuildRequires: pango-devel
|
||||
BuildRequires: pkgconfig
|
||||
|
||||
Patch1: cogl-1.8.2-lp-no-framebuffer-blit.patch
|
||||
|
||||
%description
|
||||
Cogl is a small open source library for using 3D graphics hardware to draw
|
||||
pretty pictures. The API departs from the flat state machine style of
|
||||
@ -62,7 +60,6 @@ This package contains documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .llvmpipe
|
||||
|
||||
%build
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
||||
@ -102,6 +99,10 @@ rm %{buildroot}%{_datadir}/cogl/examples-data/crate.jpg
|
||||
%{_datadir}/gtk-doc/html/cogl-2.0-experimental
|
||||
|
||||
%changelog
|
||||
* Wed Jul 18 2012 Kalev Lember <kalevlember@gmail.com> - 1.10.4-1
|
||||
- Update to 1.10.4
|
||||
- Dropped no-framebuffer-blit patch which is included in the release
|
||||
|
||||
* Thu Apr 19 2012 Adel Gadllah <adel.gadllah@gmail.com> - 1.10.2-1
|
||||
- Update to 1.10.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user