import sources
This commit is contained in:
parent
e16beea549
commit
2588ac4320
109
0001-tests-don-t-write-test-log-to-root-owned-directory.patch
Normal file
109
0001-tests-don-t-write-test-log-to-root-owned-directory.patch
Normal file
@ -0,0 +1,109 @@
|
||||
From ecaeb7d2793235466aeac0309880e560233c6516 Mon Sep 17 00:00:00 2001
|
||||
From: Ray Strode <rstrode@redhat.com>
|
||||
Date: Wed, 19 Dec 2018 10:30:36 -0500
|
||||
Subject: [PATCH] tests: don't write test log to root owned directory
|
||||
|
||||
At the moments the installed-tests require being run
|
||||
as root, since the log output is redirected to
|
||||
|
||||
/usr/libexec/installed-tests/cogl/.log
|
||||
|
||||
This commit moves it to $TMPDIR instead.
|
||||
---
|
||||
tests/run-tests.sh | 10 +++++++---
|
||||
1 file changed, 7 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/tests/run-tests.sh b/tests/run-tests.sh
|
||||
index 7e62bf0f..f4d4051b 100755
|
||||
--- a/tests/run-tests.sh
|
||||
+++ b/tests/run-tests.sh
|
||||
@@ -35,79 +35,83 @@ echo "FIXME = Test failed, but it was an expected failure"
|
||||
echo "PASS! = Unexpected pass"
|
||||
echo ""
|
||||
|
||||
get_status()
|
||||
{
|
||||
case $1 in
|
||||
# Special value we use to indicate that the test failed
|
||||
# but it was an expected failure so don't fail the
|
||||
# overall test run as a result...
|
||||
300)
|
||||
echo -n "FIXME";;
|
||||
# Special value we use to indicate that the test passed
|
||||
# but we weren't expecting it to pass‽
|
||||
400)
|
||||
echo -n 'PASS!';;
|
||||
|
||||
# Special value to indicate the test is missing a required feature
|
||||
500)
|
||||
echo -n "n/a";;
|
||||
|
||||
0)
|
||||
echo -n "ok";;
|
||||
|
||||
*)
|
||||
echo -n "FAIL";;
|
||||
esac
|
||||
}
|
||||
|
||||
run_test()
|
||||
{
|
||||
- $($TEST_BINARY $1 &>.log)
|
||||
+ LOG_FILE=$(mktemp -t $(basename ${TEST_BINARY}).XXXXX)
|
||||
+ $($TEST_BINARY $1 &>$LOG_FILE)
|
||||
TMP=$?
|
||||
var_name=$2_result
|
||||
eval $var_name=$TMP
|
||||
- if grep -q "$MISSING_FEATURE" .log; then
|
||||
+ if grep -q "$MISSING_FEATURE" $LOG_FILE; then
|
||||
if test $TMP -ne 0; then
|
||||
eval $var_name=500
|
||||
else
|
||||
eval $var_name=400
|
||||
fi
|
||||
- elif grep -q "$KNOWN_FAILURE" .log; then
|
||||
+ elif grep -q "$KNOWN_FAILURE" $LOG_FILE; then
|
||||
if test $TMP -ne 0; then
|
||||
eval $var_name=300
|
||||
else
|
||||
eval $var_name=400
|
||||
fi
|
||||
else
|
||||
if test $TMP -ne 0; then EXIT=$TMP; fi
|
||||
fi
|
||||
+
|
||||
+ cat $LOG_FILE
|
||||
+ rm -f $LOG_FILE
|
||||
}
|
||||
|
||||
TITLE_FORMAT="%35s"
|
||||
printf $TITLE_FORMAT "Test"
|
||||
|
||||
if test $HAVE_GL -eq 1; then
|
||||
GL_FORMAT=" %6s %8s %7s %6s %6s"
|
||||
printf "$GL_FORMAT" "GL+FF" "GL+ARBFP" "GL+GLSL" "GL-NPT" "GL3"
|
||||
fi
|
||||
if test $HAVE_GLES2 -eq 1; then
|
||||
GLES2_FORMAT=" %6s %7s"
|
||||
printf "$GLES2_FORMAT" "ES2" "ES2-NPT"
|
||||
fi
|
||||
|
||||
echo ""
|
||||
echo ""
|
||||
|
||||
for test in `cat unit-tests`
|
||||
do
|
||||
export COGL_DEBUG=
|
||||
|
||||
if test $HAVE_GL -eq 1; then
|
||||
export COGL_DRIVER=gl
|
||||
export COGL_DEBUG=disable-glsl,disable-arbfp
|
||||
run_test $test gl_ff
|
||||
|
||||
export COGL_DRIVER=gl
|
||||
# NB: we can't explicitly disable fixed + glsl in this case since
|
||||
# the arbfp code only supports fragment processing so we need either
|
||||
# the fixed or glsl vertends
|
||||
--
|
||||
2.20.1
|
||||
|
13
cogl.spec
13
cogl.spec
@ -6,7 +6,7 @@
|
||||
|
||||
Name: cogl
|
||||
Version: 1.22.2
|
||||
Release: 10%{?dist}
|
||||
Release: 11%{?dist}
|
||||
Summary: A library for using 3D graphics hardware to draw pretty pictures
|
||||
|
||||
License: LGPLv2+
|
||||
@ -27,7 +27,10 @@ Patch1: 0002-add-GL_ARB_shader_texture_lod-support.patch
|
||||
# and do post blurring.
|
||||
Patch2: 0003-texture-support-copy_sub_image.patch
|
||||
|
||||
Patch11: 0001-tests-don-t-write-test-log-to-root-owned-directory.patch
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: git
|
||||
BuildRequires: pkgconfig(cairo)
|
||||
BuildRequires: pkgconfig(egl)
|
||||
BuildRequires: pkgconfig(gbm)
|
||||
@ -98,10 +101,7 @@ This package contains the installable tests for %{cogl}.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%autosetup -S git
|
||||
|
||||
%build
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
||||
@ -165,6 +165,9 @@ chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libcogl-pango.so
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Dec 18 2018 Ray Strode <rstrode@redhat.com> - 1.22.2-11
|
||||
- rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.22.2-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user