cockpit/0002-When-touching-patched-files-handle-case-of-only-one-.patch
Cockpit Project 94c8300bc8 Update to 132-1
- Make basic SELinux functionality available without setroubleshootd
- Allow changing the MAC address for ethernet adapters and see them for bonds
- Hide "autoconnect" checkbox for network devices without settings
- Support for external providers other than libvirt on Machines page
- Some tooltip fixes
- Add option to restrict max read size to the Cockpit file API
- Relax dependencies on cockpit-bridge package on Debian/Ubuntu
- Rename cockpit-test-assets package to cockpit-tests
- When touching patched files handle case of only one file
- Always build the cockpit-tests subpackage
2017-02-24 07:21:16 +00:00

31 lines
1018 B
Diff

From f920c1611c8d34c3238b8d7fcbabf473a3525c9a Mon Sep 17 00:00:00 2001
From: Cockpit Project <cockpituous@gmail.com>
Date: Fri, 24 Feb 2017 05:20:38 +0000
Subject: [PATCH 2/2] When touching patched files handle case of only one file
When touching patched files so that they all have the same utime
we need to handle the case where only one file is patched.
Otherwise we get:
touch: missing file operand
---
tools/cockpit.spec | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/cockpit.spec b/tools/cockpit.spec
index 4b309a9..c81bb51 100644
--- a/tools/cockpit.spec
+++ b/tools/cockpit.spec
@@ -133,7 +133,7 @@ if [ -n "%{patches}" ]; then
git config core.autocrlf false && git config core.safecrlf false && git config gc.auto 0
git add -f . && git commit -a -q -m "Base" && git tag -a initial --message="initial"
git am --whitespace=nowarn %{patches}
- touch -r $(git diff --name-only initial..HEAD)
+ touch -r $(git diff --name-only initial..HEAD) .git
rm -rf .git
fi
--
2.9.3