Update to Cockpit 0.28

* xmllint on ARM crashes, so disable it
 * jslint on ARM hangs forever so skip it
 * Debugging on ARM sucks, so disable parallel builds
This commit is contained in:
Stef Walter 2014-10-17 22:38:14 +02:00
parent 5f379b702e
commit 8c205f43a4
2 changed files with 137 additions and 3 deletions

View File

@ -1,5 +1,5 @@
Name: cockpit
Version: 0.27
Version: 0.28
Release: 1%{?dist}
Summary: A user interface for Linux servers
@ -7,6 +7,7 @@ License: LGPLv2+
URL: http://cockpit-project.org/
Source0: https://github.com/cockpit-project/cockpit/releases/download/%{version}/cockpit-%{version}.tar.bz2
Source1: cockpit.pam
Patch0: skip-validation.patch
BuildRequires: pkgconfig(gio-unix-2.0)
BuildRequires: pkgconfig(gudev-1.0)
@ -78,11 +79,12 @@ embed or extend Cockpit.
%prep
%setup -q
%patch0 -p1
rm -rf src/libgsystem/*.{c,doap}
%build
%configure --disable-static --disable-silent-rules --with-cockpit-user=cockpit-ws
make %{?_smp_mflags}
make -j1
%check
# The check doesnt run on koji as it requires network
@ -102,6 +104,7 @@ rm -rf %{buildroot}%{_datadir}/cockpit-test-assets
%files
%doc AUTHORS COPYING README.md
%doc %{_mandir}/man1/cockpit-bridge.1.gz
%doc %{_mandir}/man5/cockpit.conf.5.gz
%doc %{_mandir}/man8/cockpit-ws.8.gz
%doc %{_mandir}/man8/cockpitd.8.gz
@ -117,7 +120,7 @@ rm -rf %{buildroot}%{_datadir}/cockpit-test-assets
%{_sbindir}/remotectl
%{_libexecdir}/cockpitd
%{_libexecdir}/cockpit-ws
%{_libexecdir}/cockpit-agent
%{_bindir}/cockpit-bridge
# HACK: We need to do attr because stripping debuginfo removes setuid
# https://bugzilla.redhat.com/show_bug.cgi?id=117858
%attr(4755, -, -) %{_libexecdir}/cockpit-polkit
@ -147,6 +150,10 @@ test -f %{_bindir}/firewall-cmd && firewall-cmd --reload --quiet || true
%systemd_postun_with_restart cockpit.socket
%changelog
* Thu Oct 16 2014 Stef Walter <stefw@redhat.com> - 0.28-1
- Update to 0.28 release
- cockpit-agent was renamed to cockpit-bridge
* Fri Oct 10 2014 Stef Walter <stefw@redhat.com> - 0.27-1
- Update to 0.27 release
- Don't create cockpit-*-admin groups rhbz#1145135

127
skip-validation.patch Normal file
View File

@ -0,0 +1,127 @@
From c3c36a71b0b82429feac45ae791f12440fb8ccd0 Mon Sep 17 00:00:00 2001
From: Stef Walter <stefw@redhat.com>
Date: Thu, 16 Oct 2014 19:11:52 +0200
Subject: [PATCH] skip-validation
diff --git a/doc/guide/Makefile-guide.am b/doc/guide/Makefile-guide.am
index b6b0001..f7152c1 100644
--- a/doc/guide/Makefile-guide.am
+++ b/doc/guide/Makefile-guide.am
@@ -39,6 +39,6 @@ CLEANFILES += \
guide/index.html: $(GUIDE_DOCBOOK) $(GUIDE_INCLUDES) $(man_MANS) $(GUIDE_STATIC) $(GUIDE_XSLT)
$(AM_V_GEN) mkdir -p guide/ && rm -rf guide/* && cp $(srcdir)/doc/guide/static/* guide/ && \
- $(XMLTO) html -m $(srcdir)/doc/guide/gtk-doc.xsl -o guide/ \
+ $(XMLTO) html -m $(srcdir)/doc/guide/gtk-doc.xsl -o guide/ --skip-validation \
--searchpath $(abs_builddir):$(abs_srcdir):$(abs_builddir)/doc \
$(srcdir)/$(GUIDE_DOCBOOK)
diff --git a/tools/rcompile b/tools/rcompile
index 3bc0c5a..9652450 100755
--- a/tools/rcompile
+++ b/tools/rcompile
@@ -111,37 +111,6 @@ guess()
esac
}
-jslint()
-{
- # Resolving external dependencies for jsl is a royal pain. We change directory
- # and preprocess all the input files so that it can find scripts. We assume:
- # - relative -> pkg/
- # - /static -> lib/
- # - /cockpit -> pkg/
-
- conf=$(resolve $base)/jsl.conf
- pkg=$base/../pkg
-
- failed=no
- for f in "$@"; do
- sed -f $base/jsl.sed "$f" |
- (
- cd $pkg
- lines=$($jsl -conf $conf -nologo -nofilelisting -nosummary -stdin)
- ret=$?
- if ! empty "$lines"; then
- echo "$lines" | while read line; do
- echo "$f$line" >&2
- done
- fi
- exit $ret
- ) || failed=yes
- done
- if is_yes $failed; then
- exit 1
- fi
-}
-
minify_javascript()
{
perl -e \
@@ -167,6 +136,17 @@ output_javascript()
cat "$@"
}
+jslint()
+{
+ failed=no
+ for f in "$@"; do
+ jsl -conf $base/jsl.conf -nologo -nofilelisting -nosummary -process "$f" || failed=yes
+ done
+ if is_yes $failed; then
+ exit 1
+ fi
+}
+
process_javascript()
{
jslint "$@"
@@ -180,6 +160,37 @@ process_javascript()
fi
}
+html_jslint()
+{
+ # Resolving external dependencies for jsl is a royal pain. We change directory
+ # and preprocess all the input files so that it can find scripts. We assume:
+ # - relative -> pkg/
+ # - /static -> lib/
+ # - /cockpit -> pkg/
+
+ conf=$(resolve $base)/jsl.conf
+ pkg=$base/../pkg
+
+ failed=no
+ for f in "$@"; do
+ sed -f $base/jsl.sed "$f" |
+ (
+ cd $pkg
+ lines=$($jsl -conf $conf -nologo -nofilelisting -nosummary -stdin)
+ ret=$?
+ if ! empty "$lines"; then
+ echo "$lines" | while read line; do
+ echo "$f$line" >&2
+ done
+ fi
+ exit $ret
+ ) || failed=yes
+ done
+ if is_yes $failed; then
+ exit 1
+ fi
+}
+
process_html()
{
if [ $# -ne 1 ]; then
@@ -187,7 +198,7 @@ process_html()
fi
# TODO: Currently we don't validate HTML only javascript in html
- jslint "$1"
+ # html_jslint "$1"
# TODO: Currently we don't support HTML minify
if ! empty $output; then
--
2.1.0