diff --git a/.gitignore b/.gitignore
index 0156404..c77ab09 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1 @@
-SOURCES/cockpit-session-recording-16.tar.xz
+cockpit-session-recording-16.tar.xz
diff --git a/SPECS/cockpit-session-recording.spec b/cockpit-session-recording.spec
similarity index 55%
rename from SPECS/cockpit-session-recording.spec
rename to cockpit-session-recording.spec
index 9773322..902fc7e 100644
--- a/SPECS/cockpit-session-recording.spec
+++ b/cockpit-session-recording.spec
@@ -1,23 +1,6 @@
-#
-# Copyright (C) 2017-2023 Red Hat, Inc.
-#
-# Cockpit is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-#
-# Cockpit is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public License
-# along with Cockpit; If not, see .
-#
-
Name: cockpit-session-recording
Version: 16
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Cockpit Session Recording
License: LGPL-2.1-or-later
URL: https://github.com/Scribery/%{name}
@@ -31,31 +14,77 @@ BuildRequires: gettext
%if 0%{?rhel} && 0%{?rhel} <= 8
BuildRequires: libappstream-glib-devel
%endif
+
Requires: cockpit-system
Requires: tlog
Requires: sssd-proxy
+Provides: bundled(npm(@babel/runtime)) = 7.23.9
+Provides: bundled(npm(@patternfly/patternfly)) = 5.2.0
+Provides: bundled(npm(@patternfly/react-core)) = 5.2.0
+Provides: bundled(npm(@patternfly/react-icons)) = 5.2.0
+Provides: bundled(npm(@patternfly/react-styles)) = 5.2.0
+Provides: bundled(npm(@patternfly/react-table)) = 5.2.0
+Provides: bundled(npm(@patternfly/react-tokens)) = 5.2.0
+Provides: bundled(npm(array-timsort)) = 1.0.3
+Provides: bundled(npm(attr-accept)) = 2.2.2
+Provides: bundled(npm(base64-js)) = 1.5.1
+Provides: bundled(npm(buffer)) = 6.0.3
+Provides: bundled(npm(comment-json)) = 4.2.3
+Provides: bundled(npm(core-util-is)) = 1.0.3
+Provides: bundled(npm(date-fns)) = 2.30.0
+Provides: bundled(npm(esprima)) = 4.0.1
+Provides: bundled(npm(file-selector)) = 0.6.0
+Provides: bundled(npm(focus-trap)) = 7.5.2
+Provides: bundled(npm(has-own-prop)) = 2.0.0
+Provides: bundled(npm(ieee754)) = 1.2.1
+Provides: bundled(npm(ini)) = 4.1.1
+Provides: bundled(npm(jquery)) = 3.7.1
+Provides: bundled(npm(js-tokens)) = 4.0.0
+Provides: bundled(npm(lodash)) = 4.17.21
+Provides: bundled(npm(loose-envify)) = 1.4.0
+Provides: bundled(npm(object-assign)) = 4.1.1
+Provides: bundled(npm(prop-types)) = 15.8.1
+Provides: bundled(npm(react-dom)) = 18.2.0
+Provides: bundled(npm(react-dropzone)) = 14.2.3
+Provides: bundled(npm(react-is)) = 16.13.1
+Provides: bundled(npm(react)) = 18.2.0
+Provides: bundled(npm(regenerator-runtime)) = 0.14.1
+Provides: bundled(npm(repeat-string)) = 1.6.1
+Provides: bundled(npm(scheduler)) = 0.23.0
+Provides: bundled(npm(tabbable)) = 6.2.0
+Provides: bundled(npm(throttle-debounce)) = 5.0.0
+Provides: bundled(npm(tslib)) = 2.6.2
+Provides: bundled(npm(xterm-addon-canvas)) = 0.4.0
+Provides: bundled(npm(xterm)) = 5.1.0
+
%description
Cockpit module providing session recording configuration and playback.
This module allows viewing and playback of journal-stored terminal session
recordings generated by the tlog component.
%prep
-%setup -qn cockpit-session-recording
+%setup -q -n %{name}
+
+%build
+LINT=0 NODE_ENV=production make
%install
%make_install PREFIX=/usr
-appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*
+appstream-util validate-relax --nonet %{buildroot}/%{_datadir}/metainfo/*
%files
-%{_datadir}/cockpit/session-recording
-%{_datadir}/metainfo/org.cockpit-project.session-recording.metainfo.xml
+%{_datadir}/cockpit/*
+%{_datadir}/metainfo/*
%changelog
-* Thu Feb 8 2024 Justin Stephenson - 16-1
-- Rebase to upstream release 16
+* Mon Jun 24 2024 Troy Dawson - 16-2
+- Bump release for June 2024 mass rebuild
+
+* Tue Feb 6 2024 Packit - 16-1
- Config: Add sssd-proxy requirement
-- Commits from release 15
+
+* Thu Feb 1 2024 Packit - 15-1
- Config: Update to authselect with-tlog feature
- stylelint: handle stylelint-scss deprecation
- Add ruff configuration
@@ -82,7 +111,17 @@ appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*
- Makefile: bump our test/common dependency
- patternfly-5-overrides should be auto-imported by the page.scss file
- Drop obsolete pf-m-redhat-font class
-- Commits from release 14
+
+* Wed Jan 24 2024 Fedora Release Engineering - 14-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
+
+* Fri Jan 19 2024 Fedora Release Engineering - 14-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
+
+* Wed Jul 19 2023 Fedora Release Engineering - 14-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
+
+* Wed May 17 2023 Packit - 14-1
- Upgrade to PatternFly 5 Alpha
- Makefile: Update Cockpit lib to da5abbb4245b0455cc8b610efe01e684
- package.json: Pin down versions of @patternfly/react-{styles,icons}
@@ -91,53 +130,22 @@ appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*
- Update release.yml
- Automate the release process
-* Tue May 2 2023 Justin Stephenson - 13-1
-- Play after rewind in testFastforwardControls
-- Set TZ to avoid CI failures with testFilter* tests
-- testZoomSpeedControls incorrectly checks scale
-- Fix testSessionRecordingConf
-- Read TMT_TEST_DATA variable for LOGS in browser.sh
-- Fix node-modules in run-test.sh
-- Install sssd-proxy in test browser.sh
-- Add Files path for test recordings
-- FMF: Run tests together
-- Add executable bit to browser shell scripts
-- FMF: Fix minor typo in plans
-- Add FMF tests and test scripts
-- Read existing sssd conf domains and services
-- Makefile: Update Cockpit lib to 269bf89276c679a03befc8a04244addd
-- Remove CentOS condition in testZoomSpeedControls
-- Add accessible name label for Progress component
-- Remove 'enable_files_domain' from SSSD Config
-- SSSD config changes
-- testFastforwardControls update after player-restart
-- Switch wait_present to wait_visible
-- ESLint error and warning fixes
-- Fix stylelint errors
-- Dependency updates
-- Bring up to date with cockpit starter kit
-- Config: Switch SSSD files provider to Proxy provider
-- Update fedora license in spec file
-- Makefile: Bump test API to 267
-- Makefile: drop installing cockpit-ws/cockpit-packagekit
-- src: load translations via po.js
-- .semaphore: update TEST_OS to Fedora 36
-- webpack.config.js: update compression plugin to succeed build
-- Makefile: Adjust to changed rpmspec -q behaviour
-- Use standard "translate" marker in HTML
-- Update dependencies excluding Patternfly
-- Remove unneeded tlog UID code
+* Thu Jan 19 2023 Fedora Release Engineering - 12-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
-* Wed Jun 8 2022 Justin Stephenson - 12-2
-- Tests: Remove usermod from browser setup
+* Wed Jul 20 2022 Fedora Release Engineering - 12-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon May 23 2022 Justin Stephenson - 12-1
- Drop moment.js dependency
- Tests: Assert pause state with a later command in rec1
- CI: Update image to ubuntu 20.04
-* Thu Nov 18 2021 Justin Stephenson - 11-2
-- Workaround cockpit-ws selinux guestfs issue
+* Mon Apr 18 2022 Justin Stephenson - 11.1
+- Enable SSSD files domain unconditionally
+
+* Wed Jan 19 2022 Fedora Release Engineering - 11-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Wed Nov 17 2021 Justin Stephenson - 11-1
- Avoid crash in unmount if journal is null
@@ -158,51 +166,46 @@ appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*
- TESTS: Fix testSessionRecordingConf cleanup issue
- TESTS: Restart SSSD after restoring config
-* Wed Nov 17 2021 Justin Stephenson - 9-1
+* Wed Jul 21 2021 Justin Stephenson - 9-1
- Release v9
- Tests: Fix RHEL9 filter test timing failures
-* Wed Nov 17 2021 Justin Stephenson - 8-1
+* Wed Jul 14 2021 Justin Stephenson - 8-1
- Release v8
- Throttle journalctl restarts
- Minor CI fixes
-* Tue Apr 27 2021 Justin Stephenson - 7-1
+* Tue Jan 26 2021 Fedora Release Engineering - 7-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
+
+* Wed Jan 13 2021 Justin Stephenson - 7-1
+- Release v7
- Remove bots sudo rm from Makefile
- Use journalctl --utc for Logs view to handle DST
- Add Applications Menu test
- Install cockpit-packagekit in local VM
- Set timezone for Logs Correlation test
-* Wed Nov 4 2020 Justin Stephenson - 6-2
-- Use journalctl --utc for Logs view to handle DST
-- Fix testZoomSpeedControls scale selector
-
-* Tue Nov 3 2020 Justin Stephenson - 6-1
+* Mon Oct 12 2020 Justin Stephenson - 6-1
- Release v6
- Bump testlib to 229
- Add binary recording test
-- Update UI to adopt PatternFly 4
-- Update dependencies
-- Use --all journalctl option
-- Fixed timezone issue by searching in client time
-- Bump cockpit test version from 199 to 219
-- Improve test coverage with more tests
-- Simplify and cleanup existing tests
-* Tue Jun 23 2020 Justin Stephenson - 4-2
-- Release v4-2
-- Fix testZoomControls test
+* Mon Jul 27 2020 Fedora Release Engineering - 4-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
-* Wed May 27 2020 Justin Stephenson - 4-1
+* Wed May 20 2020 Justin Stephenson - 4-1
- Release v4
- Update parent id in metainfo file
- Update package manifest
-- Fix rpmmacro to resolve correct path on CentOS7
+- Fix rpmmacro to resolve correc t path on CentOS7
- Handle byte-array encoded journal data
- Don't clobber cockpit bots directory
- Move code out of deprecated React lifecycle functions
+* Tue Jan 28 2020 Fedora Release Engineering - 3-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
* Mon Nov 25 2019 Justin Stephenson - 3-1
- Release v3
- Reset Logs View on Player Rewind
@@ -224,4 +227,3 @@ appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*
* Thu Apr 4 2019 Kirill Glebov - 1-1
- Release 1
- First release. Includes logs correlation, player controls, journal remote support.
-#
diff --git a/sources b/sources
new file mode 100644
index 0000000..7aa76a5
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (cockpit-session-recording-16.tar.xz) = 91aab7c6b28d18ed51928096678919fc19b9eeed795982ced69a53b92f801a0f9e98a70269245f8270730a27f2e49650bada04352a23e5758b1bdaf32a733b90