import cobbler-2.0.7.1-6.module+el8.0.0+3102+be54261a
This commit is contained in:
parent
1450175524
commit
582938d290
63
SOURCES/koan-bz1699743.patch
Normal file
63
SOURCES/koan-bz1699743.patch
Normal file
@ -0,0 +1,63 @@
|
||||
diff '--exclude=CVS' '--exclude=.svn' -ur a/koan/app.py b/koan/app.py
|
||||
--- a/koan/app.py 2019-03-21 11:35:58.000000000 +0100
|
||||
+++ b/koan/app.py 2019-04-15 15:21:12.954548508 +0200
|
||||
@@ -786,12 +786,6 @@
|
||||
|
||||
#---------------------------------------------------
|
||||
|
||||
- def get_boot_loader_info(self):
|
||||
- cmd = [ "/sbin/grubby", "--bootloader-probe" ]
|
||||
- probe_process = sub_process.Popen(cmd, stdout=sub_process.PIPE)
|
||||
- which_loader = probe_process.communicate()[0].decode()
|
||||
- return probe_process.returncode, which_loader
|
||||
-
|
||||
def replace(self):
|
||||
"""
|
||||
Handle morphing an existing system through downloading new
|
||||
@@ -862,10 +856,6 @@
|
||||
if self.grubby_copy_default:
|
||||
cmd.append("--copy-default")
|
||||
|
||||
- boot_probe_ret_code, probe_output = self.get_boot_loader_info()
|
||||
- if boot_probe_ret_code == 0 and probe_output.find("lilo") >= 0:
|
||||
- cmd.append("--lilo")
|
||||
-
|
||||
if self.add_reinstall_entry:
|
||||
cmd.append("--title=Reinstall")
|
||||
else:
|
||||
@@ -879,10 +869,7 @@
|
||||
|
||||
# Are we running on ppc?
|
||||
if arch.startswith("ppc"):
|
||||
- if "grub2" in probe_output:
|
||||
- cmd.append("--grub2")
|
||||
- else:
|
||||
- cmd.append("--yaboot")
|
||||
+ cmd.append("--grub2")
|
||||
elif arch.startswith("s390"):
|
||||
cmd.append("--zipl")
|
||||
|
||||
@@ -900,22 +887,10 @@
|
||||
utils.subprocess_call(cmd)
|
||||
|
||||
# Any post-grubby processing required (e.g. ybin, zipl, lilo)?
|
||||
- if arch.startswith("ppc") and "grub2" not in probe_output:
|
||||
- # FIXME - CHRP hardware uses a 'PPC PReP Boot' partition and doesn't require running ybin
|
||||
- print("- applying ybin changes")
|
||||
- cmd = [ "/sbin/ybin" ]
|
||||
- utils.subprocess_call(cmd)
|
||||
- elif arch.startswith("s390"):
|
||||
+ if arch.startswith("s390"):
|
||||
print("- applying zipl changes")
|
||||
cmd = [ "/sbin/zipl" ]
|
||||
utils.subprocess_call(cmd)
|
||||
- else:
|
||||
- # if grubby --bootloader-probe returns lilo,
|
||||
- # apply lilo changes
|
||||
- if boot_probe_ret_code == 0 and probe_output.find("lilo") != -1:
|
||||
- print("- applying lilo changes")
|
||||
- cmd = [ "/sbin/lilo" ]
|
||||
- utils.subprocess_call(cmd)
|
||||
|
||||
if not self.add_reinstall_entry:
|
||||
print("- reboot to apply changes")
|
@ -15,7 +15,7 @@ Name: cobbler
|
||||
License: GPLv2+
|
||||
AutoReq: no
|
||||
Version: 2.0.7.1
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Source0: cobbler-%{version}.tar.gz
|
||||
Patch0: cobbler-pxelinux-s390x-bz580072.patch
|
||||
Patch1: cobbler-xenpv-tap-driver.patch
|
||||
@ -88,6 +88,7 @@ Patch68: koan-grubby480.patch
|
||||
Patch69: koan-fix-TypeError.patch
|
||||
Patch70: koan-support-osinfo-query.patch
|
||||
Patch71: koan-support-kvm-type.patch
|
||||
Patch72: koan-bz1699743.patch
|
||||
|
||||
Group: Applications/System
|
||||
|
||||
@ -239,6 +240,7 @@ a XMLRPC API for integration with other applications.
|
||||
%patch69 -p1
|
||||
%patch70 -p1
|
||||
%patch71 -p1
|
||||
%patch72 -p1
|
||||
|
||||
%build
|
||||
%{pythonX} setup.py build
|
||||
@ -382,6 +384,9 @@ of an existing system. For use with a boot-server configured with Cobbler
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Apr 23 2019 Michael Mraka <michael.mraka@redhat.com> 2.0.7.1-6
|
||||
- 1699743 - grubby --bootloader-probe has been deprecated
|
||||
|
||||
* Thu Mar 21 2019 Michael Mraka <michael.mraka@redhat.com> 2.0.7.1-5
|
||||
- 1686794 - backported koan kvm support patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user