Update to version 1.1.2
This commit is contained in:
parent
d39e8b3e8a
commit
61c8309efb
2
.gitignore
vendored
2
.gitignore
vendored
@ -8,3 +8,5 @@
|
|||||||
/cmocka-1.0.1.tar.xz
|
/cmocka-1.0.1.tar.xz
|
||||||
/cmocka-1.1.0.tar.xz
|
/cmocka-1.1.0.tar.xz
|
||||||
/cmocka-1.1.1.tar.xz
|
/cmocka-1.1.1.tar.xz
|
||||||
|
/cmocka-1.1.2.tar.xz
|
||||||
|
/cmocka-1.1.2.tar.xz.asc
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
Index: cmocka-1.1.1/cmake/Modules/DefineCompilerFlags.cmake
|
|
||||||
===================================================================
|
|
||||||
--- cmocka-1.1.1.orig/cmake/Modules/DefineCompilerFlags.cmake
|
|
||||||
+++ cmocka-1.1.1/cmake/Modules/DefineCompilerFlags.cmake
|
|
||||||
@@ -10,7 +10,7 @@ if (UNIX AND NOT WIN32)
|
|
||||||
if (${CMAKE_C_COMPILER_ID} MATCHES "(GNU|Clang)")
|
|
||||||
|
|
||||||
# add -Wconversion ?
|
|
||||||
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -pedantic -pedantic-errors")
|
|
||||||
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -fno-builtin-strcmp -pedantic -pedantic-errors")
|
|
||||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wshadow -Wmissing-prototypes -Wdeclaration-after-statement")
|
|
||||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wunused -Wfloat-equal -Wpointer-arith -Wwrite-strings -Wformat-security")
|
|
||||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wmissing-format-attribute -Wundef -Wstrict-prototypes")
|
|
43
cmocka.spec
43
cmocka.spec
@ -1,21 +1,20 @@
|
|||||||
|
Name: cmocka
|
||||||
|
Version: 1.1.2
|
||||||
|
Release: 1%{?dist}
|
||||||
|
|
||||||
|
License: ASL 2.0
|
||||||
|
Summary: An elegant unit testing framework for C with support for mock objects
|
||||||
|
URL: https://cmocka.org
|
||||||
|
|
||||||
|
Source0: https://cmocka.org/files/1.1/%{name}-%{version}.tar.xz
|
||||||
|
Source1: https://cmocka.org/files/1.1/%{name}-%{version}.tar.xz.asc
|
||||||
|
Source2: cmocka.keyring
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: gnupg2
|
||||||
Name: cmocka
|
|
||||||
Version: 1.1.1
|
|
||||||
Release: 9%{?dist}
|
|
||||||
|
|
||||||
License: ASL 2.0
|
|
||||||
Summary: Lightweight library to simplify and generalize unit tests for C
|
|
||||||
Url: http://cmocka.org
|
|
||||||
|
|
||||||
Source0: https://open.cryptomilk.org/attachments/download/60/%{name}-%{version}.tar.xz
|
|
||||||
|
|
||||||
# add workaround for gcc7 on ppc64le temporary before it's fixed in gcc
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1420350
|
|
||||||
Patch1: cmocka-1.1.0-workaround-ppc64le-gcc.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
There are a variety of C unit testing frameworks available however many of them
|
There are a variety of C unit testing frameworks available however many of them
|
||||||
@ -82,11 +81,7 @@ Conflicts: cmockery2-devel
|
|||||||
Development headers for the cmocka unit testing library.
|
Development headers for the cmocka unit testing library.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1
|
||||||
|
|
||||||
%ifarch ppc64le
|
|
||||||
%patch1 -p1 -b .workaround-ppc64le-gcc
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if test ! -e "obj"; then
|
if test ! -e "obj"; then
|
||||||
@ -100,7 +95,7 @@ pushd obj
|
|||||||
%{_builddir}/%{name}-%{version}
|
%{_builddir}/%{name}-%{version}
|
||||||
|
|
||||||
make %{?_smp_mflags} VERBOSE=1
|
make %{?_smp_mflags} VERBOSE=1
|
||||||
make doc
|
make docs
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -115,11 +110,12 @@ ln -s libcmocka.so %{buildroot}%{_libdir}/libcmockery.so
|
|||||||
|
|
||||||
%check
|
%check
|
||||||
pushd obj
|
pushd obj
|
||||||
make test || cat Testing/Temporary/LastTest.log
|
ctest --output-on-failure
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%files -n libcmocka
|
%files -n libcmocka
|
||||||
%doc AUTHORS README ChangeLog COPYING
|
%doc AUTHORS README.md ChangeLog
|
||||||
|
%license COPYING
|
||||||
%{_libdir}/libcmocka.so.*
|
%{_libdir}/libcmocka.so.*
|
||||||
|
|
||||||
%files -n libcmocka-static
|
%files -n libcmocka-static
|
||||||
@ -138,6 +134,9 @@ popd
|
|||||||
%{_libdir}/cmake/cmocka/cmocka-config.cmake
|
%{_libdir}/cmake/cmocka/cmocka-config.cmake
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 29 2018 Andreas Schneider <asn@redhat.com> - 1.1.2-1
|
||||||
|
- Update to version 1.1.2
|
||||||
|
|
||||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-9
|
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
3
sources
3
sources
@ -1 +1,2 @@
|
|||||||
SHA512 (cmocka-1.1.1.tar.xz) = 801c4a3e1bb9047241b1cb5a90c1cbdee1b0aff5e3d0a84ec8b2dbaee79274618c24fbe5e9fedbf0b3ee18c6c98b55d93e135d037ac33ab872edc7665af41577
|
SHA512 (cmocka-1.1.2.tar.xz) = 84435c97a4002c111672f8e18a9270a61de18343de19587ba59436617e57997050a63aac2242a79ec892474e824ca382f78af3e74dc1919cc50e04fd88d5e8f4
|
||||||
|
SHA512 (cmocka-1.1.2.tar.xz.asc) = 675f3ad2c988778458146722be6aafbb7a995915a3871070598d45ff15677e93e0e2f4a64a9fe2cdf642fa946938919ddf4729d067a85a24b9742d852bd25400
|
||||||
|
Loading…
Reference in New Issue
Block a user