45 lines
1.4 KiB
Diff
45 lines
1.4 KiB
Diff
From 0c2610bd300218165e72524b87e998fd06d86ef5 Mon Sep 17 00:00:00 2001
|
|
From: Brad King <brad.king@kitware.com>
|
|
Date: Mon, 12 Jun 2023 17:53:20 -0400
|
|
Subject: [PATCH 3/9] Tests: Find GIT_EXECUTABLE early enough to use in all
|
|
tests
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Some tests work only if a `git` executable is available.
|
|
|
|
Signed-off-by: Björn Esser <besser82@fedoraproject.org>
|
|
---
|
|
Tests/CMakeLists.txt | 7 +++----
|
|
1 file changed, 3 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
|
|
index 5ef77fda62..53bb1e654b 100644
|
|
--- a/Tests/CMakeLists.txt
|
|
+++ b/Tests/CMakeLists.txt
|
|
@@ -142,6 +142,9 @@ if(BUILD_TESTING)
|
|
)
|
|
endif()
|
|
|
|
+ # Look for git to use for tests.
|
|
+ find_program(GIT_EXECUTABLE NAMES git)
|
|
+
|
|
# Look for rpmbuild to use for tests.
|
|
# The tool does not work with spaces in the path.
|
|
if(NOT CMAKE_CURRENT_BINARY_DIR MATCHES " ")
|
|
@@ -2688,10 +2691,6 @@ if(BUILD_TESTING)
|
|
endif()
|
|
|
|
# Test CTest Update with GIT
|
|
- if(NOT DEFINED CMake_TEST_CTestUpdate_GIT OR CMake_TEST_CTestUpdate_GIT)
|
|
- find_program(GIT_EXECUTABLE NAMES git)
|
|
- mark_as_advanced(GIT_EXECUTABLE)
|
|
- endif()
|
|
if(NOT DEFINED CMake_TEST_CTestUpdate_GIT AND GIT_EXECUTABLE
|
|
AND (UNIX OR NOT "${GIT_EXECUTABLE}" MATCHES "cygwin"))
|
|
set(CMake_TEST_CTestUpdate_GIT 1)
|
|
--
|
|
2.41.0
|
|
|