fix FindJNI for ppc64le (#1141782)
This commit is contained in:
parent
9f76ff0a0e
commit
ea483bb34c
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@
|
||||
/cmake-3.0.0.tar.gz
|
||||
/cmake-3.0.1.tar.gz
|
||||
/cmake-3.0.2.tar.gz
|
||||
/cmake-3.1.0-rc1.tar.gz
|
||||
|
@ -1,162 +0,0 @@
|
||||
--- cmake-3.0.0-rc1/Modules/FindPostgreSQL.cmake.orig 2014-02-26 08:41:21.000000000 -0700
|
||||
+++ cmake-3.0.0-rc1/Modules/FindPostgreSQL.cmake 2014-04-04 09:15:48.822447888 -0600
|
||||
@@ -100,77 +100,99 @@
|
||||
#
|
||||
# Look for an installation.
|
||||
#
|
||||
-find_path(PostgreSQL_INCLUDE_DIR
|
||||
- NAMES libpq-fe.h
|
||||
+find_path(PostgreSQL_CONFIG_DIR
|
||||
+ NAMES pg_config
|
||||
PATHS
|
||||
# Look in other places.
|
||||
${PostgreSQL_ROOT_DIRECTORIES}
|
||||
PATH_SUFFIXES
|
||||
- pgsql
|
||||
- postgresql
|
||||
- include
|
||||
+ ""
|
||||
+ bin
|
||||
# Help the user find it if we cannot.
|
||||
- DOC "The ${PostgreSQL_INCLUDE_DIR_MESSAGE}"
|
||||
+ DOC "The ${PostgreSQL_ROOT_DIR_MESSAGE}"
|
||||
)
|
||||
|
||||
-find_path(PostgreSQL_TYPE_INCLUDE_DIR
|
||||
- NAMES catalog/pg_type.h
|
||||
- PATHS
|
||||
- # Look in other places.
|
||||
- ${PostgreSQL_ROOT_DIRECTORIES}
|
||||
- PATH_SUFFIXES
|
||||
- postgresql
|
||||
- pgsql/server
|
||||
- postgresql/server
|
||||
- include/server
|
||||
- # Help the user find it if we cannot.
|
||||
- DOC "The ${PostgreSQL_INCLUDE_DIR_MESSAGE}"
|
||||
-)
|
||||
-
|
||||
-# The PostgreSQL library.
|
||||
-set (PostgreSQL_LIBRARY_TO_FIND pq)
|
||||
-# Setting some more prefixes for the library
|
||||
-set (PostgreSQL_LIB_PREFIX "")
|
||||
-if ( WIN32 )
|
||||
- set (PostgreSQL_LIB_PREFIX ${PostgreSQL_LIB_PREFIX} "lib")
|
||||
- set ( PostgreSQL_LIBRARY_TO_FIND ${PostgreSQL_LIB_PREFIX}${PostgreSQL_LIBRARY_TO_FIND})
|
||||
-endif()
|
||||
+macro (fail_if)
|
||||
+ if (${ARGV})
|
||||
+ message (WARNING "Couldn't determine PostgreSQL configuration.")
|
||||
+ unset (PostgreSQL_CONFIG_DIR)
|
||||
+ break ()
|
||||
+ endif ()
|
||||
+endmacro ()
|
||||
+
|
||||
+macro (run_pg_config arg var)
|
||||
+ execute_process(COMMAND ${PostgreSQL_CONFIG_DIR}/pg_config ${arg}
|
||||
+ RESULT_VARIABLE pgsql_config_result
|
||||
+ OUTPUT_VARIABLE ${var}
|
||||
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
+
|
||||
+ fail_if (NOT ${pgsql_config_result} EQUAL 0 OR NOT ${var})
|
||||
+endmacro ()
|
||||
+
|
||||
+foreach (once only)
|
||||
+ fail_if (NOT PostgreSQL_CONFIG_DIR)
|
||||
+
|
||||
+ run_pg_config (--version PostgreSQL_VERSION_STRING)
|
||||
+ string (REGEX REPLACE "^PostgreSQL (.*)$" "\\1"
|
||||
+ PostgreSQL_VERSION_STRING "${PostgreSQL_VERSION_STRING}")
|
||||
+ fail_if (NOT PostgreSQL_VERSION_STRING)
|
||||
+
|
||||
+ run_pg_config (--includedir PostgreSQL_INCLUDE_DIR)
|
||||
+ fail_if (NOT EXISTS "${PostgreSQL_INCLUDE_DIR}/libpq-fe.h")
|
||||
+
|
||||
+ find_path(PostgreSQL_TYPE_INCLUDE_DIR
|
||||
+ NAMES catalog/pg_type.h
|
||||
+ PATHS ${PostgreSQL_INCLUDE_DIR}
|
||||
+ PATH_SUFFIXES
|
||||
+ pgsql/server
|
||||
+ postgresql/server
|
||||
+ include/server
|
||||
+ # Help the user find it if we cannot.
|
||||
+ DOC "The ${PostgreSQL_INCLUDE_DIR_MESSAGE}"
|
||||
+ )
|
||||
+ fail_if (NOT PostgreSQL_TYPE_INCLUDE_DIR)
|
||||
+
|
||||
+ set (PostgreSQL_INCLUDE_DIRS
|
||||
+ ${PostgreSQL_INCLUDE_DIR} ${PostgreSQL_TYPE_INCLUDE_DIR})
|
||||
+
|
||||
+ run_pg_config (--libdir PostgreSQL_LIBRARY_DIRS)
|
||||
+
|
||||
+ # The PostgreSQL library.
|
||||
+ set (PostgreSQL_LIBRARY_TO_FIND pq)
|
||||
+ # Setting some more prefixes for the library
|
||||
+ set (PostgreSQL_LIB_PREFIX "")
|
||||
+ if (WIN32)
|
||||
+ set (PostgreSQL_LIB_PREFIX ${PostgreSQL_LIB_PREFIX} "lib")
|
||||
+ set (PostgreSQL_LIBRARY_TO_FIND ${PostgreSQL_LIB_PREFIX}${PostgreSQL_LIBRARY_TO_FIND})
|
||||
+ endif()
|
||||
+
|
||||
+ find_library (PostgreSQL_LIBRARY
|
||||
+ NAMES ${PostgreSQL_LIBRARY_TO_FIND}
|
||||
+ PATHS ${PostgreSQL_LIBRARY_DIRS}
|
||||
+ PATH_SUFFIXES lib
|
||||
+ )
|
||||
+ fail_if (NOT PostgreSQL_LIBRARY)
|
||||
+ set (PostgreSQL_LIBRARIES ${PostgreSQL_LIBRARY_TO_FIND})
|
||||
|
||||
-find_library( PostgreSQL_LIBRARY
|
||||
- NAMES ${PostgreSQL_LIBRARY_TO_FIND}
|
||||
- PATHS
|
||||
- ${PostgreSQL_ROOT_DIRECTORIES}
|
||||
- PATH_SUFFIXES
|
||||
- lib
|
||||
-)
|
||||
-get_filename_component(PostgreSQL_LIBRARY_DIR ${PostgreSQL_LIBRARY} PATH)
|
||||
-
|
||||
-if (PostgreSQL_INCLUDE_DIR AND EXISTS "${PostgreSQL_INCLUDE_DIR}/pg_config.h")
|
||||
- file(STRINGS "${PostgreSQL_INCLUDE_DIR}/pg_config.h" pgsql_version_str
|
||||
- REGEX "^#define[\t ]+PG_VERSION[\t ]+\".*\"")
|
||||
-
|
||||
- string(REGEX REPLACE "^#define[\t ]+PG_VERSION[\t ]+\"([^\"]*)\".*" "\\1"
|
||||
- PostgreSQL_VERSION_STRING "${pgsql_version_str}")
|
||||
- unset(pgsql_version_str)
|
||||
-endif()
|
||||
+endforeach()
|
||||
|
||||
# Did we find anything?
|
||||
-include(${CMAKE_CURRENT_LIST_DIR}/FindPackageHandleStandardArgs.cmake)
|
||||
-find_package_handle_standard_args(PostgreSQL
|
||||
- REQUIRED_VARS PostgreSQL_LIBRARY PostgreSQL_INCLUDE_DIR PostgreSQL_TYPE_INCLUDE_DIR
|
||||
- VERSION_VAR PostgreSQL_VERSION_STRING)
|
||||
-set( PostgreSQL_FOUND ${POSTGRESQL_FOUND})
|
||||
+include (FindPackageHandleStandardArgs)
|
||||
+find_package_handle_standard_args (PostgreSQL
|
||||
+ REQUIRED_VARS
|
||||
+ PostgreSQL_LIBRARY_DIRS
|
||||
+ PostgreSQL_CONFIG_DIR
|
||||
+ PostgreSQL_INCLUDE_DIRS
|
||||
+ PostgreSQL_LIBRARIES
|
||||
+ VERSION_VAR
|
||||
+ PostgreSQL_VERSION_STRING
|
||||
+)
|
||||
+set (PostgreSQL_FOUND ${POSTGRESQL_FOUND})
|
||||
|
||||
# Now try to get the include and library path.
|
||||
-if(PostgreSQL_FOUND)
|
||||
-
|
||||
- set(PostgreSQL_INCLUDE_DIRS ${PostgreSQL_INCLUDE_DIR} ${PostgreSQL_TYPE_INCLUDE_DIR} )
|
||||
- set(PostgreSQL_LIBRARY_DIRS ${PostgreSQL_LIBRARY_DIR} )
|
||||
- set(PostgreSQL_LIBRARIES ${PostgreSQL_LIBRARY_TO_FIND})
|
||||
-
|
||||
- #message("Final PostgreSQL include dir: ${PostgreSQL_INCLUDE_DIRS}")
|
||||
- #message("Final PostgreSQL library dir: ${PostgreSQL_LIBRARY_DIRS}")
|
||||
- #message("Final PostgreSQL libraries: ${PostgreSQL_LIBRARIES}")
|
||||
+if (PostgreSQL_FOUND)
|
||||
+ message (STATUS "PostgreSQL include dirs: ${PostgreSQL_INCLUDE_DIRS}")
|
||||
+ message (STATUS "PostgreSQL library dirs: ${PostgreSQL_LIBRARY_DIRS}")
|
||||
+ message (STATUS "PostgreSQL libraries: ${PostgreSQL_LIBRARIES}")
|
||||
endif()
|
||||
|
||||
-mark_as_advanced(PostgreSQL_INCLUDE_DIR PostgreSQL_TYPE_INCLUDE_DIR PostgreSQL_LIBRARY )
|
@ -1,48 +0,0 @@
|
||||
From 3816cd2dc7a7cc220e4f1b1e87fee986545b9cb3 Mon Sep 17 00:00:00 2001
|
||||
From: Matt McCormick <matt.mccormick@kitware.com>
|
||||
Date: Wed, 26 Feb 2014 21:47:20 -0500
|
||||
Subject: [PATCH] FindPythonLibs: Find consistent Python interp, headers, libs
|
||||
(#13794)
|
||||
|
||||
When possible, get consistent version of the Python interpreter, headers path,
|
||||
and library.
|
||||
|
||||
Now find_package(PythonLibs) internally calls find_package(PythonInterp
|
||||
QUIET) and uses the resulting PYTHON_VERSION_MAJOR and
|
||||
PYTHON_VERSION_MINOR to prefer these versions when looking for the
|
||||
header path and library. The Python_ADDITIONAL_VERSIONS variable has
|
||||
priority over the interpreter version.
|
||||
|
||||
Co-Author: Adam Wolf
|
||||
Co-Author: Gert Wollny <gw.fossdev@gmail.com>
|
||||
---
|
||||
Modules/FindPythonLibs.cmake | 13 +++++++++----
|
||||
1 file changed, 9 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
|
||||
index 0749efc..27d9e45 100644
|
||||
--- a/Modules/FindPythonLibs.cmake
|
||||
+++ b/Modules/FindPythonLibs.cmake
|
||||
@@ -80,10 +80,15 @@ endif()
|
||||
|
||||
# Set up the versions we know about, in the order we will search. Always add
|
||||
# the user supplied additional versions to the front.
|
||||
-set(_Python_VERSIONS
|
||||
- ${Python_ADDITIONAL_VERSIONS}
|
||||
- ${_PYTHON_FIND_OTHER_VERSIONS}
|
||||
- )
|
||||
+# If FindPythonInterp has already found the major and minor version,
|
||||
+# insert that version between the user supplied versions and the stock
|
||||
+# version list.
|
||||
+find_package(PythonInterp QUIET)
|
||||
+set(_Python_VERSIONS ${Python_ADDITIONAL_VERSIONS})
|
||||
+if(DEFINED PYTHON_VERSION_MAJOR AND DEFINED PYTHON_VERSION_MINOR)
|
||||
+ list(APPEND _Python_VERSIONS ${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR})
|
||||
+endif()
|
||||
+list(APPEND _Python_VERSIONS ${_PYTHON_FIND_OTHER_VERSIONS})
|
||||
|
||||
unset(_PYTHON_FIND_OTHER_VERSIONS)
|
||||
unset(_PYTHON1_VERSIONS)
|
||||
--
|
||||
1.7.10.4
|
||||
|
@ -1,31 +0,0 @@
|
||||
From bf28ff1f422407f10ecc283f03ce8c5ee57f1812 Mon Sep 17 00:00:00 2001
|
||||
From: Brad King <brad.king@kitware.com>
|
||||
Date: Wed, 5 Mar 2014 11:57:00 -0500
|
||||
Subject: [PATCH] FindPythonLibs: Do not try to find the interpreter (#13794)
|
||||
|
||||
The parent commit taught FindPythonLibs to try to find PythonInterp
|
||||
unconditionally. Some projects may want the libraries of a specific
|
||||
version even when the corresponding interpreter is not available. Drop
|
||||
the internal use of FindPythonInterp and just use the versions from it
|
||||
if it happens to have been found by the project first. That will allow
|
||||
projects to get a consistent version when they want both but not
|
||||
otherwise force them to find the interpreter.
|
||||
---
|
||||
Modules/FindPythonLibs.cmake | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
|
||||
index 27d9e45..656ed7b 100644
|
||||
--- a/Modules/FindPythonLibs.cmake
|
||||
+++ b/Modules/FindPythonLibs.cmake
|
||||
@@ -83,7 +83,6 @@ endif()
|
||||
# If FindPythonInterp has already found the major and minor version,
|
||||
# insert that version between the user supplied versions and the stock
|
||||
# version list.
|
||||
-find_package(PythonInterp QUIET)
|
||||
set(_Python_VERSIONS ${Python_ADDITIONAL_VERSIONS})
|
||||
if(DEFINED PYTHON_VERSION_MAJOR AND DEFINED PYTHON_VERSION_MINOR)
|
||||
list(APPEND _Python_VERSIONS ${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR})
|
||||
--
|
||||
1.7.10.4
|
||||
|
@ -1,34 +0,0 @@
|
||||
From 33286235048495ceafb636d549d9a4e8891967ae Mon Sep 17 00:00:00 2001
|
||||
From: "Richard M. Shaw" <hobbes1069@gmail.com>
|
||||
Date: Fri, 22 Aug 2014 11:35:00 -0500
|
||||
Subject: [PATCH] FindwxWidgets: Improve path detection logic when
|
||||
cross-compiling.
|
||||
|
||||
---
|
||||
Modules/FindwxWidgets.cmake | 7 +++----
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindwxWidgets.cmake b/Modules/FindwxWidgets.cmake
|
||||
index 45596a0..7ef06a8 100644
|
||||
--- a/Modules/FindwxWidgets.cmake
|
||||
+++ b/Modules/FindwxWidgets.cmake
|
||||
@@ -229,13 +229,12 @@ else()
|
||||
endif()
|
||||
|
||||
#=====================================================================
|
||||
+# Determine whether unix or win32 paths should be used
|
||||
#=====================================================================
|
||||
-if(WIN32 AND NOT CYGWIN AND NOT MSYS)
|
||||
+if(WIN32 AND NOT CYGWIN AND NOT MSYS AND NOT CMAKE_CROSSCOMPILING)
|
||||
set(wxWidgets_FIND_STYLE "win32")
|
||||
else()
|
||||
- if(UNIX OR MSYS)
|
||||
- set(wxWidgets_FIND_STYLE "unix")
|
||||
- endif()
|
||||
+ set(wxWidgets_FIND_STYLE "unix")
|
||||
endif()
|
||||
|
||||
#=====================================================================
|
||||
--
|
||||
1.7.10.4
|
||||
|
@ -1,31 +0,0 @@
|
||||
From e6fa6e60f6330ddf60294a0d9a6ed4cb3f27d4c4 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard M. Shaw" <hobbes1069@gmail.com>
|
||||
Date: Fri, 22 Aug 2014 10:27:48 -0500
|
||||
Subject: [PATCH] UsewxWidgets: CFLAGS are expected to be a string here, not a
|
||||
list.
|
||||
|
||||
---
|
||||
Modules/UsewxWidgets.cmake | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Modules/UsewxWidgets.cmake b/Modules/UsewxWidgets.cmake
|
||||
index f2f260d..b3633a6 100644
|
||||
--- a/Modules/UsewxWidgets.cmake
|
||||
+++ b/Modules/UsewxWidgets.cmake
|
||||
@@ -88,8 +88,11 @@ if (wxWidgets_FOUND)
|
||||
endif()
|
||||
|
||||
if (wxWidgets_CXX_FLAGS)
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${wxWidgets_CXX_FLAGS}")
|
||||
- MSG("wxWidgets_CXX_FLAGS=${wxWidgets_CXX_FLAGS}")
|
||||
+ # Flags are expected to be a string here, not a list.
|
||||
+ string(REPLACE ";" " " wxWidgets_CXX_FLAGS_str "${wxWidgets_CXX_FLAGS}")
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${wxWidgets_CXX_FLAGS_str}")
|
||||
+ MSG("wxWidgets_CXX_FLAGS=${wxWidgets_CXX_FLAGS_str}")
|
||||
+ unset(wxWidgets_CXX_FLAGS_str)
|
||||
endif()
|
||||
|
||||
# DEPRECATED JW
|
||||
--
|
||||
1.7.10.4
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 18ac6713e8657cca8fc791bcd581a47a7be6ebce Mon Sep 17 00:00:00 2001
|
||||
From: Dinar Valeev <dvaleev@suse.com>
|
||||
Date: Mon, 30 Jun 2014 18:29:20 +0200
|
||||
Subject: [PATCH] FindJNI: search for ppc64 on ppc64le as well
|
||||
|
||||
IcedTea 2.5 have changed libarch for ppc64le to ppc64. Adjust FindJNI
|
||||
to look for both for backward compatibility.
|
||||
|
||||
Signed-off-by: Dinar Valeev <dvaleev@suse.com>
|
||||
---
|
||||
Modules/FindJNI.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Modules/FindJNI.cmake b/Modules/FindJNI.cmake
|
||||
index 6a496af..3dcb0d0 100644
|
||||
--- a/Modules/FindJNI.cmake
|
||||
+++ b/Modules/FindJNI.cmake
|
||||
@@ -55,7 +55,7 @@ macro(java_append_library_directories _var)
|
||||
# endianess of the underlying system.
|
||||
set(_java_libarch "${CMAKE_SYSTEM_PROCESSOR}" "mips" "mipsel" "mipseb")
|
||||
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^(powerpc|ppc)64le")
|
||||
- set(_java_libarch "ppc64le")
|
||||
+ set(_java_libarch "ppc64" "ppc64le")
|
||||
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^(powerpc|ppc)64")
|
||||
set(_java_libarch "ppc64" "ppc")
|
||||
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^(powerpc|ppc)")
|
@ -1,6 +1,6 @@
|
||||
diff -up cmake-2.8.10.2/Modules/CMakeNinjaFindMake.cmake.ninja cmake-2.8.10.2/Modules/CMakeNinjaFindMake.cmake
|
||||
--- cmake-2.8.10.2/Modules/CMakeNinjaFindMake.cmake.ninja 2012-11-27 06:26:32.000000000 -0700
|
||||
+++ cmake-2.8.10.2/Modules/CMakeNinjaFindMake.cmake 2013-02-08 09:30:26.437739370 -0700
|
||||
diff -up cmake-3.1.0-rc1/Modules/CMakeNinjaFindMake.cmake.ninja cmake-3.1.0-rc1/Modules/CMakeNinjaFindMake.cmake
|
||||
--- cmake-3.1.0-rc1/Modules/CMakeNinjaFindMake.cmake.ninja 2014-10-27 08:40:56.000000000 -0600
|
||||
+++ cmake-3.1.0-rc1/Modules/CMakeNinjaFindMake.cmake 2014-10-29 19:36:04.758871982 -0600
|
||||
@@ -12,6 +12,6 @@
|
||||
# (To distribute this file outside of CMake, substitute the full
|
||||
# License text for the above reference.)
|
||||
@ -9,10 +9,10 @@ diff -up cmake-2.8.10.2/Modules/CMakeNinjaFindMake.cmake.ninja cmake-2.8.10.2/Mo
|
||||
+find_program(CMAKE_MAKE_PROGRAM ninja-build
|
||||
DOC "Program used to build from build.ninja files.")
|
||||
mark_as_advanced(CMAKE_MAKE_PROGRAM)
|
||||
diff -up cmake-2.8.10.2/Source/cmGlobalNinjaGenerator.cxx.ninja cmake-2.8.10.2/Source/cmGlobalNinjaGenerator.cxx
|
||||
--- cmake-2.8.10.2/Source/cmGlobalNinjaGenerator.cxx.ninja 2012-11-27 06:26:33.000000000 -0700
|
||||
+++ cmake-2.8.10.2/Source/cmGlobalNinjaGenerator.cxx 2013-02-08 09:32:30.397949661 -0700
|
||||
@@ -1034,7 +1034,7 @@ std::string cmGlobalNinjaGenerator::ninj
|
||||
diff -up cmake-3.1.0-rc1/Source/cmGlobalNinjaGenerator.cxx.ninja cmake-3.1.0-rc1/Source/cmGlobalNinjaGenerator.cxx
|
||||
--- cmake-3.1.0-rc1/Source/cmGlobalNinjaGenerator.cxx.ninja 2014-10-29 19:36:04.761872039 -0600
|
||||
+++ cmake-3.1.0-rc1/Source/cmGlobalNinjaGenerator.cxx 2014-10-29 19:37:00.528930970 -0600
|
||||
@@ -1171,7 +1171,7 @@ std::string cmGlobalNinjaGenerator::ninj
|
||||
lgen->GetMakefile()->GetRequiredDefinition("CMAKE_MAKE_PROGRAM"),
|
||||
cmLocalGenerator::SHELL);
|
||||
}
|
||||
@ -20,4 +20,4 @@ diff -up cmake-2.8.10.2/Source/cmGlobalNinjaGenerator.cxx.ninja cmake-2.8.10.2/S
|
||||
+ return "ninja-build";
|
||||
}
|
||||
|
||||
void cmGlobalNinjaGenerator::WriteTargetClean(std::ostream& os)
|
||||
std::string cmGlobalNinjaGenerator::ninjaVersion() const
|
||||
|
@ -1,25 +0,0 @@
|
||||
commit b94ecab6d6540512df5e7c11deb9d168566d346f
|
||||
Author: Clinton Stimpson <clinton@elemtech.com>
|
||||
Date: Wed Feb 26 10:53:53 2014 -0700
|
||||
|
||||
FindQt4: prevent overlinking when using UseQt4.cmake.
|
||||
|
||||
Now it only links with the Qt libraries specified by the user,
|
||||
instead of automatically including all dependencies.
|
||||
Fixes #14750 and thanks to Orion Poplawski.
|
||||
|
||||
diff --git a/Modules/UseQt4.cmake b/Modules/UseQt4.cmake
|
||||
index 7478310..cba22af 100644
|
||||
--- a/Modules/UseQt4.cmake
|
||||
+++ b/Modules/UseQt4.cmake
|
||||
@@ -98,7 +98,9 @@ foreach(module QT3SUPPORT QTOPENGL QTASSISTANT QTDESIGNER QTMOTIF QTNSPLUGIN
|
||||
include_directories(SYSTEM ${QT_${module}_INCLUDE_DIR})
|
||||
endif(QT_INCLUDE_DIRS_NO_SYSTEM)
|
||||
endif()
|
||||
- set(QT_LIBRARIES ${QT_LIBRARIES} ${QT_${module}_LIBRARY})
|
||||
+ if(QT_USE_${module} OR QT_IS_STATIC)
|
||||
+ set(QT_LIBRARIES ${QT_LIBRARIES} ${QT_${module}_LIBRARY})
|
||||
+ endif()
|
||||
set(QT_LIBRARIES_PLUGINS ${QT_LIBRARIES_PLUGINS} ${QT_${module}_PLUGINS})
|
||||
if(QT_IS_STATIC)
|
||||
set(QT_LIBRARIES ${QT_LIBRARIES} ${QT_${module}_LIB_DEPENDENCIES})
|
42
cmake.spec
42
cmake.spec
@ -4,7 +4,7 @@
|
||||
# Set to bcond_with or use --without gui to disable qt4 gui build
|
||||
%bcond_without gui
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
%define rcver %{nil}
|
||||
%define rcver -rc1
|
||||
|
||||
%define rpm_macros_dir %{_sysconfdir}/rpm
|
||||
%if 0%{?fedora} > 18
|
||||
@ -12,8 +12,8 @@
|
||||
%endif
|
||||
|
||||
Name: cmake
|
||||
Version: 3.0.2
|
||||
Release: 2%{?dist}
|
||||
Version: 3.1.0
|
||||
Release: 0.1.rc1%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -23,44 +23,23 @@ Group: Development/Tools
|
||||
# some GPL-licensed bison-generated files, these all include an exception granting redistribution under terms of your choice
|
||||
License: BSD and MIT and zlib
|
||||
URL: http://www.cmake.org
|
||||
Source0: http://www.cmake.org/files/v3.0/cmake-%{version}%{?rcver}.tar.gz
|
||||
Source0: http://www.cmake.org/files/v3.1/cmake-%{version}%{?rcver}.tar.gz
|
||||
Source1: cmake-init.el
|
||||
Source2: macros.cmake
|
||||
# Patch to find DCMTK in Fedora (bug #720140)
|
||||
Patch0: cmake-dcmtk.patch
|
||||
# Patch to fix RindRuby vendor settings
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
# Patch to use ninja-build instead of ninja (renamed in Fedora)
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=886184
|
||||
Patch1: cmake-ninja.patch
|
||||
# Patch to fix RindRuby vendor settings
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
Patch2: cmake-findruby.patch
|
||||
# Patch to fix FindPostgreSQL
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=828467
|
||||
# http://public.kitware.com/Bug/view.php?id=13378
|
||||
Patch3: cmake-FindPostgreSQL.patch
|
||||
# Fix issue with finding consistent python versions
|
||||
# http://public.kitware.com/Bug/view.php?id=13794
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=876118
|
||||
Patch4: cmake-FindPythonLibs.patch
|
||||
# Add FindLua52.cmake
|
||||
Patch5: cmake-2.8.11-rc4-lua-5.2.patch
|
||||
# Add -fno-strict-aliasing when compiling cm_sha2.c
|
||||
# http://www.cmake.org/Bug/view.php?id=14314
|
||||
Patch6: cmake-strict_aliasing.patch
|
||||
# Remove automatic Qt module dep adding
|
||||
# http://public.kitware.com/Bug/view.php?id=14750
|
||||
Patch8: cmake-qtdeps.patch
|
||||
# Additiona python fixes from upstream
|
||||
Patch9: cmake-FindPythonLibs2.patch
|
||||
# Fix FindwxWidgets when cross-compiling for Windows
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1081207
|
||||
# http://public.kitware.com/Bug/view.php?id=11296
|
||||
Patch10: cmake-FindwxWidgets.patch
|
||||
# Upstream fix to UsewxWidgets for CFLAGS handling
|
||||
Patch11: cmake-UsewxWidgets.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1141782#c2
|
||||
Patch12: cmake-java-ppc64le.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -124,15 +103,8 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1 -b .strict_aliasing
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
|
||||
|
||||
%build
|
||||
|
Loading…
Reference in New Issue
Block a user