- vim 7.0 now ships cmake files, so don't ship ours (bug #201018)
- Add patch to Linux.cmake for Fortran soname support for plplot
This commit is contained in:
parent
b1ddb248ea
commit
e7ba797012
64
cmake-2.4.3-soname.patch
Normal file
64
cmake-2.4.3-soname.patch
Normal file
@ -0,0 +1,64 @@
|
|||||||
|
--- Modules/Platform/Linux.cmake 20 Apr 2006 14:23:17 -0000 1.9
|
||||||
|
+++ Modules/Platform/Linux.cmake 1 Aug 2006 19:36:49 -0000 1.10
|
||||||
|
@@ -7,4 +7,5 @@
|
||||||
|
SET(CMAKE_SHARED_LIBRARY_RUNTIME_C_FLAG_SEP ":")
|
||||||
|
SET(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG "-Wl,-soname,")
|
||||||
|
SET(CMAKE_SHARED_LIBRARY_SONAME_CXX_FLAG "-Wl,-soname,")
|
||||||
|
+SET(CMAKE_SHARED_LIBRARY_SONAME_Fortran_FLAG "-Wl,-soname,")
|
||||||
|
INCLUDE(Platform/UnixPaths)
|
||||||
|
--- Source/cmInstallTargetGenerator.cxx 30 Jun 2006 17:48:43 -0000 1.12.2.3
|
||||||
|
+++ Source/cmInstallTargetGenerator.cxx 1 Aug 2006 19:36:49 -0000 1.17
|
||||||
|
@@ -3,8 +3,8 @@
|
||||||
|
Program: CMake - Cross-Platform Makefile Generator
|
||||||
|
Module: $RCSfile: cmInstallTargetGenerator.cxx,v $
|
||||||
|
Language: C++
|
||||||
|
- Date: $Date: 2006/06/30 17:48:43 $
|
||||||
|
- Version: $Revision: 1.12.2.3 $
|
||||||
|
+ Date: $Date: 2006/08/01 19:36:49 $
|
||||||
|
+ Version: $Revision: 1.17 $
|
||||||
|
|
||||||
|
Copyright (c) 2002 Kitware, Inc., Insight Consortium. All rights reserved.
|
||||||
|
See Copyright.txt or http://www.cmake.org/HTML/Copyright.html for details.
|
||||||
|
@@ -81,16 +81,25 @@
|
||||||
|
{
|
||||||
|
// Add shared library installation properties if this platform
|
||||||
|
// supports them.
|
||||||
|
- const char* lib_version = this->Target->GetProperty("VERSION");
|
||||||
|
- const char* lib_soversion = this->Target->GetProperty("SOVERSION");
|
||||||
|
- if(!this->Target->GetMakefile()
|
||||||
|
- ->GetDefinition("CMAKE_SHARED_LIBRARY_SONAME_C_FLAG"))
|
||||||
|
+ const char* lib_version = 0;
|
||||||
|
+ const char* lib_soversion = 0;
|
||||||
|
+
|
||||||
|
+ // Versioning is supported only for shared libraries and modules,
|
||||||
|
+ // and then only when the platform supports an soname flag.
|
||||||
|
+ cmGlobalGenerator* gg =
|
||||||
|
+ this->Target->GetMakefile()->GetLocalGenerator()->GetGlobalGenerator();
|
||||||
|
+ if(const char* linkLanguage = this->Target->GetLinkerLanguage(gg))
|
||||||
|
{
|
||||||
|
- // Versioning is supported only for shared libraries and modules,
|
||||||
|
- // and then only when the platform supports an soname flag.
|
||||||
|
- lib_version = 0;
|
||||||
|
- lib_soversion = 0;
|
||||||
|
+ std::string sonameFlagVar = "CMAKE_SHARED_LIBRARY_SONAME_";
|
||||||
|
+ sonameFlagVar += linkLanguage;
|
||||||
|
+ sonameFlagVar += "_FLAG";
|
||||||
|
+ if(this->Target->GetMakefile()->GetDefinition(sonameFlagVar.c_str()))
|
||||||
|
+ {
|
||||||
|
+ lib_version = this->Target->GetProperty("VERSION");
|
||||||
|
+ lib_soversion = this->Target->GetProperty("SOVERSION");
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
+
|
||||||
|
if(lib_version)
|
||||||
|
{
|
||||||
|
props += " VERSION ";
|
||||||
|
@@ -272,7 +281,7 @@
|
||||||
|
//----------------------------------------------------------------------------
|
||||||
|
void cmInstallTargetGenerator
|
||||||
|
::AddInstallNamePatchRule(std::ostream& os,
|
||||||
|
- const char* destination)
|
||||||
|
+ const char* destination)
|
||||||
|
{
|
||||||
|
// Build a map of build-tree install_name to install-tree install_name for
|
||||||
|
// shared libraries linked to this target.
|
13
cmake.spec
13
cmake.spec
@ -1,6 +1,6 @@
|
|||||||
Name: cmake
|
Name: cmake
|
||||||
Version: 2.4.3
|
Version: 2.4.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -9,6 +9,7 @@ URL: http://www.cmake.org
|
|||||||
Source0: http://www.cmake.org/files/v2.4/cmake-%{version}.tar.gz
|
Source0: http://www.cmake.org/files/v2.4/cmake-%{version}.tar.gz
|
||||||
Source1: cmake-init-fedora
|
Source1: cmake-init-fedora
|
||||||
Patch0: cmake-2.4.2-fedora.patch
|
Patch0: cmake-2.4.2-fedora.patch
|
||||||
|
Patch1: cmake-2.4.3-soname.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: ncurses-devel, libX11-devel
|
BuildRequires: ncurses-devel, libX11-devel
|
||||||
|
|
||||||
@ -24,6 +25,7 @@ generation, code generation, and template instantiation.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch -p1 -b .fedora
|
%patch -p1 -b .fedora
|
||||||
|
%patch1 -p0 -b .soname
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -38,12 +40,8 @@ make %{?_smp_mflags}
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
|
find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/vim/vim70/syntax
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/vim/vim70/indent
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
|
mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
|
||||||
cp -a Example $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}/
|
cp -a Example $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}/
|
||||||
install -m 0644 Docs/cmake-syntax.vim $RPM_BUILD_ROOT%{_datadir}/vim/vim70/syntax/cmake.vim
|
|
||||||
install -m 0644 Docs/cmake-indent.vim $RPM_BUILD_ROOT%{_datadir}/vim/vim70/indent/cmake.vim
|
|
||||||
install -m 0644 Docs/cmake-mode.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/
|
install -m 0644 Docs/cmake-mode.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/
|
||||||
|
|
||||||
|
|
||||||
@ -61,10 +59,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/%{name}/
|
%{_datadir}/%{name}/
|
||||||
%{_mandir}/man1/*.1*
|
%{_mandir}/man1/*.1*
|
||||||
%{_datadir}/emacs/
|
%{_datadir}/emacs/
|
||||||
%{_datadir}/vim/
|
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 2 2006 Orion Poplawski <orion@cora.nwra.com> - 2.4.3-2
|
||||||
|
- vim 7.0 now ships cmake files, so don't ship ours (bug #201018)
|
||||||
|
- Add patch to Linux.cmake for Fortran soname support for plplot
|
||||||
|
|
||||||
* Tue Aug 1 2006 Orion Poplawski <orion@cora.nwra.com> - 2.4.3-1
|
* Tue Aug 1 2006 Orion Poplawski <orion@cora.nwra.com> - 2.4.3-1
|
||||||
- Update to 2.4.3
|
- Update to 2.4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user