Update wxWidgets patches
This commit is contained in:
parent
f54d18f1c1
commit
e411e9f683
@ -1,15 +1,34 @@
|
||||
--- cmake-3.0.0-rc3/Modules/FindwxWidgets.cmake.orig 2014-03-20 10:50:27.000000000 -0600
|
||||
+++ cmake-3.0.0-rc3/Modules/FindwxWidgets.cmake 2014-04-04 09:34:41.194072417 -0600
|
||||
@@ -230,10 +230,10 @@
|
||||
From 33286235048495ceafb636d549d9a4e8891967ae Mon Sep 17 00:00:00 2001
|
||||
From: "Richard M. Shaw" <hobbes1069@gmail.com>
|
||||
Date: Fri, 22 Aug 2014 11:35:00 -0500
|
||||
Subject: [PATCH] FindwxWidgets: Improve path detection logic when
|
||||
cross-compiling.
|
||||
|
||||
---
|
||||
Modules/FindwxWidgets.cmake | 7 +++----
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindwxWidgets.cmake b/Modules/FindwxWidgets.cmake
|
||||
index 45596a0..7ef06a8 100644
|
||||
--- a/Modules/FindwxWidgets.cmake
|
||||
+++ b/Modules/FindwxWidgets.cmake
|
||||
@@ -229,13 +229,12 @@ else()
|
||||
endif()
|
||||
|
||||
#=====================================================================
|
||||
+# Determine whether unix or win32 paths should be used
|
||||
#=====================================================================
|
||||
-if(WIN32 AND NOT CYGWIN AND NOT MSYS)
|
||||
+if(WIN32 AND NOT CYGWIN AND NOT MSYS AND NOT CMAKE_CROSSCOMPILING)
|
||||
set(wxWidgets_FIND_STYLE "win32")
|
||||
else()
|
||||
- if(UNIX OR MSYS)
|
||||
+ if(UNIX OR MSYS OR WIN32 AND CMAKE_CROSSCOMPILING)
|
||||
set(wxWidgets_FIND_STYLE "unix")
|
||||
endif()
|
||||
- set(wxWidgets_FIND_STYLE "unix")
|
||||
- endif()
|
||||
+ set(wxWidgets_FIND_STYLE "unix")
|
||||
endif()
|
||||
|
||||
#=====================================================================
|
||||
--
|
||||
1.7.10.4
|
||||
|
||||
|
31
cmake-UsewxWidgets.patch
Normal file
31
cmake-UsewxWidgets.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From e6fa6e60f6330ddf60294a0d9a6ed4cb3f27d4c4 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard M. Shaw" <hobbes1069@gmail.com>
|
||||
Date: Fri, 22 Aug 2014 10:27:48 -0500
|
||||
Subject: [PATCH] UsewxWidgets: CFLAGS are expected to be a string here, not a
|
||||
list.
|
||||
|
||||
---
|
||||
Modules/UsewxWidgets.cmake | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Modules/UsewxWidgets.cmake b/Modules/UsewxWidgets.cmake
|
||||
index f2f260d..b3633a6 100644
|
||||
--- a/Modules/UsewxWidgets.cmake
|
||||
+++ b/Modules/UsewxWidgets.cmake
|
||||
@@ -88,8 +88,11 @@ if (wxWidgets_FOUND)
|
||||
endif()
|
||||
|
||||
if (wxWidgets_CXX_FLAGS)
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${wxWidgets_CXX_FLAGS}")
|
||||
- MSG("wxWidgets_CXX_FLAGS=${wxWidgets_CXX_FLAGS}")
|
||||
+ # Flags are expected to be a string here, not a list.
|
||||
+ string(REPLACE ";" " " wxWidgets_CXX_FLAGS_str "${wxWidgets_CXX_FLAGS}")
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${wxWidgets_CXX_FLAGS_str}")
|
||||
+ MSG("wxWidgets_CXX_FLAGS=${wxWidgets_CXX_FLAGS_str}")
|
||||
+ unset(wxWidgets_CXX_FLAGS_str)
|
||||
endif()
|
||||
|
||||
# DEPRECATED JW
|
||||
--
|
||||
1.7.10.4
|
||||
|
10
cmake.spec
10
cmake.spec
@ -13,7 +13,7 @@
|
||||
|
||||
Name: cmake
|
||||
Version: 3.0.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -56,7 +56,9 @@ Patch9: cmake-FindPythonLibs2.patch
|
||||
# Fix FindwxWidgets when cross-compiling for Windows
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1081207
|
||||
# http://public.kitware.com/Bug/view.php?id=11296
|
||||
Patch10: cmake-FindwxWidgets.patch
|
||||
Patch10: cmake-FindwxWidgets.patch
|
||||
# Upstream fix to UsewxWidgets for CFLAGS handling
|
||||
Patch11: cmake-UsewxWidgets.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -127,6 +129,7 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -248,6 +251,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 25 2014 Orion Poplawski <orion@cora.nwra.com> - 3.0.1-3
|
||||
- Update wxWidgets patches
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user