cmake-3.21.0-rc1 (#1975377)
This commit is contained in:
parent
cc03ad334f
commit
e2873452a2
@ -1,11 +0,0 @@
|
||||
diff -up cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake.CPACK_THREADS cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake
|
||||
--- cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake.CPACK_THREADS 2021-03-23 10:43:17.000000000 -0500
|
||||
+++ cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake 2021-03-23 13:29:14.539434722 -0500
|
||||
@@ -1,6 +1,6 @@
|
||||
install(FILES CMakeLists.txt DESTINATION foo COMPONENT test)
|
||||
|
||||
-set(CPACK_THREADS 0)
|
||||
+set(CPACK_THREADS 4)
|
||||
|
||||
if(PACKAGING_TYPE STREQUAL "COMPONENT")
|
||||
set(CPACK_COMPONENTS_ALL test)
|
16
cmake.spec
16
cmake.spec
@ -58,9 +58,9 @@
|
||||
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 20
|
||||
%global minor_version 21
|
||||
# Set to RC version if building RC, else %%{nil}
|
||||
#global rcsuf rc1
|
||||
%global rcsuf rc1
|
||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||
%{?rcsuf:%global versuf -%{rcsuf}}
|
||||
|
||||
@ -72,7 +72,7 @@
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.5
|
||||
Version: %{major_version}.%{minor_version}.0
|
||||
Release: %{baserelease}%{?relsuf}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
@ -106,13 +106,10 @@ Patch101: %{name}-fedora-flag_release.patch
|
||||
# Add dl to CMAKE_DL_LIBS on MINGW
|
||||
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
||||
Patch102: %{name}-mingw-dl.patch
|
||||
# memory-hungry tests when building on koji builders with *lots* of cores
|
||||
# so limit it to some reasonable number (4)
|
||||
Patch103: cmake-3.20-CPACK_THREADS.patch
|
||||
# (upstreamable)
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1972535
|
||||
# fix FTBFS
|
||||
Patch104: cmake-3.20.4-glibc_libdl.patch
|
||||
Patch103: %{name}-3.20.4-glibc_libdl.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -442,7 +439,7 @@ find %{buildroot}%{_bindir} -type f -or -type l -or -xtype l | \
|
||||
pushd %{_vpath_builddir}
|
||||
# CTestTestUpload require internet access
|
||||
# CPackComponentsForAll-RPM-IgnoreGroup failing wih rpm 4.15 - https://gitlab.kitware.com/cmake/cmake/issues/19983
|
||||
NO_TEST="CTestTestUpload|CPackComponentsForAll-RPM-IgnoreGroup|CPack_RPM.DEBUGINFO"
|
||||
NO_TEST="CTestTestUpload"
|
||||
# kwsys.testProcess-{4,5} are flaky on s390x.
|
||||
%ifarch s390x
|
||||
NO_TEST="$NO_TEST|kwsys.testProcess-4|kwsys.testProcess-5"
|
||||
@ -523,6 +520,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 23 2021 Björn Esser <besser82@fedoraproject.org> - 3.21.0-1.rc1
|
||||
- cmake-3.21.0-rc1 (#1975377)
|
||||
|
||||
* Mon Jun 21 2021 Björn Esser <besser82@fedoraproject.org> - 3.20.5-1
|
||||
- cmake-3.20.5 (#1942118)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.20.5.tar.gz) = 4ad7f194353be291e76d86d95928633daea653a0bd8d35369ac6ee2bb3f811c3a1aabe6a2bd51c6d5b07af2c6edc7e38d8b347ded32ab1ddcf331dbfce40c008
|
||||
SHA512 (cmake-3.21.0-rc1.tar.gz) = 91607aacd76fe53a146c23119d07c6eb9f91bdddc0c30498fd43786f3347f67cd4a2d51f76ec3b5d7849a9b4d6beddeec4ef2249ca981493a9b2581309cd1ef3
|
||||
|
Loading…
Reference in New Issue
Block a user