Update to 3.11.0 (#1536233)
This commit is contained in:
parent
8ed1da6e7f
commit
de2a36b648
1
.gitignore
vendored
1
.gitignore
vendored
@ -41,3 +41,4 @@
|
|||||||
/cmake-3.10.0.tar.gz
|
/cmake-3.10.0.tar.gz
|
||||||
/cmake-3.10.1.tar.gz
|
/cmake-3.10.1.tar.gz
|
||||||
/cmake-3.10.2.tar.gz
|
/cmake-3.10.2.tar.gz
|
||||||
|
/cmake-3.11.0.tar.gz
|
||||||
|
30
1785.patch
30
1785.patch
@ -1,30 +0,0 @@
|
|||||||
From 972f7caad354e0bb04d338446601d391e4b0efbd Mon Sep 17 00:00:00 2001
|
|
||||||
From: Brad King <brad.king@kitware.com>
|
|
||||||
Date: Wed, 21 Feb 2018 14:34:56 -0500
|
|
||||||
Subject: [PATCH] Tests: Make CompileFeatures C dialect check consistent with
|
|
||||||
impl
|
|
||||||
|
|
||||||
`Modules/CMakeCCompilerId.c.in` will report the C dialect as 11 whenever
|
|
||||||
`__STDC_VERSION__` indicates *at least* C 11. Make the test consistent
|
|
||||||
with this. We already do this for the C++ case.
|
|
||||||
|
|
||||||
Fixes: #17740
|
|
||||||
---
|
|
||||||
Tests/CompileFeatures/default_dialect.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Tests/CompileFeatures/default_dialect.c b/Tests/CompileFeatures/default_dialect.c
|
|
||||||
index 4debd9410c..2b4627ca46 100644
|
|
||||||
--- a/Tests/CompileFeatures/default_dialect.c
|
|
||||||
+++ b/Tests/CompileFeatures/default_dialect.c
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
|
|
||||||
#if DEFAULT_C11
|
|
||||||
-#if __STDC_VERSION__ != 201112L
|
|
||||||
+#if __STDC_VERSION__ < 201112L
|
|
||||||
#error Unexpected value for __STDC_VERSION__.
|
|
||||||
#endif
|
|
||||||
#elif DEFAULT_C99
|
|
||||||
--
|
|
||||||
2.14.3
|
|
||||||
|
|
@ -1,14 +0,0 @@
|
|||||||
diff -up cmake-3.10.2/Source/cmQtAutoGenerators.cxx.automoc cmake-3.10.2/Source/cmQtAutoGenerators.cxx
|
|
||||||
--- cmake-3.10.2/Source/cmQtAutoGenerators.cxx.automoc 2018-01-18 07:48:42.000000000 -0700
|
|
||||||
+++ cmake-3.10.2/Source/cmQtAutoGenerators.cxx 2018-03-08 21:09:50.451726324 -0700
|
|
||||||
@@ -80,8 +80,8 @@ static bool ReadFile(std::string& conten
|
|
||||||
std::size_t const length = cmSystemTools::FileLength(filename);
|
|
||||||
cmsys::ifstream ifs(filename.c_str(), (std::ios::in | std::ios::binary));
|
|
||||||
if (ifs) {
|
|
||||||
- content.resize(length);
|
|
||||||
- ifs.read(&content.front(), content.size());
|
|
||||||
+ content.reserve(length);
|
|
||||||
+ content.assign(std::istreambuf_iterator<char>{ifs}, {});
|
|
||||||
if (ifs) {
|
|
||||||
success = true;
|
|
||||||
} else {
|
|
16
cmake.spec
16
cmake.spec
@ -51,7 +51,7 @@
|
|||||||
%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||||
|
|
||||||
%global major_version 3
|
%global major_version 3
|
||||||
%global minor_version 10
|
%global minor_version 11
|
||||||
# Set to RC version if building RC, else %%{nil}
|
# Set to RC version if building RC, else %%{nil}
|
||||||
#global rcsuf rc3
|
#global rcsuf rc3
|
||||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||||
@ -62,8 +62,8 @@
|
|||||||
%global orig_name cmake
|
%global orig_name cmake
|
||||||
|
|
||||||
Name: %{orig_name}%{?name_suffix}
|
Name: %{orig_name}%{?name_suffix}
|
||||||
Version: %{major_version}.%{minor_version}.2
|
Version: %{major_version}.%{minor_version}.0
|
||||||
Release: 4%{?relsuf}%{?dist}
|
Release: 1%{?relsuf}%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
# most sources are BSD
|
# most sources are BSD
|
||||||
@ -91,14 +91,9 @@ Source5: %{name}.req
|
|||||||
Patch100: %{name}-findruby.patch
|
Patch100: %{name}-findruby.patch
|
||||||
# replace release flag -O3 with -O2 for fedora
|
# replace release flag -O3 with -O2 for fedora
|
||||||
Patch101: %{name}-fedora-flag_release.patch
|
Patch101: %{name}-fedora-flag_release.patch
|
||||||
# Fix C17 handling
|
|
||||||
Patch102: https://gitlab.kitware.com/cmake/cmake/merge_requests/1785.patch
|
|
||||||
# Add dl to CMAKE_DL_LIBS on MINGW
|
# Add dl to CMAKE_DL_LIBS on MINGW
|
||||||
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
||||||
Patch103: cmake-mingw-dl.patch
|
Patch102: %{name}-mingw-dl.patch
|
||||||
# Fix autogen crash with empty files
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1551147
|
|
||||||
Patch104: cmake-automoc.patch
|
|
||||||
|
|
||||||
# Patch for renaming on EPEL
|
# Patch for renaming on EPEL
|
||||||
%if 0%{?name_suffix:1}
|
%if 0%{?name_suffix:1}
|
||||||
@ -504,6 +499,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 29 2018 Björn Esser <besser82@fedoraproject.org> - 3.11.0-1
|
||||||
|
- Update to 3.11.0 (#1536233)
|
||||||
|
|
||||||
* Thu Mar 08 2018 Orion Poplawski <orion@nwra.com> - 3.10.2-4
|
* Thu Mar 08 2018 Orion Poplawski <orion@nwra.com> - 3.10.2-4
|
||||||
- Add patch to fix autogen with empty files (bug #1551147)
|
- Add patch to fix autogen with empty files (bug #1551147)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (cmake-3.10.2.tar.gz) = f58fdd025285c9ff5396c0bd0d9573fc8a498fcbe5c11b336cb8ad6154ca6bc875c1a5e22d6654ba98596791ecf89ae8adffb83450839fa1275756b0af5bf82b
|
SHA512 (cmake-3.11.0.tar.gz) = 03b058483d236d4f4427c93cc41af77068c243fc4b6f24aeaf2daf97af215bc664bc1b733195463af4cfc94ec70076710f425661859d752ddf3b9610adca9834
|
||||||
|
Loading…
Reference in New Issue
Block a user