pull in some upstream fixes (FindPkgConfig,boost-1.59)
This commit is contained in:
parent
f091375c19
commit
c61fc84029
34
0624-FindBoost-Add-support-for-Boost-1.59.patch
Normal file
34
0624-FindBoost-Add-support-for-Boost-1.59.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From ff5bb2efbe9f7bb4a1824b0ad727713fcd6bc54a Mon Sep 17 00:00:00 2001
|
||||
From: Roger Leigh <rleigh@codelibre.net>
|
||||
Date: Thu, 13 Aug 2015 23:34:39 +0100
|
||||
Subject: [PATCH 624/677] FindBoost: Add support for Boost 1.59
|
||||
|
||||
---
|
||||
Modules/FindBoost.cmake | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
|
||||
index 05b552a..33e6a49 100644
|
||||
--- a/Modules/FindBoost.cmake
|
||||
+++ b/Modules/FindBoost.cmake
|
||||
@@ -512,13 +512,15 @@ else()
|
||||
# The user has not requested an exact version. Among known
|
||||
# versions, find those that are acceptable to the user request.
|
||||
set(_Boost_KNOWN_VERSIONS ${Boost_ADDITIONAL_VERSIONS}
|
||||
- "1.58.0" "1.58" "1.57.0" "1.57" "1.56.0" "1.56" "1.55.0" "1.55" "1.54.0" "1.54"
|
||||
- "1.53.0" "1.53" "1.52.0" "1.52" "1.51.0" "1.51"
|
||||
+
|
||||
+ "1.59.0" "1.59" "1.58.0" "1.58" "1.57.0" "1.57" "1.56.0" "1.56" "1.55.0" "1.55"
|
||||
+ "1.54.0" "1.54" "1.53.0" "1.53" "1.52.0" "1.52" "1.51.0" "1.51"
|
||||
"1.50.0" "1.50" "1.49.0" "1.49" "1.48.0" "1.48" "1.47.0" "1.47" "1.46.1"
|
||||
"1.46.0" "1.46" "1.45.0" "1.45" "1.44.0" "1.44" "1.43.0" "1.43" "1.42.0" "1.42"
|
||||
"1.41.0" "1.41" "1.40.0" "1.40" "1.39.0" "1.39" "1.38.0" "1.38" "1.37.0" "1.37"
|
||||
"1.36.1" "1.36.0" "1.36" "1.35.1" "1.35.0" "1.35" "1.34.1" "1.34.0"
|
||||
"1.34" "1.33.1" "1.33.0" "1.33")
|
||||
+
|
||||
set(_boost_TEST_VERSIONS)
|
||||
if(Boost_FIND_VERSION)
|
||||
set(_Boost_FIND_VERSION_SHORT "${Boost_FIND_VERSION_MAJOR}.${Boost_FIND_VERSION_MINOR}")
|
||||
--
|
||||
2.4.3
|
||||
|
40
0640-FindPkgConfig-remove-variable-dereference.patch
Normal file
40
0640-FindPkgConfig-remove-variable-dereference.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From b9ec9392da21a3421e48c6961976060d872faffb Mon Sep 17 00:00:00 2001
|
||||
From: Rolf Eike Beer <eike@sf-mail.de>
|
||||
Date: Tue, 18 Aug 2015 12:14:43 +0200
|
||||
Subject: [PATCH 640/677] FindPkgConfig: remove variable dereference
|
||||
|
||||
If CMAKE_MINIMUM_REQUIRED_VERSION is not set because no
|
||||
cmake_minimum_required() call is present this line can lead to an error as that
|
||||
string is empty so too few arguments are passed to if():
|
||||
|
||||
See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeOutput.log".
|
||||
See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeError.log".
|
||||
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:112 (elseif):
|
||||
given arguments:
|
||||
|
||||
"VERSION_LESS" "3.1"
|
||||
|
||||
Unknown arguments specified
|
||||
Call Stack (most recent call first):
|
||||
/usr/share/cmake/Modules/FindPkgConfig.cmake:501 (_pkgconfig_parse_options)
|
||||
/usr/share/cmake/Modules/FindOpenSSL.cmake:43 (pkg_check_modules)
|
||||
---
|
||||
Modules/FindPkgConfig.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
|
||||
index 526a62e..ae6903e 100644
|
||||
--- a/Modules/FindPkgConfig.cmake
|
||||
+++ b/Modules/FindPkgConfig.cmake
|
||||
@@ -109,7 +109,7 @@ macro(_pkgconfig_parse_options _result _is_req _is_silent _no_cmake_path _no_cma
|
||||
set(${_no_cmake_path} 1)
|
||||
set(${_no_cmake_environment_path} 1)
|
||||
endif()
|
||||
- elseif(${CMAKE_MINIMUM_REQUIRED_VERSION} VERSION_LESS 3.1)
|
||||
+ elseif(CMAKE_MINIMUM_REQUIRED_VERSION VERSION_LESS 3.1)
|
||||
set(${_no_cmake_path} 1)
|
||||
set(${_no_cmake_environment_path} 1)
|
||||
endif()
|
||||
--
|
||||
2.4.3
|
||||
|
12
cmake.spec
12
cmake.spec
@ -13,7 +13,7 @@
|
||||
|
||||
Name: cmake
|
||||
Version: 3.3.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -36,6 +36,11 @@ Patch0: cmake-dcmtk.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
Patch2: cmake-findruby.patch
|
||||
|
||||
## upstream patches
|
||||
# some post v3.3.1 tag commits
|
||||
Patch624: 0624-FindBoost-Add-support-for-Boost-1.59.patch
|
||||
Patch640: 0640-FindPkgConfig-remove-variable-dereference.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: gcc-gfortran
|
||||
@ -102,6 +107,8 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
# We cannot use backups with patches to Modules as they end up being installed
|
||||
%patch0 -p1
|
||||
%patch2 -p1
|
||||
%patch624 -p1
|
||||
%patch640 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -274,6 +281,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 25 2015 Rex Dieter <rdieter@fedoraproject.org> 3.3.1-3
|
||||
- pull in some upstream fixes (FindPkgConfig,boost-1.59)
|
||||
|
||||
* Fri Aug 21 2015 Rex Dieter <rdieter@fedoraproject.org> 3.3.1-2
|
||||
- Provides: bundled(kwsys)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user