cmake-3.20.2 (#1942118)
bash-completion fixes (#1924340) Release build type optimization options differ from upstream package (#1751155) parse parallel build from %_smp_mflags instead of _NPROCESSORS_ONLN drop old dist references (rhel6)
This commit is contained in:
parent
ec77e26a43
commit
c50f9727e8
@ -1,11 +0,0 @@
|
|||||||
diff -up cmake-3.19.2/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake.CPACK_ARCHIVE_THREADS cmake-3.19.2/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake
|
|
||||||
--- cmake-3.19.2/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake.CPACK_ARCHIVE_THREADS 2020-12-16 06:35:29.000000000 -0600
|
|
||||||
+++ cmake-3.19.2/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake 2021-01-12 16:47:40.139581556 -0600
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
install(FILES CMakeLists.txt DESTINATION foo COMPONENT test)
|
|
||||||
|
|
||||||
-set(CPACK_ARCHIVE_THREADS 0)
|
|
||||||
+set(CPACK_ARCHIVE_THREADS 4)
|
|
||||||
|
|
||||||
if(PACKAGING_TYPE STREQUAL "COMPONENT")
|
|
||||||
set(CPACK_COMPONENTS_ALL test)
|
|
11
cmake-3.20-CPACK_THREADS.patch
Normal file
11
cmake-3.20-CPACK_THREADS.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake.CPACK_THREADS cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake
|
||||||
|
--- cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake.CPACK_THREADS 2021-03-23 10:43:17.000000000 -0500
|
||||||
|
+++ cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake 2021-03-23 13:29:14.539434722 -0500
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
install(FILES CMakeLists.txt DESTINATION foo COMPONENT test)
|
||||||
|
|
||||||
|
-set(CPACK_THREADS 0)
|
||||||
|
+set(CPACK_THREADS 4)
|
||||||
|
|
||||||
|
if(PACKAGING_TYPE STREQUAL "COMPONENT")
|
||||||
|
set(CPACK_COMPONENTS_ALL test)
|
@ -101,58 +101,6 @@ Index: cmake-3.17.0-rc1/Modules/Compiler/PGI.cmake
|
|||||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -gopt")
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -gopt")
|
||||||
|
|
||||||
if(CMAKE_HOST_WIN32)
|
if(CMAKE_HOST_WIN32)
|
||||||
Index: cmake-3.17.0-rc1/Modules/Compiler/SunPro-ASM.cmake
|
|
||||||
===================================================================
|
|
||||||
--- cmake-3.17.0-rc1.orig/Modules/Compiler/SunPro-ASM.cmake
|
|
||||||
+++ cmake-3.17.0-rc1/Modules/Compiler/SunPro-ASM.cmake
|
|
||||||
@@ -11,7 +11,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_ASM_FLAG
|
|
||||||
string(APPEND CMAKE_ASM_FLAGS_INIT " ")
|
|
||||||
string(APPEND CMAKE_ASM_FLAGS_DEBUG_INIT " -g")
|
|
||||||
string(APPEND CMAKE_ASM_FLAGS_MINSIZEREL_INIT " -xO2 -xspace -DNDEBUG")
|
|
||||||
-string(APPEND CMAKE_ASM_FLAGS_RELEASE_INIT " -xO3 -DNDEBUG")
|
|
||||||
+string(APPEND CMAKE_ASM_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
|
||||||
string(APPEND CMAKE_ASM_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
|
||||||
|
|
||||||
# Initialize ASM link type selection flags. These flags are used when
|
|
||||||
Index: cmake-3.17.0-rc1/Modules/Compiler/SunPro-C.cmake
|
|
||||||
===================================================================
|
|
||||||
--- cmake-3.17.0-rc1.orig/Modules/Compiler/SunPro-C.cmake
|
|
||||||
+++ cmake-3.17.0-rc1/Modules/Compiler/SunPro-C.cmake
|
|
||||||
@@ -19,7 +19,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG "
|
|
||||||
string(APPEND CMAKE_C_FLAGS_INIT " ")
|
|
||||||
string(APPEND CMAKE_C_FLAGS_DEBUG_INIT " -g")
|
|
||||||
string(APPEND CMAKE_C_FLAGS_MINSIZEREL_INIT " -xO2 -xspace -DNDEBUG")
|
|
||||||
-string(APPEND CMAKE_C_FLAGS_RELEASE_INIT " -xO3 -DNDEBUG")
|
|
||||||
+string(APPEND CMAKE_C_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
|
||||||
string(APPEND CMAKE_C_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
|
||||||
|
|
||||||
set(CMAKE_DEPFILE_FLAGS_C "-xMD -xMF <DEPFILE>")
|
|
||||||
Index: cmake-3.17.0-rc1/Modules/Compiler/SunPro-CXX.cmake
|
|
||||||
===================================================================
|
|
||||||
--- cmake-3.17.0-rc1.orig/Modules/Compiler/SunPro-CXX.cmake
|
|
||||||
+++ cmake-3.17.0-rc1/Modules/Compiler/SunPro-CXX.cmake
|
|
||||||
@@ -19,7 +19,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_CXX_FLAG
|
|
||||||
string(APPEND CMAKE_CXX_FLAGS_INIT " ")
|
|
||||||
string(APPEND CMAKE_CXX_FLAGS_DEBUG_INIT " -g")
|
|
||||||
string(APPEND CMAKE_CXX_FLAGS_MINSIZEREL_INIT " -xO2 -xspace -DNDEBUG")
|
|
||||||
-string(APPEND CMAKE_CXX_FLAGS_RELEASE_INIT " -xO3 -DNDEBUG")
|
|
||||||
+string(APPEND CMAKE_CXX_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
|
||||||
string(APPEND CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
|
||||||
|
|
||||||
set(CMAKE_DEPFILE_FLAGS_CXX "-xMD -xMF <DEPFILE>")
|
|
||||||
Index: cmake-3.17.0-rc1/Modules/Compiler/SunPro-Fortran.cmake
|
|
||||||
===================================================================
|
|
||||||
--- cmake-3.17.0-rc1.orig/Modules/Compiler/SunPro-Fortran.cmake
|
|
||||||
+++ cmake-3.17.0-rc1/Modules/Compiler/SunPro-Fortran.cmake
|
|
||||||
@@ -17,7 +17,7 @@ set(CMAKE_EXECUTABLE_RUNTIME_Fortran_FLA
|
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -xO2 -xspace -DNDEBUG")
|
|
||||||
-string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -xO3 -DNDEBUG")
|
|
||||||
+string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
|
||||||
set(CMAKE_Fortran_MODDIR_FLAG "-moddir=")
|
|
||||||
set(CMAKE_Fortran_MODPATH_FLAG "-M")
|
|
||||||
Index: cmake-3.17.0-rc1/Modules/Platform/Windows-Clang.cmake
|
Index: cmake-3.17.0-rc1/Modules/Platform/Windows-Clang.cmake
|
||||||
===================================================================
|
===================================================================
|
||||||
--- cmake-3.17.0-rc1.orig/Modules/Platform/Windows-Clang.cmake
|
--- cmake-3.17.0-rc1.orig/Modules/Platform/Windows-Clang.cmake
|
||||||
|
49
cmake.spec
49
cmake.spec
@ -32,12 +32,7 @@
|
|||||||
# Enable RPM dependency generators for cmake files written in Python
|
# Enable RPM dependency generators for cmake files written in Python
|
||||||
%bcond_without rpm
|
%bcond_without rpm
|
||||||
|
|
||||||
# Sphinx-build cannot import CMakeLexer on EPEL <= 6
|
|
||||||
%if 0%{?rhel} && 0%{?rhel} <= 6
|
|
||||||
%bcond_with sphinx
|
|
||||||
%else
|
|
||||||
%bcond_without sphinx
|
%bcond_without sphinx
|
||||||
%endif
|
|
||||||
|
|
||||||
%if !0%{?rhel}
|
%if !0%{?rhel}
|
||||||
%bcond_with bundled_jsoncpp
|
%bcond_with bundled_jsoncpp
|
||||||
@ -63,7 +58,7 @@
|
|||||||
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
||||||
|
|
||||||
%global major_version 3
|
%global major_version 3
|
||||||
%global minor_version 19
|
%global minor_version 20
|
||||||
# Set to RC version if building RC, else %%{nil}
|
# Set to RC version if building RC, else %%{nil}
|
||||||
#global rcsuf rc1
|
#global rcsuf rc1
|
||||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||||
@ -77,7 +72,7 @@
|
|||||||
%global orig_name cmake
|
%global orig_name cmake
|
||||||
|
|
||||||
Name: %{orig_name}%{?name_suffix}
|
Name: %{orig_name}%{?name_suffix}
|
||||||
Version: %{major_version}.%{minor_version}.7
|
Version: %{major_version}.%{minor_version}.2
|
||||||
Release: %{baserelease}%{?relsuf}%{?dist}
|
Release: %{baserelease}%{?relsuf}%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
@ -105,20 +100,19 @@ Source5: %{name}.req
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||||
Patch100: %{name}-findruby.patch
|
Patch100: %{name}-findruby.patch
|
||||||
# replace release flag -O3 with -O2 for fedora
|
# replace release flag -O3 with -O2 for fedora
|
||||||
|
%if 0%{?fedora} < 34
|
||||||
Patch101: %{name}-fedora-flag_release.patch
|
Patch101: %{name}-fedora-flag_release.patch
|
||||||
|
%endif
|
||||||
# Add dl to CMAKE_DL_LIBS on MINGW
|
# Add dl to CMAKE_DL_LIBS on MINGW
|
||||||
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
||||||
Patch102: %{name}-mingw-dl.patch
|
Patch102: %{name}-mingw-dl.patch
|
||||||
# memory-hungry tests when building on koji builders with *lots* of cores
|
# memory-hungry tests when building on koji builders with *lots* of cores
|
||||||
# so limit it to some reasonable number (4)
|
# so limit it to some reasonable number (4)
|
||||||
Patch103: cmake-3.19-CPACK_ARCHIVE_THREADS.patch
|
Patch103: cmake-3.20-CPACK_THREADS.patch
|
||||||
|
|
||||||
# Patch for renaming on EPEL
|
# Patch for renaming on EPEL
|
||||||
%if 0%{?name_suffix:1}
|
%if 0%{?name_suffix:1}
|
||||||
Patch1: %{name}-rename.patch
|
Patch1: %{name}-rename.patch
|
||||||
%if 0%{?rhel} && 0%{?rhel} <= 6
|
|
||||||
Patch2: %{name}-libarchive3.patch
|
|
||||||
%endif
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
BuildRequires: coreutils
|
BuildRequires: coreutils
|
||||||
@ -177,7 +171,6 @@ BuildRequires: python%{python3_pkgversion}-devel
|
|||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
#BuildRequires: xmlrpc-c-devel
|
|
||||||
%if %{with gui}
|
%if %{with gui}
|
||||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
BuildRequires: pkgconfig(Qt5Widgets)
|
BuildRequires: pkgconfig(Qt5Widgets)
|
||||||
@ -187,6 +180,9 @@ BuildRequires: pkgconfig(QtGui)
|
|||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: pkgconfig(bash-completion)
|
||||||
|
%global bash_completionsdir %(pkg-config --variable=completionsdir bash-completion 2>/dev/null || echo '%{_datadir}/bash-completion/completions')
|
||||||
|
|
||||||
%if %{without bootstrap}
|
%if %{without bootstrap}
|
||||||
# Ensure we have our own rpm-macros in place during build.
|
# Ensure we have our own rpm-macros in place during build.
|
||||||
BuildRequires: %{name}-rpm-macros
|
BuildRequires: %{name}-rpm-macros
|
||||||
@ -309,7 +305,7 @@ pushd %{_vpath_builddir}
|
|||||||
$SRCDIR/bootstrap --prefix=%{_prefix} --datadir=/share/%{name} \
|
$SRCDIR/bootstrap --prefix=%{_prefix} --datadir=/share/%{name} \
|
||||||
--docdir=/share/doc/%{name} --mandir=/share/man \
|
--docdir=/share/doc/%{name} --mandir=/share/man \
|
||||||
--%{?with_bootstrap:no-}system-libs \
|
--%{?with_bootstrap:no-}system-libs \
|
||||||
--parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
|
--parallel="$(echo %{?_smp_mflags} | sed -e 's|-j||g')" \
|
||||||
%if %{with bundled_rhash}
|
%if %{with bundled_rhash}
|
||||||
--no-system-librhash \
|
--no-system-librhash \
|
||||||
%endif
|
%endif
|
||||||
@ -336,12 +332,7 @@ find %{buildroot}%{_datadir}/%{name}/Modules -type f | xargs chmod -x
|
|||||||
exit 1
|
exit 1
|
||||||
# Install major_version name links
|
# Install major_version name links
|
||||||
%{!?name_suffix:for f in ccmake cmake cpack ctest; do ln -s $f %{buildroot}%{_bindir}/${f}%{major_version}; done}
|
%{!?name_suffix:for f in ccmake cmake cpack ctest; do ln -s $f %{buildroot}%{_bindir}/${f}%{major_version}; done}
|
||||||
# Install bash completion symlinks
|
|
||||||
mkdir -p %{buildroot}%{_datadir}/bash-completion/completions
|
|
||||||
for f in %{buildroot}%{_datadir}/%{name}/completions/*
|
|
||||||
do
|
|
||||||
ln -s ../../%{name}/completions/$(basename $f) %{buildroot}%{_datadir}/bash-completion/completions
|
|
||||||
done
|
|
||||||
%if %{with emacs}
|
%if %{with emacs}
|
||||||
# Install emacs cmake mode
|
# Install emacs cmake mode
|
||||||
mkdir -p %{buildroot}%{_emacs_sitelispdir}/%{name} %{buildroot}%{_emacs_sitestartdir}
|
mkdir -p %{buildroot}%{_emacs_sitelispdir}/%{name} %{buildroot}%{_emacs_sitestartdir}
|
||||||
@ -444,13 +435,10 @@ find %{buildroot}%{_bindir} -type f -or -type l -or -xtype l | \
|
|||||||
|
|
||||||
%if %{with test}
|
%if %{with test}
|
||||||
%check
|
%check
|
||||||
%if 0%{?rhel} && 0%{?rhel} <= 6
|
|
||||||
mv -f Modules/FindLibArchive.cmake Modules/FindLibArchive.disabled
|
|
||||||
%endif
|
|
||||||
pushd %{_vpath_builddir}
|
pushd %{_vpath_builddir}
|
||||||
# CTestTestUpload require internet access
|
# CTestTestUpload require internet access
|
||||||
# CPackComponentsForAll-RPM-IgnoreGroup failing wih rpm 4.15 - https://gitlab.kitware.com/cmake/cmake/issues/19983
|
# CPackComponentsForAll-RPM-IgnoreGroup failing wih rpm 4.15 - https://gitlab.kitware.com/cmake/cmake/issues/19983
|
||||||
NO_TEST="CTestTestUpload|CPackComponentsForAll-RPM-IgnoreGroup"
|
NO_TEST="CTestTestUpload|CPackComponentsForAll-RPM-IgnoreGroup|CPack_RPM.DEBUGINFO"
|
||||||
# kwsys.testProcess-{4,5} are flaky on s390x.
|
# kwsys.testProcess-{4,5} are flaky on s390x.
|
||||||
%ifarch s390x
|
%ifarch s390x
|
||||||
NO_TEST="$NO_TEST|kwsys.testProcess-4|kwsys.testProcess-5"
|
NO_TEST="$NO_TEST|kwsys.testProcess-4|kwsys.testProcess-5"
|
||||||
@ -460,12 +448,10 @@ NO_TEST="$NO_TEST|kwsys.testProcess-4|kwsys.testProcess-5"
|
|||||||
NO_TEST="$NO_TEST|curl"
|
NO_TEST="$NO_TEST|curl"
|
||||||
%endif
|
%endif
|
||||||
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -E "$NO_TEST" --output-on-failure
|
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -E "$NO_TEST" --output-on-failure
|
||||||
|
## do this only periodically, not for every build -- rdieter 20210429
|
||||||
# Keep an eye on failing tests
|
# Keep an eye on failing tests
|
||||||
bin/ctest%{?name_suffix} %{?_smp_mflags} -V -R "$NO_TEST" --output-on-failure || :
|
#bin/ctest%{?name_suffix} %{?_smp_mflags} -V -R "$NO_TEST" --output-on-failure || :
|
||||||
popd
|
popd
|
||||||
%if 0%{?rhel} && 0%{?rhel} <= 6
|
|
||||||
mv -f Modules/FindLibArchive.disabled Modules/FindLibArchive.cmake
|
|
||||||
%endif
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
@ -484,7 +470,7 @@ mv -f Modules/FindLibArchive.disabled Modules/FindLibArchive.cmake
|
|||||||
|
|
||||||
%files data -f data_files.mf
|
%files data -f data_files.mf
|
||||||
%{_datadir}/aclocal/%{name}.m4
|
%{_datadir}/aclocal/%{name}.m4
|
||||||
%{_datadir}/bash-completion
|
%{bash_completionsdir}/c*
|
||||||
%if %{with emacs}
|
%if %{with emacs}
|
||||||
%if 0%{?fedora} || 0%{?rhel} >= 7
|
%if 0%{?fedora} || 0%{?rhel} >= 7
|
||||||
%{_emacs_sitelispdir}/%{name}
|
%{_emacs_sitelispdir}/%{name}
|
||||||
@ -533,6 +519,13 @@ mv -f Modules/FindLibArchive.disabled Modules/FindLibArchive.cmake
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 29 2021 Rex Dieter <rdieter@fedoraproject.org> - 3.20.2-1
|
||||||
|
- cmake-3.20.2 (#1942118)
|
||||||
|
- bash-completion fixes (#1924340)
|
||||||
|
- Release build type optimization options differ from upstream package (#1751155)
|
||||||
|
- parse parallel build from %%_smp_mflags instead of _NPROCESSORS_ONLN
|
||||||
|
- drop old dist references (rhel6)
|
||||||
|
|
||||||
* Mon Mar 15 2021 Rex Dieter <rdieter@fedoraproject.org> - 3.19.7-1
|
* Mon Mar 15 2021 Rex Dieter <rdieter@fedoraproject.org> - 3.19.7-1
|
||||||
- cmake-3.19.7
|
- cmake-3.19.7
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (cmake-3.19.7.tar.gz) = 6af1fe3ea41906324d4c29f5f982281d92145d086f4a47fa2220b93483bc65d59b1e23f5b51d82305c630690be7c552827bb795560674b03620763e0917bf14a
|
SHA512 (cmake-3.20.2.tar.gz) = 675a92f84b437169aee86dbfa59715671b9195ddeffc6fea83c7803a70abe3116106ad0a627b9e4bef326bfb2a10fdf624ad341fd9d3d08e3d8a69c271cd2b32
|
||||||
|
Loading…
Reference in New Issue
Block a user