- Update to 2.6.0-RC-5
- Add gui sub-package for Qt frontend
This commit is contained in:
parent
abc4e2896d
commit
c2a3b67831
@ -1 +1 @@
|
|||||||
cmake-2.4.8.tar.gz
|
cmake-2.6.0-RC-5.tar.gz
|
||||||
|
@ -1,21 +1,3 @@
|
|||||||
--- cmake-2.4.2/Modules/FindSWIG.cmake.fedora 2006-07-11 10:21:11.000000000 -0600
|
|
||||||
+++ cmake-2.4.2/Modules/FindSWIG.cmake 2006-07-11 10:22:47.000000000 -0600
|
|
||||||
@@ -7,13 +7,11 @@
|
|
||||||
SET(SWIG_FOUND FOOBAR)
|
|
||||||
FIND_PATH(SWIG_DIR
|
|
||||||
SWIGConfig.cmake
|
|
||||||
- /usr/share/swig1.3
|
|
||||||
- /usr/lib/swig1.3
|
|
||||||
+ /usr/share/swig/*
|
|
||||||
/usr/local/share/swig1.3)
|
|
||||||
FIND_PATH(SWIG_DIR
|
|
||||||
swig.swg
|
|
||||||
- /usr/share/swig1.3
|
|
||||||
- /usr/lib/swig1.3
|
|
||||||
+ /usr/share/swig/*
|
|
||||||
/usr/local/share/swig1.3)
|
|
||||||
IF(EXISTS ${SWIG_DIR})
|
|
||||||
IF("x${SWIG_DIR}x" STREQUAL "x${CMAKE_ROOT}/Modulesx")
|
|
||||||
--- cmake-2.4.3/Modules/FindJNI.cmake.orig 2006-10-31 16:07:57.000000000 -0700
|
--- cmake-2.4.3/Modules/FindJNI.cmake.orig 2006-10-31 16:07:57.000000000 -0700
|
||||||
+++ cmake-2.4.3/Modules/FindJNI.cmake 2006-10-31 16:09:36.000000000 -0700
|
+++ cmake-2.4.3/Modules/FindJNI.cmake 2006-10-31 16:09:36.000000000 -0700
|
||||||
@@ -14,6 +14,7 @@
|
@@ -14,6 +14,7 @@
|
58
cmake.spec
58
cmake.spec
@ -3,19 +3,21 @@
|
|||||||
%bcond_with bootstrap
|
%bcond_with bootstrap
|
||||||
|
|
||||||
Name: cmake
|
Name: cmake
|
||||||
Version: 2.4.8
|
Version: 2.6.0
|
||||||
Release: 3%{?dist}
|
Release: 0.rc5.1%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://www.cmake.org
|
URL: http://www.cmake.org
|
||||||
Source0: http://www.cmake.org/files/v2.4/cmake-%{version}.tar.gz
|
Source0: http://www.cmake.org/files/v2.6/cmake-%{version}-RC-5.tar.gz
|
||||||
Source2: macros.cmake
|
Source2: macros.cmake
|
||||||
Patch0: cmake-2.4.2-fedora.patch
|
Patch0: cmake-2.6.0-jni.patch
|
||||||
Patch1: cmake-2.4.5-xmlrpc.patch
|
Patch1: cmake-2.4.5-xmlrpc.patch
|
||||||
|
Patch2: cmake-2.6.0-systemlibs.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: ncurses-devel, libX11-devel
|
BuildRequires: ncurses-devel, libX11-devel
|
||||||
|
BuildRequires: qt-devel, desktop-file-utils
|
||||||
BuildRequires: curl-devel, expat-devel, zlib-devel
|
BuildRequires: curl-devel, expat-devel, zlib-devel
|
||||||
%{?!with_bootstrap:BuildRequires: xmlrpc-c-devel}
|
%{?!with_bootstrap:BuildRequires: xmlrpc-c-devel}
|
||||||
Requires: rpm
|
Requires: rpm
|
||||||
@ -30,18 +32,32 @@ to support complex environments requiring system configuration, pre-processor
|
|||||||
generation, code generation, and template instantiation.
|
generation, code generation, and template instantiation.
|
||||||
|
|
||||||
|
|
||||||
|
%package gui
|
||||||
|
Summary: Qt GUI for %{name}
|
||||||
|
Group: Development/Tools
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description gui
|
||||||
|
The %{name}-gui package contains the Qt based GUI for CMake.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n %{name}-%{version}-RC-5
|
||||||
%patch -p1 -b .fedora
|
%patch -p1 -b .jni
|
||||||
%patch1 -p1 -b .xmlrpc
|
%patch1 -p1 -b .xmlrpc
|
||||||
|
%patch2 -p1 -b .systemlibs
|
||||||
|
# Fixup permissions
|
||||||
|
find -name \*.h -o -name \*.cxx | xargs chmod -x
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$RPM_OPT_FLAGS"
|
export CFLAGS="$RPM_OPT_FLAGS"
|
||||||
export CXXFLAGS="$RPM_OPT_FLAGS"
|
export CXXFLAGS="$RPM_OPT_FLAGS"
|
||||||
./bootstrap --init=%SOURCE1 --prefix=%{_prefix} --datadir=/share/%{name} \
|
./bootstrap --prefix=%{_prefix} --datadir=/share/%{name} \
|
||||||
--docdir=/share/doc/%{name}-%{version} --mandir=/share/man \
|
--docdir=/share/doc/%{name}-%{version} --mandir=/share/man \
|
||||||
--%{?with_bootstrap:no-}system-libs
|
--%{?with_bootstrap:no-}system-libs \
|
||||||
|
--parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
|
||||||
|
--qt-gui
|
||||||
make VERBOSE=1 %{?_smp_mflags}
|
make VERBOSE=1 %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
@ -55,16 +71,29 @@ install -m 0644 Docs/cmake-mode.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/
|
|||||||
# RPM macros
|
# RPM macros
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rpm
|
||||||
install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/
|
install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/
|
||||||
|
# Desktop file
|
||||||
|
desktop-file-install --delete-original \
|
||||||
|
--dir=%{buildroot}%{_datadir}/applications \
|
||||||
|
%{buildroot}/%{_datadir}/applications/CMake.desktop
|
||||||
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
ctest -V
|
bin/ctest -V
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%post gui
|
||||||
|
update-desktop-database &> /dev/null || :
|
||||||
|
update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||||
|
|
||||||
|
%postun gui
|
||||||
|
update-desktop-database &> /dev/null || :
|
||||||
|
update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
|
%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
|
||||||
@ -77,8 +106,19 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/*.1*
|
%{_mandir}/man1/*.1*
|
||||||
%{_datadir}/emacs/
|
%{_datadir}/emacs/
|
||||||
|
|
||||||
|
%files gui
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_bindir}/cmake-gui
|
||||||
|
%{_datadir}/applications/CMake.desktop
|
||||||
|
%{_datadir}/mime/packages/cmakecache.xml
|
||||||
|
%{_datadir}/pixmaps/CMakeSetup.png
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 28 2008 Orion Poplawski <orion@cora.nwra.com> - 2.6.0-0.rc5.1
|
||||||
|
- Update to 2.6.0-RC-5
|
||||||
|
- Add gui sub-package for Qt frontend
|
||||||
|
|
||||||
* Fri Mar 7 2008 Orion Poplawski <orion@cora.nwra.com> - 2.4.8-3
|
* Fri Mar 7 2008 Orion Poplawski <orion@cora.nwra.com> - 2.4.8-3
|
||||||
- Add macro for bootstrapping new release/architecture
|
- Add macro for bootstrapping new release/architecture
|
||||||
- Add %%check section
|
- Add %%check section
|
||||||
|
Loading…
Reference in New Issue
Block a user