- add support for Python 2.7 to FindPythonLibs.cmake (Orcan Ogetbil)
This commit is contained in:
parent
bd83b5f1ea
commit
bfc0d14d74
12
cmake-2.8.2-python27.patch
Normal file
12
cmake-2.8.2-python27.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -ur cmake-2.8.2/Modules/FindPythonLibs.cmake cmake-2.8.2-python27/Modules/FindPythonLibs.cmake
|
||||||
|
--- cmake-2.8.2/Modules/FindPythonLibs.cmake 2010-06-28 17:15:57.000000000 +0200
|
||||||
|
+++ cmake-2.8.2-python27/Modules/FindPythonLibs.cmake 2010-07-23 20:42:29.000000000 +0200
|
||||||
|
@@ -27,7 +27,7 @@
|
||||||
|
# Search for the python framework on Apple.
|
||||||
|
CMAKE_FIND_FRAMEWORKS(Python)
|
||||||
|
|
||||||
|
-FOREACH(_CURRENT_VERSION 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
|
||||||
|
+FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
|
||||||
|
STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
|
||||||
|
IF(WIN32)
|
||||||
|
FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
|
11
cmake.spec
11
cmake.spec
@ -8,7 +8,7 @@
|
|||||||
|
|
||||||
Name: cmake
|
Name: cmake
|
||||||
Version: 2.8.2
|
Version: 2.8.2
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -16,6 +16,10 @@ License: BSD
|
|||||||
URL: http://www.cmake.org
|
URL: http://www.cmake.org
|
||||||
Source0: http://www.cmake.org/files/v2.8/cmake-%{version}%{?rcver}.tar.gz
|
Source0: http://www.cmake.org/files/v2.8/cmake-%{version}%{?rcver}.tar.gz
|
||||||
Source2: macros.cmake
|
Source2: macros.cmake
|
||||||
|
|
||||||
|
# add support for Python 2.7 to FindPythonLibs.cmake (Orcan Ogetbil)
|
||||||
|
Patch0: cmake-2.8.2-python27.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: gcc-gfortran
|
BuildRequires: gcc-gfortran
|
||||||
@ -51,6 +55,8 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{?rcver}
|
%setup -q -n %{name}-%{version}%{?rcver}
|
||||||
|
# Python 2.7 patch (don't use -b as the backup would get installed)
|
||||||
|
%patch0 -p1
|
||||||
# Fixup permissions
|
# Fixup permissions
|
||||||
find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
|
find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
|
||||||
|
|
||||||
@ -138,6 +144,9 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 23 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.8.2-2
|
||||||
|
- add support for Python 2.7 to FindPythonLibs.cmake (Orcan Ogetbil)
|
||||||
|
|
||||||
* Tue Jul 6 2010 Orion Poplawski <orion@cora.nwra.com> - 2.8.2-1
|
* Tue Jul 6 2010 Orion Poplawski <orion@cora.nwra.com> - 2.8.2-1
|
||||||
- Update to 2.8.2 final
|
- Update to 2.8.2 final
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user