Update to 3.2.0-rc1
- Drop ninja patch fixed upstream - Upstream now ships icons, add icon-cache scriptlets
This commit is contained in:
parent
2f03d1934f
commit
ad69af3eb0
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@
|
||||
/cmake-3.1.1.tar.gz
|
||||
/cmake-3.1.2.tar.gz
|
||||
/cmake-3.1.3.tar.gz
|
||||
/cmake-3.2.0-rc1.tar.gz
|
||||
|
@ -1,23 +0,0 @@
|
||||
diff -up cmake-3.1.0-rc1/Modules/CMakeNinjaFindMake.cmake.ninja cmake-3.1.0-rc1/Modules/CMakeNinjaFindMake.cmake
|
||||
--- cmake-3.1.0-rc1/Modules/CMakeNinjaFindMake.cmake.ninja 2014-10-27 08:40:56.000000000 -0600
|
||||
+++ cmake-3.1.0-rc1/Modules/CMakeNinjaFindMake.cmake 2014-10-29 19:36:04.758871982 -0600
|
||||
@@ -12,6 +12,6 @@
|
||||
# (To distribute this file outside of CMake, substitute the full
|
||||
# License text for the above reference.)
|
||||
|
||||
-find_program(CMAKE_MAKE_PROGRAM ninja
|
||||
+find_program(CMAKE_MAKE_PROGRAM ninja-build
|
||||
DOC "Program used to build from build.ninja files.")
|
||||
mark_as_advanced(CMAKE_MAKE_PROGRAM)
|
||||
diff -up cmake-3.1.0-rc1/Source/cmGlobalNinjaGenerator.cxx.ninja cmake-3.1.0-rc1/Source/cmGlobalNinjaGenerator.cxx
|
||||
--- cmake-3.1.0-rc1/Source/cmGlobalNinjaGenerator.cxx.ninja 2014-10-29 19:36:04.761872039 -0600
|
||||
+++ cmake-3.1.0-rc1/Source/cmGlobalNinjaGenerator.cxx 2014-10-29 19:37:00.528930970 -0600
|
||||
@@ -1171,7 +1171,7 @@ std::string cmGlobalNinjaGenerator::ninj
|
||||
lgen->GetMakefile()->GetRequiredDefinition("CMAKE_MAKE_PROGRAM"),
|
||||
cmLocalGenerator::SHELL);
|
||||
}
|
||||
- return "ninja";
|
||||
+ return "ninja-build";
|
||||
}
|
||||
|
||||
std::string cmGlobalNinjaGenerator::ninjaVersion() const
|
29
cmake.spec
29
cmake.spec
@ -4,7 +4,7 @@
|
||||
# Set to bcond_with or use --without gui to disable qt4 gui build
|
||||
%bcond_without gui
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
%define rcver %{nil}
|
||||
%define rcver -rc1
|
||||
|
||||
%define rpm_macros_dir %{_sysconfdir}/rpm
|
||||
%if 0%{?fedora} > 18
|
||||
@ -12,8 +12,8 @@
|
||||
%endif
|
||||
|
||||
Name: cmake
|
||||
Version: 3.1.3
|
||||
Release: 1%{?dist}
|
||||
Version: 3.2.0
|
||||
Release: 0.1.rc1%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -23,14 +23,11 @@ Group: Development/Tools
|
||||
# some GPL-licensed bison-generated files, these all include an exception granting redistribution under terms of your choice
|
||||
License: BSD and MIT and zlib
|
||||
URL: http://www.cmake.org
|
||||
Source0: http://www.cmake.org/files/v3.1/cmake-%{version}%{?rcver}.tar.gz
|
||||
Source0: http://www.cmake.org/files/v3.2/cmake-%{version}%{?rcver}.tar.gz
|
||||
Source1: cmake-init.el
|
||||
Source2: macros.cmake
|
||||
# Patch to find DCMTK in Fedora (bug #720140)
|
||||
Patch0: cmake-dcmtk.patch
|
||||
# Patch to use ninja-build instead of ninja (renamed in Fedora)
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=886184
|
||||
Patch1: cmake-ninja.patch
|
||||
# Patch to fix RindRuby vendor settings
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
@ -102,7 +99,6 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
%setup -q -n %{name}-%{version}%{?rcver}
|
||||
# We cannot use backups with patches to Modules as they end up being installed
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1 -b .strict_aliasing
|
||||
@ -178,17 +174,21 @@ popd
|
||||
%if %{with gui}
|
||||
%post gui
|
||||
update-desktop-database &> /dev/null || :
|
||||
touch --no-create %{_datadir}/mime ||:
|
||||
/bin/touch --no-create %{_datadir}/mime || :
|
||||
/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
|
||||
%postun gui
|
||||
update-desktop-database &> /dev/null || :
|
||||
if [ $1 -eq 0 ] ; then
|
||||
touch --no-create %{_datadir}/mime ||:
|
||||
update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
/bin/touch --no-create %{_datadir}/mime || :
|
||||
update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
fi
|
||||
|
||||
%posttrans gui
|
||||
update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%endif
|
||||
|
||||
|
||||
@ -221,12 +221,17 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
%{_bindir}/cmake-gui
|
||||
%{_datadir}/applications/CMake.desktop
|
||||
%{_datadir}/mime/packages/cmakecache.xml
|
||||
%{_datadir}/pixmaps/CMakeSetup32.png
|
||||
%{_datadir}/icons/hicolor/*/apps/CMakeSetup.png
|
||||
%{_mandir}/man1/cmake-gui.1.gz
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Feb 15 2015 Orion Poplawski <orion@cora.nwra.com> - 3.2.0-0.1.rc1
|
||||
- Update to 3.2.0-rc1
|
||||
- Drop ninja patch fixed upstream
|
||||
- Upstream now ships icons, add icon-cache scriptlets
|
||||
|
||||
* Fri Feb 13 2015 Orion Poplawski <orion@cora.nwra.com> - 3.1.3-1
|
||||
- Update to 3.1.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user